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Introduction

This document describes the activities that you can perform with the Dell EMC Server Management Pack Suite version 7.0 for Microsoft
System Center Operations Manager.

The integration of Dell EMC Server Management Pack Suite with Microsoft System Center 2016 Operations Manager, Microsoft System
Center 2012 R2 Operations Manager, Microsoft System Center 2012 SP1 Operations Manager, Microsoft System Center 2012 Operations
Manager, or Microsoft System Center Operations Manager 2007 R2, environment allows you to manage, monitor, and also ensure the
availability of the required Dell devices.

To avoid data corruption, data loss, or both; perform the procedures in this document only if you have proper
knowledge and experience in using Microsoft Windows operating system and Microsoft System Center 2016 Operations
Manager, Microsoft System Center 2012 R2 Operations Manager, Microsoft System Center 2012 SP1 Operations Manager,
Microsoft System Center 2012 Operations Manager, and Microsoft System Center Operations Manager 2007 R2.

(D | NOTE: Read the Dell EMC Server Management Pack Suite’s release notes, which contains the latest information about software
and management server requirements, in addition to information about known issues. The release notes is posted to the Systems
Management documentation page on Dell.com/OMConnectionsEnterpriseSystemsManagement. The release notes is also
packaged in the self-extracting executable Dell_EMC_Server_Management_Pack_Suite_v7.0_Axx.exe file. (where xx is the Dell
EMC Server Management Pack Suite version 7.0 release number) file.

Before installing this version of Dell EMC Server Management Pack Suite for Microsoft System Center Operations Manager, download the
latest documents from Dell.com/omconnectionsEnterpriseSystemsManagement or Dell.com/openmanagemanuals.

Topics:

Terms used in this document
What is new in this release
Key features of Dell EMC Server Management Pack Suite

Terms used in this document

Table 1. Terms used in this document

Term Refers to

OpsMgr Microsoft System Center 2016 Operations Manager, Microsoft System Center 2012 R2
Operations Manager, Microsoft System Center 2012 SP1 Operations Manager, Microsoft
System Center 2012 Operations Manager, and Microsoft System Center Operations
Manager 2007 R2, unless otherwise specified.

OpsMgr 2016 Microsoft System Center 2016 Operations Manager, unless otherwise specified.

OpsMgr 2012 Microsoft System Center 2012 R2 Operations Manager, Microsoft System Center 2012
SP1 Operations Manager, and Microsoft System Center 2012 Operations Manager, unless
otherwise specified.

Dell Remote Access Controller (DRAC) DRAC of Dell servers, Dell branded OEM servers, and Dell OEM Ready servers, unless
otherwise specified.
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Term Refers to

Integrated Dell Remote Access Controllers iDRAC of Dell servers, Dell branded OEM servers, and Dell OEM Ready servers, unless

(iDRAC) otherwise specified.

Chassis Chassis Management Controller (CMC), unless otherwise specified.

Servers PowerEdge servers, PowerVault monolithic and modular servers, supported Rack
Workstations, Dell branded OEM servers, and Dell OEM Ready servers, unless otherwise
specified.

iDRAC Service Module (iSM) iDRAC Service Module is a lightweight software that runs on the Server and

complements iDRAC with monitoring information from the OS. The Service Module does
not expose any new interfaces of its own, rather it complements iDRAC with additional
data that users can work with using iDRAC consoles. For more information about iSM and
the supported platform, see IDRAC Service Module Installation Guide at Dell.com/

support.

Servers (iISM) PowerEdge servers and Precision Rack Workstations discovered using the SCOM agent
through iSM.

Servers and Rack Workstation monitoring PowerEdge servers, PowerVault monolithic and modular servers, supported Rack

Workstations, Dell branded OEM servers, and Dell OEM Ready servers, unless otherwise
specified. This is a license-free feature.

Servers and Rack Workstation monitoring PowerEdge servers, PowerVault monoalithic and modular servers, supported Rack
(Licensed) Workstations, Dell branded OEM servers, and Dell OEM Ready servers, unless otherwise
specified. This is a license based feature.

What is new in this release

The 7.0 release of Dell EMC Server Management Pack Suite includes:

Rebranding changes for Dell Server Management Pack Suite; Dell Server Management Pack Suite is now Dell EMC Server
Management Pack Suite.

Support for 14th generation of the PowerEdge servers

Support for detailed monitoring of the Dell servers through iDRAC Service Module (iISM) using Windows Management Instrumentation
(WMD)

Supports the following iDRAC features of 14th generation of the PowerEdge servers:
System Configuration Lockdown Mode feature
iDRAC Group Manager feature
Server Port Connection Information
iDRAC detection of a failed CMC

Added Chassis Power Consumption Performance View for Dell Chassis Management Controller discovered through the Chassis
Monitoring feature

Added Event Auto Resolution feature to automatically resolve the Dell device events for the Dell servers discovered through WS-MAN
Added Capacity Planning feature for Dell Servers discovered through Server and Rack Workstation Monitoring (Licensed) feature

Added Check Node Interfaces task to check if the Dell devices and their corresponding interfaces are reachable or non-reachable for all
the monitoring features.
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Key features of Dell EMC Server Management

Pack Suite

This version of Dell EMC Server Management Pack Suite provides the following features for managing the Dell devices:

Table 2. Features and Functionalities

Feature

Functionality

Discovery and Monitoring — Servers and Rack Workstation

Supports discovery and monitoring of PowerEdge servers,
PowerVault Monolithic and Modular systems, Dell OEM Ready
servers, and supported Dell Precision Racks running the supported
Windows operating system, using the supported OpenManage
Server Administrator (OMSA).

License based Discovery and Monitoring — Servers and Rack
Workstation (Licensed)

Supports:

License based discovery and monitoring of 12th, 13th and 14th
generation of PowerEdge servers, PowerVault systems,
supported Dell Precision Racks, Dell branded OEM servers, and
Dell OEM Ready servers through:

iDRAC using WS-MAN
iDRAC access via Host OS
iSM using Windows Management Instrumentation (WMI)

Discovery and monitoring of 12th, 13th, and 14th generation of
PowerEdge servers, PowerVault systems, supported Dell
Precision Racks, Dell branded OEM servers, and Dell OEM
Ready servers using iDRAC.

Discovery and monitoring of 12th, 13th, and 14th generation of
PowerEdge servers using iSM. For the complete list of
supported servers, see Supported platforms in the iDRAC
Service Module Installation Guide at Dell.com/manuals.

SNMP traps for devices discovered through WS-MAN of
Servers and Rack Workstation Monitoring (Licensed) feature.

Discovery and Monitoring — Chassis Management

Supports:

Discovery and monitoring of Chassis, and Dell OEM Ready
chassis devices.

Discovery of server modules and chassis slot summary for CMC
chassis.

SNMP traps for Chassis devices.

Discovery and Monitoring — Dell Remote Access Controllers
(DRAC)

Supports:

Discovery and monitoring of supported iDRAC devices — 12th
and 13th generation only.

SNMP and PET traps for DRAC devices.

DALEMC



2

Overview of Dell EMC Server Management Pack
Suite

The Dell EMC Server Management Pack Suite for OpsMgr enables you to:

Discover and classify the following Dell devices:
Dell Servers—Using license-free monitoring, and license-based monitoring
Dell Remote Access Controllers
Dell Chassis—PowerEdge FX2/ FX2s, PowerEdge VRTX, PowerEdge M1000e, and Dell OEM Ready Chassis
Supported Dell Precision Racks
Monitor the discovered Dell devices through OMSA, iDRAC, or iSM based on your requirements.
View, analyze, and resolve alerts using Knowledge Base (KB) articles.
Perform various tasks on the discovered Dell devices.
View reports for discovered Dell devices.

C
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Server and Rack Workstation Monitoring feature

Server and Rack Workstation Monitoring feature supports the discovery and monitoring of the following devices that are installed with the
supported Windows OS, using the OpenManage Server Administrator (OMSA):

PowerEdge Modular and Monoalithic servers
PowerVault storage servers

Dell OEM Ready servers

Dell Precision Racks

Inventory and monitoring of these devices could be done through the server's OpenManage Server Administrator (OMSA) which is a
license-free monitoring feature.

For information about the supported OMSA versions, see Dell EMC Server Management Pack Suite Version 7.0 for Microsoft System
Center Operations Manager Release Notes.

The Dell EMC Server Management Pack Suite installer automatically imports the Server and Rack Workstation monitoring scalable feature
into OpsMgr.

Topics:

Comparison of Scalable and Detailed Edition features
Discovery and grouping

Monitoring

Tasks

Reports

Comparison of Scalable and Detailed Edition features

The following table helps you understand the environment in which you can use the Scalable and Detailed Edition features:

Table 3. Scalable management pack versus the Detailed management pack

Features Scalable Edition Detailed Edition

Server and Rack Workstation Monitoring | | Inventory and monitoring of component - Detailed inventory and health monitoring

Feature groups. Also, display the presence of of individual components
IDRAC. View metrics of memory, processors,
Reports—Only OpenManage Windows network interfaces, sensors, storage
Event log report is available. controllers, disks, and virtual disks. Also,

displays BIOS information.

Reports—Availability of BIOS
configuration, firmware and driver version,
and RAID configuration reports
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Discovery and grouping

The Dell EMC Server Management Pack Suite enables you to discover and classify Dell Servers—Monolithic, Modular, Sleds, and
supported Dell Precision Racks. The following table lists the details of the hardware discovery and grouping:

Table 4. Dell hardware discovery and grouping

Group Diagram View Hardware Type
Dell Servers Dell Monolithic Servers PowerEdge systems.
Dell Modular Servers PowerVault storage servers.

Dell Sled Servers

Dell Rack Workstations Rack Workstation Diagram Dell Precision Racks.

Discovering Dell Server in OpsMgr

Dell servers are discovered through the OpsMgr Agent Management infrastructure.
@| NOTE: Discover a Dell server in the Agent Managed view under the Administration section of the OpsMgr console.
To discover a Dell server:

Log on to the Management Server as an OpsMgr administrator.
On the OpsMgr console, click Administration.
At the bottom of the navigation pane, click Discovery Wizard.

DN -

Run the Discovery Wizard, select Windows computers and follow the instructions on the screen.
For more information, see the OpsMgr documentation at technet.microsoft.com.

| NOTE: The installer automatically imports the license-free monitoring feature management packs into the OpsMgr. If
the installer fails to install the management packs, then, import the management packs using the OpsMgr Import
Management Packs wizard or the Feature Management Dashboard.

(D | NOTE: Dell servers that do not have Dell OpenManage Server Administrator (OMSA) installed, or are running an unsupported
OMSA version are grouped as Dell Unmanaged Devices.

Discoveries by the Server and Rack Workstation Monitoring
Feature

Table 5. Server and Rack Workstation Monitoring Feature Discoveries

discovery Description
Dell Server discovery Classifies the Dell servers and populates the attributes.
Dell Server Network Interface discovery Discovers the network interface at group level of the Dell server.
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discovery

Description

Dell Server Hardware Components discovery

Discovers hardware components at a group level (such as sensors,
processor, memory, and power supply).

Dell OpenManage Software Services discovery

Discovers the objects for OpenManage Server Administrator
Windows services.

Dell Server Detailed BIOS discovery

Discovers BIOS objects for each Dell server (Detailed edition only).

Dell Server Detailed Memory discovery

Discovers memory instances for the Dell server (Detailed edition
only).

Dell Server Detailed Power Supply discovery

Discovers power supply instances for the Dell server (Detailed
edition only).

Dell Server Detailed Processor discovery

Discovers processor instances for the Dell server (Detailed edition
only).

Dell Server Detailed Storage discovery

Discovers the complete storage hierarchy for the Dell server
(Detailed edition only).

Dell Windows Server Detailed Sensor discovery

Discovers sensor instances for Dell server (Detailed edition only).

Dell Windows Server Detailed Network Interfaces discovery
module

Discovers the physical and teamed network interface instances of
the Dell server (Detailed edition only).

Dell Windows Server Network Interfaces Group discovery
module

Discovers the Network Interfaces group.

Dell Rack Workstation Group discovery

Discovers the Dell Rack Workstation group.

Dell Unmanaged Server Group discovery

Discovers Dell servers that are not being monitored either due to
the absence of Dell instrumentation, an unsupported OMSA
version, or has an instrumentation version lower than the required
version.

Monitoring

The Monitoring pane of the OpsMagr is used to select views that provide complete health information of the discovered Dell servers. The
Severity Level Indicators helps you to indicate the health of the Dell servers on the network.

It includes monitoring the health of Modular servers, Monolithic servers, and supported Dell Precision Racks and their components, both at

regular intervals and on occurrence of events.
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Monitored hardware components

The following table provides information about the monitored hardware components supported in the Scalable and Detailed feature:

Table 6. Monitored hardware components — Scalable and Detailed feature

Hardware components Scalable Detailed
iDRAC Yes Yes
Memory Yes Yes
Network Interfaces Group Yes Yes
OpenManage Software Services Yes Yes
Power Supplies Yes Yes
Processors Yes Yes
Storage Yes Yes
Storage Controller Yes Yes
Sensors Yes Yes
Physical Network Interface Instance No Yes
BIOS Config Instance No No
Battery Sensor No Yes
Battery Sensor Group No Yes
Current Sensor No Yes
Current Sensor Group No Yes
Chassis Intrusion Sensor No Yes
Fan Sensor No Yes
Fan Sensor Group No Yes
Memory Unit Instance No Yes
Network Interfaces Physical Group No Yes
Network Interfaces Teamed Group No Yes
Processor Unit Instance No Yes

DYALEMC Server and Rack Workstation Monitoring feature



Hardware components Scalable Detailed
Power Supplies Unit Instance No Yes
Storage Controller Physical Disk Instance No Yes
Storage Connector Physical Disk Group No Yes
Storage Controller Connector Instance No Yes
Storage Controller Enclosure Instance No Yes
Storage Controller Sensors No Yes
Storage Controller Virtual Disk Group No Yes
Storage Enclosure EMM Instance No Yes
Storage Enclosure Physical Disk Group No Yes
Storage Enclosure Power Supply Group No Yes
Storage Enclosure Sensors No Yes
Teamed Network Interface Instance No Yes
Voltage Sensor No Yes
Voltage Sensor Group No Yes

Views

Dell EMC Server Management Pack Suite provides the following types of views for monitoring, under Monitoring > Dell on the OpsMgr

console:

Alerts Views
Diagram Views

Performance and Power Monitoring Views

State Views

Alerts Views

This view is available for managing hardware and storage events from Servers and Rack Workstations. The following alerts are displayed:

Alerts for events received from OpenManage Server Administrator for the Dell servers and Rack Workstations

(| NOTE: Informational alerts are turned off by default. To enable informational alerts, run the Set Informational Alerts On
task for the Server and Rack Monitoring feature on the Feature Management Dashboard.

Link-up and Link-down alerts for events received from the Broadcom and Intel network interface cards.
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Viewing Alerts on OpsMgr Console

To view alerts on the OpsMgr console:

1 Launch the OpsMgr console and click Monitoring > Dell > Alerts Views.
The following alerts are displayed:
Network Interface Alerts—Link-up and Link-down alerts from the discovered NICs are displayed.
Server and Rack Workstation Alerts—OMSA alerts from the Dell servers and Rack Workstations are displayed.
Dell Rack Workstation Alert Views
Network Interface Alerts — Alerts—Link-up and Link-down alerts from the discovered NICs are displayed.
Rack Workstation Alerts —OMSA alerts from Rack Workstations are displayed.
2 Select any of the Alerts Views.

On the right pane of each of the individual Alerts Views, alerts that meet the criteria you specify—such as alert severity, resolution
state, or alerts that are assigned to you are displayed.

3 Select an alert to view the details in the Alert Details pane.

Diagram Views

The Diagram Views offers a hierarchical and graphical representation of all Dell servers and supported Rack Workstations on the network.

Viewing Diagram Views on the OpsMgr console
To view the diagram views on the OpsMgr console:

1 Launch the OpsMgr console and click Monitoring > Dell > Diagram Views.
2 Navigate to the Diagram Views folder for the following views:
Complete Diagram View
Dell Rack Workstation Diagram Views
Rack Workstation Diagram
Dell Server Diagram Views
Modular Systems Diagram
Monolithic Servers Diagram
Sled Servers Diagram
3 Select any of the Diagram Views.
On the right pane the hierarchical and graphical representation of the selected Dell server or Rack Workstation is displayed.

4 Select a component in the diagram to view its details in the Detail View pane.

Complete Diagram View

The Complete Diagram View offers a graphical representation of all Dell devices that the OpsMgr monitors. You can expand and verify the
status of individual devices and their components in the diagram. You can view the details for the following:

Modular and Monolithic servers
Sled Group

Rack Workstations

Chassis Management Controllers
Remote Access Controllers

Dell Unmanaged systems
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Rack Workstation Diagram

The Dell Rack Workstation Diagram Views offers a graphical representation of all supported Rack Workstations and allows you to expand
and verify the status of individual devices and their components in the diagram. Select a Rack Workstation in the diagram to view its details
in the Detail View pane.

Modular and Monolithic Systems

The Modular Systems Diagram and Monolithic Servers Diagram views offer the following details:

Physical and teamed network interfaces
Memory

Power supply

Sensors

Processors

Dell OpenManage software services
Storage components

BIOS (inventory only)

iDRAC

Modular Systems Diagram

The Modular Systems Diagram View offers a graphical representation of all Dell modular systems and allows you to expand and verify the
status of individual devices and their components in the diagram.

Monolithic Servers Diagram

The Monolithic Servers Diagram view offers a graphical representation of all Monolithic systems and allows you to expand and verify the
status of individual devices and their components in the diagram.

Sled Servers Diagram

The Sled Servers Diagram view offers a graphical representation of all Sled servers and allows you to expand and verify the status of
individual devices and their components in the diagram. Select a Sled server in the diagram to view its details in the Detail View pane.

Dell Server Instance Diagram

Select a Dell server from the Modular System or Monolithic Servers diagram views, to view the diagram specific to that particular system.
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Figure 1. Dell Server Instance Diagram
System-specific diagrams illustrate and indicate the status of the following components:

Physical and teamed network interfaces
Memory

Power supply

Sensors

Processors

Dell OpenManage software services
Storage components

BIOS (inventory only)

The memory, processors, network, sensors, storage, and power supply components are displayed in detail by the Detailed edition of the
Server and Rack Workstation Monitoring feature.

Storage Controller Component Hierarchy

Expand the Storage component in any Dell system instance diagram view, to view the status and health of components such as physical
disks, connectors, virtual disks, controllers, sensors, and enclosures.

Network Interfaces Component Hierarchy

The Network Interfaces group is created only when an Intel or Broadcom network interface card is present and enabled on the Dell Server.
Network interfaces are grouped under Physical Interfaces and Teamed Interfaces. If you disable a network interface, the network
interfaces group will be removed from management in the next discovery cycle.

A reference relationship is created between a Teamed network interface and its associated Physical network interfaces. You can view the
reference relationship only when you enable the Enable Correlation attribute of Dell Windows Server Physical and Teamed Relationship
Discovery. For more information, see Enabling Correlation.

Enabling Correlation

To enable the Enable Correlation attribute:

Launch the OpsMgr console.

From the navigation pane, click Authoring.

In the Authoring tab, click Management Pack Objects > Object Discoveries.

Search for Dell Windows Server Physical and Teamed Relationship Discovery Rule in the Look for: field.

g DN NN -

Right-click Dell Windows Server Physical and Teamed Relationship Discovery Rule > Overrides > Override the Object Discovery >
For all objects of class: Teamed Network Interface instance (Enriched).
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The Override Properties page is displayed.
6  Select Enable Correlation and set the Override Value to True and click OK.

The status roll-up of network interfaces on the diagram view is displayed only up to the Network Interfaces group level. For example, if the
remaining components of the Dell server are normal and only one or more of the network interfaces are critical or noncritical, then, the Dell
system displays the health state normal icon, and the Network Interfaces group displays the critical or warning icon.

Diagram View

Figure 2. Network Interfaces Diagram View

Enabling Network Interfaces Group to Dell Server Health Roll Up

For the status roll-up to be displayed at the server level, enable the Network Interfaces Group to Dell Server Health Roll up dependency
monitor.

To enable the monitor:

1 Launch the OpsMgr console.
2 From the navigation pane, click Authoring.

3 Click Monitors on the left pane and then, search Network Interfaces Group for the type of server you want to enable the
functionality. For example, Dell Windows Server.

4  Click Entity Health > Availability.

Right-click Network Interfaces Group to Dell Server Health Roll up and select Overrides > Override the Monitor > For all objects
of class: Dell Windows Server

The Override Properties screen is displayed.
Select Enabled and set the Override Value to True.

7 Under Management Pack, either select a management pack created from the Select destination management pack: drop-down
menu or create a management pack by clicking New...

To create a management pack:

a Click New...

The Create a Management Pack screen is displayed.
b Provide a name for the management pack in the Name field and click Next.

For information on creating a management pack, see the OpsMgr documentation at technet.microsoft.com.
¢ Click Create.

The management pack you created is selected in the Select destination management pack: drop-down menu.
8  Click Apply.
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Performance and Power Monitoring Views

To view the performance and power monitoring on the OpsMgr console:

1 Launch the OpsMgr console and click Monitoring.
2 In the Monitoring pane, click Dell > Performance and Power Monitoring for the following views:
Ambient Temperature (Centigrade)
Amperage (Amps)
Disk Performance View(%)
Energy Consumption (kWh)
Peak Amperage (Amps)
Peak Power (Watts)
Physical Network Interface
Power Consumption (BTU/hr)
Power Consumption (Watts)
Teamed Network Interface

®

NOTE: Power monitoring is applicable only for Dell servers with power monitoring capability for a particular attribute. It
is enabled only when the detailed edition of Server and Rack Workstation Monitoring feature is present.

®

NOTE: Disk Performance View (%), Teamed and Physical network interface instances are disabled by default and
appears only when the detailed edition of the Server and Rack Workstation Monitoring feature is installed and imported.

3 Select the counters from the individual performance views and select the time range for which the values are required.
The data collected is represented in a graphical format for each system.

A unit monitor, monitors the performance counter over two successive cycles to check if it exceeds a threshold value. When the threshold
value is exceeded, the Dell server changes state and generates an alert. This unit monitor is disabled by default. You can override (enable)
the threshold values from the Authoring pane of the OpsMgr console. Unit monitors are available under Dell Windows Server objects for
Server and Rack Workstation Monitoring feature. To enable the threshold values of unit monitors, see Enabling Performance and Power
Monitoring Unit Monitors.

For more information on performance information collection, see Performance Collection Rules.

Enabling Performance and Power Monitoring Unit Monitors

To enable the unit monitors for Performance and Power Monitoring Views:

Launch OpsMgr console and click Authoring.

Click Management Pack Objects > Monitors, and then search for Performance in the Look for: field.
Click Dell Windows Server > Performance.

Right-click the unit monitor you want to enable.

g DN NN -

Select Overrides > Override the Monitor and select an option based on your requirement.

For example, to override the unit monitors for all objects of class: Dell Windows Server, select For all objects of class: Dell Windows
Server

The Override Properties screen is displayed.
Select Enabled and set the Override Value to True.

7 Under Management Pack, either select a management pack created from the Select destination management pack: drop-down
menu or create a management pack by clicking New...

To create a management pack:
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a Click New...

The Create a Management Pack screen is displayed.
b Provide a name for the management pack in the Name field and click Next.

For information on creating a management pack, see the OpsMgr documentation at technet.microsoft.com.
¢ Click Create.

The management pack you created is selected in the Select destination management pack: drop-down menu.
8  Click Apply.

State Views

This view is available for viewing the health of all Dell servers and Rack Workstations. To view the status of each Dell Server or Rack
Workstation managed by the OpsMgr on the network, click Monitoring > Dell > State Views in the OpsMgr console.

You can view the status of the Dell Servers and Rack Workstations in the following views:

Servers and Rack Workstations
Dell Rack Workstation State Views
Managed Rack Workstation
Dell Server State Views

FM Servers
Sled Servers

The health of a component is derived by reviewing the unresolved alerts associated with the component.

Unit Monitors

Unit monitors assess the various conditions that can occur in monitored objects. The result of this assessment determines the health state
of a target.

The unit monitors are:

Event Monitor — triggered by the event that the Dell instrumentation logs in the Windows event log, indicating the health of the
corresponding object.

Periodic Monitor — triggered by a periodic poll configured as Interval Seconds.

The following tables illustrate the various Dell monitors and the applicable parameters.

Dell Unit Monitors — Scalable Edition

Monitors to assess various conditions that can occur in the license-free monitoring feature — Scalable Edition monitored objects.

Table 7. Dell Unit Monitors — Scalable Edition

Object Unit Monitor
Memory
Dell Server Memory Status Event and Periodic
Dell Server Memory Redundancy Status Event and Periodic
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Availability Status

Object Unit Monitor
OpenManage Software Services
Dell Server Management (DSM) Connection Service Periodic
Availability Status
DSM Data Manager Availability Status Periodic
DSM Event Manager Availability Status Periodic
DSM Shared Service Availability Status Periodic
DSM Storage Service Availability Status Periodic
Windows Management Instrumentation (WMI) Service Periodic

Power Supplies

Dell Server Power Supplies Status

Event and Periodic

Processors

Dell Server Processors Status

Event and Periodic

Sensors

Dell Server Battery Status

Event and Periodic

Dell Server Current Status

Event and Periodic

Dell Server Fans Status

Event and Periodic

Dell Server Intrusion Sensor Status

Event and Periodic

Dell Server Temperature Sensor Status

Event and Periodic

Dell Server Voltage Sensor Status

Event and Periodic

Storage Controller

Storage Controller Status

Event and Periodic

Network Interfaces Group (Basic)

Global Network Interfaces (Basic) Connection Status

Event and Periodic

Network Interfaces Group (Enriched)

Global Enriched Network Interfaces Status

Event and Periodic

Global Network Interfaces (Basic) Connection Status

Event and Periodic

iDRAC
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Object Unit Monitor
Dell Server iDRAC Network Interface Monitor Periodic
Dell OM Performance
Ambient Temperature Average Threshold AlertMonitor Periodic
Amperage Average Threshold AlertMonitor Periodic
EnergyConsumption Average Threshold AlertMonitor Periodic
PowerConsumption (BTU/hr) Average Threshold Periodic
PowerConsumption (Watts) Average Threshold Periodic
AlertMonitor
Dell OM Server Unsupported Unit Monitor Periodic
Dell Unit Monitors — Detailed Edition
Table 8. Dell Unit Monitors — Detailed Edition
Object Unit Monitor

Memory Unit Instance

Detailed Memory Event Monitor

Event and Periodic

Detailed Memory Unit Monitor

Event and Periodic

Power Supplies Unit Instance

Detailed Power Supply

Event and Periodic

Processor Unit Instance

Detailed Processor

Event and Periodic

Storage Controller Connector Instance

Controller Connector Event Monitor

Event and Periodic

Controller Connector Unit Monitor

Event and Periodic

Storage Controller EMM Instance

Enclosure EMM Event Monitor

Event and Periodic

Enclosure EMM Unit Monitor

Event and Periodic

Storage Controller Enclosure Instance
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Object

Unit Monitor

Controller Enclosure Event Monitor

Event and Periodic

Controller Enclosure Unit Monitor

Event and Periodic

Storage Controller Physical Disk Instance

Controller Physical Disk Event Monitor

Event and Periodic

Controller Physical Disk Unit Monitor

Event and Periodic

Enclosure Physical Disk Event Monitor

Event and Periodic

Enclosure Physical Disk Unit Monitor

Event and Periodic

Storage Controller Power Supply Instance

Enclosure Power Supply Event Monitor

Event and Periodic

Enclosure Power Supply Unit Monitor

Event and Periodic

Storage Controller Sensors

Controller Sensor Event Unit Monitor

Event and Periodic

Controller Sensor Unit Monitor

Event and Periodic

Storage Controller Virtual Disk Group

Event and Periodic

Storage Controller Virtual Disk Instance

Event and Periodic

Controller Virtual Disk Event Monitor

Event

Controller Virtual Disk Unit Monitor

Periodic

Storage Enclosure Physical Disk Group

Event and Periodic

Storage Enclosure Sensors

Enclosure Fan Event Unit Monitor

Event and Periodic

Enclosure Fan Unit Monitor

Event and Periodic

Enclosure Temperature Event Monitor

Event and Periodic

Enclosure Temperature Unit Monitor

Event and Periodic

Physical Network Interface Instance (Basic)

Connection Status

Event and Periodic

Physical Network Interface Instance (Enriched)
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Object Unit Monitor

Administrative Status Event and Periodic
Connection Status Event and Periodic
Link Status Event and Periodic
Operational Status Event and Periodic

Teamed Network Interface Instance (Basic)

Teamed Network Interface (Basic) Availability Status Event and Periodic

Teamed Network Interface Instance (Enriched)

Teamed Network Interface Instance (Enriched) Event and Periodic
Administrative Status

Teamed Network Interface Instance (Enriched) Connection | Event and Periodic
Status

Teamed Network Interface Instance (Enriched) Link Status | Event and Periodic

Teamed Network Interface Instance (Enriched) Operational | Event and Periodic
Status

Teamed Network Interface Instance (Enriched) Redundancy | Event and Periodic
Status

Fan Sensor

Fan Sensor Unit Monitor Periodic

Current Sensor

Current Sensor Unit Monitor Periodic

Voltage Sensor

Voltage Sensor Unit Monitor Periodic

Battery Sensor

Battery Sensor Unit Monitor Periodic

Chassis Intrusion Sensor

Chassis Intrusion Sensor Unit Monitor Periodic

Rules

The following section lists the rules specific to the Server and Rack Workstation Monitoring feature.
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Dell Systems Event Processing Rules

The Dell EMC Server Management Pack Suite processes rules from OMSA and OMSA Storage Management events.

Server Administrator

All informational, warning, and critical events for OMSA have corresponding event processing rule.

Each of these rules are processed based on the following criteria:

Source Name = "Server Administrator"
Event ID = Actual event ID of the Server Administrator instrumentation event

Data Provider = Windows System Event Log

Storage Management

All informational, warning, and critical events for the Server Administrator Storage Management Service have a corresponding event
processing rule.

Each of these rules are processed based on the following criteria:

Source Name = "Server Administrator"
Event ID = Actual event ID of the Server Administrator Storage Management Service event
Data Provider = Windows system event log

Performance Collection Rules

In the OpsMgr console, click Monitoring > Dell > Performance and Power Monitoring Views to view the performance information that is
collected from Dell servers. By default this feature is disabled, to enable the feature, see Enabling Performance Collection Rules.

The performance collection rules collect information on the following parameters:

Disk Performance (%)

Ambient Temperature (Centigrade)
Amperage (Amps)

Energy Consumption (kWh)

Peak Amperage (Amps)

Peak Power (Watts)

Physical Network Interface

Power Consumption (BTU/hr)
Power Consumption (Watts)
Teamed Network Interface

@ | NOTE:

When the Detailed edition of the Server and Rack Workstation Monitoring feature is imported, the disabled Performance (excluding
Network Performance) and license-free Disk Performance (%) collection rules are enabled by default.

Disk Performance (%) — This view displays the Remaining Rated Write Endurance of Solid-State Drives (SSDs) of a Dell server.
Search for the object SSD to view the data.
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(D | NOTE: Network Statistics are defined in Detailed edition of the Server and Rack Workstation Monitoring feature only and are
disabled by default. To enable the feature, see Enabling Performance Collection Rules.

Enabling Performance Collection Rules

To enable this feature:

1 Launch OpsMgr console and click Authoring.
Click Rules and search for Enriched in the Look for: field.
Right-click the rule you want to enable.
For example, to collect information on Network Interface of all Dell systems, perform step 4 to step 5 for the rules listed below:
Total Transmitted Packets
Received Bytes
Total Received Packets
Transmitted Bytes
4  Select Overrides > Override the Rule > For all objects of class.
Select Enabled and set the Override Value to True..

6  Under Management Pack, either select a management pack created from the Select destination management pack: drop-down
menu or create a new management pack by clicking New...

To create a new management pack:

a Click New...
The Create a Management Pack screen is displayed.
b Provide a name for the management pack in the Name field and click Next.
For information on creating a management pack, see the OpsMgr documentation at technet.microsoft.com.
¢ Click Create.
The management pack you created is selected in the Select destination management pack: drop-down menu.

7 Click Apply.

Tasks

Tasks are available in the Tasks pane of the OpsMgr console. When you select a device or a component, the relevant tasks appear in the
Tasks pane.

Task summary

Performing Dell tasks

Following table provides a summary of the Dell tasks that you can perform on the OpsMgr:

Table 9. Dell Windows Server tasks

Task Description

Check Node Interfaces Checks if the selected Dell server and its corresponding interface;
WML is reachable or non-reachable.

Check Power Status Check the overall power status of the system.
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Task

Description

Clear ESM Logs

Backs up the content of the Embedded System Management
(ESM) log and clears the ESM log file for a selected system.

Force Power Off

Turns off the system power without shutting down the operating
system.

Get Warranty Information

Retrieves the warranty information for the selected system.

(O | NOTE: An active internet connection is required to
retrieve the warranty information.

Launch Dell License Manager on X64 bit Management Server

Launches the Dell license manager on management systems
running 64-bit operating system.

Launch Dell OpenManage Power Center

Launches the Dell OpenManage Power Center console on the
Management Server.

Launch Dell Remote Access Console

Launches the DRAC console for the Dell Servers discovered using
the Server and Rack Workstation Monitoring feature.

Launch OpenManage Server Administrator

Launches the OpenManage Server Administrator.

Launch Remote Desktop

Launches the remote desktop for the selected system.

Power Cycle

Turns off the power, and after a delay, turns it on again.

Power Off Gracefully

Shuts down the operating system first, then turns off the system
power.

Power On

Turns on the system power. This option is available only if the
system is off.

Power Reset

Turns off the system power and turns it on again.

Turn LED lIdentification On

Turns on the identify LED for 255 seconds on the selected system.

Turn LED lIdentification Off

Turns off the identify LED on the selected system.

Dell Windows Server Tasks

Check Node Interfaces

The Check Node Interfaces task checks if the selected Dell server and its corresponding interface; WMI is reachable or non-reachable.

To check the node interfaces:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Dell Diagram Views, State Views, or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Windows Server Tasks > Check Node Interfaces.

The task provides a summary of the reachability check, and interface check after the successful completion of the task.
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Check Power Status

You can check the power status and allow power control tasks through the IPMI shell.

(D | NOTE: To enable Advanced Power Control, install Baseboard Management Controller Management Utility (BMU) in the default
path. If BMU is not installed in the default path, create a new console task. For more information on creating a new console task,
see Creating Advanced Power Control And LED Identification Tasks.

To check the power status of a system:

1 Inthe OpsMgr console, navigate to a Dell Diagram View, State View, or Alert View.
2 Select the desired Dell server in any of the Diagram View or State View or an alert in the Alerts View.
3 In the Tasks pane, select Dell Windows Server Tasks > Check Power Status.

Clear ESM Logs

The Server Administrator Embedded Server Management (ESM) log, also referred to as the hardware log, maintains a list of all system
events generated by the hardware, such as error-correcting code (ECC), system reset and boot, and probe threshold changes. You can
refer to this log when hardware errors appear or when the system is not functioning properly.

To run the Clear ESM Logs task:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell system in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 In the Tasks pane, select Dell Windows Server Tasks > Clear ESM Logs.
The Run Tasks window is displayed.
4 Click Run to clear the ESM logs of the device that you selected.

When you run the Clear ESM Logs task, on the task execution screen only the result of the task initiating is displayed. For example, the
task execution screen may show a success result even if the ESM logs are not cleared. This means that the Clear ESM Logs task initiation
was successful.

Force Power Off

The Force Power Off task allows you to turn off the Dell server without shutting down the operating system.

(D | NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in the default path, create a
new console task. For more information on creating a new console task, see Creating Advanced Power Control And LED
Identification Tasks.

To power off the system:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alert Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Windows Server Tasks > Force Power Off.

Get Warranty Information

The Get Warranty Information task allows you to view the warranty status of the selected Dell server.

®| NOTE: An active Internet connection is required to retrieve the warranty information.
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To get warranty information:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Windows Server Tasks > Get Warranty Information.

Launch Dell License Manager on X64 Bit Management Server

The Launch Dell License Manager on X64 bit Management Server task allows you to launch the Dell License Manager on management
systems running 64-bit operating system. Dell License Manager is a one-to-many license deployment and reporting tool for Dell iDRAC
licenses.

(O | NOTE: If the Dell License Manager has not been installed in the default path, create a new task to launch Dell License Manager.
For more information, see Creating A Launch License Manager Task.

To launch Dell License Manager:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Windows Server Tasks > Launch Dell License Manager on X64 bit Management Server.

Launch Dell OpenManage Power Center

You can use this task to launch the OpenManage Power Center console.
To launch OpenManage Power Center:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 In the Tasks pane, select Dell Windows Server Tasks > Launch Dell OpenManage Power Center.

Launch Dell Remote Access Console

To launch Dell Remote Access console:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Windows Server Tasks > Launch Dell Remote Access Console.

Launch OpenManage Server Administrator

To launch OpenManage Server Administrator:

1 Inthe OpsMgr console, navigate to Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 In the Tasks pane, select Dell Windows Server Tasks > Launch Server Administrator.

®| NOTE: The Dell EMC Server Management Pack Suite tasks launch the remote console in the Internet Explorer.
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Launch Remote Desktop

To launch remote desktop:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Windows Server Tasks > Launch Remote Desktop.

®| NOTE: Launching remote desktop is possible only if the remote desktop is enabled manually in the managed node.

Power Cycle

The Power Cycle task allows you to turn off the Dell server and turn it on again after a delay.

(D | NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in the default path, create a
new console task. For more information on creating a new console task, see Creating Advanced Power Control And LED
Identification Tasks.

To run the power cycle:
1 Inthe OpsMgr console, navigate to a Diagram Views, State Views, or Alert Views.

2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Windows Server Tasks > Power Cycle.

Power Off Gracefully

The Power Off Gracefully task allows you to shut down the operating system and power off the Dell server.

(O | NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in the default path, create a
new console task. For more information on creating a new console task, see Creating Advanced Power Control And LED
Identification Tasks.

To power off the system gracefully:
1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alert Views.

2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Windows Server Tasks > Power Off Gracefully.

Power On

The Power On task allows you to power on the server. This option is available even if the system power is off.

(D | NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in the default path, create a
new console task. For more information on creating a new console task, see Creating Advanced Power Control And LED
Identification Tasks.

To power on a system:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 In the Tasks pane, select Dell Windows Server Tasks > Power On.
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Power Reset

The Power Reset task allows you to power off and then power on the Dell server.

(D | NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in the default path, create a
new console task. For more information on creating a new console task, see Creating Advanced Power Control And LED
Identification Tasks.

To reset the power of the system:
1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 In the Tasks pane, select Dell Windows Server Tasks > Power Reset.

Turn LED Identification On

The Turn LED Identification On task allows you to turn on the LED identification on the selected Dell server.

(O | NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in the default path, create a
new console task. For more information on creating a new console task, see Creating Advanced Power Control And LED
Identification Tasks.

To turn on LED identification:
1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Windows Server Tasks > Turn LED Identification On.

Turn LED Identification Off

The Turn LED Identification Off task allows you to to turn off the LED identification on the selected Dell server.

(D | NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in the default path, create a
new console task. For more information on creating a new console task, see Creating Advanced Power Control And LED
Identification Tasks.

To turn off LED identification:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Windows Server Tasks > Turn LED Identification Off.

Reports

The reporting feature allows you to create reports for OpenManage Windows Event Log, Dell server BIOS, firmware, and RAID
configuration.

@ | NOTE:

Server and Rack Workstation Monitoring feature supports Reports only for object-level.

Dell server BIOS, firmware, and RAID configuration reports are available only in the Detailed
Edition.
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Accessing Reports

To access reports:

1 Click Reporting on the OpsMgr console.

2 Click Dell Windows Server (Scalable Edition) for the OpenManage Windows Event Log and click Dell Windows Server (Detail
Edition) for BIOS Configuration, Firmware and Driver Versions, and RAID Configuration reports.

0]

NOTE: You can also access Reporting from the Diagram View or State View by clicking on the server instance. The option for Dell
Reports is located in the Tasks pane under the Dell System instance reports along with the default Microsoft reports.

Generating OpenManage Windows Event Log Report

To create a report for OpenManage Windows Event Logs:

On the OpsMgr console, click Reporting.

Click Dell Windows Server (Scalable Edition).

Click OpenManage Windows Event Log then click Open in the Tasks pane.
Select a time period for which you want the report generated.

Click Add Object.

Search for objects of class Dell Windows Server and click Add.

D O N NN

You will find the object in the Selected object pane.

Choose the Severity of the events whose report you want to generate.
Click Run.

The OpenManage Windows Event Log report is generated.

oo

Generating BIOS Configuration Report

To create a report for the BIOS configuration:

On the OpsMgr console, click Reporting.

Click Dell Windows Server (Detail Edition).

Click BIOS Configuration, then click Open in the Tasks pane.

Select a time period for which you want the report generated.

Click Add Object.

Search for objects of class De11 Windows Server and click Add.

[©) I 2 BN NN G NI R

You will find the object in the Selected object pane.
Choose the required Properties.

Click Run.

The BIOS Configuration report is generated.

o

Generating Firmware and Driver Versions Report

To create a report for firmware and driver versions:

1 On the OpsMgr console, click Reporting.
2 Click Dell Windows Server (Detail Edition).

| DZLLEMC



Click Firmware and Driver Versions, then click Open on the Task pane.
Select a time period for which you want the report generated.

Click Add Object.

Search for objects of class Dell Windows Server and click Add.
You will find the object in the Selected object pane.

7 Click Run.

The Firmware and Driver Versions report is generated.

D O N W

Generating RAID Configuration Report

To create a report for RAID configuration:

On the OpsMgr console, click Reporting.

Click Dell Windows Server (Detailed Edition).

Click RAID Configuration, then click Open on the Task pane.

Select a time period for which you want the report generated.

Click Add Object.

Search for objects of class Dell Windows Server and click Add.
You will find the object in the Selected object pane.

D O N NN -

Choose the required Properties.
Click Run.
The RAID Configuration report is generated.

o
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Server and Rack Workstation Monitoring
(Licensed) Feature

Server and Rack Workstation Monitoring (Licensed) feature provides detailed or scalable inventory, based on your method of discovery, and
monitoring of the following devices:

12th, 13th, and 14th generation of PowerEdge servers
PowerVault systems

Dell Precision Racks

Dell branded OEM servers

Dell OEM Ready servers

Inventory and monitoring of these devices could be done through iDRAC or iDRAC Service Module (iISM) installed on the managed Server
or Rack Workstation through one of the following methods based on your monitoring preference:

iDRAC using WS-MAN
iDRAC access via Host OS
iSM using WMI

This is a licensed feature.

For more information about monitoring servers through iDRAC using WS-MAN or Host OS, see the section Server and Rack Workstation
Monitoring (Licensed) Feature in the Dell EMC Server Management Pack Suite Version 7.0 for Microsoft System Center Operations
Manager User's Guide.

For the list of Supported Platforms for iSM, see the iDRAC Service Module Installation Guide at Dell.com/manuals.

Dell EMC Server Management Pack Suite installer automatically imports the Server and Rack Workstation Monitoring (Licensed) feature if
the prerequisites are met.

Topics:

iDRAC using WS-MAN or iDRAC access via Host OS
iSM using WMI

iIDRAC using WS-MAN or iDRAC access via Host OS

This section describes how you can monitor Dell devices through the servers’s iDRAC using WS-MAN (iDRAC IP) or iDRAC access via
Host OS (Host IP). The latter is an experimental feature.

This option provides detailed inventory and monitoring of the following Dell devices:

12th, 13th, and 14th generation of PowerEdge servers
PowerVault systems

Dell Precision Racks

Dell branded OEM servers
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Dell OEM Ready servers

@| NOTE: PowerVault systems are not supported for iDRAC Service Module (iSM).

For more information about discovering Dell devices, see Discovering a Dell Server

For more information about using the iDRAC access via Host OS (Experimental Feature), see the Integrated Dell Remote Access
Controller7/8/9 with Lifecycle Controller User’s Guide at Dell.com/idracmanuals.

Comparison of Scalable and Detailed Edition Features

The following table helps you understand the environment in which you can use Scalable and Detailed Edition features.

Table 10. Scalable Management Pack Versus Detailed Management Pack

Features

Scalable Edition

Detailed Edition

Server and Rack Workstation Monitoring
(Licensed)

Inventory up to individual components.
Health monitoring at server, Rack

Workstation and component group level.

Inventory and health monitoring of
individual components.

View metrics for power, temperature, and
network interface cards, processor,
memory, Compute Usage per Second
(CUPS), PCle SSD wear percentage and
IO performance metrics.

Discovery and grouping

The Dell EMC Server Management Pack Suite enables you to discover and classify Dell servers.

The following table lists the details of the hardware discovery and grouping by the Server and Rack Monitoring (Licensed) feature through

iDRAC using WS-MAN.

Table 11. Dell Hardware discovery and grouping

Group

Diagram View

Hardware Type

Dell Servers

Dell Monoalithic Servers
Dell Modular Servers

Dell Sled Group

PowerEdge systems.

PowerVault storage servers.

Dell Rack Workstation

Rack Workstation Diagram

Dell Precision Racks

Discovering a Dell Server

Prerequisites:

Common prerequisites:

Install Microsoft SMASH Library (MPB) file before discovering a Dell Server using Server and Rack Monitoring (Licensed) feature.
For more information about installing the Microsoft SMASH Library (MPB) file, see the "Installing the WS-Management and
SMASH Device Template" section in the Dell EMC Server Management Pack Suite Version 7.0 for Microsoft System Center
Operations Manager Installation Guide at dell.com/OMConnectionsEnterpriseSystemsManagement.
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For iDRAC access via Host OS:
Required iSM version is installed on the managed node.
iDRAC access via Host OS is enabled.

This is an experimental feature. For more information, see the iDRAC access via Host OS (Experimental Feature) section in the
Integrated Dell Remote Access Controller//8 with Lifecycle Controller User’s Guide at Dell.com/idracmanuals.

To discover a Dell server though iDRAC using WS-MAN or iDRAC access via Host OS:

10
M

12
13
14

15
6

17

18
19

20

Log on to OpsMgr as an administrator for the OpsMgr Management Group.

On the OpsMgr console, click Authoring.

At the bottom of the navigation pane, click Add Monitoring Wizard.

The Add Monitoring Wizard screen is displayed.

On the Select Monitoring Type screen, select WS-Management and SMASH Device Discovery and click Next.

On the General Properties screen, in the Name field provide a name for the wizard.

Under Management pack, click New.

The Create a Management Pack screen is displayed.

Provide a name for the management pack in the Name field and click Next.

For information on creating a management pack, see the OpsMgr documentation at technet.microsoft.com.

Click Create.

The management pack you created is selected in the Management pack drop-down box.

Click Next.

On the Specify the target drop-down menu, select a resource pool for monitoring these devices and click Next.

On the Specify the account to be used to run discovery screen, click New and create a Simple Authentication Run As Account.
For more information on creating a Simple Authentication type Run As Account, see Creating a Simple Authentication Run As Account.

®|NOTE: If you are using AD domain credentials for iDRAC, then, enter the credentials in the following format:
username@domainname.com.

Select the Run As Account you created from the Run As Account drop-down menu and click Next.
Click Add.

On the Add Devices screen specify the 1DRAC IP (if your preferred discovery method is iDRAC using WS-MAN) or the Host IP (if
your preferred discovery method is iDRAC access via Host OS) address of the systems you want to discover, based on your
monitoring preference. You can specify the preferred IP address of the systems by:

Scanning the IP Subnet that you provided.
Scanning a specified IP Range.
Importing a text file containing the list of iIDRAC IP/ Host IP addresses.

For more information, see Configuration by using iSM PowerShell script in the Integrated Dell Remote Access Controller7/9 with
Lifecycle Controller User’s Guide at Dell.com/idracmanuals.

Click Advanced Options, select the Skip CA Check and Skip CN Check option and click OK.
Click Scan for Devices to search Dell servers on your network.

The IP addresses are listed under Available Devices.

Click Add to add the list of IP addresses you want to monitor and click OK.

On the Specify the devices you want to monitor screen, click Create.

Click Close.

The scanned Dell servers initially appear in Monitoring > WS-Management and SMASH Monitoring > WS-Management Device
State screen. After the automatically triggered SMASH discovery is completed by the OpsMgr, the Dell servers appear in Monitoring
> WS-Management and SMASH Monitoring > SMASH Device State screen.

Enable the Server and Rack Monitoring (Licensed) feature through Feature Management Dashboard.
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Object discoveries by iDRAC using WS-MAN

Table 12. Objects discovered through iDRAC using WS-MAN

Discovery Object Description
Dell Server Discovery Classifies the Dell servers and populates the key attributes and
components.
Dell Device Helper Discovery Discovers the DellDeviceHelper as an object.
Dell Host NIC Correlation Discovery Correlates the Host NIC interfaces with Physical interfaces.
( | NOTE: Teamed network interfaces will show only one of
the NICs in the team.

Monitoring

After you install the Dell EMC Server Management Pack Suite, you can use the Monitoring pane of the OpsMgr to select views that
provide health information of the discovered Dell servers. The Server and Rack Workstation Monitoring (Licensed) feature discovers and
monitors the health of the Dell servers.

0]

NOTE: To receive SNMP alerts from devices discovered through the iDRAC access via Host OS feature, you must install SNMP
services on the Managed Node and set the Management Server IP address as the trap destination in the SNMP Services.

To install SNMP services on the Managed Node, perform the following steps:

Navigate to Server Manager > Roles and Features > Features for the managed node.
Install SNMP Services.
From the list of available services, right-click SNMP Services and select Properties.

In the SNMP Services Properties (Local Computer) window, select the Traps tab.

(@2 "GN G T

Set a Community string in the Community name field and provide the Management Server IP address in the Trap Destinations
field and then click OK.

You will now be able to receive SNMP traps for the node discovered through iSM using the iDRAC access via Host OS (Experimental)
method.

The Severity Level Indicators indicates the health of the Dell servers on the network. It includes monitoring health of Modular, Monolithic
systems and supported Dell Precision Racks and their components at regular intervals.

As the system components monitored through Server and Rack Workstation Monitoring, which is a license free monitoring feature, and
the Server and Rack Workstation Monitoring (Licensed) feature are not exactly the same, it is possible that the overall server health that
is shown through license-free (OMSA) and licensed (iDRAC using WS-MAN, iDRAC access via Host OS, or iSM using WMI) methods could
be different. Drill-down to the specific component status when you observe such discrepancies to resolve specific problem conditions in
the system component to bring the overall health of the server to OK state.
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Monitored hardware components

The following table provides information about the monitored hardware components supported in Scalable and Detailed feature for devices
discovered through iDRAC using WS-MAN.

Table 13. Monitored hardware components — Scalable and Detailed feature (iDRAC using WS-MAN)

Hardware components Scalable Detailed
BIOS No No
Battery Sensor Group No Yes
Battery Sensor No Yes
Current Sensor Group No Yes
Current Sensor No Yes
Fan Sensor Group No Yes
Fan Sensor No Yes
Host NIC Group No Yes
Host NIC No Yes
iDRAC Network Interface Yes Yes
iDRAC No No
Intrusion Sensor Group No Yes
Intrusion Sensor No Yes
License Group Yes No
License No Yes
Memory Yes No
Memory Instance Yes Yes
Physical Network Interface No Yes
Physical Network Interface Group Yes Yes
Processors Group Yes No
Processor Yes No
Power Supply Group Yes Yes
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Hardware components Scalable Detailed
Power Supply No Yes
PCleSSD Extender No Yes
PCleSSD Backplane No Yes
PCleSSD Physical Disk No Yes
Server Sensors No Yes
Server Storage Yes Yes
Storage Controller Connector No Yes
Storage Controller No Yes
Storage Controller Sensor No Yes
Storage Controller Battery Group No Yes
Storage Controller Battery No Yes
Storage Virtual Disk Group No Yes
Storage Virtual Disk No Yes
Storage Controller Physical Disk Group No Yes
Storage Controller Physical Disk No Yes
Storage Controller Enclosure No Yes
Storage Controller Enclosure EMM No Yes
Storage Controller Enclosure Fan Sensor Group | No Yes
Storage Controller Enclosure Fan Sensor No Yes
Storage Controller Enclosure Power Supply No Yes
Group

Storage Controller Enclosure Power Supply No Yes
Storage Controller Enclosure Temperature Sensor | No Yes
Group

Storage Controller Enclosure Temperature Sensor | No Yes
Storage Controller Enclosure Sensor No Yes
SD Card Group No Yes
SD Card No Yes

DEALLEMC Server and Rack Workstation Monitoring (Licensed) Feature | 39



Hardware components Scalable Detailed

Temperature Sensor Group No Yes

Temperature Sensor No Yes

Voltage Sensor Group No Yes

Voltage Sensor No Yes
Views

Dell EMC Server Management Pack Suite provides the following types of views for monitoring, under the Dell folder on the OpsMgr
console:

Alerts Views

Diagram Views
Performance and Power Monitoring Views
State Views

Alerts Views

This view is available for managing hardware and storage events from Dell Servers and Rack Workstations. The following alerts are
displayed by the Server and Rack Workstation Monitoring (Licensed) feature:

Link-up and Link-down alerts for events received from Broadcom and Intel network interface cards for PowerEdge servers, PowerVault
systems and supported Dell Precision Racks.

Viewing Alerts on the OpsMgr Console

To view Server and Rack Monitoring (Licensed) feature alerts on the OpsMgr console:

1
2

Launch the OpsMgr console and click Monitoring.
Click Dell > Alerts Views.
The following Alerts Views are displayed:
Network Interface Alerts — Link-up and Link-down alerts from the discovered NICs are displayed.

Server and Rack Workstation Alerts — SNMP traps for 12th, 13th, and 14th generation of PowerEdge servers, PowerVault
storage servers and Dell Precision Racks with iDRAC7, iDRACS or iDRACS are displayed.

Dell Rack Workstation Alert Views
Network Interface Alerts
Rack Workstation Alerts
Select Server and Rack Workstation Alerts or Rack Workstation Alerts.

On the right pane of each of the individual Alerts Views, alerts that meet the criteria you specify, such as alert severity, resolution
state, or alerts that are assigned to you is displayed.

Select an alert to view the details in the Alert Details pane.
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Diagram Views

The Diagram Views offers a hierarchical and graphical representation of all PowerEdge servers and supported Precision Rack Workstations
on the network.

Viewing Diagram Views On The OpsMgr Console

To view the diagram views on the OpsMgr console:

1 Launch the OpsMgr console and click Monitoring > Dell > Diagram Views.
2 Navigate to the Diagram Views folder for the following views:

Complete Diagram View

Modular Systems Diagram

Monolithic Servers Diagram
3 Select any of the Diagram Views.

On the right pane the hierarchical and graphical representation of the selected Dell device is displayed.

4 Select a component in the diagram to view its details in the Detail View pane.

Rack Workstation Diagram

The Dell Rack Workstation Diagram Views offers a graphical representation of all supported Rack Workstations and allows you to expand
and verify the status of individual devices and their components in the diagram. Select a Rack Workstation in the diagram to view its details
in the Detail View pane.

Modular and Monolithic Systems

The Modular Systems Diagram and Monolithic Servers Diagram views offer the following details:

Physical network interfaces
Memory

Power supply
Sensors

Processors

Storage components
BIOS (inventory only)
iDRAC NIC

Host NIC

SD Card

License

Modular Systems Diagram

The Modular Systems Diagram View offers a graphical representation of all Modular systems and allows you to expand and verify the
status of individual devices and their components in the diagram.
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Monolithic Servers Diagram

The Monolithic Systems Diagram View offers a graphical representation of all Monolithic systems and allows you to expand and verify the
status of individual devices and their components in the diagram.

Sled Servers Diagram

The Sled Servers Diagram view offers a graphical representation of all Sled servers and allows you to expand and verify the status of
individual devices and their components in the diagram. Select a Sled server in the diagram to view its details in the Detail View pane.

Dell Server Instance Diagram

Select a Dell server, from the Modular System or Monolithic Server diagram views, to view the diagram specific to that particular system.
System-specific diagrams illustrate and indicate the status of the following components:

Physical interfaces
Memory

Power supply
Sensors

Processors

Storage components
Host NIC

License

PCle/ SSD

SD Card

BIOS (inventory only)
iDRAC NIC

Storage Controller Component Hierarchy

Expand the Storage component in any Dell system instance diagram view, to view the status and health of components such as physical
disks, connectors, virtual disks, controllers, sensors, and enclosures.

Performance and Power Monitoring Views

®|NOTE:

System Board Usage metrics are supported only on some of the 13th generation of the PowerEdge servers. For more information
on performance information collection, see Performance Collection Rules. Also, enable the Dell Server Performance rule.

Dell Performance View displays the performance index of CPU, memory, I/0 utilization, and system level CUPS index in a graphical
format.

To view the performance and power monitoring on the OpsMgr console:

1 Launch the OpsMgr console and click Monitoring.
2 In the Monitoring pane, click Dell > Performance and Power Monitoring for the following views:
Dell Performance View
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Disk Performance - Licensed (%)

®| NOTE: Al performance metric rules are disabled by default for Server and Rack Workstation Monitoring (Licensed)
feature.

3 To view the System Board Usage metrics, click Performance and Power Monitoring > System Board Usage for the following views:
CPU Usage (%)
10 Usage (%)
Memory Usage (%)
Overall System Usage (%)
4 Select the counters from the individual performance views and select the time range for the values required.
The data collected is represented in a graphical format for each system.

A unit monitor, monitors the performance counter over two successive cycles to check if it exceeds a threshold value. When the threshold
value is exceeded, the server changes state and generates an alert. This unit monitor is disabled by default. You can override (enable) the
threshold values from the Authoring pane of the OpsMgr console. Unit monitors are available under the Dell Server objects for the
Licensed monitoring feature. To enable the threshold values of unit monitors, see Enabling Performance and Power Monitoring Unit
Monitors.

For more information on performance information collection, see Performance Collection Rules.

Enabling Performance and Power Monitoring Unit Monitors

To enable the unit monitors for Performance and Power Monitoring Views:

Launch OpsMgr console and click Authoring.

Click Management Pack Objects > Monitors, and then search for Performance in the Look for: field.
Click Dell Server > Performance.

Right-click the unit monitor you want to enable.

a D W -

Select Overrides > Override the Monitor and select an option based on your requirement.
For example, to override the unit monitors for all objects of class: Dell Server, select For all objects of class: Dell Server

The Override Properties screen is displayed.
Select Enabled and set the Override Value to True.

7 Under Management Pack, either select a management pack created from the Select destination management pack: drop-down
menu or create a management pack by clicking New...

To create a management pack:

a Click New...
The Create a Management Pack screen is displayed.
b Provide a name for the management pack in the Name field and click Next.

For information on creating a management pack, see the OpsMgr documentation at technet.microsoft.com.
¢ Click Create.

The management pack you created is selected in the Select destination management pack: drop-down menu.
8  Click Apply.

State Views

This view is available for viewing the health of all Dell servers and supported Rack Workstations. In the OpsMgr console, click Monitoring >
Dell > State Views, the status of each Dell server and Rack Workstation managed by OpsMgr on the network is displayed.
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You can view the status for the following groups:

Servers and Rack Workstations (Licensed)
Dell Rack Workstation State Views

Managed Rack Workstation (Licensed)
Dell Server State Views

FM Servers

Sled Servers (Licensed)

Unmanaged Servers (Licensed)

The health of a component is derived by reviewing the unresolved alerts associated with the component. Severity Level Indicators explains
the various state components that the Dell EMC Server Management Pack Suite uses with their corresponding severity levels.

Key features of Server and Rack Workstation Monitoring (Licensed)
Feature

This section lists the key features for servers discovered through Server and Rack Workstation Monitoring (Licensed) feature.

System Configuration Lockdown Mode
iDRAC Group Manager

Event Auto Resolution

Capacity Planning

iDRAC detection of failed CMC

Server Port Connection Information

System Configuration Lockdown Mode

System Configuration Lockdown mode feature is available in iDRAC for 14th generation of the PowerEdge servers which locks the system’s
configuration including firmware updates. Once, the System Configuration Lockdown Mode is enabled, you cannot change the system’s
configuration. This feature is intended to protect the system from unintentional changes. Using iDRAC console, you can enable or disable
the System Configuration Lockdown mode.

When the System Configuration Lockdown mode is enabled, you cannot configure the trap destination information in the servers. Hence,
alerts are not generated for monitoring. In such a case, you are notified with a critical alert conveying that System Configuration Lockdown
mode is enabled, and trap destination information for alerts is not configured.

(| NOTE: It is recommended to update the Del/ OM : System configuration lockdown alert rule interval, immediately after the server
discovery interval is updated or modified. This recommendation ensures that the System Lockdown mode alert is generated after
the completion of server discovery with a certain interval.

You can view the details of the System Configuration Lockdown mode in the Detail View pane of the Diagram View. For more information
about this feature, see Integrated Dell Remote Access Controller 9 Version 3.00.00.00 User's Guide.

This feature is available for servers discovered through both, iDRAC and iSM methods of Server and Rack Workstation Monitoring
(Licensed) feature.

iDRAC Group Manager

iDRAC Group Manager feature is available for 14th generation of the PowerEdge servers to offer simplified basic management of iDRAC,
and associated servers on the same local network. Group Manager feature allows one-to-many console experience without involving a
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separate application. Using iDRAC Group Manager, you can view the details of a set of servers by permitting more powerful management
than by inspecting servers visually for faults and other manual methods.

You can view the details of the IDRAC Group Manager; iDRAC Group Manager Status, and iDRAC Group Name under the iDRAC object in
the Detail View pane of the Diagram View. For more information about this feature, see Integrated Dell Remote Access Controller 9
Version 3.00.00.00 User's Guide.

This feature is available for servers discovered through both, iDRAC and iSM methods of Server and Rack Workstation Monitoring
(Licensed) feature.

Event Auto Resolution

This section describes the automatic resolution or acknowledgement of the Dell device events using the Event Auto Resolution feature.

Dell EMC Server Management Pack Suite receives, and processes the events from the Dell devices. These events can be broadly classified
as problem, information, and resolution events. All these events remain on the console until they are manually closed. Even after the
problem gets resolved at the node, the problem event, and the corresponding resolution event remains in the console until they are
manually acknowledged. Event Auto Resolution feature automatically resolves or acknowledges such Dell device events.

The auto resolution of events can be classified as:

Problem to problem— One problem event resolves another problem event. For example, a temperature sensor sends a warning event
when it crosses the warning threshold. If there is no action, after certain time, the same sensor sends critical event when it crosses the
critical event. In this case, there is no importance of the warning event, as it does not exist. Hence, the warning event is acknowledged,
and only critical event is shown on the console.

Problem to resolution— One resolution or a normal event resolves a problem event. For example, a temperature sensor sends a warning
event when it crosses the warning threshold. When the administrator takes appropriate action; the same sensor sends the resolution
event or normal event after certain amount of time. In this case, there is no importance of the warning event, as it does not exist.
Hence, the warning event is acknowledged, and only normal event is shown on the console.

This feature is available only for servers discovered through iDRAC using WS-MAN. By default, the Event Auto Resolution is set to
Disabled. Enable this feature using the Enable Event Auto Resolution task. The tasks; Enable Event Auto Resolution, and Disable Event
Resolution are available under Dell > Feature Management Dashboard > Server and Rack Workstation Monitoring (Licensed) > Dell
Monitoring Feature Tasks.

Capacity planning

You can monitor if the server’s utilization has exceeded the configured capacity threshold value using the unit monitor; Dell Server Capacity
Check. The unit monitor Dell Server Capacity Check monitors the average system or CUPS usage for the last one day of each server
against the configured capacity threshold value. By default, this unit monitor is set to Disabled. To enable the Dell Server Capacity Check
unit monitor, see the Enabling Dell Server Capacity Check unit monitor.

The minimum threshold value is 1, and the maximum threshold value is 99. The default threshold value is 60. You can configure the
threshold values within the specified range i.e 1-99. In case, you provide a threshold value other than the specified ranges, that threshold is
reset to its default value.

A warning event per server is generated when the average system or CUPS usage for the last one day exceeds the configured threshold
value. The warning event is auto resolved when the average system or CUPS usage for the last one day returns within the configured
threshold value.

You can view the details of the warning alert in the Alert Details pane under Monitoring > Dell > Alerts Views > Server and Rack
Workstation Alerts.

You can view the health state obtained from the unit monitor; Dell Server Capacity Check under Monitoring > Dell > State Views > Server
and Rack Workstation Alerts (Licensed) > Dell Server Capacity Threshold Check. You can also view the component Dell Server
Capacity Threshold Check under the Dell Server object in Diagram Views.
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@| NOTE: By default, the Dell Server Capacity Threshold Check column under State Views is disabled.

Capacity Planning feature also provides a performance graph to show the trend for the Average SYS Usage/Day.
To view the performance graph for the capacity planning feature:

1 Click Monitoring > Dell > Performance and Power Monitoring Views > System Board Usage > Overall System Usage (%).

2 Select Capacity Check System Board Average Sys Usage(last day) under the Counter column for the desired Dell device and
select the time range for the values required

The data collected is represented in a graphical format for the selected Dell device.

This feature is available for servers discovered through both, the iDRAC and iSM methods of Server and Rack Workstation Monitoring
(Licensed) feature.

Enabling Dell Server Capacity Check unit monitor

This section explains how to enable the Dell Server Capacity Check unit monitor.
To enable the Dell server capacity check unit monitor:

Launch OpsMgr console, and click Authoring.
Click Management Pack Objects > Monitors, and then search for Dell Server Capacity Check in the Look for: field.
Click Entity Health > Availability.

Right-click Dell Server Capacity Check and select Overrides > Override the Monitor > For all objects of class: Dell Server
Capacity Threshold Check.

The Override Properties screen is displayed.

DN -

5  Select Enabled and set the Override Value to True.

6  Under Management Pack, either select a management pack created from the Select destination management pack: drop-down
menu or create a management pack by clicking New...

To create a management pack:

a Click New...

The Create a Management Pack screen is displayed.
b Provide a name for the management pack in the Name field and click Next.

For information on creating a management pack, see the OpsMgr documentation at Technet.microsoft.com.
¢ Click Create.

The management pack you created is selected in the Select destination management pack: drop-down menu.
7 Click Apply.

iDRAC detection of failed CMC

Using the feature; iDRAC detection of a failed CMC, the iDRAC of a Rack Style Management (RSM) enabled modular server detects a
failed or an unavailable chassis controller. By using this feature, you can take immediate remedial action to bring the failed CMC to a normal
state.

The Dell Chassis Controller Sensor indicates the presence or failure of a CMC.

You can view the health state obtained from the unit monitor; Dell Chassis Controller Sensor under Sensors in Diagram Views.
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@ | NOTE:

The Dell Chassis Controller Sensor is available in both; Scalable and Detailed Management Pack.
iDRAC detection of failed CMC is supported for 13th and 14th generation of the PowerEdge FX2 Chassis.

Server port connection information

Server port connection information feature provides details of the physical mapping of switch ports to server ports, and iDRAC dedicated
port connections. This feature helps you to reduce cabling error debugging by identifying which switch ports are connected to a server’s
network ports, and iDRAC dedicated port.

You can view the details of the Server port connection information under iDRAC NIC and NIC objects in the Detail View pane of the
Diagram View. Along with the inventory information of each NIC; chassis ID information of the switch and the port ID information is
populated.

This feature is available for servers discovered through both, the iDRAC and iSM methods of Server and Rack Workstation Monitoring
(Licensed) feature.

@| NOTE: This feature is supported for 14th generation of the PowerEdge servers only.

Dell Unit Monitors for Server and Rack Workstation Monitoring
(Licensed) feature

Monitors to assess various conditions that can occur in the monitored objects.

Table 14. Dell Unit Monitors for Server and Rack Workstation Monitoring (Licensed) feature

Object Unit Monitor
Dell Server

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic

Dell Server Power Supply

Dell Server Power Supply Unit Periodic

Dell Server Processor Group

Dell Server Processor Group Periodic

Dell Server Chassis Controller Sensor

Dell Server Chassis Controller Sensor Periodic

Dell Storage Controller

Dell Server Storage Controller Periodic
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Object

Unit Monitor

Dell Server Controller Battery

Dell Server Controller Battery Unit Periodic
Dell Battery Sensor

Dell Server Battery Sensor Health Periodic
Dell Battery Sensor Group

Dell Server Battery Group Sensor Health Periodic
Dell Current Sensor

Dell Server Current Sensor Health Periodic
Dell Fan Sensor

Dell Server Fan Sensor Health Periodic
Dell Fan Sensor Group

Dell Server Fan Group Sensor Health Periodic
Dell Intrusion Sensor

Dell Server Intrusion Sensor Health Periodic
Dell Modular Blade Server With Operating System

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic
Dell Modular Blade Server Without Operating System

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic
Dell Monolithic Server With Operating System

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic
Dell Monolithic Server Without Operating System

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic
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Object Unit Monitor
Dell Network Interfaces Group

Dell Server Network Interface Group Periodic
Dell iDRAC Network Interface

Dell Server iDRAC Network Interface Unit Periodic
Dell Server Capacity Threshold Check

Dell Server Capacity Threshold Check Periodic
Dell Server Host NIC

Dell Server Host NIC Periodic
Dell Server License

Dell Server License Periodic
Dell Server License Group

Dell Server License Group Periodic
Physical Network Interface

Dell Server Network Interface Unit Periodic
PCle SSD Backplane

Dell Server PCleSSD Backplane Periodic
PCle SSD Extender

Dell Server PCleSSD Extender Periodic
PCle SSD Physical Disk

Dell Server PCleSSD Physical Disk Predictive Failure Disk Periodic

Dell Server PCleSSD Physical Disk Primary Status Periodic
Dell Server SD Card

Dell Server SD Card Periodic

Dell Server SD Card Group Periodic
Dell Server Connector Enclosure

Dell Server Connector Enclosure Periodic
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Object Unit Monitor
Dell Storage Controller Enclosure EMM

Dell Server Enclosure EMM Periodic
Dell Storage Controller Enclosure Fan Sensor

Dell Server Enclosure Fan Sensor Periodic
Dell Storage Controller Enclosure Physical Disk

Dell Server Enclosure External Physical Disk Periodic
Dell Storage Controller Enclosure Power Supply

Dell Server Enclosure Power Supply Periodic
Dell Storage Controller Enclosure Temperature Sensor

Dell Server Temperature Sensor Periodic
Dell Storage Controller Internal Physical Disk

Dell Server Internal Physical Disk Unit Periodic
Dell Storage Controller Physical Disk

Dell Server Controller Direct Attached Physical Disk Periodic
Dell Storage Group

Dell Server Storage Periodic
Dell Storage Virtual Disk

Dell Server Controller Virtual Disk Unit Periodic
Dell Temperature Sensor

Dell Server Temperature Sensor Health Periodic
Dell Temperature Sensor Group

Dell Server Temperature Sensor Group Health Periodic
Dell Voltage Sensor

Dell Server Voltage Sensor Health Periodic
Dell Voltage Sensor Group

Dell Server Sensors Voltage Group Periodic

DALEMC



Rules

The following section lists the rules specific to the Server and Rack Workstation Monitoring (Licensed) feature.

Dell Systems Event Processing Rules

The Dell EMC Server Management Pack Suite processes rules from Dell servers.

Dell Servers

All informational, warning, and critical SNMP traps for Dell servers discovered using Server and Rack Monitoring (Licensed) feature, have a
corresponding SNMP trap rule.

Each of these rules are processed based on the following criteria:

Source Name = "Dell Server [P"
OID = Actual trap ID of the trap event
Data Provider = SNMP trap event provider

Tasks

Tasks are available in the Tasks pane of the OpsMgr console. When you select a device or a component, the relevant tasks appear in the
Tasks pane.

Task summary

Performing tasks using Server and Rack Workstation Monitoring
(Licensed) Feature

Following table provides a summary of the tasks that you can perform using Server and Rack Workstation Monitoring (Licensed) feature:

Table 15. Summary of the Dell tasks discovered using Server and Rack Workstation Monitoring (Licensed) Feature

Task Description

Check Node Interfaces Checks if the selected Dell server and its corresponding interfaces;
WS-MAN or SNMP is reachable or non-reachable.

Get Warranty Information Retrieves the warranty information for the selected system.

( | NOTE: An active Internet connection is required to
retrieve the warranty information.

Launch Dell License Manager Launches the Dell License Manager on the management system.

(O | NOTE: Launching Dell License Manager is possible only if
a Windows or Linux operating system is installed and Dell
License Manager is also installed.
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Task Description

Launch Dell OpenManage Power Center Launches the OpenManage Power Center console for the selected
system.

(O | NOTE: Launching OpenManage Power Center is possible
only if the Windows or Linux operating system,
OpenManage Server Administrator, and OpenManage
Power Center are installed on the managed node.

Launch Dell OpenManage Server Administrator (Monolithic Server) | Launches the OpenManage Server Administrator console for the
selected system.

(O | NOTE: Launching OpenManage Server Administrator is
possible only if a Windows or Linux operating system and
OpenManage Server Administrator are installed on the
managed node.

Launch Dell Remote Access Console Launches the iDRAC console for the discovered Dell Servers and
Rack Workstations that are license based.

Launch Remote Desktop (Monoalithic Server) Launches the remote desktop for the selected system.

(® | NOTE: Launching remote desktop is possible only if the
Windows operating system is installed and remote desktop
is manually enabled in the managed node.

Dell Server Tasks

Check Node Interfaces

The Check Node Interfaces task checks if the selected Dell server and its corresponding interfaces; WS-MAN or SNMP is reachable or
non-reachable.
To check the node interfaces:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Dell Diagram Views, State Views, or an alert in the Alerts Views.
3 In the Tasks pane, select Dell Server Tasks > Check Node Interfaces.

The task provides a summary of the reachability check, and interface check after the successful completion of the task.

Get Warranty Information

You can use this task to see the warranty status of the selected Dell server.
To get warranty information:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 In the Tasks pane, select Dell Server Tasks > Get Warranty Information.

Launch Dell License Manager

The Launch Dell License Manager task allows you to launch the Dell License Manager on management systems. Dell License Manager is a
one-to-many license deployment and reporting tool for Dell iDRAC licenses.

(D | NOTE: If the Dell License Manager has not been installed in the default path create a new task to launch Dell License Manager.
For more information, see Creating A Launch License Manager Task.
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To launch Dell License Manager:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 In the Task pane, select Dell Server Tasks > Launch Dell License Manager.

Launch Dell OpenManage Power Center

(O | NOTE: Launching OpenManage Power Center is possible only if Windows or Linux operating system and OpenManage Server
Administrator are installed on the managed node.

The Launch Dell OpenManage Power Center task allows you to launch the OpenManage Power Center console.
To launch the OpenManage Power Center:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Server Tasks > Launch Dell OpenManage Power Center.

Launch Dell OpenManage Server Administrator (Monolithic Server)

(D | NOTE: Launching OpenManage Server Administrator (OMSA) is possible only if Windows or Linux operating system and
OpenManage Server Administrator is installed on the managed node.

To launch OMSA from the OpsMgr console:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Server Tasks > Launch Dell OpenManage Server Administrator (Monolithic Server).

®| NOTE: The Dell EMC Server Management Pack Suite tasks launches the remote console in the Internet Explorer.

Launch Dell Remote Access Console

To launch the Dell Remote Access Console:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 In the Task pane, select Dell Server Tasks > Launch Dell Remote Access Console.

Launch Remote Desktop (Monolithic Server)
®

NOTE: Launching remote desktop is possible only if the Windows operating system is installed and remote desktop is manually
enabled on the managed system.

®

NOTE: Remote Desktop task uses hostname to connect to the management server of a system. If the management server
cannot resolve the hostname then, add the hostname and the IP address to a route to the server using its hostname that is
configured on the management server.

To launch Remote Desktop from the OpsMgr console:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 In the Tasks pane, select Dell Server Tasks > Launch Remote Desktop (Monolithic Server).
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iISM using WMI

This section describes how you can monitor Dell devices with iISM using Windows Management Instrumentation (WMI) to retrieve details
from the supported Dell devices.

This option provides scalable inventory and monitoring of the 12th, 13th, and 14th generation of PowerEdge servers, and supported Dell
Precision Rack Workstations. For more information about the supported platforms, see the iDRAC Service Module Installation Guide at
Dell.com/manuals. This is a licensed feature.

Dell EMC Server Management Pack Suite installer automatically imports the Server and Rack Workstation Monitoring (Licensed) feature if
the prerequisites are met.

Comparison of Scalable and Detailed Edition Features

The following table helps you understand the environment in which you can use the Scalable and Detailed edition features for devices
discovered through iSM. These devices are classified as Servers (iSM) in the OpsMgr console.

Table 16. Scalable Management Pack versus Detailed Management Pack

Features Scalable Edition Detailed Edition

Servers (iSM) Inventory up to individual components. - Inventory and health monitoring of
Health monitoring at server, Rack individual components.
Workstation, and component group level. | - View metrics for power, temperature,

energy, network interface cards,
processor, memory, Compute Usage per
Second (CUPS), the PCle SSD wear
percentage, and IO performance metrics.

Discovery and grouping
The Dell EMC Server Management Pack Suite enables you to discover and classify Dell servers.

The following table lists the details of the hardware discovery and grouping by the Server and Rack Monitoring (Licensed) feature through
iSM using WMI.

Table 17. Dell Hardware discovery and grouping

Group Diagram View Hardware Type

Dell Servers Dell Monolithic Servers PowerEdge servers.
Dell Modular Servers

Dell Sled Group

Dell Rack Workstation Rack Workstation Diagram Dell Precision Rack Workstations.

Discovering Dell Server in OpsMgr

Ensure that the following prerequisites are met before you discover the Dell devices through iSM using WMI:
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Required version of iSM is installed on the managed node.

®| NOTE: If you are monitoring devices through iSM using WMI feature on systems running Microsoft Nano server, see the
section Installing iDRAC Service Module on Nano operating system in the /DRAC Service Module Installation Guide at
Dell.com/support.

Windows Management Instrumentation (WMI) feature is enabled on the host.

For more information, see the section Windows Management Instrumentation providers in the Integrated Dell Remote Access
Controller7/8/9 with Lifecycle Controller User’s Guide at Dell.com/idracmanuals.

In the Feature Management Dashboard, the Enable Agent Proxying task is run for the Server and Rack Workstation (Licensed)
monitoring feature.

Dell servers are discovered through the OpsMgr Agent Management infrastructure.
@| NOTE: Discover the Dell servers in the Agent Managed view under the Administration section of the OpsMgr console.
To discover a Dell server:

Log on to the management server as an OpsMgr administrator.
On the OpsMgr console, click Administration.
At the bottom of the navigation pane, click Discovery Wizard.

DN -

Run the Discovery Wizard, select the Windows computers, and follow the instructions on the screen.
For more information, see the OpsMgr documentation at Technet.microsoft.com.

(| NOTE: The installer automatically imports the Server and Rack Workstation Monitoring (Licensed) management packs
into the OpsMgr. If the installer fails to install the management packs, then, import the management packs using the
OpsMgr Import Management Packs wizard or the Feature Management Dashboard.

The discovered devices are displayed under State Views under Servers (iSM) as shown in the following figure:
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Figure 3. Servers (iSM)

ADell Server (iSM) informational alert is generated when a Dell server is discovered through iDRAC Service Module
(iSM) for the first time. This informational alert is a one-time alert.
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Object discoveries for iSM using WMI

Table 18. Objects discovered through iSM using WMI.

Discovery Object

Description

Dell Server Discovery

Classifies the Dell servers and populates the key attributes and
components.

Monitoring

The Monitoring pane of the OpsMagr is used to select views that provide health information of the discovered Dell servers. The Severity
Level Indicators helps you to indicate the health of the Dell servers on the network.

It includes monitoring the health of Modular and Monolithic servers, and Dell Precision Rack Workstations at their group level, both at

regular intervals and on occurrence of events.

Monitored Hardware components

The following table provides information about the monitored hardware components supported in the Scalable and Detailed feature for

servers discovered through iSM:

Table 19. Monitored hardware components—Scalable and Detailed Feature

Hardware components Scalable Detailed
Battery Sensor Group Yes Yes
Battery Sensor No Yes
BIOS Instance No No
Current Sensor Group No No
Current Sensor No No
Fan Sensor Group Yes Yes
Fan Sensor No Yes
iDRAC No No
Host NIC Group Yes Yes
Host NIC No Yes
iDRAC License Group Yes Yes
iDRAC License No Yes
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Hardware components Scalable Detailed
iDRAC Network Interface Yes Yes
Intrusion Sensor Group Yes Yes
Intrusion Sensor No Yes
Memory Group Yes Yes
Memory Instance No Yes
Network Interfaces Group Yes Yes
Network Interfaces No Yes
PCleSSD Backplane No Yes
PCleSSD Physical Disk No Yes
PCleSSD Extender No Yes
Processor Group Yes Yes
Processor Instance No Yes
Power Supply Group Yes Yes
Power Supply Instance No Yes
SD Card Group Yes Yes
SD Card No Yes
Storage Group Yes Yes
Storage Controller No Yes
Storage Controller Battery Group No Yes
Storage Controller Battery No Yes
Storage Connector internal/external/direct No Yes
attached Physical Disk Group

Storage Controller internal/external/direct No Yes
attached Physical Disk Instance

Storage Controller Enclosure Fan Sensor Group No Yes
Storage Controller Enclosure Fan Sensor No Yes
Storage Controller Enclosure Instance No Yes
Storage Controller Sensors No Yes
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Hardware components Scalable Detailed
Storage Controller Virtual Disk Group No Yes
Storage Controller Virtual Disk No Yes
Storage Enclosure EMM Instance No Yes
Storage Enclosure Power Supply Group No Yes
Storage Enclosure Power Supply No Yes
Storage Enclosure Sensors No Yes
Storage Enclosure Temperature Sensor No Yes
Storage Enclosure Temperature Sensor Group No Yes
Teamed Network Interface Instance No No
Sensors Group Yes Yes
Temperature Sensor Group Yes Yes
Temperature Sensor No Yes
Voltage Sensor Group Yes Yes
Voltage Sensor No Yes

Views

Dell EMC Server Management Pack Suite provides the following types of views for monitoring, under Monitoring > Dell on the OpsMgr

console:

Alerts Views

Diagram Views

Performance and Power Monitoring Views
State Views

Alerts Views

This view is available for managing hardware and storage events from Dell Servers and Rack Workstations. The following alerts are

displayed:

Link-up or Link-down alerts for events received from Broadcom and Intel network interface cards.
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Viewing Alerts on the OpsMgr Console

To view the alerts on the OpsMgr console:

1 Launch the OpsMgr console and click Monitoring.
2 Click Dell > Alerts Views.
The following alerts are displayed:
Network Interface Alerts — Link-up and Link-down alerts from the discovered NICs are displayed.
Server and Rack Workstation Alerts — SNMP traps for 12th, 13th, and 14th generation of PowerEdge servers, PowerVault
storage servers and Dell Precision Racks with iDRACY, iDRACS or iDRACS are displayed.
Dell Rack Workstation Alert Views
Network Interface Alerts— Link-up and Link-down alerts from the discovered NICs are displayed.
Rack Workstation Alerts
3 Select any of the Alerts Views.

On the right pane of each of the individual Alerts Views, alerts that meet the criteria you specify, (such as alert severity, resolution
state, or alerts that are assigned to you) are displayed.

4 Select an alert to view its details in the Alert Details pane.

Diagram Views

The Diagram Views offers a hierarchical and graphical representation of all Dell servers and supported Rack Workstations on the network.

Viewing Diagram Views on the OpsMgr console

To view the diagram views on the OpsMgr console:

1 Launch the OpsMgr console and click Monitoring > Dell > Diagram Views.
2 Navigate to the Diagram Views folder for the following views:
Complete Diagram View
Dell Rack Workstation Diagram Views
Rack Workstation Diagram
Dell Server Diagram Views
Modular Systems Diagram
Monolithic Servers Diagram
Sled Servers Diagram
3 Select any of the Diagram Views.
On the right pane the hierarchical and graphical representation of the selected Dell server or Rack Workstation is displayed.

4 Select a component in the diagram to view its details in the Detail View pane.

Diagram view for Dell servers discovered through iSM using WMI.

The following figure represents the servers discovered through iSM using WMI in the Diagram View:

DUALLEMC



Disgraen View

LMOHAPE.

3
o
-
aueg yse)

! ! ! ! 1
o #o #o *5 8. B, = @o
ORAL *

Memacy Netwo o Processar % Semn v Swrage % HMIYAZ e ORACEm +
[ Gooup Group. Eedded 1.1

f
4
=
Hohal v DR
Group Lwnse G Growy erince

Figure 4. Servers (iSM) Diagram

Complete Diagram View

The Complete Diagram View offers a graphical representation of all the supported Dell devices discovered and monitors in the OpsMgr.

You can expand and verify the status of individual devices and their components in the OpsMgr. You can view the details for the following:

Modular and Monolithic servers
Dell Sled Group

Dell Rack Workstations

Chassis Management Controllers
Remote Access Controllers

Dell Unmanaged systems

Rack Workstation Diagram

The Dell Rack Workstation Diagram Views offers a graphical representation of all supported Rack Workstations and allows you to expand
and verify the status of individual devices and their components in the diagram. Select a Rack Workstation in the diagram to view its details

in the Detail View pane.

Modular and Monolithic Systems

The Modular Systems Diagram and Monolithic Servers Diagram views offer the following details:

Network Interfaces Group
Memory Group

Power Supply Group
Sensors Group

Processor Group

Storage Components Group
BIOS

iDRAC

Host NIC Group

SD Card Group

DALEMC



iDRAC License Group

Modular Systems Diagram

The Modular Systems Diagram View offers a graphical representation of all Modular systems and allows you to expand and verify the
status of individual devices and their components in the diagram.

Monolithic Servers Diagram

The Monolithic Servers Diagram View offers a graphical representation of all Monolithic systems and allows you to expand and verify the
status of individual devices and their components in the diagram.

Sled Servers Diagram

The Sled Servers Diagram View offers a graphical representation of all Sled servers and allows you to expand and verify the status of
individual devices and their components in the diagram. Select a Sled server in the diagram to view its details in the Detail View pane.

Dell Server Instance Diagram

Select a Dell server, from the Modular System or Monolithic Server diagram views, to view the diagram specific to that particular system.
System-specific diagrams illustrate and indicate the status of the following components:

Network Interfaces Group
Memory Group

Power Supply Group
Sensors Group

Processor Group

Storage Components Group
Host NIC Group

iDRAC License Group
PCle/ SSD Group

SD Card Group

BIOS (inventory only)
iDRAC

Performance and Power Monitoring Views

®| NOTE:

System Board Usage metrics are supported only on some of the 13th generation of the PowerEdge servers. For more information
on performance information collection, see Performance Collection Rules. By default, the Dell Server Performance rule is set to
Disabled.

The Dell Performance View displays the performance index of CPU, Memory and 1/0 utilization index, and system level CUPS
index in a graphical format.

To view the performance and power monitoring on the OpsMgr console:

1 Launch the OpsMgr console and click Monitoring.
2 In the Monitoring pane, click Dell > Performance and Power Monitoring for the following views:
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Dell Performance View (iSM)
Disk Performance - iSM (%)

®| NOTE: All performance metric rules are disabled by default for Server and Rack Workstation Monitoring (Licensed)
feature.

3 To view the System Board Usage metrics, click Performance and Power Monitoring > System Board Usage for the following views:
CPU Usage - iSM (%)
10 Usage - iSM (%)
Memory Usage - iSM (%)
Overall System Usage - iSM (%)
4  Select the counters from the individual performance views and select the time range for which the values are required.
The data collected is represented in a graphical format for each system.

A unit monitor, monitors the performance counter over two successive cycles to check if it exceeds the configured critical threshold value.
When the critical threshold value is exceeded, the server changes state and generates a critical alert. This unit monitor is disabled by
default. You can override (enable) the threshold values from the Authoring pane of the OpsMgr console. Unit monitors are available under
the Dell Server objects for the Licensed monitoring feature. To enable the unit monitors and set threshold values of unit monitors, see
Enabling Performance and Power Monitoring Unit Monitors.

For more information on performance information collection, see Performance Collection Rules.

Enabling Performance and Power Monitoring Unit Monitors

To enable the unit monitors for Performance and Power Monitoring Views:

Launch OpsMgr console and click Authoring.

Click Management Pack Objects > Monitors, and then search for Performance in the Look for: field.
Click Dell Server > Performance.

Right-click the unit monitor you want to enable.

g D NN -

Select Overrides > Override the Monitor and select an option based on your requirement.
For example, to override the unit monitors for all objects of class: Dell Server, select For all objects of class: Dell Server

The Override Properties screen is displayed.
6  Select Enabled and set the Override Value to True.

7 Under Management Pack, either select a management pack created from the Select destination management pack: drop-down
menu or create a management pack by clicking New...

To create a management pack:

a Click New...
The Create a Management Pack screen is displayed.
b Provide a name for the management pack in the Name field and click Next.

For information on creating a management pack, see the OpsMgr documentation at technet.microsoft.com.
c Click Create.

The management pack you created is selected in the Select destination management pack: drop-down menu.
8  Click Apply.

State Views

This view is available for viewing the health of all Dell servers and supported Rack Workstations. In the OpsMgr console, click Monitoring >
Dell > State Views, the status of each Dell server and Rack Workstation managed by OpsMgr on the network is displayed.
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You can view the status for the following groups:

Servers (iSM)
Dell Server State Views
Sled Servers (iSM)

The health of a component is derived by reviewing the unresolved alerts associated with the component. Severity Level Indicators explains
the various state components that the Dell EMC Server Management Pack Suite uses with their corresponding severity levels.

Key features of Server and Rack Workstation Monitoring (Licensed)
Feature

This section lists the key features for servers discovered through Server and Rack Workstation Monitoring (Licensed) feature.
System Configuration Lockdown Mode
iDRAC Group Manager
Event Auto Resolution
Capacity Planning
iDRAC detection of failed CMC
Server Port Connection Information

System Configuration Lockdown Mode

System Configuration Lockdown mode feature is available in iDRAC for 14th generation of the PowerEdge servers which locks the system’s
configuration including firmware updates. This feature is intended to protect the system from unintentional changes. Using iDRAC console,
you can enable or disable the System Configuration Lockdown mode. Once, the System Configuration Lockdown Mode is enabled, you
cannot change the system'’s configuration.

You can view the details of the System Configuration Lockdown mode in the Detail View pane of the Diagram View. For more information
about this feature, see lintegrated Dell Remote Access Controller 9 Version 3.00.00.00 User's Guide.

This feature is available for servers discovered through both, the iDRAC and iSM methods of Server and Rack Workstation Monitoring
(Licensed) feature.

iDRAC Group Manager

iDRAC Group Manager feature is available for 14th generation of the PowerEdge servers to offer simplified basic management of iDRAC,
and associated servers on the same local network. Group Manager feature allows one-to-many console experience without involving a
separate application. Using iDRAC Group Manager, you can view the details of a set of servers by permitting more powerful management
than by inspecting servers visually for faults and other manual methods.

You can view the details of the IDRAC Group Manager; iDRAC Group Manager Status, and iDRAC Group Name under the iDRAC object in
the Detail View pane of the Diagram View. For more information about this feature, see Integrated Dell Remote Access Controller 9
Version 3.00.00.00 User's Guide.

This feature is available for servers discovered through both, iDRAC and iSM methods of Server and Rack Workstation Monitoring
(Licensed) feature.

Capacity planning

You can monitor if the server’s utilization has exceeded the configured capacity threshold values using the unit monitor; Dell Server
Capacity Check. The unit monitor Dell Server Capacity Check monitors the average system or CUPS usage for the last one day of each
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server against the configured capacity threshold value. By default, this unit monitor is set to Disabled. To enable the Dell Server Capacity
Check unit monitor, see the Enabling Dell Server Capacity Check unit monitor.

The minimum threshold value is 1, and the maximum threshold value is 99. The default threshold value is 60. You can configure the
threshold values within the specified range i.e 1-99. In case, you provide a threshold value other than the specified ranges, the default
threshold value is considered.

A warning event per server is generated when the average system or CUPS usage for the last one day exceeds the configured threshold
value. The warning event is auto resolved when the average system or CUPS usage for the last one day returns within the configured
threshold value.

You can view the details of the warning alert in the Alert Details pane under Monitoring > Dell > Alerts Views > Server and Rack
Workstation Alerts.

You can view the health state obtained from the unit monitor; Dell Server Capacity Check under Monitoring > Dell > State Views >
Servers (iSM) > Dell Server Capacity Threshold Check. You can also view the component;Dell Server Capacity Threshold Capacity
Check under the Dell Server Capacity object in Diagram Views.

Capacity Planning feature also provides a performance graph to show the trend for the Average SYS Usage/Day.

To view the performance graph for the capacity planning feature:

1 Click Monitoring > Dell > Performance and Power Monitoring Views > System Board Usage > Overall System Usage - iSM (%).

2 Select Capacity Check System Board Average Sys Usage(last day) under the Counter column for the desired Dell device and
select the time range for the values required

The data collected is represented in a graphical format for the selected Dell device.

This feature is available for servers discovered through both, the iDRAC and iSM methods of Server and Rack Workstation Monitoring
(Licensed) feature.

iIDRAC detection of failed CMC

Using the feature; iDRAC detection of a failed CMC, the iDRAC of a Rack Style Management (RSM) enabled modular server detects a
failed or an unavailable chassis controller. By using this feature, you can take immediate remedial action to bring the failed CMC to a normal
state.

The Dell Chassis Controller Sensor indicates the presence or failure of a CMC.
You can view the health state obtained from the unit monitor; Dell Chassis Controller Sensor under Sensors in Diagram Views.
| NOTE:

The Dell Chassis Controller Sensor is available in both; Scalable and Detailed Management Pack.
iDRAC detection of failed CMC is supported for 14th generation of the PowerEdge FX2 Chassis only.

Server port connection information

Server port connection information feature provides details of the physical mapping of switch ports to server ports, and iDRAC dedicated
port connections. This feature helps you to reduce cabling error debugging by identifying which switch ports are connected to a server’s
network ports, and iDRAC dedicated port.
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You can view the details of the Server port connection information under iDRAC NIC and NIC objects in the Detail View pane of the
Diagram View. Along with the inventory information of each NIC; chassis ID information of the switch and the port ID information is

populated.

This feature is available for servers discovered through both, the iDRAC and iSM methods of Server and Rack Workstation Monitoring
(Licensed) feature.

@l NOTE: This feature is supported for 14th generation of the PowerEdge servers only.

Dell Unit Monitors for Server and Rack Workstation Monitoring
(iISM) feature

Monitors to assess various conditions that can occur in the monitored objects.

Table 20. Dell Unit Monitors for Server and Rack Workstation Monitoring (iSM) feature

Object Unit Monitor
Dell Server

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic
Dell Server Power Supply

Dell Server Power Supply Unit Periodic
Dell Server Processor Group

Dell Server Processor Group Periodic
Dell Server Chassis Controller Sensor

Dell Server Chassis Controller Sensor Periodic
Dell Storage Controller

Dell Server Storage Controller Periodic
Dell Server Controller Battery

Dell Server Controller Battery Unit Periodic
Dell Battery Sensor

Dell Server Battery Sensor Health Periodic
Dell Battery Sensor Group

Dell Server Battery Group Sensor Health Periodic

Dell Current Sensor
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Object Unit Monitor

Dell Server Current Sensor Health Periodic
Dell Fan Sensor

Dell Server Fan Sensor Health Periodic
Dell Fan Sensor Group

Dell Server Fan Group Sensor Health Periodic
Dell Intrusion Sensor

Dell Server Intrusion Sensor Health Periodic
Dell Modular Blade Server With Operating System

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic
Dell Modular Blade Server Without Operating System

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic
Dell Monolithic Server With Operating System

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic
Dell Monolithic Server Without Operating System

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic
Dell Network Interfaces Group

Dell Server Network Interface Group Periodic
Dell iDRAC Network Interface

Dell Server iDRAC Network Interface Unit Periodic
Dell Server Capacity Threshold Check

Dell Server Capacity Threshold Check Periodic

Dell Server H

ost NIC
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Object Unit Monitor

Dell Server Host NIC Periodic
Dell Server License

Dell Server License Periodic
Dell Server License Group

Dell Server License Group Periodic
Physical Network Interface

Dell Server Network Interface Unit Periodic
PCle SSD Backplane

Dell Server PCleSSD Backplane Periodic
PCle SSD Extender

Dell Server PCleSSD Extender Periodic
PCle SSD Physical Disk

Dell Server PCleSSD Physical Disk Predictive Failure Disk Periodic

Dell Server PCleSSD Physical Disk Primary Status Periodic
Dell Server SD Card

Dell Server SD Card Periodic

Dell Server SD Card Group Periodic
Dell Server Connector Enclosure

Dell Server Connector Enclosure Periodic
Dell Storage Controller Enclosure EMM

Dell Server Enclosure EMM Periodic
Dell Storage Controller Enclosure Fan Sensor

Dell Server Enclosure Fan Sensor Periodic
Dell Storage Controller Enclosure Physical Disk

Dell Server Enclosure External Physical Disk Periodic

Dell Storage Controller Enclosure Power Supply
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Object Unit Monitor

Dell Server Enclosure Power Supply Periodic
Dell Storage Controller Enclosure Temperature Sensor

Dell Server Temperature Sensor Periodic
Dell Storage Controller Internal Physical Disk

Dell Server Internal Physical Disk Unit Periodic
Dell Storage Controller Physical Disk

Dell Server Controller Direct Attached Physical Disk Periodic
Dell Storage Group

Dell Server Storage Periodic
Dell Storage Virtual Disk

Dell Server Controller Virtual Disk Unit Periodic
Dell Temperature Sensor

Dell Server Temperature Sensor Health Periodic
Dell Temperature Sensor Group

Dell Server Temperature Sensor Group Health Periodic
Dell Voltage Sensor

Dell Server Voltage Sensor Health Periodic
Dell Voltage Sensor Group

Dell Server Sensors Voltage Group Periodic

Rules

The following section lists the rules specific to the Server and Rack Workstation Monitoring (Licensed) feature.

Dell Systems Event Processing Rules

The Dell EMC Server Management Pack Suite processes rules from Dell servers.
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Dell servers

All informational, warning, and critical events for Dell servers discovered using Server and Rack Monitoring (Licensed) feature, have a
corresponding event rule.

Each of these rules are processed based on the following criteria:

Source Name = “Lifecycle controller Log”
Event no= Actual event ID of the event
Data Provider = Windows System Event Log

Tasks

Tasks are available in the Tasks pane of the OpsMgr console. When you select a device or a component, the relevant tasks appear in the
Tasks pane.

Task summary

Performing tasks using Server and Rack Workstation Monitoring
(Licensed) Feature

Following table provides a summary of the tasks that you can perform using Server and Rack Workstation Monitoring (Licensed) feature:

Table 21. Summary of the tasks discovered using iSM method of Server and Rack Workstation Monitoring (Licensed) Feature

Task Description

Check Node Interfaces Checks if the selected Dell server and its corresponding interface;
WM is reachable or non-reachable.

Get Warranty Information Retrieves the warranty information for the selected system.

( | NOTE: An active Internet connection is required to
retrieve the warranty information.

iDRAC Hard Reset Performs a remote iDRAC reset operation without having to shut
down the server.

(O | NOTE: This task is available only for servers discovered
through iSM.

Launch Dell License Manager Launches the Dell License Manager on the management system.

(O | NOTE: Launching Dell License Manager is possible only if
a Windows or Linux operating system is installed and Dell
License Manager is also installed.

Launch Dell OpenManage Power Center Launches the Dell OpenManage Power Center console for the
selected system.
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Task

Description

(O | NOTE: Launching OpenManage Power Center is possible
only if the Windows or Linux operating system,
OpenManage Server Administrator, and Dell OpenManage
Power Center are installed on the managed node.

Launch Dell Remote Access Console

Launches the iDRAC console for the discovered Dell servers and
Rack Workstations that are License based.

Launch Remote Desktop (Monolithic Server)

Launches the remote desktop for the selected system.

(O | NOTE: Launching remote desktop is possible only if the
Windows operating system is installed and remote desktop
is manually enabled in the managed node.

Check Node Interfaces

The Check Node Interfaces task checks if the selected Dell server and its corresponding interfaces; WMI is reachable or non-reachable.

To check the node interfaces:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2 Select the desired Dell server in any of the Dell Diagram Views, State Views, or an alert in the Alerts Views.

3 In the Tasks pane, select Dell Server Tasks > Check Node Interfaces.

The task provides a summary of the reachability check, and interface check after the successful completion of the task.

Get Warranty Information

You can use this task to see the warranty status of the selected Dell server.

To get warranty information:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 In the Tasks pane, select Dell Server Tasks > Get Warranty Information.

Remote iDRAC hard reset

This feature allows the administrator to perform a remote iDRAC reset operation without having to shut down the server.

Using iDRAC, you can monitor the supported servers for critical system hardware, firmware, or software issues. Sometimes, the iDRAC may
become unresponsive due to various reasons. During such scenarios, you may have to turn off the server by unplugging it from the socket,

after which the iDRAC will be reset.

Using the Remote iDRAC hard reset feature, whenever iDRAC becomes unresponsive, you can perform a remote iDRAC reset operation
without the need to power off (iDRAC hard reset) the server. By default, the remote iDRAC hard reset feature is enabled.

This feature is available for servers discovered through iSM using WMI. For more information about this feature, see the iDRAC Service
Module Installation Guide and the section Remote iDRAC Hard Reset in the iDRAC 8/7 v2.30.30.30 User’s Guide at support.dell.com.
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Performing a remote iDRAC hard reset

This section explains the steps to perform a remote iDRAC hard reset for a device discovered thorugh iSM using WMI.
To reset the iIDRAC remotely, you must first ensure that you have administrative privileges on the host OS.
To reset the iIDRAC remotely, perform the following steps:

1 Launch the OpsMgr console and click Monitoring.
2 Click Dell > State Views > Servers (iSM).
The state details are displayed and the servers discovered though iSM using WM are listed in the right pane.
Select a server for which you want to reset the iDRAC remotely.
4 From the list of Dell Server Tasks displayed in the right pane, click iDRAC Hard Reset.
The Run Task - iDRAC Hard Reset window is displayed.
5  Click Run to confirm.
The Task Status - iDRAC Hard Reset window is displayed with the status of the reset.
6  Click Close.

The iDRAC has been remotely reset successfully.

Launch Dell License Manager
The Launch Dell License Manager task allows you to launch the Dell License Manager on management systems. Dell License Manager is a
one-to-many license deployment and reporting tool for Dell iDRAC licenses.

(O | NOTE: If the Dell License Manager has not been installed in the default path create a new task to launch Dell License Manager.
For more information, see Creating A Launch License Manager Task.

To launch Dell License Manager:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Task pane, select Dell Server Tasks > Launch Dell License Manager.

Launch Dell OpenManage Power Center

(O | NOTE: Launching OpenManage Power Center is possible only if Windows or Linux operating system and OpenManage Server
Administrator are installed on the managed node.

The Launch Dell OpenManage Power Center task allows you to launch the OpenManage Power Center console.
To launch the OpenManage Power Center:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Server Tasks > Launch Dell OpenManage Power Center.

Launch Dell Remote Access Console

To launch the Dell Remote Access Console:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Task pane, select Dell Server Tasks > Launch Dell Remote Access Console.
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Launch Remote Desktop (Monolithic Server)

NOTE: Launching remote desktop is possible only if the Windows operating system is installed and remote desktop is manually
enabled on the managed system.

0]

NOTE: Remote Desktop task uses hostname to connect to the management server of a system. If the management server
cannot resolve the hostname then, add the hostname and the IP address to a route to the server using its hostname that is
configured on the management server.

0]

To launch Remote Desktop from the OpsMgr console:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Server Tasks > Launch Remote Desktop (Monolithic Server).
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DRAC Monitoring Feature

DRAC monitoring feature supports discovery, and monitoring for the various generations of iDRAC—iDRACG, iDRACY, and iDRACS8 systems
using SNMP.

Topics:

Discovery and grouping

Monitoring

Dell Unit Monitors for DRAC Monitoring Feature
Rules

Tasks

Discovery and grouping

The Dell EMC Server Management Pack Suite enables you to discover and classify Dell Remote Access Controllers (DRAC), and integrated
DRAC (iDRAC).

The following table lists the details of the hardware discovery and grouping by the Dell DRAC monitoring feature.

Table 22, Dell Hardware discovery and grouping.

Group Diagram View Hardware Type
Dell Remote Access Controllers Remote Access Controller Group iDRAC modular, and iDRAC monolithic
instances.

(D | NOTE: DRAC monitoring feature
does not support the discovery of
xx0x iDRAC modular controllers.
You can manage these devices using
the Scalable Edition of the Server
and Rack Workstation Monitoring
feature.

Discovering DRAC Devices

The DRAC devices must be discovered as network devices under the Administration section of the OpsMgr console.
To discover DRAC devices:

Log on to the management server as an OpsMgr administrator.
On the OpsMgr console, click Administration.
At the bottom of the navigation pane, click Discovery Wizard.

DN -

Run the Discovery Wizard, select Network devices and follow the instructions on the screen.
For more information, see the OpsMgr documentation at technet.microsoft.com.

5 On the Add a Device console screen in OpsMgr, type the IP address that you want to scan, select the appropriate Run As account
from the SNMP V1 or V2 Run As account drop-down box.
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6  Enable the DRAC monitoring feature using Feature Management Dashboard.

Scalability recommendation for OpsMgr

When managing large number of network devices in a distributed setup, use dedicated resource pools of Management Servers for each
device type, if the same Management Group is also used to manage devices discovered through the Server and Rack Workstation

Monitoring feature.

Discoveries by the DRAC Monitoring Feature

Table 23. DRAC Monitoring Feature Discoveries.

Discovery Object

Description

iDRAC Discovery

Discovers all supported Integrated Dell Remote Access Controllers.

Dell Integrated Remote Access Modular Discovery

Discovers the Chassis Name and Chassis Service Tag of Dell
Integrated Remote Access Controllers for Modular systems.

iDRAC6 Modular Discovery

Discovers the iDRAC6 (Modular) group.

iDRAC6 Monolithic Discovery

Discovers the iDRAC6 (Monalithic) group.

iDRAC7 Modular Discovery

Discovers the iDRAC7 (Modular) group.

iDRAC7 Monolithic Discovery

Discovers the iDRAC7 (Monoalithic) group.

iDRAC8 Modular Discovery

Discovers the iDRAC8 (Modular) group.

iDRAC8 Monolithic Discovery

Discovers the iDRAC8 (Monolithic) group.

Dell Remote Access Group Discovery

Discovers the Dell Remote Access group and populates iDRAC.

Dell Integrated Remote Access Monolithic Group Discovery

Discovers the Dell Integrated Remote Access Monolithic group and
iDRAC (Monoalithic).

Dell Integrated Remote Access Modular Group Discovery

Discovers and populates the iDRAC (Modular) group.

Monitoring

After you install the Dell EMC Server Management Pack Suite, you can use the Monitoring pane of the OpsMgr to select views that
provide complete health information of the discovered Dell DRAC devices. The DRAC monitoring feature discovers and monitors the health
of the Dell DRAC devices. It includes monitoring health of the Dell DRAC devices, both at regular intervals and on occurrence of events.
The Severity Level Indicators indicates the health of the Dell DRAC devices on the network.

(D | NOTE: To monitor the health of DRAC devices, associate the community string Run As account with the SNMP Monitoring
Account with the target as the Dell Remote Access Controller class or respective DRAC object (if you have different Run As

accounts for different DRAC devices).
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Views

Dell EMC Server Management Pack Suite provides the following types of views for monitoring, under Dell > Monitoring on the OpsMgr
console:

Alerts Views

Diagram Views

State Views

Alerts Views

This view is available for managing hardware and storage events from Dell DRAC devices. SNMP traps and Platform Event Traps (PET)
sent by DRAC devices are displayed by the DRAC monitoring feature.

Viewing Alerts on the OpsMgr Console

To view DRAC alerts on the OpsMgr console:

1 Launch the OpsMgr console and click Monitoring.
2 Click Dell > Alerts Views.
The following Alerts Views are displayed.
PET Traps — These alerts contain information on PET traps from iDRACG, iDRAC7, and iDRACS devices.
Remote Access Alerts — These alerts contains information on SNMP traps from iDRACGE, iDRAC7 and iDRACS devices.
3 Select an alert to view the details in the Alert Details pane.

On the right pane of each of the individual Alerts Views, alerts that meet the criteria you specify, such as alert severity, resolution
state, or alerts that are assigned to you is displayed.

Diagram Views

The Diagram Views offers a hierarchical and graphical representation of all Dell DRAC devices on the network.

Viewing Diagrams on the OpsMgr console

To view the diagrams for DRAC monitoring feature on the OpsMgr console:

1 Launch the OpsMgr console and click Monitoring > Dell > Diagram Views.
2 In the Monitoring pane on the left side, navigate to the Diagram Views folder for the following views:
Complete Diagram View
Remote Access Controllers Group
3 Select any of the Diagram Views.
On the right pane the hierarchical and graphical representation of the selected Dell device is displayed.

4 Select a component in the diagram to view its details in the Detail View pane.
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Remote Access Controllers Group

The Remote Access Controllers Group diagram view offers a graphical representation of all IDRACS, iDRAC7, and iDRACS devices. Select
a component in the diagram to view its details in the Detail View pane.

Remote Access Controllers Group
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Figure 5. Remote Access Controllers Group Diagram

State Views

This view is available for viewing the health of the Dell DRAC devices. In the OpsMgr console, click Monitoring > Dell > State Views >
DRAC, the status of each Dell DRAC device managed by OpsMgr on the network is displayed.

The health of a component is derived by reviewing the unresolved alerts associated with the component. Severity Level Indicators explains
the various state components that the Dell EMC Server Management Pack Suite uses with their corresponding severity levels.

Dell Unit Monitors for DRAC Monitoring Feature

Monitors to assess various conditions that can occur in DRAC monitored objects.

Table 24. Dell Unit Monitors for DRAC Monitoring Feature

Object Unit Monitor
iDRAC6 Modular

Dell Remote Access Status Event and Periodic

iDRAC6 Monolithic

Dell Remote Access Status Event and Periodic
iDRAC7 Modular
(© | NOTE: For iDRAC?7 modular and monolithic servers, the Dell RAC periodic-based and Dell RAC triggered-based unit monitors
are disabled.
Dell Remote Access Status Event and Periodic
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Object Unit Monitor

Controller Global Status Event and Periodic

Controller Global Storage Status Event and Periodic

iDRAC7 Monolithic

Dell Remote Access Status Event and Periodic

Controller Global Status Event and Periodic

Controller Global Storage Status Event and Periodic
iDRAC8 Modular

(® | NOTE: For iDRAC8 modular and monolithic servers, the Dell RAC periodic-based and Dell RAC triggered-based unit monitors

are disabled.
Dell Remote Access Status Event and Periodic
Controller Global Status Event and Periodic
Controller Global Storage Status Event and Periodic

iDRAC8 Monolithic

Dell Remote Access Status Event and Periodic
Controller Global Status Event and Periodic
Controller Global Storage Status Event and Periodic

Rules

The following section lists the rules specific to the Dell DRAC monitoring feature.

Dell Systems Event Processing Rules

The Dell EMC Server Management Pack Suite processes rules from DRAC traps.

DRAC Devices

All informational, warning, and critical SNMP traps for the DRAC devices have a corresponding SNMP trap rule.

Each of these rules are processed based on the following criteria:

Source Name = "DRAC/CMC name or ip"
OID = Actual trap ID of the DRAC /CMC SNMP trap event
Data Provider = SNMP trap
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NOTE: Informational alerts are turned off by default. To receive these alerts, import informational alerts management
pack.

Tasks

Tasks are available in the Tasks pane of the OpsMgr console. When you select a device or a component, the relevant tasks appear in the
Tasks pane.

0]

Task summary

Performing tasks using DRAC

Following table provides a summary of the tasks that are performed using the DRAC:

Table 25. Tasks using DRAC

Task Description

Check Node Interfaces Checks if the selected Dell DRAC/IDRAC device and its
corresponding interface; SNMP is reachable or non-reachable.

Launch Dell License Manager Launches the Dell License manager on the management system.
Launch Dell Remote Access Console Launches the DRAC console for the discovered DRAC.
Launch Remote Desktop Launches the remote desktop for the selected system.

(® | NOTE: This feature is available only on systems with
iDRAC?, and iDRACS.

Launch Server Administrator Launches the Server Administrator.

@ |NOTE:

Server Administrator console is launched only if the
Server Administrator is configured on the default port.

This feature is available only on systems with iDRAC7,
and iDRACS.

Dell Remote Access Controller (DRAC) tasks

Check Node Interfaces

The Check Node Interfaces task checks if the selected Dell DRAC/IDRAC device and its corresponding interface; SNMP is reachable or
non-reachable.
To check the node interfaces:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell DRAC/IDRAC in any of the Dell Diagram Views, State Views, or an alert in the Alerts Views.
3 In the Tasks pane, select Dell Remote Access Controller Tasks > Check Node Interfaces.
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The task provides a summary of the reachability check, and interface check after the successful completion of the task.

Launch Dell License Manager
The Launch Dell License Manager task allows you to launch the Dell License Manager on management systems. Dell License Manager is a
one-to-many license deployment and reporting tool for Dell iDRAC licenses.

(O | NOTE: If the Dell License Manager has not been installed in the default path, create a new task to launch Dell License Manager.
For more information, see Creating a Launch License Manager Task.

To launch Dell License Manager:

1 Inthe OpsMgr console, navigate to Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell DRAC /iDRAC device in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 In the Tasks pane, select Dell Remote Access Controller Tasks > Launch Dell License Manager.

Launch Dell Remote Access Console

You can use this task to launch the Dell Remote Access Console, if the DRAC is installed on the Dell system.
To launch Dell Remote Access console:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired DRAC/IDRAC device in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Remote Access Controller Tasks > Launch Dell Remote Access Console.

Launch Remote Desktop

@ | NOTE:

The remote desktop feature is available only on systems with iDRAC7, and iDRACS.

Launching remote desktop is possible only if remote desktop is enabled manually in the managed node.
To launch remote desktop:
1 Inthe OpsMgr console, navigate to Dell Diagram Views, State Views, or Alerts Views.

2 Select the desired Dell DRAC/ iDRAC device in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 In the Tasks pane, select Dell Remote Access Controller Tasks > Launch Remote Desktop.

Launch OpenManage Server Administrator

®| NOTE:

OpenManage Server Administrator (OMSA) console is launched only if the Server Administrator is configured on the default
port.

Server Administrator feature is available only on systems with iDRAC?, and iDRACS.

To launch Server Administrator:

1 Inthe OpsMgr console, navigate to Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell DRAC/ iDRAC device in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell Remote Access Controller Tasks > Launch Server Administrator.
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Chassis Monitoring Feature

The chassis monitoring feature supports discovery and monitoring of Chassis Management Controller (CMC) on PowerEdge FX2/FX2s
chassis, PowerEdge VRTX chassis, PowerEdge M1000e chassis, and Dell OEM Ready chassis using SNMP or WS-MAN protocol.

Chassis monitoring feature also supports Detailed monitoring of individual chassis components in the supported OpsMgr.

Topics:

Discovery and grouping

Monitoring

Dell Unit Monitors for Chassis Monitoring feature
Rules

Tasks

Discovery and grouping

The Dell EMC Server Management Pack Suite enables you to discover and classify Dell Chassis Management Controllers (CMC),
PowerEdge FX2/ FX2s, PowerEdge M1000e, and PowerEdge VRTX.

The following table lists the details of the hardware discovery and grouping by the Chassis monitoring feature:

Table 26. Dell hardware discovery and grouping

Group Diagram View Hardware Type

Dell CMC Dell Chassis Management Controllers CMC instances on the network, chassis slot
(CMC) group summary, and server modules for CMC.

Dell PowerEdge M1000e Dell M1000e Chassis group PowerEdge M1000e

Dell PowerEdge VRTX Dell VRTX Chassis group PowerEdge VRTX

Dell FX2 Dell FX2 Chassis Group PowerEdge FX2

Discovering Chassis devices

The Chassis devices should be discovered as network devices under the Administration section of the OpsMgr console.

To discover Chassis devices:

Log on to the management server as an OpsMgr administrator.

On the OpsMgr console, click Administration.

At the bottom of the navigation pane, click Discovery Wizard.

Run the Discovery Wizard, select Network devices and follow the instructions on the screen.

DNy -
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For more information, see the OpsMgr documentation at technet.microsoft.com.

(D| NOTE: Select the Run As Account created for discovering the chassis devices. For more information, see the
"Configuring Dell Chassis Management Controller feature for correlating Server modules with Chassis slot summary"
section of the Dell EMC Server Management Pack Suite Version 7.0 for Microsoft System Center Operations Manager
Installation Guide at dell.com/OMConnectionsEnterpriseSystemsManagement.

5  On the Add a Device console screen in OpsMagr, type the IP address that you want to scan, select the appropriate Run As Account
from the SNMP V1 or V2 Run As Account drop-down box.

6  Enable the Chassis monitoring feature using the Feature Management Dashboard.

Discoveries by the Chassis Monitoring Feature

Table 27. Chassis Monitoring Feature Discoveries.

Discovery Object Description

Dell CMC Discovery Discovers all supported Dell CMCs, PowerEdge FX2, PowerEdge
VRTX, PowerEdge M1000e, and Dell OEM Ready chassis.

Dell CMC Slot Discovery Discovers slots on the CMC device.

Dell Chassis Detailed Discovery Discovers all Dell chassis components.

Monitoring

After you install the Dell EMC Server Management Pack Suite, you can use the Monitoring pane of the OpsMgr to select views that
provide complete health information of the discovered Dell CMC devices. The Chassis monitoring feature discovers and monitors the health
of the Dell CMC devices. The Severity Level Indicators indicates the health of the Dell CMC devices on the network.

Chassis Monitoring includes monitoring the health of the Dell chassis devices, both at regular intervals and on occurrence of events.

(D | NOTE: To perform the Chassis Detailed monitoring, associate the WS-MAN credentials Run As account required for accessing
the Dell CMCs with the target as Dell Modular Chassis class or respective CMC object (if you have different Run As accounts for
different CMC devices) to the profile—Dell CMC Login Account Run As Profile

Monitored hardware components

The following table provides information on the monitored hardware components supported in Scalable and Detailed feature.

@ | NOTE:

Some inventory attributes and health will not be available if RACADM utility is not present. Hence, an one-time warning alert is
generated asking you to install RACADM utility.

In absence of RACADM utility CMC Group, CMC component, |0 Module component, 10 Module Group, and Power Supply Group
components will be in Warning state. To monitor CMC Group, CMC component, 10 Module component, |O Module Group, and
Power Supply Group components; enable RACADM utility.
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Table 28. Monitored hardware components — Scalable and Detailed feature.

Hardware Components Scalable Detailed
CMC Slot Information No No
CMC Slot No No
Fan Group No Yes
Fan No Yes
10 Module No Yes
IO Module Group No Yes
PCle Device Group No No
PCle Device No No
Power Supply Group No Yes
Power Supply No Yes
Storage No Yes
Storage Controller No Yes
Storage Controller Virtual Disk Group No Yes
Storage Controller Virtual Disk No Yes
Storage Controller Physical Disk Group No Yes
Storage Controller Physical Disk No Yes
Storage Enclosure No Yes

Views

Dell EMC Server Management Pack Suite provides the following types of views for monitoring, under Dell > Monitoring on the OpsMgr

console:

Alerts Views
Diagram Views

State Views

82 | Chassis Monitoring Feature
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Alerts Views

This view is available for managing hardware and storage events from Dell CMC devices. SNMP traps sent by Chassis devices are displayed
by the Chassis monitoring feature.

Viewing Alerts on the OpsMgr console

To view the Chassis monitoring alerts on the OpsMgr console:

1 Launch the OpsMgr console and click Monitoring.
2 Click Dell > Alerts Views.
The following individual Alerts Views are displayed:
CMC Alerts —SNMP traps from the discovered Chassis devices are displayed.
Dell Chassis Alert Views

Dell FX2 Chassis Alerts —SNMP traps from the discovered PowerEdge FX2 chassis devices are displayed.
Dell M1000e Chassis Alerts —SNMP traps from the discovered PowerEdge M1000e chassis devices are displayed.

Dell VRTX Chassis Alerts —SNMP traps from the discovered PowerEdge VRTX chassis devices are displayed.
3 Select any of the Alerts Views.

On the right pane of each of the individual Alerts Views, alerts that meet the criteria you specify, such as alert severity, resolution
state, or alerts that are assigned to you is displayed.

4 Select an alert to view the details in the Alert Details pane.

Diagram views

The Diagram Views offers a hierarchical and graphical representation of all Dell CMC devices, PowerEdge FX2, M1000e, and VRTX on the
network.

Viewing Diagrams on the OpsMgr console

To view the diagrams for chassis monitoring feature on the OpsMgr console:

1 Launch the OpsMgr console and click Monitoring > Dell > Diagram Views.
2 Navigate to the Diagram Views folder for the following views:
Complete Diagram View.
Chassis Management Controllers Group
Dell Chassis Diagram Views
Dell FX2 Chassis Diagram View
Dell M1000e Chassis Diagram View
Dell VRTX Chassis Diagram View
3 Select any of the Diagram Views.
On the right pane the hierarchical and graphical representation of the selected Dell device is displayed.

4 Select a component in the diagram to view its details in the Detail View pane.
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Chassis Management Controllers group

The Chassis Management Controllers Group diagram view offers a graphical representation of all Dell CMC, PowerEdge FX2, PowerEdge
M1000e, and PowerEdge VRTX, and their inventory. For the Chassis discovery, see the Discovering Chassis devices.

Chassis Management Controllers Group
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Figure 6. Chassis Management Controllers group diagram
For discovered CMC chassis, enable slot discovery which is disabled by default to view:

The occupied and free slot summary in the Chassis Slots Summary
The slot-inventory details modified on CMC chassis that are reflected in the Diagram View.
The correlation of discovered Dell servers using Licensed or license-free monitoring feature with the server modules of CMC chassis

that are displayed in the Chassis Management Controllers Group diagram. The Dell system is visible under the slot in the diagram.

(O | NOTE: Create Run As Account for CMC slot discovery with simple, basic, or digest authentication only. For more information,
see "Configuring the Dell Chassis Management Controller Feature for Correlating Server Modules with Chassis Slot Summary"
section of the Dell EMC Server Management Pack Suite Version 7.0 for Microsoft System Center Operations Manager
Installation Guide at Dell.com/support/home.

(O | NOTE: The iDRAC firmware of the modular systems should be compatible with the CMC firmware, failing which, the Service Tag
is displayed as Not Available and the Chassis Blade correlation may not be possible.

Dell Chassis Diagram views

The Dell Chassis diagram view offers a graphical representation of PowerEdge FX2, PowerEdge M1000e chassis, and PowerEdge VRTX
chassis devices. Select a component in the diagram to view its details in the Detail View pane.
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Performance and Power Monitoring Views

(D | NOTE: Chassis Power Consumption view is available only when the detailed feature of the Chassis Monitoring feature is installed,
and the Chassis Performance Collection rule is enabled. By default, the Chassis Performance Collection rule is set to Disabled. To
enable the rule, see Enabling Chassis Performance Collection Rule.

To view the performance and power monitoring on the OpsMgr console:

1 Launch the OpsMgr console, and click Monitoring.
2 In the Monitoring pane, click Dell > Performance and Power Monitoring Views to view:
Chassis Power Consumption

3 Select the counters from the individual performance views and select the time range for which the values are required. The data
collected is represented in a graphical format for each system.

State views

This view is available for viewing the health of the Dell CMC devices. In the OpsMgr console, click Monitoring > Dell > State Views,
the status of each Dell device managed by OpsMgr on the network is displayed.

Select the Dell CMC group for which you want to see the State view. You can view the status for the following:

CMC

Dell Chassis State Views

Dell FX2 Chassis State View
Dell M1000e Chassis State View
Dell VRTX Chassis State View

The health of a component is derived by reviewing the unresolved alerts associated with the component. Severity Level Indicators explains
the various state components that the Dell EMC Server Management Pack Suite uses with their corresponding severity levels.

Dell Unit Monitors for Chassis Monitoring feature

Monitors to assess various conditions that can occur in chassis monitored objects.

Table 29. Dell Unit Monitors for Chassis Monitoring feature.

Object Unit Monitor
Dell CMC

Dell CMC Status Event and Periodic

Dell Chassis Overall Health

Dell Chassis Overall Health Unit Monitor Event and Periodic

Dell Chassis 10 Module

Dell Chassis 10 Module Health Poll Based Unit Monitor Periodic
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Object Unit Monitor
Dell Modular Chassis Fan
Dell Chassis Fan Health Poll Based Unit Monitor Periodic
Dell Chassis Modular Controller
Dell Chassis CMC Health Poll Based Unit Monitor Periodic
Dell Chassis Modular Controller Group
Dell Chassis CMC Group Health Poll Based Unit Monitor Periodic
Dell Chassis Modular Power Supply
Dell Chassis Power Supply Health Poll Based Unit Monitor Periodic
Dell Chassis Modular Power Supply Group
Dell Chassis Power Supply Group Health Poll Based Unit Periodic
Monitor
Dell Chassis Modular PCle Device
Dell Chassis PCle Device Health Poll Based Unit Monitor Periodic
Dell Chassis Storage Enclosure
Dell Chassis Storage Enclosure Health Poll Based Unit Monitor Periodic
Dell Chassis Storage Controller
Dell Chassis Storage Controller Health Poll Based Unit Periodic
Monitor
Dell Chassis Storage Controller Battery Health Poll Based Unit | periodic
Monitor
Dell Chassis Storage Controller Virtual Disk
Dell Chassis Storage Virtual Disk Health Poll Based Unit Periodic
Monitor
Dell Chassis Storage Controller Enclosure Internal Physical Disk
Dell Chassis Storage Internal Physical Disk Primary Health Periodic
Status Poll Based Unit Monitor
Dell Chassis Storage Internal Physical Disk Predictive Failure | pgriodic
Health Status Poll Based Unit Monitor
Dell Chassis Storage Controller Enclosure External Physical Disk
Dell Chassis Storage External Physical Disk Primary Health Periodic

Status Poll Based Unit Monitor
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Object Unit Monitor

Dell Chassis Storage External Physical Disk Predictive Failure | pgriodic
Health Status Poll Based Unit Monitor

Rules

The following section lists the rules specific to the Dell Chassis monitoring feature.

Dell Systems Event Processing Rules

The Dell EMC Server Management Pack Suite processes rules from Chassis traps.

Chassis devices

All informational, warning, and critical SNMP traps for the chassis devices have a corresponding SNMP trap rule.

Each of these rules are processed based on the following criteria:

Source Name = "DRAC/CMC name or IP"
OID = Actual trap ID of the DRAC/CMC SNMP trap event
Data Provider = SNMP trap

NOTE: Informational alerts are turned off by default. To receive these alerts, import informational alerts management
pack.

®

Performance Collection Rules

In the OpsMgr console, click Monitoring > Dell > Performance and Power Monitoring Views to view the performance information that is
collected from Dell Chassis. By default this feature is disabled, to enable the feature, see Enabling Chassis Performance Collection Rule.

The performance collection rules collect information on Chassis Power Consumption.

Enabling Chassis Performance Collection Rule

To enable Chassis performance collection rule:

Launch the OpsMgr console, and click Authoring.

Click Rules and search for De11 Performance in the Look for: field.

Right-click Dell Performance: Chassis Power Consumption collection rule (Watts).
Select Overrides > Override the Rule > For all objects of class.

Select Enabled and set the Override Value to True.

Under Management Pack, either select a management pack created from the Select destination management pack: drop-down
menu or create a new management pack by clicking New...

[©) I N "N G N O ]

To create a new management pack:

a Click New...
The Create a Management Pack screen is displayed.
b Provide a name for the management pack in the Name field and click Next.
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For information on creating a management pack, see the OpsMgr documentation at technet.microsoft.com.
¢ Click Create.

The management pack you created is selected in the Select destination management pack: drop-down menu.
d Click Apply.

Tasks

Tasks are available in the Tasks pane of the OpsMgr console. When you select a device or a component, the relevant tasks appear in the
Tasks pane.

Task summary

Performing tasks using Dell Chassis

Following table provides a summary of the tasks that you can perform using the Dell chassis:

Table 30. Tasks using Dell Chassis

Task Description

Check Node Interfaces Checks if the selected Dell CMC device and its corresponding
interface; WS-MAN or SNMP is reachable or non-reachable.

Launch Dell CMC Console Launches the CMC console.

Dell Chassis tasks

Check Node Interfaces

The Check Node Interfaces task checks if the selected Dell CMC device and its corresponding interface are reachable or non-reachable.
To check the node interfaces:

1 Inthe OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.
2 Select the desired Dell CMC in any of the Dell Diagram Views, State Views, or an alert in the Alerts Views.
3 In the Tasks pane, select Dell CMC Tasks > Check Node Interfaces.

Launch Dell CMC console

To launch the CMC console.

1 Inthe OpsMgr console, navigate to Dell Diagram Views, State Views, or Alerts Views.
2 Select the CMC device in any of the Diagram Views or State Views or an alert in the Alerts Views.
3 Inthe Tasks pane, select Dell CMC Tasks > Launch Dell CMC Console.
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Chassis Modular Server Correlation Feature

Chassis Modular Server Correlation feature supports:

Correlation of discovered Modular Servers using the licensed or license-free monitoring feature with Chassis slots.

@l NOTE: CMC slot discovery is disabled by default. Hence, enable CMC slot discovery for the correlation feature to work.
Correlation of Chassis Shared Storage components with Dell servers.

@l NOTE: Imports Chassis detailed monitoring for the correlation of chassis shared components with Dell servers.

Discoveries by the chassis modular server correlation

feature

Table 31. Chassis modular server correlation feature discoveries.

Discovery Object

Description

Dell CMC chassis to modular server correlation discovery

Discovers the correlation between the CMC chassis and the Dell
modular systems.

Dell chassis storage to blade server correlation discovery

Discovers the correlation between chassis shared components with
Dell servers discovered through the Server and Rack Workstation
Monitoring.
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Feature Management Dashboard

The Feature Management Dashboard provides facilities for the configuration of the Dell EMC Server Management Pack Suite monitoring
features to monitor the various Dell systems—Dell servers, Dell Precision Racks, Dell Remote Access Controllers (DRAC), PowerEdge FX2/
FX2s, PowerEdge VRTX, PowerEdge M1000e, and integrated DRAC (iDRAC). The Feature Management Dashboard provides the following
monitoring features:

Server and Rack Workstation Monitoring Feature

Server and Rack Workstation Monitoring (Licensed) Feature
DRAC Monitoring Feature

Chassis Monitoring Feature

Chassis Modular Server Correlation Feature

Topics:

Discovery by Dell Feature Management Pack
Tasks

Discovery by Dell Feature Management Pack

Table 32. Dell Feature Management Pack Discovery.

Discovery Object Description

Dell Feature Management Host Discovery Populates the dashboard if the management server is the feature
management pack host. The management server on which the Dell
EMC Server Management Pack Suite is installed first, is selected as
the feature management pack host.

Tasks

Tasks are available in the Tasks pane of the OpsMgr console. When you select a device or a component, the relevant tasks appear in the
Tasks pane.

Feature Management Tasks

The following table lists the tasks available on the Feature Management Dashboard. Some tasks listed in the Feature Management Tasks
table appear only after you have imported a particular monitoring feature.
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®| NOTE:

feature.
Management Dashboard.

contents.

Table 33. Feature Management Tasks.

In the Event log, ignore the errors pertaining to reimporting of existing management packs. These errors occur when Feature
Management Dashboard reimports all the dependent management packs that were already imported while importing a monitoring

Wait for a task to complete (view the state update change in the dashboard) before launching another task using the Feature

The Refresh dashboard task may not update the dashboard immediately; it might take a few minutes to update the dashboard

Tasks

Description

Chassis Modular Server Correlation

Import Chassis Modular Server Correlation Feature

Imports the chassis modular server correlation feature.

Refresh Dashboard

Updates the Feature Management Dashboard.

Refresh Node Count

Updates the node count.

Remove Chassis Modular Server Correlation Feature

Removes the chassis modular server correlation monitoring
feature.

Upgrade Chassis Modular Server Correlation Feature

Upgrades to the latest version of the chassis modular server
correlation feature.

Chassis Monitoring

Import Chassis Monitoring Detailed Feature

Imports the chassis detailed monitoring feature.

Import Chassis Monitoring Scalable Feature

Imports the chassis scalable monitoring feature.

Refresh Dashboard

Updates the Feature Management Dashboard.

Refresh Node Count

Updates the node count.

Remove Chassis Monitoring Feature

Removes the chassis monitoring feature (both scalable and
detailed monitoring feature).

Set to Chassis Detailed Monitoring Feature

If the Scalable feature is running on the system, the Feature
Management Dashboard switches from the Scalable feature to
the Detailed feature.

On upgrading from a previous version, run this task to use the
latest version for this monitoring feature.

Set to Chassis Scalable Monitoring Feature

If the Detailed feature is running on the system, the Feature
Management Dashboard switches from the Detailed feature to
the Scalable feature. On upgrading from the previous version,
run this task to use the latest version for this monitoring feature.

DRAC Monitoring

Import DRAC Monitoring Feature

Imports the DRAC monitoring feature.

Refresh Dashboard

Updates the Feature Management Dashboard.

Refresh Node Count

Updates the node count.

Remove DRAC Monitoring Feature

Removes the DRAC monitoring feature.

Upgrade DRAC Monitoring Feature

Upgrades to the latest version of the DRAC monitoring feature.
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Tasks

Description

Server and Rack Workstation Monitoring

Enable Agent Proxying

Enables agent proxying for Dell servers.

Import Detailed Feature

Imports the Detailed feature of the Server and Rack Workstation
Monitoring feature.

Import Scalable Feature

Imports the Scalable feature of the Server and Rack Workstation
Monitoring feature.

Refresh Dashboard

Updates the Feature Management Dashboard.

Refresh Node Count

Updates the node count.

Remove Monitoring Feature

Removes the Server and Rack Workstation Monitoring feature.

Set as Preferred Monitoring Method

This task enables the Server and Rack Workstation Monitoring
feature as the preferred monitoring method for the Servers and
Rack Workstations, when the Servers and Rack Workstations in
the setup are monitored through both the Server and Rack
Workstation Monitoring feature, and the Server and Rack
Workstation Monitoring (Licensed) feature.

Set Informational Alerts Off

Informational alerts are turned off when the Server and Rack
Workstation Monitoring Scalable Monitoring is in use.

Set Informational Alerts On

Informational alerts are turned on when the Server and Rack
Workstation Monitoring Scalable Monitoring is in use.

Set to Detailed Feature

If the Scalable feature is running on the system, the Feature
Management Dashboard switches from the Scalable feature to
the Detailed feature.

On upgrading from the previous version, run this task to use the
latest version for this monitoring feature.

Set to Scalable Feature

If the Detailed feature is running on the system, the Feature
Management Dashboard switches from the Detailed feature to
the Scalable feature.

On upgrading from the previous version, run this task to use the
latest version for this monitoring feature.

Server and Rack Workstation Monitoring (Licensed)

Associate Run-As Account

This task associates the Run As Account used for SMASH
discovery with all Dell Server objects, required for health
monitoring. For more information, see Associate Run-As Account
Task.

Enable Agent Proxying

Enables agent proxying for Dell servers running the supported
iISM version and also triggers discovery of these servers.

Enable Event Auto-Resolution

Enables the Event Auto-Resolution feature.

Disable Event Auto-Resolution

Disables the Event Auto-Resolution feature.

Refresh Dashboard

Updates the Feature Management Dashboard.

Refresh Node Count

Updates the node count.
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Tasks

Description

Remove Monitoring Feature (Licensed)

Removes the Server and Rack Workstation Monitoring
(Licensed) feature.

Set as Preferred Monitoring Method (Licensed)

This task enables the Server and Rack Workstation Monitoring
(Licensed) feature as the preferred monitoring method for the
Servers and Rack Workstations, when the Servers and Rack
Workstations in the setup are monitored through both, Server
and Rack Workstation Monitoring feature, and Server and Rack
Workstation Monitoring (Licensed) feature.

Set to Detailed Feature (Licensed)

If the Scalable feature is running on the system, the Feature
Management Dashboard switches from the Scalable feature to
the Detailed feature.

On upgrading from the previous version, run this task to use the
latest version for this monitoring feature.

Set to Scalable Feature (Licensed)

If the Detailed feature is running on the system, the Feature
Management Dashboard switches from the Detailed feature to
the Scalable feature.

On upgrading from the previous version, run this task to use the
latest version for this monitoring feature.
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Licensing for Dell EMC Server Management Pack
Suite

License Information

The Server and Rack Workstation Monitoring (Licensed) feature in Dell EMC Server Management Pack Suite for OpsMgr is licensed.
Information on the process for obtaining software licenses is as follows.

Licenses
Licenses must be purchased based on the desired number of nodes you want to monitor.
Purchasing Licenses

To leverage the Server and Rack Workstation Monitoring (Licensed) feature functionalities, you must purchase licenses (based on the
desired number of managed nodes) from Dell. The order confirmation and license is sent as an e-mail to the e-mail ID that you have
specified in My Account — Dell. The purchased licenses are also downloadable from the Dell Digital Locker portal at http://www.dell.com/
support/licensing. If you are unable to download your licenses, email Dell Customer Support by going to www.dell.com/support/incidents-
online/in/en/indhs1/email/order-support.

Checking License Usage

A Console requires a license to manage PowerEdge servers. To view the PowerEdge servers managed by Server and Rack Workstation
Monitoring (Licensed) feature for OpsMgr: In OpsMgr, select Monitoring > Dell > Feature Management Dashboard

The number of nodes consumed is displayed in the Total Node Count column.
Change from Dell Server Management Pack Suite Version 6.0 for OpsMgr

Until Dell Server Management Pack Suite Version 6.0 for OpsMgr; Dell Connections License Manager (DCLM) was required to manage
licenses. For Dell Server Management Pack Suite Version 6.1 and later, you do not require DCLM.

There is no longer a license-count enforcement post DCLM being removed. You can continue to manage the PowerEdge servers using
Server and Rack Workstation Monitoring (Licensed) feature for OpsMgr even after reaching or exceeding the limit of the number of
licenses purchased from Dell. The Checking License Usage section presents the steps to help you determine the number of nodes being
managed to ensure that you have the appropriate number of license entitlements from Dell Inc. Purchase additional licenses if the number
of nodes you are managing exceeds the number of licenses you have purchased.

Licenses that you have purchased for Dell Server Management Pack Suite Version 6.0 for OpsMgr are still applicable to Dell Server
Management Pack Suite Version 6.1 and later for OpsMgr. So, after a product upgrade, the earlier license is still valid and you can still
manage servers per the permissible count mentioned in the previously purchased license.

License terms and conditions

The licenses are also governed by the same license terms as the product EULA. You can get the latest updated license terms at dell.com/
learn/us/en/uscorp1/terms?s=corp. For further queries, contact Dell Sales and Support.
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Related documentation and resources

This chapter gives the details of documents and references to help you work with Dell EMC Server Management Pack Suite.

Topics:

Microsoft guidelines for performance and scalability for Operations Manager
Other documents you may need

Accessing Documents From Dell Support Site

Contacting Dell

Microsoft guidelines for performance and scalability
for Operations Manager

For optimal performance, deploy device-specific Server Management Pack Suite on different management servers.
For information on Microsoft’s recommendations for scalability, see the Microsoft website at technet.microsoft.com.

0]

NOTE: Make sure that the Autogrow option is enabled in Operations Manager Data Warehouse and/or Database for improved
performance.

Other documents you may need

Besides this User's Guide, you may need to see the following guides available at dell.com/support/home.

Integrated Dell Remote Access Controller with Life Cycle Controller User’'s Guide
IDRAC Service Module Installation Guide

Dell OpenManage Installation and Security User's Guide

Dell OpenManage Server Administrator Installation Guide

Dell OpenManage Server Administrator Compatibility Guide

Dell OpenManage Server Administrator CIM Reference Guide

Dell OpenManage Server Administrator Messages Reference Guide

Dell OpenManage Server Administrator Command Line Interface User's Guide
Dell OpenManage Baseboard Management Controller Utilities User’s Guide
Dell OpenManage Port Information Guide

Dell Lifecycle Controller User’s Guide

Dell Chassis Management Controller User's Guide

Dell Chassis Management Controller for Dell PowerEdge VRTX User’s Guide
Dell Chassis Management Controller for Dell PowerEdge FX2 User’s Guide

The Dell Systems Management Tools and Documentation DVD contains a release notes file for Server Administrator and additional release
notes files for other systems management software applications found on the DVD.
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Accessing Documents From Dell Support Site

To access the documents from Dell Support site:

Go to dell.com/support/manuals.
In the Tell us about your Dell system section, under No, select Choose from a list of all Dell products and click Continue.
In the Select your product type section, click Software and Security.

DN -

In the Choose your Dell Software section, click the required link from the following:
Client System Management
Enterprise System Management
Remote Enterprise System Management
Serviceability Tools
5  To view the document, click the required product version.

(D | NOTE: You can also directly access the documents using the following links:

For Enterprise System Management documents — dell.com/openmanagemanuals
For Remote Enterprise System Management documents — dell.com/esmmanuals
For Serviceability Tools documents — dell.com/serviceabilitytools

For Client System Management documents — dell.com/OMConnectionsClient

For OpenManage Connections Enterprise systems management documents — dell.com/
OMConnectionsEnterpriseSystemsManagement

For OpenManage Connections Client systems management documents — dell.com/OMConnectionsClient

Contacting Dell

(D | NOTE: If you do not have an active Internet connection, you can find contact information on your purchase invoice, packing slip,
bill, or Dell product catalog.

Dell provides several online and telephone-based support and service options. Availability varies by country and product, and some services
may not be available in your area. To contact Dell for sales, technical support, or customer service issues:

Visit dell.com/support.
Select your support category.
Verify your country or region in the Choose a Country/Region drop-down menu at the top of page.

DN NN -

Select the appropriate service or support link based on your need.
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Appendix A—Issues and resolutions

Issues and resolutions

The following table lists the known issues, resolutions, and where the issues are applicable:

Table 34. Issues and resolutions

Issue

Resolution

Applicable To

Discovery through iSM using WMI fails
when a managed node is running
Windows Server 2008 R2 and the
Management server is running OpsMgr
2012 R2.

Ensure that you have installed Windows
Management Framework version 4.0.

On the management server, apply the
Microsoft Security update for Update Rollup 7
(or later) for System Center 2012 R2
Operations Manager. For more information,
see Support.microsoft.com.

You can install the following updates from
Catalog.update.microsoft.com. Ensure that
you install these updates in the order listed
below:

1 Update Rollup for Microsoft System
Center 2012 R2 - Operations Manager
Server

2 Update Rollup for Microsoft System
Center 2012 R2 - Operations Manager
Console

Discover the server running Windows Server
2008 R2 operating system.

Server and Rack Workstation Monitoring
(Licensed) Feature.

This issue pertains to discovery through ASM
using WMI only.

Set as the Preferred Monitoring
Method task fails to remove the
duplicate objects in either or both of the
following scenarios:

Correlation of the Dell Modular
servers with chassis slots

Monitoring FM servers

To remove the duplicate objects, perform the
following steps:

1 Navigate to the Feature Management
Dashboard, select the Chassis Modular
Server Correlation feature, and then
click Remove Chassis Modular Server
Correlation Feature from the Dell
Monitoring Feature Tasks menu in the
right pane. Re-import the Chassis
Modular Server Correlation. You will
now be able to use the Set as Preferred
Monitoring Method task functions to
remove the duplicate objects.

2 If the task is still failing, then perform the
following steps:

a Disable the Dell CMC Chassis to
the Modular Blade Server
Correlation Discovery object
discovery.

Chassis Modular Server Correlation Feature
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Issue

Resolution

Applicable To

b Disable the object discovery
corresponding to the method used
for discovering the modular
servers. For example: If the
duplicate object is discovered
through OMSA, then navigate to
Authoring > Object Discoveries
and then search for Dell
Server Discovery; whichis
targeted at the Windows
Computer and disable the
Discovery attribute for that object.

@® | NOTE: In case the
duplicate object has been
created for FM servers,
then disable the following
object discoveries for FM
servers:

Dell FM Server

Agent-based
Discovery

Dell FM Server
Agent-free
Discovery

Dell FM Server
iSM Discovery

3 Run the following command from the
Operations Manager Shell:
Remove-
SCOMDisabledClassInstance

® NOTE: This step may take
up to 48 hours to complete.

The Agent proxy not enabled alerts are
displayed in the Active Alerts list for the
Dell servers discovered through iSM.

To resolve this issue, perform the following
steps:

1 Navigate to the Feature Management
Dashboard, and click Server and Rack
Workstation Monitoring (Licensed).

2 Inthe right pane, under Dell Monitoring
Feature Tasks, click Enable Agent
Proxying.

The Run Task - Enable Agent Proxying
window is displayed.

3 Click Override, and then click the field
under New Value for the AutoResolve
Warnings/Errors parameter and set the
value as True.

4 Now click Override and then click Run.
Close the task status window.

Clear the existing alerts from the active alerts
list. These alerts will no longer be displayed
for future discoveries.

Server and Rack Workstation Monitoring
(Licensed) Feature

In the Diagram View for Dell network
devices, the basic attributes are not
displayed for the Dell DRAC and chassis
objects.

To resolve this issue, you can view the
detailed set of attributes by clicking the
objects in the State View.

Chassis Monitoring Feature
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Issue

Resolution

Applicable To

Server Modules and Chassis Slot
Summary Information are not visible
under CMC.

Make sure that OpenManage Server
Administrator (OMSA) or DRAC tools are
installed on the management server
managing the CMC.

Make sure that you have configured the
Run As Account for CMC devices and
associated them with "Dell CMC Login
Account",

Make sure that Dell CMC Slot Discovery
and rules are enabled from the Authoring
Pane of the OpsMgr console.

Chassis Monitoring Feature

Errors while running the Repair option in
Dell EMC Server Management Pack
Suite from the Add/Remove Programs
or Uninstall or change a program
window.

Use the Repair option in the installer. For
more information, see "Using The Repair
Option In The Installer" section of the Dell
EMC Server Management Pack Suite Version
/7.0 for Microsoft System Center Operations
Manager Installation Guide.

Dell EMC Server Management Pack Suite

If there is a delayed response while
discovering a chassis, then the latest
information from the device is not
updated, the Script Timeout Error is
generated or the log files in the Temp
folder are not cleared.

Increase the Seript Timeout value on the
Override Properties screen for the CMC
device which is experiencing a delayed
response. For more information on Overrides,
see the OpsMgr documentation at
Technet.microsoft.com.

Chassis Monitoring Feature

Feature management host server health
service is nonfunctional.

If the selected management server has
stopped functioning, the executed Feature
Management task fails. In such an instance,
where the selected management server is
corrupt or the health service cannot be
obtained, decommission the management
server to remove stale objects. For more
information, see Technet.microsoft.com/en-
us/library/hh456439.aspx.

Select a management server from the
remaining management servers, and override
the FMPHostFQDN of Feature Management
Host Discovery.

Dell EMC Server Management Pack Suite

Dell OM: Server and its component
health computation failed alert is
displayed under Monitoring > Alerts
Views > Server Alerts on the console.

Manually associate the Run As Account for
monitoring Dell server. For more information,
see Associating Run As Account for
monitoring a Dell Server using the Server and
Rack Workstation Monitoring (Licensed)
Feature.

Server and Rack Workstation Monitoring
(Licensed) Feature

Known limitations

Table 35. Known limitations.

Limitation

Applicable to

Dell MP, Power Control, and LED tasks use only the default
credentials. When you create a new task in the Authoring pane and

Dell EMC Server Management Pack Suite
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Limitation

Applicable to

view it, you can see the username and the password you specified.

The credentials are not hidden when you view the task.

While using health explorer, some unit monitors in Dell EMC Server
Management Pack Suite (under Sensors and OpenManage
Services instances) may display a green status though the sub-
instance does not exist. This is because unit monitors cannot have
an Unavailable state when the target class is present and the unit
monitor has been executed.

Dell EMC Server Management Pack Suite

Intrusion unit monitor status under sensors is only for chassis and
does not include health of bezel intrusion.

Dell EMC Server Management Pack Suite
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Appendix B

Creating a Simple Authentication Run As Account

Log on to OpsMgr as an administrator for the OpsMgr Management Group.
On the OpsMgr console, click Administration.
Click Run As Configuration > Accounts.

DN -

Right-click Accounts, and then click Create Run As Account.

The Create Run As Account Wizard screen is displayed.

Click Next.

From the Run As account type: drop-down menu, select Simple Authentication.
Provide a display name in the Display name: text box.

Provide a brief description in the Description (optional): text box and click Next.

© 00 N O O

On the Credentials screen provide the iDRAC login credentials for the systems you want to discover using the Server and Rack
Workstation Monitoring (Licensed) feature.

10 Click Next.
1 Select the Less secure or More secure option as appropriate.
For more information, see the OpsMgr documentation at technet.microsoft.com/en-us/library/hh321655.aspx.

®

NOTE: If the iDRAC login credentials are different for each of the systems, create a separate Run As Account for each
of them.

12 Click Create.
13 After the Run As Account has been created, click Close.

Associating a Run As Account for monitoring a Dell
server using the Server and Rack Workstation
Monitoring (Licensed) feature

For monitoring the Dell server, the Run As account used to discover it must be associated with the Dell server in the SMASH Device
Monitoring Profile. The management pack performs the association automatically. But sometimes, you have to manually associate the Run
As account.

To manually associate the Run As account in the SMASH Device Monitoring Profile:

1 Launch OpsMgr, and click Administration.

2 In the Administration pane, browse to Run As Configuration > Profiles.

3 From the list of available profiles, right-click SMASH Device Monitoring Profile and click Properties.
The Introduction screen is displayed.

4  Click Next.

The Specify the Run As profile's general properties screen is displayed.
5 Click Next.

The Run As Accounts screen is displayed.
6  Click Add.

The Add a Run As Account screen is displayed.
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7 Select the run as account used to discover the Dell server from the Run As Account: drop-down list.

®| NOTE: If you are using multiple Run As Account to discover devices, associate each device with its associated Run As
account.

8  Click. A selected class, group, or object and add the association for the server in the SMASH Monitoring Profile.
Click Select > Class option, use Dell server as the selection.
Click Select > Group option, use the group containing the Dell server objects as the selection.
Click Select > Object option, use the individual Dell server object as the selection.

9  Click OK.
10 Click Save and Close.
(D | NOTE: If the Run As Account association is not successful, the alert Dell OM: Server and its component health computation

failed is displayed under Monitoring > Alerts View > Server Alerts on the console.

Severity Level Indicators

The following table lists the icons that indicate the severity levels of the discovered Dell devices on the OpsMgr console.

Table 36. Severity Level Indicators.

Severity Level

Normal/OK — The component is working as expected.

Warning/Noncritical — A probe or other monitoring device has detected a reading for the component that is
above or below the acceptable level. The component may still be functioning, but it could fail. The component may
also be functioning in an impaired state.

AL

Critical/Failure/Error — The component has either failed or failure is imminent. The component requires
immediate attention and may need to be replaced. Data loss may have occurred.

The health status is not applicable for the specific component.

The service is unavailable.

®[0]&

Associate Run As Account task — Server and Rack
Workstation Monitoring (Licensed) feature

Associate Run As Account task associates the Run As Account used for SMASH discovery with all Dell Server objects, required for health
monitoring. This task is available as an option for performing object-level association.

A

WARNING: Perform the Associate Run As Account task only if necessary. This task affects the configuration of all Dell Server
objects. Dell Server Run As Account Association unit monitor automatically performs the object-level association.
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Appendix C - Enabling External Program Tasks

For tasks provided by the Dell EMC Server Management Pack Suite that launch external programs have to be installed in the default
location. Create new tasks to launch the application if the program is not installed in the default location.

Topics:

Creating Advanced Power Control and LED Identification Tasks
Creating a Launch License Manager task

Creating Advanced Power Control and LED
|dentification Tasks

Advanced power control and LED identification tasks use the default BMC credentials and install path (C:\Program Files\Del\SysMgt
\bmc).

If the systems deviate from the default BMC credentials and install path, install BMU 2.0 or later on the management server and create
new console tasks.

For the following steps, create a task and set the password in plaintext. If BMC is not installed on management server,
the OpsMgr Console may display an error with the entire command in a dialog box, and reveal the password. If you export the
created override management pack containing this task to a disk, you can open the exported management pack in a common text
editor or OpsMgr Authoring Console and the view the password in plain text. Create a task only if necessary and consider the
security aspects before you proceed.

To create a task:

1 Launch the OpsMgr console and click Authoring.

2 Inthe Authoring pane, right-click Tasks under Management Pack Objects, and select Create new task.
Create Task Wizard scree is displayed.
In the Select a Task Type screen, select Command line under Console Tasks.

4  Select the destination management pack and click Next.
Enter Task name, Description, and select Dell Windows Server as the Task target and click Next.
The Command-Line screen is displayed.

6  Enter the path of the application ipmitool.exe (the path where BMU was installed on the management server) in the Application field.
For example, C: \Program Files\Dell\SysMgt\bmc\ipmitool.exe. For the two LED identification tasks, the application
pathis C:\Program Files\Dell\SysMgt\bmc\ipmish.exe (default BMU path may differ based on the operating system
language).

7 For power control tasks, in the Parameters field, enter the command-line parameters in the following format:

Enter -I lanplus -H and then choose the Remote Access IP with IPMI capability from the drop-down menu.
Enter -U <username> -P <password> -k <kgkey> <IPMI Task String>
Replace <IPMI Task String> with one of the following options:

power status (for Check Power Status task)

power on (for Power On task)
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power soft (for Power Off Gracefully task)
power off (for Force Power Off task)

power cycle (for Power Cycle task)

power reset (for Power Reset task)
identify on (for LED ldentification On task)
identify off (for LED ldentification Off task)

Example:

-I lanplus -H $Target/Property[Type="Dell.WindowsServer.Server"]/RemoteAccessIP$ -U root -P
<password> -k <kgkey> power status

8  For LED on or off tasks, enter the command-line parameters in the following format:
Enter -ip and choose the Remote Access IP with IPMI capability from drop-down menu.
Enter -u <username> -p <password> -k <kgkey> <IPMI task string>.

9  Click Create to create the task and repeat this procedure for each new BMC task.

Creating a Launch License Manager task

Launch the License Manager task uses the default Dell License Manager (DLM) install path (%sPROGRAMFILES(X86)%\Dell\SysMgt
\LicenseManager\Dell.DimUl.exe or %PROGRAMFILES%\Del\SysMgt\LicenseManager\Dell. DimUl.exe), that cannot be modified.

If the systems deviate from this, install DLM on the management server and create new console tasks in the Authoring pane targeted on
DLM for Dell Server.

To create a task:

Launch OpsMgr console, and click Authoring.

In the Authoring pane, right-click Tasks under Management Pack Objects, and select Create a New Task.
In the Task Type screen, select the Command line under Console Tasks.

Select the destination management pack, and click Next.

o DN

Enter Task name, Description, and set the Task Target with one of the following:
Dell Windows Server—for Server and Rack Workstation Monitoring feature
Dell Server—for Server and Rack Workstation Monitoring (Licensed) feature)
Dell iDRACY or iDRACS8 for DRAC Monitoring

6  Click Next.

The Command Line screen is displayed.

7 Enter the path of the application Dell. DimUl.exe (the path where DLM was installed on the management server) in the Application
field.

For example, C: \Program Files\Dell\SysMgt\LicenseManager\Dell.DImUI.exe —default DLM path may differ
based on the operating system language.

8  Click Create to create the task, and repeat this procedure for each new DLM task.
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