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As part of an improvement effort, revisions of the software and hardware are periodically released. Some functions that are
described in this document are not supported by all versions of the software or hardware currently in use. The product release
notes provide the most up-to-date information about product features. Contact your service provider if a product does not
function properly or does not function as described in this document.

Where to get help
Support, product, and licensing information can be obtained as follows:

● Product information

For product and feature documentation or release notes, go to the PowerStore Documentation page at https://
www.dell.com/powerstoredocs.

● Troubleshooting

For information about products, software updates, licensing, and service, go to https://www.dell.com/support and locate
the appropriate product support page.

● Technical support

For technical support and service requests, go to https://www.dell.com/support and locate the Service Requests page.
To open a service request, you must have a valid support agreement. Contact your Sales Representative for details about
obtaining a valid support agreement or to answer any questions about your account.

Preface

4 Additional Resources
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Monitoring Your System Overview
This chapter includes:

Topics:

• Overview

Overview
This document describes the functionality available in the PowerStore Manager to monitor, and optimize various PowerStore
appliances.

Monitoring features

PowerStore Manager provides the following features and functionality to monitor your system:

● Events to notify when there are changes in the system.
● Alerts to inform you that an event occurred that requires your attention.
● Capacity charts display current capacity usage of a PowerStore cluster and resources.
● Performance charts indicate the system health so you can anticipate problems before they occur.

Optimizing features and functionality

As you monitor the system, alert notifications provide a mechanism to respond to the issue and reduce troubleshooting times.

Understanding how the system capacity is being used can:

● Alert you to the resources that are the top consumers of storage space.
● Help you to balance the load across your available storage.
● Indicate when you may need to add more storage to your cluster.

Finally, should an event occur that requires further troubleshooting, PowerStore has a mechanism for collecting support
materials which helps analyze and resolve the issue.
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Managing Alerts
This chapter includes:

Topics:

• Alerts and events
• Monitor alerts
• Configure email notification preferences
• Temporarily disable alert notifications
• Configure SNMP
• Critical Information Banner
• System Checks
• Remote logging

Alerts and events
Events provide information about changes to the system. Alerts are events that require attention. Most alerts indicate that
there is a problem with the system. The system displays ongoing alerts in the dashboard on the Alerts card. You can also view
and monitor alerts for individual objects in a cluster such as an appliance, storage resource, or virtual machine, from the Alerts
card on the details page of the object.

Clicking the description of an alert reveals additional information about the alert.

The severity of the alerts are:

● Critical: An error has occurred that has a significant impact on the system and must be remedied immediately. For example,
a component is missing or has failed and recovery may not be possible.

● Major: An error has occurred that may have an impact on the system and should be remedied as soon as possible. For
example, the last synchronization time for a resource does not match the time that its protection policy indicates.

● Minor: An error has occurred that you should be aware of but does not have a significant impact on the system. For
example, a component is working, but its performance may not be optimum.

● Info: An event has occurred that does not impact system functions. No action is required. For example, new software is
available for download.

When you view alerts, you can sort the alerts by the columns and filter the alerts by the column categories.

To review events that do not rise to the level of an alert, go to Monitoring > Events.

Acknowledged alerts

When a user acknowledges an alert, the alert is hidden from the default view on the Alerts page. Acknowledged alerts can be
viewed by selecting the acknowledged check mark from the Acknowledged filter dialog box.

NOTE: Acknowledging an alert does not indicate that the issue is resolved. Acknowledging an alert only indicates that the

alert has been acknowledged by a user.

Cleared alerts

When an alert is no longer relevant or is resolved, the system clears the alert with no user intervention. Cleared alerts are hidden
from the default view on the Alerts page and can be viewed by selecting the cleared check mark from the Cleared filter dialog
box.
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Monitor alerts
PowerStore Manager provides alert views at multiple levels, from the overall cluster to individual objects.

About this task

The alerts page is automatically refreshed every 30 seconds.

Steps

1. Find the alert view that you are interested in.
● To view alerts at the cluster level, select View All on the Alerts card in the dashboard or select Notifications > Alerts

from any screen.
● To view alerts for an individual object, such as a volume, select the alert icon in the table row corresponding to the object

in the table view for that object type.

2. From the alerts page, you can:

● Show or hide acknowledged and cleared alerts.
● Filter the alert list by any combination of severity, type, name, or description.
● Choose the columns to be displayed in the table.
● Export the alerts to a .csv file.

● Refresh the table.

3. Click the description of an alert to see more information, including its impact on the system, timeline, suggested remediation,
and other associated events.

NOTE: The Associated Events table can display only ten events. To view the full list of events associated with a

resource, go to the Events tab and filter the displayed events by the resource name.

4. Click Acknowledge to indicate that you have seen the alert. When you acknowledge an alert, the system removes the alert
from the alert list unless Show acknowledged alerts is selected.

Configure email notification preferences
You can configure your system to send alert notifications through email using an SMTP server.

About this task

Use this procedure to configure an SMTP server and email recipients. For more information about SMTP server settings, see the
context-sensitive help entry for this feature.

Steps

1. Select the Settings icon, and then select SMTP Server in the Networking section.

2. To access the SMTP server settings, change the status to Enabled.

3. Add the SMTP server address and the email address that notifications should be sent from and click Apply.

(Optional) Send a test email to verify that the SMTP server is set up correctly.

4. Select the Settings icon, and then select Email Notifications in the Users section.

5. To add email recipients, click Add in the Email Subscribers area and type the email address that you want to send alert
notifications to.

When you add an address, you can select the severity level of the alert notifications that are sent to that address.

(Optional) To verify whether email addresses are entered correctly, select the target email addresses and then click Send
Test Email.
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Temporarily disable alert notifications
You might want to disable alert notifications during specific procedures, for example, during a software upgrade or a support
procedure.

Steps

1. On the Settings page, select Disable Support Notifications in the Support section.

2. Select the appliance for which you want to suspend notifications and click Modify.

3. In the Modify Maintenance Mode slide-out panel, select the Enable Maintenance Mode option.

4. Specify how many hours to suspend notifications (up to 48 hours).

NOTE: After the specified suspension period expires, alert notifications are automatically resumed.

5. Click Apply.

You can confirm the end time for maintenance mode in the table.

Configure SNMP

About this task

You can configure your system to send alert information to up to 10 designated SNMP Managers (trap destinations).

NOTE: Only notifications are supported.

The authoritative Local Engine ID used for SNMPv3 messages is given as a hexadecimal string. It is discovered and added
automatically.

NOTE: To verify the Local Engine ID select Settings, and under Networking, select SNMP. The Local Engine ID

appears under Details.

Using PowerStore Manager, do the following:

Steps

1. Select Settings and, under Networking, select SNMP.
The SNMP card appears.

2. To add an SNMP Manager, click Add under SNMP Managers.
The Add SNMP Manager slide out appears.

3. Depending on the version of SNMP, configure the following information for the SNMP Manager:
● For SNMPv2c:

○ Network Name or IP address
○ Port
○ Minimal Severity Level of Alerts
○ Version
○ Trap Community String

● For SNMPv3
○ Network Name or IP address
○ Port
○ Minimal Severity Level of Alerts
○ Version
○ Security Level

NOTE: Depending on the security level selected, additional fields appear.

￭ For the level None, only Username appears.

￭ For the level Authentication only, Password and Authentication Protocol appear along with Username.

￭ For the level Authentication and privacy, Password, Authentication Protocol, and Privacy Protocol

appear along with Username.

○ Username
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NOTE: When the Security Level of None is selected, the username must be NULL. When a Security Level of

Authentication only or Authentication and privacy is selected, the username is the Security Name of the

SNMPv3 user sending the message. The SNMP username can contain up to 32 characters in length and include

any combination of alphanumeric characters (uppercase letters, lowercase letters, and numbers).

○ Password
NOTE: When a Security Level of either Authentication only or Authentication and privacy is selected, the

system determines the password.

○ Authentication Protocol
NOTE: When a Security Level of either Authentication only or Authentication and privacy is selected, select

either MD5 or SHA256.

○ Privacy Protocol

NOTE: When a Security Level of Authentication and privacy is selected, select either AES256 or TDES.

4. Click Add.

5. (Optional) To verify whether SNMP Manager destinations can be reached and the correct information is received, click Sent
Test SNMP Trap.

Critical Information Banner
A banner displays critical information for system users.

The information banner, which is displayed at the top of PowerStore Manager, displays information about global alerts to all
users logged into the system.

When only a single global alert is issued, the banner displays the alert's description. When there are multiple alerts, the banner
indicates the number of active global alerts.

The color of the banner matches the alert with the highest severity level as follows:

● Information alerts - blue (information) banner
● Minor/Major alerts - yellow (warning) banner
● Critical alerts - Red (error) banner

The banner disappears when the alerts are cleared by the system.

System Checks
The System Checks page enables you to initiate health checks on the overall system, independent of the system-issued alerts.

About this task

You can launch a system check prior to actions such as upgrade, to be able to intercept and resolve any issues prior to
upgrading the system.

The System Check table displays the following information:

Table 1. System check information 

Name Description

Item The health check item

Description The description of the health check result

Status The health check result (Passed/failed)

Category The health check category (Configured Resource/Hardware/Software Services)

Appliance The appliance for which the health check item was performed

Node The node for which the health check item was performed

You can add and remove filters to narrow the displayed results according to your needs.
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Steps

1. Under Monitoring, select the System Checks tab.

2. Click Run System Check.

Results

The system check results are listed in the table. Clicking a failed item reveals additional information about the check results.

Remote logging
The storage system supports sending audit log messages to a maximum of two hosts. The hosts must be accessible from
the storage system. Audit log message transfers can use a one-way authentication (Server CA Certificates) or an optional
two-way authentication (Mutual Authentication Certificate). An imported certificate applies to each remote syslog server that is
configured to use TLS Encryption.

To review or update remote logging settings, log into PowerStore and click Settings. In the Setting side bar, under Security,
select Remote Logging.

For more information on remote logging, refer to PowerStore Security Configuration Guide.
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Monitoring Capacity
This chapter includes:

Topics:

• About monitoring system capacity
• Capacity data collection and retention periods
• Capacity forecasting and recommendations
• Capacity data locations in PowerStore Manager
• Start monitoring capacity usage
• Data Savings features

About monitoring system capacity
PowerStore provides various current usage, and historical metrics. The metrics can help you monitor the amount of space that
is used by your system resources, and determine your future storage needs.

Capacity data can be viewed from the PowerStore CLI, REST API, and PowerStore Manager. This document describes how to
view this information from PowerStore Manager. Refer to the PowerStore Online Help for specific capacity metric definitions
and calculations.

Monitoring current usage capacity

You can use the PowerStore Manager, REST API, or CLI to monitor the current capacity usage for a cluster, and for
individual storage resources such as storage containers, volumes, file systems, and appliances. Also, with a PowerStore X
model implementation, you can view the capacity usage of a virtual machine and a virtual volume.

NOTE: Monitoring capacity metrics is enabled when an appliance is in Out Of Space (OOS) mode. This way it is possible to

monitor the amount of space freed as a result of deleting unused snapshots and storage resources.

Monitoring historical usage and forecasting

PowerStore capacity trending and predictive metrics are also collected for forecasting future storage needs of a cluster or
appliance. Also, the trending and predictive metrics can be shared with the Dell EMC Support Center when PowerStore is
configured with Support Assist. These metrics provide intelligent insight on how capacity is being used and help to predict
future capacity needs.

Capacity data collection and retention periods
Collection of capacity metrics is always enabled.

Current capacity data collection and retention periods

Capacity data for system resources is collected at 5 minute intervals and rolled up to 1 hour and 1-day aggregates.

The capacity charts refresh interval is set according to the selected granularity level as follows:

3
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Table 2. Capacity charts refresh intervals 

Granularity Level Refresh Interval

Last 24 hours 5 minutes

Last month 1 hour

Last 2 years 1 day

The following table displays the retention periods for each timescale and the resources to which they apply:

Table 3. Real-time capacity data retention periods 

Timescale Retention period Resources

5 minutes 1 day Cluster, appliances, volume groups, volumes, VVols, and virtual machines

1 hour 30 days Cluster, appliances, volume groups, volumes, VVols, and virtual machines

1 day 2 years Cluster, appliances, volume groups, volumes, VVols, and virtual machines

Historical capacity data collection and retention periods

Historical capacity is displayed once data collection begins. One year of capacity usage data is displayed in the charts, and the
data is retained for up to 2 years. Historical charts scroll automatically to the left when new data is available.

Capacity forecasting and recommendations
PowerStore uses historical capacity metrics to forecast when your appliance or cluster may run out of storage space, and to
provide recommendations on how to free up the system resources.

Capacity forecasting

There are three threshold levels used to forecast system capacity alerts. Thresholds are set by default and cannot be changed.

Table 4. Capacity alert thresholds 

Priority Threshold

Major 1 to 14 days until the appliance or cluster is full.

Minor 15 to 28 days until the appliance or cluster is full.

Okay 4+ weeks until the appliance or cluster is full.

Alerts appear in the appliance or cluster charts, and also in the Notifications > Alerts page.

Forecasting starts after 15 days of data collection for the cluster or appliance. Prior to 15 days an "Insufficient data to predict
time to full," message appears in the Physical Capacity area next to the chart. Forecasting includes data for up to one year, with
a two year retention period.

You can look at the capacity chart to get a graphic visualization of capacity forecast for the cluster. To open the capacity chart,
go to the Dashboard window and select the Capacity tab.
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Figure 1. Cluster capacity chart - forecasting

1. Selecting the Forcast option, you can see the mean predicted physical usage (for the next 7days).
2. Selecting the Forcast Range option, you can see the range of low-to-high predicted physical usage (for the next 7days).
3. Hovering the mouse over the forecast section of the capacity chart, you can see the values for mean predicted usage and

range of predicted usage.

Capacity recommendations

PowerStore also provides a recommended repair flow. The repair flow provides options to free up space on the cluster or
appliance. The Repair Flow options are provided in the Alerts panel and include the following:

Table 5. Capacity recommendations 

Option Description

Assisted
Migration

Provides recommendations of volumes, or volume groups to migrate from one appliance to another.
Migration recommendations are generated based on factors such as appliance capacity, and health. You
can also choose to manually migrate volumes, or volume groups, based on your own calculations, when your
cluster or appliance is approaching capacity.

Migration is not supported for file systems.

Migration is supported within a single cluster with multiple appliances.

Migration recommendations are provided in the PowerStore Manager after a Major threshold is met.
However, you can use the PowerStore Management REST API to review migration recommendations at
anytime.

Clean Up System Delete system resources that are no longer being used.

Add More
Devices

Purchase additional storage for your appliance.

Recommendations expire in 24 hours to ensure that the recommendation is always current.

Capacity data locations in PowerStore Manager
You can view capacity charts for PowerStore systems, and system resources from the PowerStore Manager Capacity cards
and views in the following locations:

Table 6. Capacity data locations 

For Access path

Cluster Dashboard > Capacity

Appliance Hardware > [appliance] opens the Capacity card.

Virtual Machine Compute > Virtual Machines > [virtual machine] opens the Capacity card.
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Table 6. Capacity data locations (continued)

For Access path

Virtual Volume (vVol) Compute > Virtual Machines > [virtual machine] > Virtual Volumes > [virtual volume]
opens the Capacity card.

Volume Storage > Volumes > [volume] opens the Capacity card.

Volume Family Storage > Volumes. Select the checkbox next to the volume and select More Actions >
View Topology. In the Topology view, select Capacity.a

Storage Container Storage > Storage Containers > [storage container] opens the Capacity card.

Volume Group Storage > Volume Groups > [volume group] opens the Capacity card.

Volume Group Family Storage > Volume Groups. Select the checkbox next to the volume group and select More
Actions > View Topology. In the Topology view, select Capacity.b

Volume Group member
(volume)

Storage > Volume Groups > [volume group] > Members > [member] opens the
Capacity card.

File System Storage > File Systems > [file system] opens the Capacity card.

NOTE: Only available with PowerStore T model appliances.

NAS Server Storage > NAS Servers > [NAS server] opens the Capacity card.

NOTE: Only available with PowerStore T model appliances.

a. Family Capacity displays all the space that the base volume, snapshots, and clones use. The Family Capacity space values
may include system snapshots that are used for replication, but do not appear in the volume topology diagram. As a result,
the Family Capacity space values may not match the objects in the topology.

b. Family Capacity displays all the space that the base volume group, snapshots, and clones use. The Family Capacity space
values may include system snapshots that are used for replication, but do not appear in the volume group topology
diagram. As a result, the Family Capacity space values may not match the objects in the topology.

Start monitoring capacity usage
You can start to evaluate your capacity usage and needs from the PowerStore Manager Dashboard > Capacity card.

Current capacity usage

The cluster capacity dashboard presents the current amount of storage being used, and the amount of available storage in the
cluster. When there is a risk to the capacity usage of a cluster, alerts are also in the Capacity area of the capacity dashboard.

Historical capacity usage and recommendations

You can use the historical chart to evaluate space utilization trends for the cluster, and review recommendations for your future
capacity storage requirements. You can view the historical data for the last 24 hours, month, or year. Also, print charts for
presentation, or export the data into a .CSV format for further analysis using your tool of choice.

Top consumers

The cluster capacity dashboard also presents which of the cluster resources are the top capacity consumers in the cluster. The
Top Consumer area provides a high-level summary of the capacity statistics for each resource. Once you have identified the
top consumers, you can further analyze to the resource level to review the capacity of a specific Volume, Volume group, Virtual
Machine, or File system.
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Data savings

Finally, the capacity dashboard shows you the Data Savings as a result of automated data efficiency features such as
deduplication, compression, and thin provisioning. Refer to Data Savings features for details.

Data Savings features
Data savings metrics are based on the automated inline data services that are provided with PowerStore.

The automated inline data services occur in the system before the data is written to the storage drives. The automated inline
data services include:

● Data reduction, which consists of deduplication and compression.
● Thin provisioning, which enables multiple storage resources to subscribe to a common storage capacity.

The drive usage that is saved by these data services results in cost savings and consistent, predictable high performance,
regardless of workload.

Data reduction

The system achieves data reduction by using the following techniques:

● Data deduplication
● Data compression

There is no performance impact from the use of data deduplication or compression.

Data deduplication

Deduplication is the process of consolidating redundancies that are contained within data to reduce storage overhead. With
deduplication, only one copy of data is stored on drives. Duplicates are replaced with a reference that points back to the original
copy. Deduplication is always enabled and cannot be disabled. Deduplication occurs before the data is written to storage drives.

Deduplication provides the following benefits:

● Enables high capacity growth without requiring a drastic increase in space, power, or cooling.
● Improves drive endurance, because there are fewer writes to the drives.
● Improves performance, because the system reads the deduplicated data from the cache instead of from the drives.

Compression

Compression is the process of reducing the number of bits needed to store and transmit data. Compression is always enabled,
and cannot be disabled. Compression occurs before data it is written to storage drives.

Inline compression provides the following benefits:

● Saves storage capacity by storing data blocks efficiently.
● Improves drive endurance, because there are fewer writes to the drives.

There is no performance impact from compression.

Reporting the capacity savings

The system reports the capacity savings that is gained from data reduction using the Unique Data metric. The Unique Data
metric is calculated for a volume and its associated clones and snapshots.
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Thin provisioning

Storage provisioning is the process of allocating available drive capacity to meet the capacity, performance, and availability
requirements of hosts and applications. In PowerStore, volumes and file systems are thin provisioned to optimize the use of
available storage.

Thin provisioning works as follows:

● When you create a volume or file system, the system allocates an initial quantity of storage to the storage resource. This
provisioned size represents the maximum capacity to which the storage resource can grow without being increased. The
system reserves only a portion of the requested size, called the initial allocation. The requested size of the storage resource
is called the subscribed quantity.

● The system will only allocate physical space when data is written. A storage resource appears full when data written to the
storage resource reaches the provisioned size of the storage resource. Since provisioned space is not physically allocated
multiple storage resources could subscribe to the common storage capacity.

Thin provisioning allows multiple storage resources to subscribe to a common storage capacity. Therefore, it allows
organizations to purchase less storage capacity up front, and increase available drive capacity on an on-demand basis, according
to actual storage usage. While the system allocates only a portion of the physical capacity requested by each storage resource,
it leaves the remaining storage available for other storage resources to use.

The system reports the capacity savings gained from thin provisioning using the Thin Savings metric, which is calculated for
volume families and file systems. A volume family consists of a volume and its associated thin clones and snapshots.

Thin provisioning is always enabled.
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Monitoring Performance
This chapter includes:

Topics:

• About monitoring system performance
• Performance metrics collection and retention periods
• Performance data locations in PowerStore Manager
• Monitoring user virtual machines performance
• Comparing object performance
• Performance policies
• Working with performance charts
• Generating performance metrics archives

About monitoring system performance
PowerStore provides you with various metrics that can help you monitor the health of your system, anticipate problems before
they occur, and reduce troubleshooting times.

You can use the PowerStore Manager, REST API, or CLI to monitor the performance of a cluster, and for individual storage
resources such as volumes, file systems, volume groups, appliances, and ports. Also, with a PowerStore X model implementation,
you can view compute performance of a virtual machine, and the storage performance for a virtual machine, and virtual volume.

You can print performance charts and download metrics data as a PNG, PDF, JPEG, or .csv file for further analysis. For
example, you can graph downloaded CSV data using Microsoft Excel, and then view the data from an offline location or pass the
data through a script.

Performance metrics collection and retention periods
Collection of performance metrics is always enabled in PowerStore.

All system performance metrics are collected every 5 seconds except for volumes, virtual volumes, and file systems, for which
performance metrics are collected by default every 20 seconds.

All storage resources that are configured to collect performance metrics every 5 seconds are listed in the Metric Collection
Configuration window (Settings > Support > Metric Collection Configuration.

You can change the granularity of performance data collection for volumes, virtual volumes, and file system:

1. Select the relevant storage resource (or resources).
2. Select More Actions > Change Metric Granularity.
3. From the Change Metric Collection Granularity slide-out panel, select the granularity level.
4. Click Apply.

The collected data is retained as follows:

● Five second data is retained for one hour.
● 20 second data is retained for one hour.
● Five minute data is retained for one day.
● One hour data is retained for 30 days.
● One day data is retained for Two years.

The performance charts refresh interval is set according to the selected Timeline as follows:

4
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Table 7. Performance charts refresh intervals 

Timeline Refresh Interval

Last hour Five minutes

Last 24 hours Five minutes

Last month One hour

Last two years One day

Performance data locations in PowerStore Manager
You can view performance charts for PowerStore systems, and system resources from the PowerStore Manager Performance
card, views, and details as follows:

Performance data is available from the PowerStore CLI, REST API, and PowerStore Manager user interface. This document
describes how to access performance data and charts from PowerStore Manager.

Refer to the PowerStore Online Help for specific performance metric definitions and calculations.

Table 8. Performance data locations 

For Access path

Cluster Dashboard > Performance

Virtual Machine ● Compute > Virtual Machine > [virtual machine] opens with the Compute
Performance card that is displayed for the virtual machine.

● Compute > Virtual Machine > [virtual machine] > Storage Performance

NOTE: Only available with PowerStore X model appliances.

Virtual Volume (VVol) Storage > Virtual Volumes > [virtual volume] > Performance

Volume Storage > Volumes > [volume] > Performance

Volume Group Storage > Volume Groups > [volume group] > Performance

Volume Group member
(volume)

Storage > Volume Groups > [volume group] > Members > [member] > Performance

File System Storage > File Systems > [file system] > Performance

NOTE: Only available with PowerStore T model appliances.

Nas Server Storage > NAS Servers > [NAS server] > Performance

Host Compute > Host Information > Hosts &Hosts Groups > [host] > Performance

Host Group Compute > Host Information > Hosts &Hosts Groups > [host group] > Performance

Initiator Compute > Host Information > Initiators > [initiator] > Performance

Appliance Hardware > [appliance] > Performance

Node Hardware > [appliance] > Performance

Ports ● Hardware > [appliance] > Ports > [port] > IO Performance
● Hardware > [appliance] > Ports > [port] > Network Performance opens the

Network Performance card that is displayed for the port

Monitoring user virtual machines performance
Use PowerStore Manager to monitor CPU and memory usage of all user-configured VMs or per VM.

In PowerStore X model clusters, 50 percent of the resources are reserved to user VMs. The AppsOn feature enables you to run
user VMs on the same hardware as PowerStore.
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You can monitor the percentage of CPU and memory usage of user VMs in PowerStore Manager and use this information to
improve resource management.

Select Hardware > [appliance] and select AppsON CPU Utilization from the Category menu to view historical CPU
utilization of user VMs per appliance. To view CPU utilization of user VMs per node, use the Show/Hide menu.

Select Hardware > [appliance] and select AppsON Mem Utilization from the Category menu to view historical memory
utilization of user VMs per appliance. To view CPU utilization of user VMs per node, use the Show/Hide menu.

You can view the CPU and memory usage per virtual machine in the Virtual Machines list (Compute > Virtual Machines).

NOTE: If you cannot see the CPU Usage (%) and Memory Usage (%) columns, add them using the Show/Hide Table

Columns.

Comparing object performance
Use the PowerStore Manager to compare performance metrics of objects of the same type.

You can compare performance metrics to help troubleshoot system performance-related issues.

You can select two or more objects from the respective lists of the following objects:

● volumes
● volume groups
● file systems
● hosts
● host groups
● virtual volumes
● virtual machines
● appliances
● ports

Selecting More Actions > Compare Performance Metrics displays the performance charts of the selected objects.

See Working with performance charts for details on how to use the different menus of the performance charts to display the
relevant data.

Comparing object performance can help in identifying potential misconfiguration or resource allocation issues.

Performance policies
You can choose to change the performance policy set on a volume, or a virtual volume (vVol).

The performance policies are provided with PowerStore. You cannot create or customize performance policies.

By default, volumes and vVols are created with a medium performance policy. The performance policies are relative to the
performance of the volumes. For example, if you set a High-performance policy on a volume, the usage of the volume will take
priority over volumes set with a medium, or low policy.

You can change the performance policy from medium to low or high, when a volume is created or after the volume has been
created.

Members of a volume group can be assigned different performance policies. You can set the same performance policy for
multiple volumes in a volume group simultaneously.

Change performance policy set for a volume

About this task

You can change the performance policy set for a volume.

Steps

1. Select Storage > Volumes.

2. Check the checkbox next to the volume and select More Actions > Change Performance Policy.
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3. In the Change Performance Policy slide-out, select the performance policy.

4. Select Apply.

Change performance policy for multiple volumes

About this task

You can set the same performance policy for multiple volumes in a volume group simultaneously.

Steps

1. Select Storage > Volume Groups > [volume group] > Members.

2. Select the volumes on which you are changing the policy.

NOTE: You can only set the same policy on the selected volumes.

3. Select More Actions > Change Performance Policy.

4. Select a performance policy, and select Apply.

Working with performance charts
You can work with the performance charts to customize the display. Print performance charts, or export the performance data
to display in an alternative application.

A performance summary for the current time period is always displayed at the top of the Performance card.

Performance charts are displayed differently for the cluster and the cluster resources.

Working with the performance chart for a cluster

After you have selected the Performance card, you can:

Figure 2. Cluster performance chart

1. Select whether to view the Overall or File performance of a cluster.
NOTE: The File tab displays a summary of file protocols (SMB and NFS) operations for all NAS file systems. The

Overall tab displays the summary of all block-level operations across volumes, virtual volumes, and NAS file systems

internal volumes, but does not include the file protocols operations that are displayed in the File tab.

2. Select or clear the type of metric values to show or hide in the chart.
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3. Select the type of chart to display from the View menu. You can choose whether to display the performance summary in the
chart, or display the details of a specific metric in the chart.

4. Select the time range to display by changing the time period selected in the For: menu.
5. View the historical data in the chart area, and hover over any point on the line graph to get display the metric values at that

point-in-time.
NOTE: You can zoom into an area of the chart by selecting the area with the mouse. To reset the zoom setting, click

Reset zoom.

Working with performance charts for cluster resources

Performance charts are displayed for virtual volumes (vVols), volumes, volume groups, file systems, appliances, and nodes.

The following options are available for viewing the performance metrics for appliances and nodes:

Figure 3. Appliance/node performance chart

1. Select whether to view the Overall or File performance of a cluster.
NOTE: The File tab displays a summary of file protocols (SMB and NFS) operations for all NAS file systems. The

Overall tab displays the summary of all block-level operations across volumes, virtual volumes, and NAS file systems

internal volumes, but does not include the file protocols operations that are displayed in the File tab.

2. Select the metric category to display from the Category list. A chart is displayed for each appliance and node that are
selected in the Show/Hide list.

3. Select or clear the appliance and nodes to display or hide from the Show/Hide list.
4. Select the amount of historical performance data to display from the Timeline list.
5. Download the charts as a .png, .jpg, .pdf file or export the data to a .csv file.
6. View the historical performance data in the chart or hover over a point on the line graph to display the metric values at that

point-in-time.
7. Select or clear the types of metric values to show or hide in the chart.

NOTE: You can zoom into an area of the chart by selecting the area with the mouse. To reset the zoom setting, click

Reset zoom.

The following options are available for viewing the performance metrics for other cluster resources, such as volume groups:
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Figure 4. Volume group performance chart

1. Select the metric categories to display from the Host IO list. A chart is displayed for each category that is selected.
2. Select the amount of historical performance data to display from the Timeline list.
3. Download the charts as a .png, .jpg, .pdf file or export the data to a .csv file.
4. View the historical performance data in the chart or hover over a point on the line graph to display the metric values at that

point-in-time.
5. View the current metric values for the average latency, read latency, and write latency metrics.
6. Select or clear the types of metric values to show or hide in the chart.

NOTE: You can zoom into an area of the chart by selecting the area with the mouse. To reset the zoom setting, click

Reset zoom.

Generating performance metrics archives
You can collect and download performance metrics to help troubleshoot performance-related issues.

About this task

You can use the PowerStore manager, REST API, or CLI to collect performance data and download the generated archives. You
can use the gathered information to analyze and troubleshoot performance-related issues.

Steps

1. Select the Settings icon and then select Metrics Archives in the Support section.

2. Select Generate Metrics Archive and confirm to initiate the process.
A progress bar indicates when the archive is generated and the new archive is added to the Metrics Archives list.

3. Select the generated archive and then select Download and confirm to initiate the download.
When download is complete, the download date and time is displayed in the Downloaded column.
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Collecting System Data
This chapter includes:

Topics:

• Support materials collection
• Collect support materials

Support materials collection
You can collect support materials to help troubleshoot the appliances in your system.

Depending on the option you choose, support materials can include system logs, configuration details, and other diagnostic
information. Use this information to analyze performance issues, or send it to your service provider so they can diagnose and
help you resolve the issues. This process does not collect user data.

You can collect support materials for one or more appliances. When you start a collection, data is always collected at the
appliance level. For example, if you request a collection for a volume, the system collects support materials for the appliance
that contains the volume. If you request a collection for multiple volumes, the system collects support materials for all appliances
that contain the volumes.

You can set a timeframe for collecting support materials. Setting a timeframe can result in smaller and more relevant data
collection which is easier to analyze . You can either set a predefined timeframe or set a custom timeframe that suits your
needs.

You can also include additional information in the support materials collection from Advanced collection options. Collecting
additional information can take longer than the default support materials collection, and the size of the resulting data collection
is larger. Select this option if your service provider requests it. By default the support materials collection uses the essentials
profile. Use the svc_dc service script to collect support materials for other profiles. See the PowerStore Service Scripts Guide
for more information about the svc_dc service script and the available profiles.

NOTE: The system can run only one collection job at a time.

You can perform the following actions on a collection of support materials:

● View information about existing collections.
● Upload a collection to support, if remote support through Secure Remote Services is enabled.
● Download a collection to a local client.
● Delete a collection.

NOTE: Some of these operations might not be available if the cluster is operating in a degraded state.

Collect support materials

Steps

1. Select the Settings icon, and then select Gather Support Materials in the Support section.

2. Click Gather Support Materials.

3. Select the timeframe for the data collection.

You can select one of the available options from the drop-down menu, or select Custom and set a timeframe.

4. Select the type of support data that is needed and the appliances for which to collect support information.

5. Write a description of the collection.

This description is displayed in the list of support materials on the Support Materials page and can help you recognize the
collection.

5
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6. Select the Send materials to Support when finished checkbox if you want the system to automatically send the
collection to support when the job completes.

This option is only enabled when remote support through Secure Remote Services is enabled on the system. You can also
send the collection to support at a later time.

7. Click Start.
Data collection is initiated, and the new job appears in the Gather Support Materials page. You can click the job entry to
view its details and progress.

Results

When the job is completed, the system posts the job information, including its status, on the Support Materials page.

Next steps

After the job is finished, you can download the support materials collection to a client, send the collection to support, or delete
the collection. Select the support materials collection, then select Download, Send to Support, or Delete.
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