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1
OpenManage Management Pack for vRealize 
Operations Manager
OpenManage Management Pack for vRealize Operations Manager enables monitoring of different metrics and hardware resources in 
the Dell server (12th generation servers and later) and chassis by using vRealize Operations Manager. OpenManage Management 
Pack for vRealize Operations Manager requires VMware vRealize Operations Manager version 6.3 or later.

OpenManage Integration for VMware vCenter (OMIVV) is a product that manages the ESXi servers within the VMware vCenter. 
OpenManage Management Pack for vRealize Operations Manager supports OpenManage Integration for VMware vCenter 4.0 or 
later.

OpenManage Management Pack for vRealize Operations Manager enables you to monitor and analyze the health, inventory, and 
status of the Dell PowerEdge servers and chassis that are managed by the OMIVV.

The OpenManage adapter retrieves the data of the managed Dell servers and its associated Dell chassis from the configured OMIVV. 
The retrieved details are used to discover and monitor the Dell PowerEdge servers and chassis. For more information, see Dell.com/
OMConnectionsEnterpriseSystemsManagement

NOTE: 

OpenManage adapter affects only the Health Badge of the resources, and it does not have any impact on the sub-badges.

NOTE: 

The Project tab is not pertinent in vROPS while accessing the Dell servers, chassis, and components.

NOTE: 

After you update the firmware versions, BIOS, OS, or after you change the iDRAC IP, you must run the inventory to view the 
updated status.

 

What's new in this release
This release of OpenManage vRealize Operations Management Pack has the following features:

• Support for monitoring and analyzing Dell PowerEdge servers, chassis, and components.
• Support for power consumption metrics.
• Support for firmware update report.
• Supports server relationship for Dell PowerEdge servers and ESXi.

Use case scenarios
This section describes typical use cases and tasks that can be performed with OpenManage Management Pack for vRealize 
Operations Manager.

Monitoring the servers

Server monitoring is the process of reviewing and analyzing a server for health, inventory, availability, and other operations-related 
processes. You can also monitor the components of servers such as CPU, memory, PSU, fan, temperature, physical disks, and so on.

For more information, see the Dell servers overview dashboard.
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Perform the following steps to monitor a server:

1. Launch the vRealize Operations Manager console.

2. From the Home tab, click Environment.

3. In Inventory Trees, select Dell Servers.

4. Select the server that you want to monitor.

The health status, alerts, and the associated details of the selected server is displayed. For more information about alerts, see 
Viewing Alerts

Monitoring the chassis

Chassis monitoring is the process of reviewing and analyzing chassis level health, inventory, and availability of supported chassis 
connected through OMIVV. You can also view the overall health status of the fan and PSU that enables you to view the metrics for 
various Dell chassis.

For more information, see the Dell chassis overview dashboard.

Perform the following steps to monitor a chassis:

1. Launch the vRealize Operations Manager console.

2. On the Home tab, click Environment.

3. In Inventory Trees, select Dell Chassis.

4. Select the chassis that you want to monitor.

The health status, alerts, and the associated details of the selected chassis is displayed. For more information about alerts, see 
Viewing Alerts

NOTE: 

If the PowerEdge FX2/FX2s chassis is not on the network, and the RSM mode is enabled in Chassis Management 
Controller, then the chassis overall health alerts are not generated on the server.

Frimware update report for servers

Firmware update report displays the current and available versions of the firmware for each component. This enables you to update 
the firmware to the latest version for the Dell servers from OMIVV. For more information, see the Dell firmware update summary 
report.

Perform the following steps to generate firmware update report:

1. On the Home tab, click Content and then click Report.

2. Select Dell Server Firmware Update Summary Report.

3. Click Run Template and select All Objects → Dell OpenManage Adapter → Dell Firmware Group → Dell Firmware Group.

4. Click OK.

Firmware update reports are generated for all Dell servers.

Power monitoring report for servers

Power Monitoring report displays the server metrics for the Dell PowerEdge servers. For more information, see Dell server power 
details.

Perform the following steps to generate power monitoring report:

1. On the Home tab, click Content, and then click Report.

2. Select Dell Server Power Consumption Report.

3. Click Run Template and select All Objects →Dell OpenManage Adapter→Dell Servers Group →Dell Servers Group.

4. Click OK.

Power monitoring reports are generated for all Dell servers.
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Viewing dashboards

Dashboards enable you to monitor and analyze the Dell PowerEdge servers and chassis environment in vROPS.

The following dashboards are available in vRealize Operations Manager:

• Dell Servers Overview Dashboard

• Dell Server Detailed Dashboard

• Dell Chassis Overview Dashboard

• Dell Chassis Detailed Dashboard

Dell servers overview dashboard

Following are the parameters displayed in the Dell Servers Overview Dashboard:

Figure 1. Dell Servers Overview Dashboard

1. Dell Servers Environmental Health: Displays the health status of all the servers. Red indicates Critical state, yellow indicates 
Warning state, and green indicates Healthy state. The source of Dell Servers Environmental Health is defined as Dell Server|
Badge|Health Status.

2. Top High Power Consuming Servers (watt): Displays the top 15 power consuming servers. The source of Top High Power 
Consuming Servers (watt) is defined as Dell Server|Server Extended Metrics| System Board Power Consumption (Watt).

3. Select Above For Fan Speed Trend: Displays the fan speed trend for the server selected in the Top High Fan Speed Servers 
(RPM) widget.

4. Dell Servers Top Alerts: Displays the top 15 alerts of PowerEdge servers. The source of Dell Servers Top Alerts is defined as 
Dell Servers Group.

5. Top High Temperature Servers (Fahrenheit): Displays the top 15 high temperature servers. The source of Top High 
Temperature Servers is defined as Dell Sever System Board Inlet Temperature|Dell Sever System Board Inlet Temperature 
Sensor Metrics|Current Reading (Fahrenheit).

6. Select Above For Temperature Trend: Displays the system board inlet temperature trend for the server selected in the Top 
High Temperature Servers (Fahrenheit) widget.

7. Proactive HA Distribution View: Displays whether the Proactive High Availability (HA) is enabled or disabled. For more 
information about Proactive HA, see OpenManage Integration for VMware vCenter User's Guide version 4.0. The source of 
Proactive HA Distribution View is defined as Dell Proactive HA Servers View.

8. Top High Fan Speed Servers (RPM): Displays the top 15 high fan speed servers. The source of Top High Fan Speed Servers 
(RPM) is defined as Dell Server Fan|Dell Server Fan Metrics|Current Reading (RPM).
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9. Select Above For Power Consumption Trend: Displays the power consumption trend for the server selected in the Top High 
Power Consuming Servers (watt) widget.

Dell server detailed dashboard

In the Dell server detailed dashboard, you can view the overall health status of the fan, battery, voltage, memory, temperature, 
physical disk, power supply, and processor of the server.

Figure 2. Dell Server Detailed Dashboard

1. Dell Server List: Displays the servers and the details such as, Server Rollup Status, Memory Rollup Status, Battery Rollup 
Status, Processor Rollup Status, Voltage Rollup Status, PSU Rollup Status, Fan Rollup Status, Temperature Rollup Status, 
Storage Rollup Status, and Proactive HA. The source of Dell Server List is defined as Server Metrics|Server Rollup Status, 
Server Metrics|Memory Rollup Status, Server Metrics|Battery Rollup Status, Server Metrics|Processor Rollup Status, 
Server Metrics|Voltage Rollup Status, Server Metrics|PSU Rollup Status, Server Metrics|Fan Rollup Status, Server 
Metrics|Temperature Rollup Status,Server Metrics|Storage Rollup Status, and Server Metrics|ProactiveHA.

2. Dell Server Metric Chart: Displays the system board power consumption and energy consumption of the server for the 
selected period. The source of Dell Server Metric Chart is defined as Server Extended Metrics|System Board Power 
Consumption and Server Extended Metrics|Energy Consumption.

3. Server Relationship: Displays the relationship of the host system, servers and the associated components.

NOTE: 

Battery, voltage, or the IDSDM components are not associated with a server in the relationship map. For more 
information about the components, log in to the iDRAC console.

4. Dell Server Top Alerts: Displays the alerts of the servers and the associated components.

5. Firmware Update Pending View: Displays the number of pending firmware updates for the server, such as number of pending 
Critical Updates, Recommended Updates, and Optional Updates. The source of Firmware Update Pending View is defined 
as Dell Server Available Firmware Update Summary.

Dell chassis overview dashboard

Dell chassis overview dashboard displays the overall heath status of the chassis environment.
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Figure 3. Dell Chassis Overview Dashboard

1. Dell Chassis Environmental Health: Displays the health status of all the chassis. Red indicates the critical state, yellow 
indicates warning state, and green indicates healthy state. The source of Dell Chassis Environmental Health is defined as Dell 
Chassis|Badge|Health State.

2. Dell Chassis Top Alerts: Displays top 15 alerts of the chassis. The source of Dell Chassis Top Alerts is defined as Dell Chassis 
Group.

3. Top High-Power Consumption Chassis (watt): Displays the top 15 high-power consuming chassis. The source of Top High-
Power Consumption Chassis (watt) is defined as Chassis Metrics|Energy Consumption (KWh).

4. Top High Fan Speed Chassis (RPM): Displays the top 15 high fan speed chassis. The source of Top High Fan Speed Chassis 
(RPM) is defined as Dell Chassis Fan Metrics|Current Reading (RPM).

5. Select Above For Energy Consumption Trend: Displays the energy consumption trend for the chassis selected in Top High-
Power Consumption Chassis (watt) widget.

6. Select Above For Fan Speed Trend: Displays the fan speed trend for the chassis selected in Top High Fan Speed Chassis 
(RPM) widget.

Dell chassis detailed dashboard 

Dell Chassis Detailed Dashboard displays the overall health status of the fan, PSU, and the servers of the chassis.
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Figure 4. Dell Chassis Detailed Dashboard

1. Dell Chassis List: Displays the chassis and the details such as, Hostname, Model, ServiceTag, IPAddress, Chassis Overall 
health, PSU Rollup Status, and Fan Rollup Status. The source of Dell Chasssi List is defined as Chassis Metrics|Model, 
Chassis Metrics|Host Name, Chassis Metrics|IpAddress, Chassis Metrics|Service Tag, Chassis Metrics|Chassis Overall 
Health, Chassis Metrics|PSU Rollup Status, and Chassis Metrics|Fan Rollup Status.

2. Dell Chassis Alerts: Displays the alerts of the chassis.

3. Dell Chassis Relationship: Displays the relationship between the Dell chassis and its associated components.

4. Dell Chassis Metric Chart: Displays the energy consumption and system peak power for the selected period. The source of 
Dell Chassis Metric Chart is defined as Chassis Metrics|Energy Consumption and Chassis Metrics|System Peak Power.

NOTE: 

If the CMC firmware versions are earlier than CMC 5.2 for M1000e, CMC 2.2 for VRTX, and CMC 1.4 for FX2, after the 
network outage the chassis detailed dashboard displays a wrong chassis name.

NOTE: 

Chassis components are reported with healthy and non-healthy status. All non-healthy statuses are reported as critical.

Accessing views
OpenManage Management Pack for vRealize Operations Manager enables you to view statistics of metrics and the warranty period 
for various Dell PowerEdge servers and chassis.

Accessing views for a specific server

Perform the following steps to access the views for a specific server:

1. Launch vRealize Operations Manager for a console.

2. On the Home tab, click Environment.

3. In Inventory Trees, select Dell Servers.

4. Select the server that you want view, and then select the Details tab.

A List of views is displayed.
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Accessing views for the group of servers

Perform the following steps to access Dell server group views for all the servers:

1. Launch vRealize Operations Manager for a console.

2. On the Home tab, click Environment.

3. Expand All Objects, and click Dell OpenManage Adapter.

4. Expand Dell Servers Group, again click Dell Servers Group, and then select the Details tab.

A List of views is displayed.

The following views are available in Dell Views

• Dell Server Available Firmware Update Summary — Displays the critical, recommended, and optional firmware updates for 
servers

• Dell Server Power Details — Displays the PowerEdge Model, Average Energy Consumption, System Peak Power (Watt), 
System Peak Amps (A), Warning Threshold (Watt), and Failure Threshold (Watt).

• Dell OMIVV License List View — Displays the list of available nodes, used nodes, evaluation license, licensed node, expiry status, 
and license status.

• Dell Pro Active Servers View — Displays whether or not the proactive high availability is enabled or disabled.
• Dell FRM capable Servers View — Displays the Fault Resilient Memory (FRM) capability on the Dell PowerEdge servers.
• Dell Server Firmware Summary List — Displays the list of firmware available for all the PowerEdge servers.
• Dell Chassis Warranty List — Displays the list of warranties for all the chassis.
• Dell Server Warranty List — Displays the list of warranties for all the PowerEdge servers.

Accessing reports
The OpenManage Management Pack for vRealize Operations Manager provides custom reports for the following:

• Dell Server Firmware Summary List
• Dell Server Power Details
• Dell Server Warranty

Dell server firmware summary list

Dell server firmware summary list displays Servicetag, Hostname, Component, Current Version, Available Version, Criticality, and 
Reboot Required of Dell PowerEdge servers.

Dell server power details

Dell server power details displays the PowerEdge Model, Average Energy Consumption, System Peak Power (Watt), System 
Peak Amps (A), Warning Threshold (Watt), and Failure Threshold (Watt) of the Dell PowerEdge servers.

Dell server warranty

Dell server warranty displays Name, Days Left, End Date, Entitilement Type, Provider, Service Level Description, Start Date and 
Status for PowerEdge servers. There are separate warranty reports that are available for PowerEdge servers and chassis.

Viewing alerts

OpenManage Management Pack for vRealize Operations Manager displays any unusual events from the Dell servers, chassis and 
associated components as alerts. It also recommends that you perform certain steps to overcome the unusual events. If the 
extended monitoring or firmware metric collection job fails for a server, it may create a warning alert for that particular server.

The following are the type of alerts:
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1. Critical - Indicates that the component has either failed or failure is imminent. It requires immediate attention and may require 
replacement. 

2. Warning - Indicates that a probe or other monitoring device has detected a reading for the component that is exceeding the 
acceptable level. The component may be functioning, but it can fail. The component may also be functioning in an impaired 
state. 

Warranty Metrics

Server and chassis warranty information is retrieved and displayed by OpenManage Management Pack for vRealize Operations 
Manager. The service tags are used to gather warranty information about the servers and chassis. When you set up a Warranty 
Expiration Notification Threshold at OMIVV, OpenManage Management pack creates a warning or critical alert based on the 
threshold that has been set.

NOTE: 

Warranty metrics is displayed for each PowerEdge server and chassis.

NOTE: 

When there are different types of warranties for chassis and servers, alerts are created for the longest warranty peirod.
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2
License metrics of OMIVV
The license for OMIVV directly interprets to the licensing used for the management pack. License metrics of OMIVV enables you to 
view the license information and metrics.

The following metrics are associated with Dell OMIVV License:

• Available Nodes: Displays the number of licenses that are available.

• Used Nodes: Displays the number of licenses that are used.

• Evaluation License: Displays the current license type whether or not it is evaluation or standard license.

• Licensed Nodes: Displays the number of licensed nodes.

• Expiry Status: Displays the expiry status of license.

• License Status: Displays the status of the servers that are managed. Alerts are generated, when X+1 servers are managed.

The license metrics is associated with each OMIVV license that displays Activation Date, Days Remaining, Entitlement ID, 
Expiration Date, License Sub State, License Type, and Number of Nodes.

NOTE: 

In case, you have installed a new evaluation license despite having an active or expired older evaluation license, the older 
evaluation license generates and displays the alerts to show number of days remaining for the license to expire.
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Dell server metrics
Table 1. Dell Server Metrics

Resources Available Server- Resource Metrics

Server Metrics Battery Rollup Status

Chassis Service Tag

Fan Rollup Status

Host Entity ID

iDRAC IP

IDSDM Present

IDSDM Rollup Status

Memory Rollup Status

Model

Overall Warranty Status

ProactiveHA

Processor Rollup Status

PSU Rollup Status

Server Generation

Server Rollup Status

Service Tag

Storage Rollup Status

Temperature Rollup Status

Voltage Rollup Status

Server Extended Metrics Energy Consumption End Date Time

Energy Consumption Start Date Time

Energy Consumption (KWh)

Extended Metrics Collection Job Status

Failure Threshold (Watt)

FRM Capable
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FRM Enable

FRM Type

Peak Amps End Date Time

Peak Amps Start Date Time

System Board Power Consumption (Watt)

System Instantaneous Headroom (Watt)

System Peak Amps

System Peak Headroom (Watt)

System Peak Power End Date Time

System Peak Power Start Date Time

System Peak Power (Watt)

Warning Threshold (Watt)

Server Firmware Updates Critical

Firmware Metrics Collection Job Status

Optional

Recommended

Server Warranty Days Left

End Date

Entitlement Type

Last Updated Time

Provider

Service Level Description

Start Date

Status

Dell Server Temperature Sensor Metrics Current Reading (Fahrenheit)

Health Status

Maximum Critical Threshold (Fahrenheit)

Maximum Warning Threshold (Fahrenheit)

Minimum Critical Threshold (Fahrenheit)

Minimum Warning Threshold (Fahrenheit)

Dell Server Processor Metrics Processor Health Status

Dell Server Memory Metrics Memory Unit Instance Health
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Dell Server System Board Inlet Temperature Sensor Metrics Current Reading (Fahrenheit)

Health Status

Maximum Critical Threshold (Fahrenheit)

Maximum Warning Threshold (Fahrenheit)

Minimum Critical Threshold (Fahrenheit)

Minimum Warning Threshold (Fahrenheit)

Dell Server PSU Metrics Health Status

Input Voltage (Volts)

Redundancy Status

NOTE: 

Power supply redundancy status is displayed as 
Unknown, if the Redundancy Policy is set to Not 
Redundant in Integrated Dell Remote Access 
Controller (iDRAC).

Dell Server Physical Disk Metrics Available Disk Space (GB)

Health Status

Media Type

Remaining Rated Write Endurance

Smart Alert Enabled State

Total Disk Size (GB)

NOTE: 

The default value for non-SSD disk is 255.
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Dell chassis metrics
Table 2. Dell Chassis Metrics

Resources Available Chassis- Resource Metrics

Chassis Metrics Chassis Overall Health

Enegy Consumption (KWh)

Fan Rollup Status

Host Name

IPAddress

Model

Overall Warranty Status

PSU Rollup Status

Service Tag

System Peak Power End Date Time

System Peak Power Start Date Time

System Peak Power (Watt)

NOTE: 

When rack server Mode is enabled, chassis PSU and 
fans are discovered and monitored as server 
components.

Chassis Warranty Days Left

End Date

Entitlement Type

Last Updated Time

Provider

Service Level Description

Start Date

Status

Dell Chassis PSU Metrics Health Status

Input Voltage (Volts)

Dell Chassis Fan Metrics Health Status
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Current Reading (RPM)
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5
View Dell PowerEdge servers and ESXi of VMware 
relationship
This dashboard provides a visual representation of server relationship between Dell PowerEdge servers and ESXi.

To view the object relationship health tree, see Dell server detailed dashboard.
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6
Issues
• Servers that have an in-built PSU or the drives that are connected to Embedded Controller always display a warning status in 

vROPS, because Embedded Controller is not monitored by iDRAC.

• The removed PSUs or fans exist under Dell chassis. In such a situation, because the health cannot be retrieved the FAN or PSU 
status is displayed as Critical.

• Disconnecting the power cable and non-removal of PSU from a specific port of chassis results in the relationship maps displaying 
the specific PSU as Critical. However, if the PSU is removed, the removed PSU is not displayed in the relationship map.

• The FAN Rollup status for PowerEdge FX2/FX2s and VRTX is based on the chassis firmware constraint. For more information, 
see Chassis Management Controller User's Guide.

• When the chassis has an object down alert, the server may have a descendent alert, but the overall health status of the server 
and relationship map are not impacted.

• Power supply unit health is not recorded for PowerEdge C6320.

• Alerts are not created when Non-Raid Physical Disk is removed from the server, and the Dell server overall health status is 
displayed as Critical.

• Ensure that the basic health update and extended metric jobs are running successfully for the specified host, if the data is not 
populated.

• The vROPS report displays the entries of a removed server. To generate an updated report, remove the non existent Dell objects 
from inventory explorer.
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7
Accessing documents from Dell support site
You can access the required documents in one of the following ways:

• Using the following links:

– For all Enterprise Systems Management documents — Dell.com/SoftwareSecurityManuals

– For OpenManage documents — Dell.com/OpenManageManuals

– For Remote Enterprise Systems Management documents — Dell.com/esmmanuals

– For iDRAC and Lifecycle Controller documents — Dell.com/idracmanuals

– For OpenManage Connections Enterprise Systems Management documents — Dell.com/
OMConnectionsEnterpriseSystemsManagement

– For Serviceability Tools documents — Dell.com/ServiceabilityTools

– For Client Command Suite Systems Management documents — Dell.com/DellClientCommandSuiteManuals

• From the Dell Support site:

a. Go to Dell.com/Support/Home.

b. Under Select a product section, click Software & Security. 

c. In the Software & Security group box, click the required link from the following:

– Enterprise Systems Management

– Remote Enterprise Systems Management

– Serviceability Tools

– Dell Client Command Suite

– Connections Client Systems Management 

d. To view a document, click the required product version.

• Using search engines:

– Type the name and version of the document in the search box.
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