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Overview of OpenManage Integration with
Microsoft Windows Admin Center

Dell EMC OpenManage Integration with Microsoft Windows Admin Center (OMIMSWAC) enables IT administrators to manage
PowerEdge servers as hosts, Microsoft Failover Clusters created with PowerEdge servers, and Hyper-Converged Infrastructure
(HCI) created by using Dell EMC HCI Solutions for Microsoft Windows Server or Dell EMC Integrated System for Microsoft
Azure Stack HCI. OMIMSWAC simplifies the tasks of IT administrators by remotely managing the PowerEdge servers
and clusters throughout their life cycle. For more information about the features and benefits of OMIMSWAC, see the
documentation at Dell.com/OpenManageManuals.

What is new in this release
● 'CPU core management' feature enables CPU cores for distributions in an HCI (AS HCI and WS HCI) cluster or individual

nodes. This feature gives you the ability to configure the CPU core count to achieve the right balance between power and
performance optimal for workloads. This feature helps you to keep the Total Cost of Ownership for Hybrid cloud at an
optimal level.

● 'Expand Cluster' feature that enables you to prepare nodes for cluster expansion. This feature helps you to identify and
prepare right nodes for a cluster that follow Dell EMC recommendations, which can be later added into the cluster. This
feature is supported in Failover clusters and HCI clusters.

● Hardware symmetry check has been renamed as HCI configuration profile check.
● Supports below YX5X PowerEdge servers.

○ R450, R550, R650, R650xs, R750xs, R750, R750XA, XR11, XR12, C6520, MX750c, and XE8545.
● Supports below AX nodes.

○ AX-650 and AX-750
● Enhancements:

○ Updating firmware, BIOS, and drivers of individual nodes part of an Azure Stack HCI cluster using the server extension
tool is suboptimal and not recommended by Dell Technologies. This version has introduced this restriction to help
maintain the cluster homogeneity.

○ Supports health and inventory retrieval when the port number other than the default port 443.
○ Enhanced HCI configuration policy checks to ensure a minimum of 5% of cache capacity available in clusters to improve

cluster performance.

Revision history

Date Document revision Description of changes

July 2021 A00 Initial release for OMIMSWAC 2.1.

August 2021 A01 Added support for R450, R550, R650xs,
R750xs, XR11, XR12 PowerEdge servers.

September 2021 A02 Added support for AX-650 and AX-750

Key features of OMIMSWAC
● OMIMSWAC provides a simplified solution for IT administrators to efficiently manage the following:

○ Dell EMC PowerEdge Servers running on supported Windows operating systems.
○ Dell EMC Integrated System for Microsoft Azure Stack HCI (also known as Azure Stack HCI or AS HCI) created using AX

nodes from Dell Technologies.
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○ Dell EMC HCI Solutions for Microsoft Windows Server (also known as Windows Server HCI or WS HCI) created using
Storage Spaces Direct Ready Nodes or combinations of AX nodes and Storage Spaces Direct Ready Nodes.

○ Microsoft Failover Clusters created with Dell EMC PowerEdge servers running supported Windows Server operating
system.

● Inventory/Monitoring—Provides information about overall Health, Hardware inventory, and iDRAC inventory of nodes
including component-level information of all supported Dell EMC platforms.

● iDRAC console—View iDRAC information of PowerEdge servers. For out-of-band management, you can directly launch the
iDRAC console from Windows Admin Center.

● Cluster creation (Integrated Cluster Deploy and Update)—Supports integrated Firmware, BIOS, and Drivers installation while
creating Azure Stack HCI cluster. Also, performs HCI configuration profile check to keep hardware configuration of cluster
nodes inline with Dell EMC recommended hardware configuration.

● Update management—
○ Online catalogs—Support for creating firmware baselines by using the following online catalogs when OMIMSWAC is

connected to the Internet:
￭ Dell EMC Enterprise Catalog-Contains firmware updates for PowerEdge servers and PowerEdge server nodes in a

cluster.
￭ Update Catalog for Microsoft HCI solutions-Contains firmware updates for AX nodes and Storage Spaces Direct

Ready Nodes and nodes in Windows Server HCI and Azure Stack HCI clusters.
￭ Dell EMC MX Solution Catalog for PowerEdge MX Modular.

○ Offline catalog—Support for creating local firmware baselines by using Dell EMC Repository Manager (DRM).
○ Compliance report—Generate update compliance report against Dell EMC verified update catalogs and provide

notifications when a new catalog version is available.
○ Server update—Supports PowerEdge server update against baseline – Firmware, BIOS, Drivers, and system

management applications.
○ Cluster-Aware Update—Supports cluster update against validated baseline (Firmware, BIOS, and Drivers) for PowerEdge

server-based Failover cluster, Dell EMC HCI Solutions for Microsoft Windows Server, and Dell EMC Integrated System
for Microsoft Azure Stack HCI.

○ Full Stack Cluster-Aware Updating—Supports integrated cluster-aware update for Azure Stack HCI clusters that include
both operating system and hardware updates (Firmware, BIOS, and Drivers).

● Dell EMC Solutions badge—
○ Displays Dell EMC Solutions badge Azure Stack HCI Certified for Dell EMC Integrated System for Microsoft Azure

Stack HCI consisting of AX nodes from Dell Technologies.
○ Displays Dell EMC Solutions badge Windows Server HCI Certified for Dell EMC HCI Solutions for Microsoft Windows

Server created using Storage Spaces Direct Ready Nodes or combinations of AX nodes and Storage Spaces Direct Ready
Nodes.

● Availability of OMIMSWAC extension and documentation localized in English, French, German, Spanish, Simplified Chinese,
and Japanese languages.
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OpenManage Integration with Microsoft
Windows Admin Center Licensing

This section provides licensing guidance for OpenManage Integration with Microsoft Windows Admin Center (OMIMSWAC).

Overview
Installing and using OMIMSWAC Base version does not require any license and can be downloaded from the NuGet feed of
Microsoft Windows Admin Center or Dell support site. The Base version provides basic management and monitoring for Dell
EMC PowerEdge Servers, AX nodes, and Storage Spaces Direct Ready Nodes from Dell Technologies. However, to use some of
the premium features, such as Cluster-Aware Updating (CAU), Hardware symmetry checks using Integrated Cluster Deployment
and Update (IDU), and Full Stack Cluster-Aware Updating you must install the OMIWAC Premium License on target nodes.

Types of premium licenses and platforms supported

There are two types of OMIWAC Premium Licenses currently available as below.

● The "OMIWAC Premium License for PowerEdge" is available for:
○ YX4X models of Dell EMC PowerEdge server and above with iDRAC firmware 4.00.00.00 or newer.

● The "OMIWAC Premium License for MSFT HCI Solutions" is available for:
○ AX nodes and Storage Space Direct Ready Nodes from Dell Technologies with firmware 4.00.00.00 or newer.
○ Dell EMC Integrated System for Microsoft Azure Stack HCI.
○ Dell EMC HCI Solutions for Microsoft Windows Server.

Premium features supported
● Cluster-Aware Updating feature is supported for:

○ Failover clusters
○ Azure Stack HCI clusters
○ Windows Server HCI clusters

● Integrated Cluster Deploy and Update as part of Azure Stack HCI cluster creation with hardware symmetry checks is
supported for:
○ AX nodes while creating Azure Stack HCI cluster.

● Full Stack Cluster-Aware updating feature is supported for:
○ Azure Stack HCI cluster.

● CPU core management is supported for:
○ Azure Stack HCI cluster created from AX nodes from Dell Technologies.
○ Windows Server HCI cluster created from AX and/or S2D ready nodes from Dell Technologies.
○ Individual nodes such as AX nodes, S2D ready nodes, and PowerEdge nodes.

● Preparing nodes for cluster expansion is supported for:
○ Azure Stack HCI cluster created from AX nodes from Dell Technologies.
○ Windows Server HCI cluster created from AX nodes from Dell Technologies.
○ Failover cluster.

Purchase OMIWAC Premium License
OMIWAC Premium Licenses can be purchased while ordering the corresponding servers and solutions through Point of Sale
(POS) or After Point of Sale (APOS) by contacting Dell sales representatives. The OMIWAC Premium License is bundled as part
of the server license if purchased along with the server. If the license is purchased in APOS method, import the license manually
using the iDRAC. For more information about importing license manually, see iDRAC documentation.
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NOTE: Licenses must be purchased for the corresponding Azure Stack HCI or PowerEdge Servers in a cluster as follows

where you want to use the premium feature. As, mixing the licenses will not be supported.

License Description Licensing model

iDRAC express All base features.

OMIWAC Premium License for
PowerEdge.

All base features along with premium
management features.

Perpetual iDRAC based license.

OMIWAC Premium License for MSFT
HCI Solutions.

This is also shown as "OMIWAC Premium
License for Azure Stack HCI" in iDRAC.

All base features along with premium
management features.

Perpetual iDRAC based license.

NOTE: The OMIWAC Premium License is not required to update individual target node.

You can download the purchased license from the Software License Management Portal at HTTPS://WWW.DELL.COM/
SUPPORT/SOFTWARE/US/EN/04.

Verify license information
In OMIMSWAC, you can view nodes details and their licenses from the iDRAC inventory. To view the iDRAC inventory of a
target node
1. In Windows Admin Center, connect to a server or cluster.
2. In the left pane of Windows Admin Center, under EXTENSIONS, click Dell EMC OpenManage Integration, and then

navigate to the iDRAC tab.
3. Under iDRAC tab, you can verify the OMIWAC Premium License available on the target nodes.

NOTE: All nodes participating in the managed cluster must have OMIWAC Premium License installed to use premium

features. If any of the cluster nodes are not licensed, OMIMSWAC notifies and does not allow you to use the premium

feature.
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Compatibility matrix
The following table lists the supported Microsoft Windows Admin Center version, browser, operating system, supported
software, and supported hardware required for OMIMSWAC.

Table 1. Compatibility matrix 

Supported software and hardware Version

Microsoft Windows Admin Center Windows Admin Center 2103.2 GA.

Microsoft recommends to use the latest version of the Windows
Admin Center. For more information, see the Microsoft Windows
Admin Center documentation at https://www.microsoft.com/en-us/cloud-
platform/windows-admin-center.

Microsoft Cluster Creation Extension 1.556.0.nupkg release.

Microsoft Failover Cluster Tool Extension 1.280.0.nupkg release.

Operating systems For more information about the supported OSs for installing
Microsoft Windows Admin Center and different modes of
installation, see the Microsoft Windows Admin Center documentation
at https://docs.microsoft.com/en-us/windows-server/manage/windows-
admin-center/plan/installation-options.

NOTE: To view the update compliance details of the devices by using
OpenManage Integration with Windows Admin Center, the supported
OSs are Microsoft Windows 2012 R2 and later.

Also, supports managing and monitoring of Azure Stack HCI solution
based on the new Azure Stack HCI version 20H2 operating system.

Browsers For more information about the supported browsers by Microsoft Windows
Admin Center, see the Microsoft Windows Admin Center documentation at
https://www.microsoft.com/en-us/cloud-platform/windows-admin-center.

Dell EMC System Update Utility (DSU) 1.9.0

The Systems-Management_Application_8CTK7_WN64_1.9.0_A00.EXE
DSU file can be downloaded from here.

Dell EMC Inventory Collector (IC) 21_04_202_1093

The supported version of IC can be downloaded from here.

Dell EMC Repository Manager (DRM) 3.3.1

The supported version of DRM can be downloaded from here.

PowerEdge servers as target nodes.

For more information on the generic naming
convention of PowerEdge servers, see
Identifying the generation of your Dell EMC
PowerEdge server on page 18.

● YX2X and YX3X models of PowerEdge servers with iDRAC7 and iDRAC8
respectively (Recommended firmware version of 2.60.60.60 or later).

NOTE:

○ For PowerEdge servers with firmware versions lesser than
2.60.60.60, information of hardware inventory and health status
of few components might not be available. For more information
about the components for which the information is not available,
see Dell EMC OpenManage Integration with Microsoft Windows
Admin Center User's Guide.

○ In YX2X and YX3X models of PowerEdge servers, following
features are not available:

￭ Cluster-Aware Updating
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Table 1. Compatibility matrix (continued)

Supported software and hardware Version

￭ Health and Inventory information of Accelerators

● YX4X models of PowerEdge servers with iDRAC9 (Recommended
firmware version of 3.30.30.30 or later).

● YX5X models of PowerEdge servers with AMD platforms having iDRAC9
(Recommended firmware version of 3.40.40.40 or later).

● YX5X models of PowerEdge servers with Intel platforms having iDRAC9
(Recommended firmware version 4.40.x.x or later)

● PowerEdge XE2420 Edge server (Recommended iDRAC firmware
4.00.129.00 or later).

NOTE: Update management features such as CAU and full stack
updates are available for the latest platforms once the applicable update
packages and the update catalog are released from Dell EMC, which is
generally within two to three weeks from platform launch.

Supported AX nodes (running Azure Stack HCI
version 20H2 operating system) as target nodes
for Dell EMC Integrated System for Microsoft
Azure Stack HCI

AX-640, AX-740xd, AX-6515, AX-7525, AX-750, and AX-650
NOTE: Integrated Cluster Deployment and Update and Full Stack
Cluster-Aware Updating features are supported in Dell EMC Integrated
System for Microsoft Azure Stack HCI cluster using OpenManage
Integration snap-in extension.

Supported AX and/or Storage Spaces Direct
Ready Nodes (using Windows Server operating
system) as target nodes for Dell EMC HCI
Solutions for Microsoft Windows Server

AX nodes: AX-640, AX-740xd, AX-6515, and AX-7525

Storage Spaces Direct Ready Nodes: R440, R640, R740xd, and R740xd2.

NOTE: Dell EMC OpenManage Integration supports target nodes running Windows Server Core operating system.

Compatibility matrix 9



Installing Dell EMC OpenManage Integration
with Microsoft Windows Admin Center

The Dell EMC OpenManage Integration with Microsoft Windows Admin Center can be installed in one of the following methods:
● By using the Microsoft's public Windows Admin Center NuGet feed. See Install Dell EMC OpenManage Integration with

Microsoft Windows Admin Center by using the official Microsoft NuGet feed on page 11.
● By using a local path or a network share as package source for installation. See Install Dell EMC OpenManage Integration

with Microsoft Windows Admin Center by using local path or network file share on page 11.
● By using the workflow of Microsoft Windows Admin Center during Azure Stack HCI cluster deployment or updates. Install

Dell EMC OpenManage Integration snap-in extension.

NOTE: If you are installing Dell EMC OpenManage Integration with Windows Admin Center extension by using the Custom

Feed option, see the Microsoft documentation to set up a custom feed or share.

Topics:

• Download Dell EMC OpenManage Integration with Microsoft Windows Admin Center
• Install Dell EMC OpenManage Integration with Microsoft Windows Admin Center by using the official Microsoft NuGet feed
• Install Dell EMC OpenManage Integration with Microsoft Windows Admin Center by using local path or network file share
• Install Dell EMC OpenManage Integration extension including snap-in with Microsoft Windows Admin Center

Download Dell EMC OpenManage Integration with
Microsoft Windows Admin Center

Steps

1. Go to Dell.com/support.

2. Perform one of the following actions:
● Enter the Service Tag of your PowerEdge server, and then select Search.
● Select Browse all products > Servers > PowerEdge, and then select the appropriate model of your PowerEdge

server.

3. On the support page of your server, select DRIVERS & DOWNLOADS.

4. From the Category list, select Systems Management.

5. Select the supported version of OpenManage Integration with Microsoft Windows Admin Center, and then click Download.

Results

The downloaded Dell_EMC_OpenManage_Integration_MS_WAC_<Version>.<Build_Number>.zip file contains
the .nupkg file which is used to install OMIMSWAC integrator in Windows Admin Center by using a local path or network
share.

NOTE: Do not rename the .nupkg file while installing the OMIMSWAC extension.

4
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Install Dell EMC OpenManage Integration with
Microsoft Windows Admin Center by using the official
Microsoft NuGet feed

Prerequisites

Before you install Dell EMC OpenManage Integration extension in Windows Admin Center by using the NuGet feed, ensure that
you have:
● Installed the Windows Admin Center 2103.2 GA.
● Logged in to Windows Admin Center as a gateway administrator.

To install Dell EMC OpenManage Integration extension by using the NuGet feed:

Steps

1. In the Windows Admin Center application, in the upper right corner, select Settings.

2. Under GATEWAY, click Extensions.

In the Available extensions tab, the Dell EMC OpenManage Integration extension is listed.

3. Select Dell EMC OpenManage Integration extension, click Install, and then click Confirm to confirm the changes and to
install the extension.

Results

After the Dell EMC OpenManage Integration extension is installed, Windows Admin Center is restarted, and the extension is
listed under Installed extensions.

Install Dell EMC OpenManage Integration with
Microsoft Windows Admin Center by using local path
or network file share

Prerequisites

Before you install Dell EMC OpenManage Integration extension in Windows Admin Center by using a local path or a network file
share, ensure that you have:
● Installed the Windows Admin Center 2103.2 GA.
● Logged in to Windows Admin Center as a gateway administrator.
● Downloaded and extracted the OpenManage Integration with Microsoft Windows Admin Center .zip file from the Dell EMC

support site.

To install Dell EMC OpenManage Integration extension by using a local or network file share:

Steps

1. In the Windows Admin Center application, in the upper right corner, select Settings.

2. Under GATEWAY, click Extensions.

3. Select Feeds > Add.

4. In the Add package source window, enter the local path or network file share where you have extracted the .zip file.
Example paths: C:\<foldername>, \\sharename\foldername.

NOTE:

● Make sure the .nupkg file name is dell-emc.openmanage-integration.<Version>.nupkg while adding the

OMIMSWAC extension.

● You must set read and write permissions to the local or network file location.
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5. Click Add.
If the extension is successfully added, the extension is listed under the Available Extensions tab.

6. Select Dell EMC OpenManage Integration extension, click Install, and then click Confirm to confirm the changes and to
install the extension.

Results

After the Dell EMC OpenManage Integration extension is installed, Windows Admin Center is restarted, and the extension is
listed under Installed extensions.

NOTE: While installing OMIMSWAC by using local path or network path, multiple instances of OMIMSWAC extension might

be listed under Available and Installed Extensions, when:

● More than one .nuget packages are available in the specified folder path.

● The .nuget packages are available in root or subfolders in addition to the folder path provided under Feeds > Add

package source.

Install Dell EMC OpenManage Integration extension
including snap-in with Microsoft Windows Admin
Center
You can install OpenManage Integration extension including snap-in during Azure Stack HCI cluster deployment or Azure Stack
HCI cluster updates in Windows Admin Center to ensure hardware symmetry compliance and run hardware updates (Firmware,
BIOS, and Drivers) on target nodes.

Prerequisites

Before you install Dell EMC OpenManage Integration snap-in in Windows Admin Center, ensure that you have:
● Installed the Windows Admin Center 2103.2 GA.
● Logged in to Windows Admin Center as a gateway administrator.

Steps

1. If OMIMSWAC extension is not installed, you can install the OpenManage Integration extension including snap-in using one of
the following methods:
● When deploying an Azure Stack HCI cluster, on Install hardware updates, click Install to install the snap-in extension.
● When updating an Azure Stack HCI cluster, under Tools > Updates, on Hardware updates page, click Install to install

the snap-in extension.

2. If the extension is getting installed for the first time, a consent form is displayed to inform you about the End User License
Agreement (EULA) and operations performed by the OpenManage Integration such as enabling the USB NIC and creating an
iDRAC user on the target node. Click Accept to continue to update the target nodes or cluster by using the OpenManage
Integration.

Results

When the OpenManage Integration snap-in is installed, the OpenManage Integration extension appears under the Tools menu in
the Windows Admin Center. You will be able to use all the features of OpenManage Integration extension along with the snap-in
specific features.

NOTE: If OpenManage Integration version 1.1.1 or earlier is already installed,

● To install OpenManage Integration snap-in extension when deploying or updating an Azure Stack HCI cluster, it is

recommended to uninstall the older version (OMIMSWAC 1.1.1 or earlier) and then use the Microsoft cluster creation or

cluster update workflow to install OpenManage Integration snap-in extension to use the latest features. See Installing

Dell EMC OpenManage Integration with Microsoft Windows Admin Center.OR,

● To upgrade to OpenManage Integration snap-in from earlier versions, go to Extensions > Installed extensions tab.

Select Dell EMC OpenManage Integration extension with the status "Update available (version)" and then click Update.
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Next steps

After the OMIMSWAC extension version 2.0 or above is installed, while deploying or updating an Azure Stack HCI cluster, select
Get updates in the Install hardware updates page or Hardware updates page respectively to continue to update the target
nodes or cluster by using OpenManage Integration snap-in.
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Upgrading OpenManage Integration with
Microsoft Windows Admin Center

Before you upgrade to OMIMSWAC version 2.1, ensure that you have installed the Windows Admin Center 2103.2 GA.

You can upgrade the OpenManage Integration with Microsoft Windows Admin Center (OMIMSWAC) extension by using one of
the following methods:
● By using the official Microsoft Nuget feed.
● By using a local path or network file share with the downloaded .zip file from Dell EMC Support Site.

NOTE: Upgrading to OMIMSWAC version 2.1 from previous versions is not supported by the Azure Stack HCI cluster

creation or update workflow interface. Instead, you can only install the OMIMSWAC version 2.1 when creating or updating

an Azure Stack HCI cluster. To do that, it is recommended to uninstall the older version (OMIMSWAC 2.0 or earlier) and

then use the Microsoft cluster creation or update workflow to install the OMIMSWAC version 2.1 to use the latest features.

However, to upgrade to OpenManage Integration snap-in from earlier versions, go to Extensions > Installed extensions

tab. Select Dell EMC OpenManage Integration extension with the status "Update available (version)" and then click

Update.

Topics:

• Upgrading Dell EMC OpenManage Integration with Microsoft Windows Admin Center by using the official Microsoft NuGet
feed

• Upgrade Dell EMC OpenManage Integration with Microsoft Windows Admin Center by using local path or network file share

Upgrading Dell EMC OpenManage Integration with
Microsoft Windows Admin Center by using the official
Microsoft NuGet feed

Prerequisites

Before you upgrade Dell EMC OpenManage Integration extension in Windows Admin Center by using a local path or a network
file share, ensure that you have:
● Installed the Windows Admin Center 2103.2 GA.
● Logged in to Windows Admin Center as a gateway administrator.
● Downloaded and extracted the OpenManage Integration with Microsoft Windows Admin Center .zip file from the Dell EMC

support site.

Steps

1. In the Windows Admin Center application, in the upper right corner, select Settings.

2. Under GATEWAY, click Extensions.

3. In the Installed extensions tab, available update to the Dell EMC OpenManage Integration extension is displayed. Click
Update.

Alternatively, you can also update the Dell EMC OpenManage Integration extension by using the Available extensions
tab and clicking Install.

Results

After the Dell EMC OpenManage Integration extension is updated to a newer version, the Microsoft Windows Admin Center is
restarted.

5
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Upgrade Dell EMC OpenManage Integration with
Microsoft Windows Admin Center by using local path
or network file share

Prerequisites

Before you upgrade the Dell EMC OpenManage Integration extension in Windows Admin Center by using a local path or a
network file share, ensure that you have:
● Installed the Windows Admin Center 2103.2 GA.
● Logged in to Windows Admin Center as a gateway administrator.
● Downloaded and extracted the latest version of OpenManage Integration with Microsoft Windows Admin Center .zip file

from the Dell EMC support site.

To upgrade Dell EMC OpenManage Integration extension by using a local or network file share:

Steps

1. In the Windows Admin Center application, in the upper right corner, select Settings.

2. Under GATEWAY, click Extensions.

3. Under Feeds, select any previously added feed and click Delete.

4. To add a new feed, click Add.

5. In the Add package source window, enter the local path or network file share where you have extracted the .zip file.
Example paths: C:\<foldername>, \\sharename\foldername.

NOTE: Do not rename the .nupkg file in the extracted folder.

NOTE: You must set read and write permissions to the local or network file location.

6. After the extension is successfully added, the latest version of the extension is listed under the Available Extensions tab.
To upgrade, click Install.

Results

After the Dell EMC OpenManage Integration extension is upgraded, Windows Admin Center is restarted, and the extension is
listed under Installed extensions.

NOTE: While installing OMIMSWAC by using local path or network path, multiple instances of OMIMSWAC extension might

be listed under Available and Installed Extensions, when:

● More than one .nuget packages are available in the specified folder path.

● The .nuget packages are available in root or subfolders in addition to the folder path provided under Feeds > Add

package source.
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Launching OpenManage Integration with
Microsoft Windows Admin Center

Before you launch Dell EMC OpenManage Integration extension in Windows Admin Center, ensure that you have:
● Logged in to Windows Admin Center as a gateway administrator.
After installing the OpenManage Integration with Microsoft Windows Admin Center (OMIMSWAC), perform the following
actions to launch the extension:

1. In the upper left corner of Windows Admin Center, select Server Manager or Cluster Manager from the drop-down menu.

The supported WAC version is Windows Admin Center 2103.2 GA.

2. From the list, select a server or cluster connection, and then click Connect.
3. Provide server or cluster credentials.

NOTE: If "Manage as" credentials are not provided while connecting to a target node or cluster or not available to the

extension, you will be prompted to specify the "Manage as" credentials inside the extension when you try to manage the

target node or cluster.

4. In the left pane of the Microsoft Windows Admin Center, under EXTENSIONS, click Dell EMC OpenManage Integration.

When you launch the OpenManage Integration for the first time, a consent form is displayed to inform you about the operations
performed by the OpenManage Integration such as enabling the USB NIC and creating an iDRAC user on the target node. Click
Accept to continue to manage the PowerEdge servers by using the OpenManage Integration.

NOTE: After the information from the target nodes is collected, the previously created iDRAC user is deleted by

OMIMSWAC.

To ensure proper functioning of OpenManage Integration with Microsoft Windows Admin Center, ensure that:
● Firewall in your enterprise environment enables communication through SMB port 445.
● Redfish service is enabled on the target node.
● An iDRAC user slot is available on the target node.
● The target node is not booted to Lifecycle Controller.
● The target node is not in the reboot state, or is powered-off.
● The USB NIC adapter is not disabled on the target node OS.
● The lockdown mode is disabled on target node.

NOTE: For management of PowerEdge servers, OMIMSWAC uses an internal OS to iDRAC Pass-through interface. By

default, iDRAC will be reachable using the IP address 169.254.0.1/<Subnet> or 169.254.1.1/<Subnet>. However, if the host

has another network interface in the same subnet (For example, when a tool like VMFleet is installed), OMIMSWAC might

not be able to communicate to the iDRAC from the host OS. To resolve the conflict, log in to iDRAC and change the USB

NIC IP address under the OS to iDRAC passthrough section. For more information about assigning this IP address, see the

iDRAC documentation on the Dell EMC support site.

For more information about using and configuring the OpenManage Integration with Microsoft Windows Admin Center
extension, see Dell EMC OpenManage Integration with Microsoft Windows Admin Center User's Guide on the Dell EMC support
site.
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Uninstall Dell EMC OpenManage Integration
with Microsoft Windows Admin Center

Steps

1. In the Windows Admin Center application, in the upper right corner, select Settings.

2. Under GATEWAY, click Extensions.

3. In the Installed extensions tab, select the Dell EMC OpenManage Integration integration, and then click Uninstall.

4. Click Confirm to proceed with the uninstallation of the extension.

Results

After the Dell EMC OpenManage Integration extension is uninstalled, Windows Admin Center is restarted, and the extension is
listed under Available extensions.

NOTE: After OpenManage Integration with Windows Admin Center is uninstalled, the update tool settings will be retained in

the Windows Admin Center instance. However, the passwords are not retained.
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Identifying the generation of your Dell EMC
PowerEdge server

To cover a range of server models, the PowerEdge servers are now be referred to using the generic naming convention and not
their generation.

This topic explains how to identify the generation of a PowerEdge server that are referred to using the generic naming
convention.

Example:

The R740 server model is a rack, two processor system from the 14th generation of servers with Intel processors. In the
documentation, to refer to R740, generic naming convention YX4X server is used, where:

● The letter Y (alphabet) denotes the type (form factor: Cloud (C), Flexible(F), Modular (M or MX), Rack(R), Tower(T)) of
the server.

● The letter X (digit) denotes the class (number of processors) of the server.

● The digit 4 denotes the generation of the server.

● The letter X (digit) denotes the make of the processor.

Table 2. PowerEdge servers naming convention and examples 

YX5X servers YX4X servers YX3X servers

PowerEdge R7515 PowerEdge M640 PowerEdge M630

PowerEdge R6515 PowerEdge R440 PowerEdge M830

PowerEdge R540 PowerEdge T130
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Additional resources

Table 3. Additional resources 

Document Description Availability

Dell EMC OpenManage
Integration with Microsoft
Windows Admin Center
User's Guide

Provides information about using
OpenManage Integration with Microsoft
Windows Admin Center.

1. Go to Dell.com/OpenManageManuals.
2. Select OpenManage Integration with

Microsoft Windows Admin Center.
3. Click DOCUMENTATION > MANUALS

AND DOCUMENTS to access these
documents.

Dell EMC OpenManage
Integration with Microsoft
Windows Admin Center
Release Notes

Provides information about new features,
known issues and workarounds in
OpenManage Integration with Microsoft
Windows Admin Center.

Dell EMC Infrastructure
Compliance Report for
PowerEdge Servers and
Azure Stack HCI Clusters
using the OMIMSWAC

This white paper describes the process
to generate update compliance report for
PowerEdge servers, Microsoft Azure Stack
HCI clusters, and Hyper-V based failover
clusters by using OMIMSWAC.

Dell EMC OpenManage
Integration with Microsoft
Windows Admin Center
Security Configuration
Guide

Provides information about security features
and capabilities of Dell EMC OpenManage
Integration with Microsoft Windows Admin
Center.

Microsoft Windows Admin
Center documentation

For more information about using Microsoft
Windows Admin Center.

https://www.microsoft.com/en-us/cloud-
platform/windows-admin-center

Integrated System for Azure
Stack HCI

For more information about Dell EMC
Integrated System for Microsoft Azure Stack
HCI.

https://infohub.delltechnologies.com/t/
microsoft-hci-solutions-from-dell-
technologies-1/
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Contacting Dell EMC
About this task

Dell EMC provides several online and telephone-based support and service options. Availability varies by country and product,
and some services may not be available in your area.

NOTE: If you do not have an active Internet connection, you can find contact information on your purchase invoice, packing

slip, bill, or Dell EMC product catalog.

To contact Dell EMC for sales, technical support, or customer service issues:

Steps

1. Go to Dell.com/support.

2. Select preferred country or region from the list at the bottom right of the page.

3. Click Contact Us and select the appropriate support link.
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