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Introduction to Power Manager
Dell EMC OpenManage Enterprise Power Manager is an extension or a plugin to the Dell EMC OpenManage Enterprise (OME)
console and uses fine-grained instrumentation to provide increased visibility to power consumption, anomalies, and utilization.
Also, Power Manager alerts and reports about power and thermal events in servers, chassis, and custom groups consisting
of servers and chassis. This reporting enables increased control, faster response times, greater accuracy, and broader decision-
making intelligence than is otherwise possible.

When used with PowerEdge servers or modular systems with an iDRAC Enterprise or iDRAC Datacenter license, or supported
chassis and OpenManage Enterprise Advanced license, Power Manager leverages information from the OME console to deliver
platform-level power reporting. Power Manager then communicates with Integrated Dell Remote Access Controller (iDRAC) or
Chassis Management Controller (CMC) on each managed device to provide power-management data and execution of control
policy—making it easy for administrators to identify areas in which they can gain efficiencies and cut wasteful costs.
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What's new in this release
● Power Manager can now support devices up to 6000.
● After upgrading OpenManage Enterprise, if the installed version of Power Manager is incompatible with the latest version of

OpenManage Enterprise, Power Manager extension is disabled.
● Flexibility to download the Power Manager files and install the extension at a convenient time.
● Sort and filter information for all the features in Power Manager.
● Support for configuring the power cap value in Watts or percentage at a group level.
● Dedicated landing page for Power Manager.
● Improvements in widgets for better user experience.
● Support for creating and maintain temperature-triggered policies to prevent damage to managed devices due to overheating

caused by failure of cooling infrastructure by applying Emergency Power Reduction (EPR) on the devices.
● Added support to view temperature-triggered policy details in existing in-built reports.
● View the top 10 devices and groups violating power and temperature thresholds.
● Support for Dell EMC VxRail systems.
● Support for PowerEdge servers with AMD processors with iDRAC version 4.10.10.10 onwards.
● Support for iDRAC Datacenter license.
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Compatibility matrix

Topics:

• Supported devices in Power Manager
• Role-based user privileges for Power Manager

Supported devices in Power Manager
Power Manager supports the following list of Dell EMC PowerEdge servers and chassis.

Table 1. Supported servers and chassis models 

Category Model

Server ● Dell EMC VxRail E460
● Dell EMC VxRail E460F
● Dell EMC VxRail P470
● Dell EMC VxRail P470F
● Dell EMC VxRail S470
● Dell EMC VxRail V470
● Dell EMC VxRail V470F
● Dell EMC VxRail E560
● Dell EMC VxRail E560F
● Dell EMC VxRail E560N
● Dell EMC VxRail P570
● Dell EMC VxRail P570F
● Dell EMC VxRail S570
● Dell EMC VxRail V570
● Dell EMC VxRail V570F
● Dell EMC VxRail P580N
● PowerEdge R320 Server
● PowerEdge R420 Server
● PowerEdge R520 Server
● PowerEdge R620 Server
● PowerEdge R720 Server
● PowerEdge R720xd Server
● PowerEdge R820 Server
● PowerEdge R920 Server
● PowerEdge M620 Server
● PowerEdge M520 Server
● PowerEdge T320 Server
● PowerEdge T420 Server
● PowerEdge T620 Server
● PowerEdge R330 Server
● PowerEdge R430 Server
● PowerEdge R440 Server
● PowerEdge R530 Server
● PowerEdge R530XD Server
● PowerEdge R540 Server
● PowerEdge R630 Server
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Table 1. Supported servers and chassis models (continued)

Category Model

● PowerEdge R730 Server
● PowerEdge R730Xd Server
● PowerEdge R7415 Server
● PowerEdge R7425 Server
● PowerEdge R930 Server
● PowerEdge R6415 Server
● PowerEdge R640 Server
● PowerEdge R740 Server
● PowerEdge R740XD Server
● PowerEdge R830 Server
● PowerEdge R840 Server
● PowerEdge R940 Server
● PowerEdge R940xa Server
● PowerEdge M630 Server
● PowerEdge M640 Server
● PowerEdge M830 Server
● PowerEdge T330 Server
● PowerEdge T430 Server
● PowerEdge T440 Server
● PowerEdge T630 Server
● PowerEdge FC430 Server
● PowerEdge FC630 Server
● PowerEdge FC640 Server
● PowerEdge FC830 Server
● PowerEdge C6320 Server
● PowerEdge C6320p Server
● PowerEdge C6420 Server
● PowerEdge MX740C Server
● PowerEdge MX840C Server
● PowerEdge R340 Server
● PowerEdge T340 Server
● PowerEdge R740xd2 Server
● PowerEdge R7525 Server
● PowerEdge R7515 Server
● PowerEdge R6515 Server
● PowerEdge R6525 Server
● PowerEdge C6525 Server

Chassis ● PowerEdge M1000e
● PowerEdge VRTX Blade Enclosure
● PowerEdge FX2/FX2s
● PowerEdge MX7000

Versions of Power Manager compatible with OpenManage
Enterprise

The following table shows Power Manager and OpenManage Enterprise version compatibility.

Table 2. Compatibility matrix of Power Manager and OpenManage Enterprise  

Power Manager Version OpenManage Enterprise Version

Power Manager 1.1 OpenManage Enterprise 3.4
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Table 2. Compatibility matrix of Power Manager and OpenManage Enterprise  (continued)

Power Manager Version OpenManage Enterprise Version

Power Manager 1.0 ● OpenManage Enterprise 3.2
● OpenManage Enterprise 3.2.1
● OpenManage Enterprise 3.3
● OpenManage Enterprise 3.3.1

Supported protocols

Power Manager supports the following protocols:
● Power Manager supports only Web Services for Management (WSMAN) protocol for servers and chassis.
● Power Manager supports only Representational State Transfer (REST) protocol for PowerEdge MX7000 chassis.

Hardware requirements

The following table lists the minimum set of hardware configurations that are based on the number of devices you want to
monitor through Power Manager.

Table 3. Minimum required hardware 

Minimum recommended
hardware

Large deployments Small deployments

Number of devices that Power
Manager can manage

Up to 6000 1000

RAM 32 GB 16 GB

Processors 8 cores 4 cores

Hard drive 250 GB 250 GB

Supported web browsers

Power Manager supports the following versions of web browsers:
● Internet Explorer (64-bit) 11 and later
● Mozilla Firefox 52 and later
● Google Chrome 58 and later
● Microsoft Edge version 41.16299 and later

Power Manager is not supported on the following:

● PowerEdge M1000e, PowerEdge VRTX, PowerEdge FX2, and PowerEdge FX2s chassis discovered with viewer credentials
● Servers with cabled Power Supply Units (PSUs)
● PowerEdge FM120x4
● Servers added through In-Band server discovery.
● iDRAC firmware version 4.00.00.00

Role-based user privileges for Power Manager
Role-based Access Control (RBAC) is a method to provide restrictive access to the users by assigning a role to each user.
The user's role determines the level of access for all the Power Manager and device management features. The following
table provides a list of different user roles and their permissions for all the features in Power Manager. Therefore, the console
enforces one role per account.
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Table 4. Role-based user privileges for Power Manager 

Features Admin user Device Manager Viewer

Install Power Manager Yes No No

Enable Power Manager Yes No No

Disable Power Manager Yes No No

Uninstall Power Manager Yes No No

Add or remove devices from
Power Manager

Yes Yes No

Add or remove groups from
Power Manager

Yes No No

Monitor metrics Yes Yes Yes

Manage power policies for
devices

Yes Yes No

Manage power policies for
groups

Yes No No

Manage temperature-
triggered policies for groups

Yes No No

Manage alert thresholds in
Power Manager

Yes Yes No

View alert thresholds in
Power Manager

Yes Yes Yes

Modify Power Manager
Settings

Yes No No

View Power Manager Settings Yes Yes Yes

Manage Emergency Power
Reduction (EPR) for devices

Yes Yes No

Manage Emergency Power
Reduction (EPR) for groups

Yes No No

Run and view reports for
devices and groups

Yes Yes Yes

Manage custom reports for
devices

Yes Yes No

Manage custom reports for
groups

Yes Yes No

View events Yes Yes Yes

Dashboard Yes Yes Yes
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License requirements
Use OpenManage Enterprise Advanced license together with your iDRAC license to work with all the features of Power
Manager. The following table provides the license combinations that are required to use Power Manager.

Table 5. License capability with servers 

OpenManag
e Enterprise
Advanced
license

iDRAC Base license iDRAC
Express
license

iDRAC
Enterprise
license

iDRAC Data
Center license

Device and
group
monitoring

Device and
group
management

Not added Added Not added Not added Not added Not added Not added

Not added Not added Added Not added Not added Not added Not added

Not added Not added Not added Added Not added Not added Not added

Not added Not added Not added Not added Added Not added Not added

Added Added Not added Not added Not added Not added Not added

Added Not added Added Not added Not added Added Not added

Added Not added Not added Added Not added Added Added

Added Not added Not added Not added Added Added Added

Table 6. License capability with chassis 

Chassis models CMC Enterprise
license

Monitoring Power policy Emergency
Power
Reduction
(EPR)

PowerEdge VRTX Not added Yes No Yes

PowerEdge VRTX Added Yes Yes Yes

PowerEdge FX2 or PowerEdge FX2s Not added Yes No Yes

PowerEdge FX2 or PowerEdge FX2s Added Yes Yes Yes

PowerEdge M1000e NA Yes Yes Yes

PowerEdge MX7000 NA Yes Yes Yes

Licensing behavior in Power Manager for devices:
● If the OpenManage Enterprise Advanced license on the target devices is expired or deleted, the devices are removed from

Power Manager. You must re-add the devices to Power Manager after adding the license.
● If EPR is enabled on a device, and the device is removed from Power Manager due to an expired or deleted license, then you

cannot access the device through Power Manager. To disable EPR, go to the iDRAC or CMC page of the device and remove
the EPR.

● If policy and alert thresholds are set on a device, and the device is removed from Power Manager due to an expired or
deleted license, then the policy and alert thresholds are removed from the device.

Licensing behavior in Power Manager for groups:
● For a group, only the devices that have a valid license are added as part of the group into Power Manager. Metrics are

collected only for these devices in the group.
● If the OpenManage Enterprise Advanced license is expired or deleted from the target devices that are part of a group,

the devices are removed from Power Manager. After updating the license, these devices are automatically added to Power
Manager in the next inventory cycle.

● If EPR is enabled on a group, and if the license is expired or deleted for any device in a group, the device is not removed
from Power Manager.
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● If EPR is enabled on a group, you cannot remove the group or any device that is part of the group from Power Manager.
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Scalability and performance
Power Manager supports up to 6000 target devices.

It is important to configure appropriate Power and Temperature Sampling Intervals in Power Manager, because sampling
intervals impact the system performance and footprint significantly, including network bandwidth consumption, database size,
and trend graph display latency.

The default power and temperature intervals in Power Manager are 15 minutes. This value is appropriate for small, or medium-
sized environments where the device number is less than 1000. However, when the environment has more managed devices,
the interval is automatically set to 30 minutes.
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Power Manager workflow
This section provides high-level information to help administrators get started with Power Manager.

Prerequisites

Ensure that the following prerequisites are met:
1. Discover the devices in Dell EMC OpenManage Enterprise.
2. After discovering the devices, create static groups in Dell EMC OpenManage Enterprise.

For more information about discovering devices and creating static groups, see OpenManage Enterprise User's Guide.

About this task

To monitor power and temperature data of devices and groups using Power Manager, perform the following steps:

Steps

1. Add OpenManage Enterprise Advanced license on iDRAC of target devices.

2. Add the supported devices or static groups to Power Manager.

NOTE: Only the devices that are supported by Power Manager can be added as part of the group. For more information

about supported devices, see List of supported devices.

3. Configure all the setting Power Manager as per your data center specifications using the Power Manager Settings page.

After configuring Power Manager, you can perform the following tasks:
● View all the device or group metrics details related to Power Manager using Metrics and Monitoring History.
● Create and apply Policies to regulate the power consumption on devices or groups.
● Create and apply to regulate device temperature.
● During a power emergency, reduce power consumption using the Emergency Power Reduction feature.
● Create alert thresholds in Power Manager by configuring the warning and critical values for devices or groups that are

monitored in Power Manager.
● Run the built-in or customized reports to view in-depth information about the devices or groups, jobs, alerts, and other

parameters of your data center.
● View and acknowledge alerts that are generated in OpenManage Enterprise through Power Manager in Alerts > Alert

Logs.
● View generic Power Manager logs generated in OpenManage Enterprise through Monitor > Audit Logs tabs.
● To quickly view power and thermal history of your favorite groups, add them to OpenManage Enterprise dashboard. For

more information, see widgets.
● To view top five devices or groups that consume maximum energy, see the Top Energy Consumer graph on the

OpenManage Enterprise dashboard.
● To view a ratio of number of devices that are added to OpenManage Enterprise and are compatible with Power

Manager to total devices that are managed by Power Manager, see Power Manager Devices Statistics graph on the
OpenManage Enterprise dashboard.

● To view top 10 offenders of power and temperature, see Viewing top 10 offenders.
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Getting started with Power Manager

Topics:

• Installing Power Manager
• Adding devices to Power Manager
• Adding static groups to Power Manager
• Viewing devices and groups added to Power Manager

Installing Power Manager
To monitor power and thermal data for devices or groups, install the Power Manager plugin on OpenManage Enterprise.

Prerequisites

Ensure that the following prerequisite is met:
● Connectivity to the repository is successful:

○ To connect to an online repository, connect to downloads.dell.com portal.

○ To connect to an offline repository, ensure that the offline server is configured with required plugin catalog and plugin
installation files.

About this task

NOTE: Installing a plugin on OpenManage Enterprise restarts the appliance services.

NOTE: From OpenManage Enterprise version 3.5 the word extension is replaced with the word plugin.

To install the plugin, perform the following steps:

Steps

1. Launch Dell EMC OpenManage Enterprise.

2. If you are using OpenManage Enterprise version 3.4 or earlier, in Application Settings, click Console and Extensions.

The Console and extensions page is displayed.

If you are using OpenManage Enterprise version 3.5, in Application Settings, click Console and Plugins.

The Console and plugins page is displayed.

3. In the Power Manager section, click Install.
The Install Extension or Install Plugin page is displayed.

4. Click Download extension or Download plugin.
The plugin is downloaded and the status of the download is displayed on a green color band at the right top corner.

5. Review and ensure that you meet the list of prerequisites that are mentioned in the Prerequisites section.

NOTE: The lists of prerequisites change depending on the version of plugin that select.

6. In Install Details, select the required version of Dell EMC OpenManage Enterprise Power Manager from the Version(s)
drop-down menu, and then click Install Extension or Install plugin.

The details of the number of users who are logged in to OpenManage Enterprise, tasks in progress, and schedule jobs are
displayed in the confirmation window.

To confirm the installation, select the I agree that I have captured the snapshot of the OM Enterprise appliance prior
to the upgrade option, and then click Confirm Install.

The status of the installation is displayed.
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● To instantly view the latest list of devices and groups that are part of Power Manager as a result of any license
changes made on the target devices, click Run Inventory in OpenManage Enterprise, and then click the Refresh Power
Manager capabilities option on the Power Manager Settings page.

● View the count of overall power-capable devices from the Power Manager Devices Statistics section of the
OpenManage Enterprise dashboard.

Adding devices to Power Manager
To collect and monitor power and thermal utilization, and airflow data of devices, add the devices in Power Manager.

Prerequisites

Ensure that the following prerequisites are met:
● The devices have the required management console license. For more information, see the License requirements section.
● Servers have an OpenManage Enterprise Advanced license. For information about adding the license, see OpenManage

Enterprise User's Guide.
● Devices are discovered in OpenManage Enterprise. For information about discovering devices, see OpenManage Enterprise

User's Guide.
● The modular server is not in a Proxied state in OpenManage Enterprise.

About this task

To view the list of devices that are compatible with Power Manager, before running the inventory in OpenManage Enterprise
and immediately after the installation, perform the following steps:
1. In OpenManage Enterprise, click Devices > Run Inventory option.
2. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Monitored Devices and

Groups > Refresh the list for Power Manager capabilities tab.

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Monitored Devices and
Groups > Refresh the list for Power Manager capabilities tab.

The list of devices compatible with Power Manager are displayed when you start to add the devices from OpenManage
Enterprise.

To add devices, perform the following steps:

Steps

1. Launch OpenManage Enterprise.

2. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Monitored Devices and
Groups.

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Monitored Devices and
Groups.

The Monitored Devices and Groups tab is displayed.

3. Click Individual Devices > Add device(s).
The Add Devices to Power Manager page is displayed.

4. View all the devices that are discovered in OpenManage Enterprise by expanding the SYSTEM GROUPS section on the left
side and in All Devices tab, select the devices that you want to add.

5. (Optional) To filter and view the data:

a. Click Advanced Filters.

The following filters are displayed:

● Health State
● Power State
● Connection State
● Name
● Service Tag
● Model
● Type
● Managed State
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6. To clear the filters, click Clear All filters.

7. To view the selected devices, click Selected Devices tab.

8. To add the devices, click Add Selected.
All the devices added individually to Power Manager are displayed on the Individual Devices tab along with the total count
of devices that are added to Power Manager.

All the individual devices and devices that are part of the selected group, are added to Power Manager, and are displayed on
the All Monitored Devices tab along with the total count of devices.

Adding static groups to Power Manager
To collect and monitor custom static group data, add the groups in Power Manager.

Prerequisites

Ensure that the following prerequisites are met:
● Static groups are created in OpenManage Enterprise. For information about creating groups, see OpenManage Enterprise

User's Guide.
● The servers that are part of a group must have OpenManage Enterprise Advanced license. For information about adding the

license, see OpenManage Enterprise User's Guide.
● None of the modular servers that are part of the group are not in a Proxied state in OpenManage Enterprise.
● It is recommended that each group contains less than or equal to 40 devices.
● The maximum number of groups that you can add to Power Manager is 500.
● The maximum level of group nesting is 5.

About this task

NOTE: Query groups that are created in OpenManage Enterprise are not supported in Power Manager.

NOTE: After adding a group into Power Manager, only devices that are compatible with Power Manager are added as part

of the group. Hence, the data is collected only for these devices in a group. For example, if a group you have added to

Power Manager consists of five devices, but only three devices have valid licenses, only three devices are added as part of

the group in Power Manager.

To add groups, perform the following steps:

Steps

1. Launch OpenManage Enterprise.

2. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Monitored Devices and
Groups.

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Monitored Devices and
Groups.

The Monitored Devices and Groups tab is displayed.

3. On the Static Groups tab, click Add Group(s).
The Add Groups to Power Manager page is displayed.

4. On the left pane, select a group from the Static Groups category and click Add Selected.
The groups added to Power Manager are displayed in Groups page along with the total count of groups added.

All the individual devices and devices that are part of the selected group, are added to Power Manager, and are displayed on
the All Monitored Devices tab along with the total count of devices.

Next steps

If the static groups were created and devices were added to the groups in OpenManage Enterprise before installing Power
Manager, and when you add the groups to Power Manager, the total number of servers present in the group is displayed as
zero. Click the Refresh the list for Power Manager capabilities option on the Monitored Devices and Groups tab after
running an inventory in OpenManage Enterprise.

For more information about running an inventory, see OpenManage Enterprise User's Guide.
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Viewing devices and groups added to Power Manager

About this task

To view devices or groups that are added to Power Manager, perform the following steps:

Steps

1. Launch OpenManage Enterprise.

2. Click Power Management section, and then click Monitored Devices and Groups.
The Monitored Devices and Groups tab is displayed.

3. To refresh the list of devices and groups that are added, click Refresh the list for Power Manager Capabilities.

4. To view a device or a group that is added to Power Manager, perform one of the following:

● To view a static group, click the Static Groups tab.
● To view a physical group, click the Physical Groups tab.
● To view a device, click the Individual Devices tab.
● To view all the devices added to Power Manager as individual devices and as a part of groups, click the All Monitored

Devices tab.

5. To filter and view the data on any of the tabs:

a. Click a tab.
b. Click Advanced Filters.
c. Select a filter category.

The following filters are displayed for the Static Groups and Physical Groups tabs:
● Group Name

The following filters are displayed for the Individual Devices tab:

● Health State
● Power State
● Connection State
● Name
● Service Tag
● Model
● Type
● Managed State

The following filters are displayed for the All Monitored Devices tab:

● Health State
● Power State
● Connection State
● Name
● Service Tag
● Model
● Type
● Managed State
● Part of Group

6. To clear the filters, click Clear All filters.

7. To sort any column alphabetically, click the column name so that an arrow is displayed with the column name.
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Maintaining Power Manager

Topics:

• Setting preferences
• Updating Power Manager
• Disabling Power Manager
• Enabling Power Manager
• Removing devices
• Removing groups
• Uninstalling Power Manager

Setting preferences
The settings on the page enables you to collect data for the devices and groups added to Power Manager. Set the Sampling
Intervals according to your data center recommendations and monitor your devices.

About this task

To set the units and sampling intervals, perform the following steps:

Steps

1. Launch OpenManage Enterprise.

2. If you are using OpenManage Enterprise version 3.4 or earlier, click From OpenManage Enterprise, click Power
Management > Settings.

If you are using OpenManage Enterprise version 3.5, click From OpenManage Enterprise, click Plugins > Power
Management > Settings.

The Settings window is displayed.

3. Click Edit.
The Edit Power Manager Preferences window is displayed.

4. Select the values for the listed options, and then click Apply.

The following table provides more information about the attributes that are displayed in Power Manager.

Table 7. Power Manager Settings 

Field Description

Data gathering interval Select the frequency to collect data from devices or groups.

Use your data center requirements such as network traffic,
and criticality of data to set the data gathering interval.

NOTE: If you have set the data gathering interval as
15 minutes, and only when the number of devices that
are added to Power Manager exceed 1000, the interval
automatically changes to 30 minutes. You cannot return
this 30 minutes setting to 15 minutes.

Duration of top energy consumers Select the duration to view the list of devices or groups that
consume maximum energy on the OpenManage Enterprise
dashboard for the selected duration.

Only top five energy consumers are displayed.

Report Duration View data for the selected duration.

8
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Table 7. Power Manager Settings (continued)

Field Description

Aggregation Period Select frequency of the level of detailed information that
has to be displayed in reports.

NOTE: If you select a Report Duration other than 1
Day, the Aggregation Period is automatically set to 1
Day.

Delete Power Manager data Based on your data requirements, select one of the options:
● Yes—To delete configured alert thresholds and metric

data that is collected from devices and groups when
they are removed from Power Manager.

● No—To retain the configured alert thresholds and metric
data that is collected from devices and groups when
they are removed from Power Manager.

NOTE: When you add a device or group and set Delete
Power Manager data to No, all Power Manager-related
data for that device or group is removed from view but
not deleted, when you remove the device or group from
Power Manager. When you re-add the device or group,
data for that device or group is available again.

Reset WSMAN power metric data Based on data accuracy requirement, select one of the
following options:
● Enabled—To reset the current cumulative energy

consumption (in kWh) for the server or chassis in iDRAC
or CMC. This reset depends on the selected Data
gathering interval.

● Disabled—To not reset the cumulative energy
consumption data in iDRAC or CMC.

NOTE: To delete the data after specific duration, configure the Data purge interval option present in the following

location: OpenManage Enterprise > Application Settings > Console Preferences > Metrics Collection Settings.

The following table provides further information about the mandatory fields and the value range for each field.

Table 8. Details about mandatory data intervals and duration 

Field Mandatory Value Range

Power Unit Yes

Watt is the default unit.

● Watt
● BTU/Hr

Temperature Unit Yes

Celsius is the default unit.

● Celsius
● Fahrenheit

Data gathering interval Yes

The default value is 15 minutes.

● 15
● 30
● 60

Duration of top energy consumers Yes

The default value is 3 Months.

● 1 Day
● 7 Days
● 15 Days
● 1 Month
● 3 Months
● 6 Months
● 1 Year

Report Duration Yes

The default value is 3 Months.

● 1 Day
● 7 Days
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Table 8. Details about mandatory data intervals and duration (continued)

Field Mandatory Value Range

● 15 Days
● 1 Month
● 3 Months
● 6 Months
● 1 Year

Aggregation Period Yes

The default value is 1 Day.

1 Day

Delete Power Manager data Yes

The default value is No.

● Yes
● No

Reset WSMAN power metric data Yes

The default value is Disabled.

● Disabled
● Enabled

Updating Power Manager

About this task

To update Power Manager from OpenManage Enterprise, perform the following:

Steps

1. Configure the location of repository to check for updates. For more information, see Configuring OpenManage Enterprise for
Power Manager updates.

2. Upgrade Power Manager. For more information, see Upgrading Power Manager.

Configuring OpenManage Enterprise for Power Manager updates

About this task

Check for Power Manager updates at downloads.dell.com or an offline location. To configure OpenManage
Enterprise to view updates, perform the following:

Steps

1. Launch Dell EMC OpenManage Enterprise.

2. Click Application Settings > Console and Extensions.

The Console and Extensions page is displayed.

3. To configure updates, click Update Settings.

The Update Settings page is displayed.

4. In How to check for updates, select one of the following options:

● Automatic—automatically check for updates every week. This frequency cannot be changed.
● Manual—manually check for updates.

5. In Where to check for updates, select one of the following options and click Apply:

● Online—check for updates at downloads.dell.com.

● Offline—check for updates at the specified offline source.

To use an internal network share as an offline update source, download the relevant files from downloads.dell.com
and save them on a NFS share preserving the same folder structure.
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a. In Local Path, provide the location of the downloaded files. The format of a network share is: nfs://<IP
Address>/<Folder_Name>, http://<IP Address>/<Folder_Name>, or https://<IP Address>/
<Folder_Name>.

b. To verify the connection, click Test now.

Upgrading Power Manager

Prerequisites

Ensure that the new version of Power Manager is compatible with OpenManage Enterprise.

About this task

To update Power Manager, perform the following steps:

Steps

1. Launch OpenManage Enterprise.

2. Click Application Settings > Console and Extensions.
The Console and Extensions page is displayed.

3. In the Power Manager section, click Update Avaiable.
The Update Extension page is displayed.

4. To view the updates for this version, click the Release Notes link.
The support page is displayed.

5. To download the update, click Download Extension.
The extension is downloaded, and the status of the download is displayed on a green color band.

6. To update Power Manager, click Update Extension.

In the Confirmation window, select the I agree that I have captured the snapshot of the OM Enterprise appliance
prior to the upgrade option, and then click Update.

Information about the number of users using OpenManage Enterprise and details about the jobs running in OpenManage
Enterprise are displayed.

After updating Power Manager the version is displayed on the Console and Extensions page at the Power Manager
section.

Disabling Power Manager
Disables all the functionality of Power Manager on OpenManage Enterprise. The REST APIs specific to Power Manager are also
disabled.

Prerequisites

Ensure that the following prerequisites are met:
● The Emergency Power Reduction (EPR) is not enabled on the device. View the EPR status of all devices and groups on the

Emergency Power Reduction page.
● There are no active policies.

About this task

NOTE: Disabling a plugin in OpenManage Enterprise restarts the appliance services.

Steps

1. Launch OpenManage Enterprise.

2. If you are using OpenManage Enterprise version 3.4 or earlier, in Application Settings, click Console and Extensions.

The Console and extensions page is displayed.

If you are using OpenManage Enterprise version 3.5, in Application Settings, click Console and Plugins.
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The Console and plugins page is displayed.

3. In the Power Manager section, click the Disable option.
The Disable page is displayed.

4. If you are using OpenManage Enterprise version 3.4 or earlier, click Enable Extension.

If you are using OpenManage Enterprise version 3.5, click Enable Plugin.

The Confirmation page is displayed.

5. On the Confirmation page, select the I agree that I have captured the snapshot of the OM Enterprise appliance
prior to the upgrade option, and then click Confirm Disable.

Information about the number of users using OpenManage Enterprise and details about the jobs running are displayed.

Results

After disabling Power Manager, you cannot see any information or pages that are related to Power Manager in OpenManage
Enterprise.

Enabling Power Manager
All functionalities of Power Manager are enabled in OpenManage Enterprise. The REST APIs specific to Power Manager are also
enabled in OpenManage Enterprise.

About this task

NOTE: Enabling a plugin in OpenManage Enterprise restarts the appliance services.

Steps

1. Launch OpenManage Enterprise.

2. If you are using OpenManage Enterprise version 3.4 or earlier, in Application Settings, click Console and Extensions.

The Console and extensions page is displayed.

If you are using OpenManage Enterprise version 3.5, in Application Settings, click Console and Plugins.

The Console and plugins page is displayed.

3. In Power Manager section, click Enable option.
The Enable page is displayed.

4. If you are using OpenManage Enterprise version 3.4 or earlier, click Enable Extesnion.

If you are using OpenManage Enterprise version 3.5, click Enable Plugin.

The Confirmation page is displayed.

5. In the Confirmation page, select I agree that I have captured the snapshot of the OM Enterprise appliance prior to
the upgrade, and then click Confirm Enable.

Information about the number of users using OpenManage Enterprise and details about the jobs running are displayed.

Removing devices
To stop monitoring the devices, remove them from Power Manager.

Prerequisites

Ensure that the following prerequisite is met:
● The Emergency Power Reduction (EPR) is not enabled on the device.

About this task

NOTE: If a device is removed in OpenManage Enterprise, then that device is automatically removed from Power

Manager.
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NOTE: When a device is added individually and as part of a group to Power Manager, ensure that all the instances of the

device are removed from Power Manager to stop monitoring the devices.

To remove a device, perform the following steps:

Steps

1. Launch OpenManage Enterprise.

2. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Monitored Devices and
Groups.

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Monitored Devices and
Groups.

The Monitored Devices and Groups tab is displayed.

3. Click the Individual Devices tab.
The Individual Devices tab is displayed.

4. Select the devices that you want to remove and click Remove Device(s).
The Remove Device confirmation window is displayed.

5. To confirm removal, click Remove.
The devices are removed from Power Manager.

Removing groups
To stop monitoring the groups, remove them from Power Manager.

Prerequisites

Ensure that the following prerequisite is met:
● Emergency Power Reduction (EPR) option is not enabled on the specific devices that are part of the group.

About this task

To remove a group, perform the following steps:
NOTE: If a group or a specific device in a group is removed from OpenManage Enterprise, then the changes are

automatically reflected in Power Manager.

NOTE: If a policy is applied on the group, on deletion of the group the policy is also removed from Power Manager.

Steps

1. Launch OpenManage Enterprise.

2. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Monitored Devices and
Groups.

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Monitored Devices and
Groups.

The Monitored Devices and Groups tab is displayed.

3. Click the Static Groups tab.
The Static Groups tab is displayed.

4. Select the groups that you want to remove and click Remove Group(s).

The Remove Group confirmation window is displayed.

5. To confirm removal, click Remove.
The groups are removed from Power Manager.
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Uninstalling Power Manager
Uninstall Power Manager and delete all the data that is collected by Power Manager.

Prerequisites

Ensure that the following prerequisites are met:
● The Emergency Power Reduction (EPR) is not enabled on the device. View the EPR status of all devices and groups on the

Emergency Power Reduction page.
● There are no active policies.

About this task

To uninstall Power Manager, perform the following steps:

Steps

1. Launch OpenManage Enterprise.

2. In Application Settings, click the Console and Extensions tab.
The Console and Extensions page is displayed.

3. In the Power Manager section, click Uninstall option.
The Uninstall Extension page is displayed.

4. Click Uninstall Extension.
The Confirmation page is displayed.

5. In the Confirmation page, select I agree that I have captured the snapshot of the OM Enterprise appliance prior to
the upgrade, and then click Confirm Uninstall.

Information about the number of users using OpenManage Enterprise and details about the jobs running are displayed.

Results

After uninstalling Power Manager, you cannot see any information or pages that are related to Power Manager on OpenManage
Enterprise.
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Viewing Metrics and Monitoring History in
Power Manager

Power Manager provides a visual representation of the data that is collected for all devices and groups.

Prerequisites

Ensure that the following prerequisite is met:
● Devices or groups are added to Power Manager. For more information, see Adding devices to Power Manager and Adding

groups to Power Manager.

About this task

To view Power Manager metric, perform the following steps:

Steps

1. From OpenManage Enterprise, perform one of the following steps:

● For device:
a. Click Devices.

All the devices that are discovered in OpenManage Enterprise are displayed.

b. From the list of devices, click a device name.

The details of the device are displayed on the Overview page.

c. To view Power Manager related information, click Metrics page.
● For group:

a. Click Devices > Static Groups > Group name.

All the devices that are part of the static group are displayed.

b. To view Power Manager related information, click Group Details.

2. View metrics and monitoring data in Metrics and Monitoring History tab.

NOTE: For static groups, only the power and thermal data is displayed.

The power, thermal, CPU, Input Output, memory utilization and system airflow history is indicated in a graphical format.

3. To view a metric, expand the metric and select a duration from the Duration drop-down menu. Hover the mouse pointer
over the graph to view the maximum, average, and minimum values.

NOTE: The values are displayed according to the format that you have specified in the Monitoring Units, and Metric

gathering interval in the Power Manager Preferences section.

NOTE: You can view only Instant temperature for PowerEdge M1000e, PowerEdge FX2, and PowerEdge FX2s

chassis.

NOTE: You can view only the power, temperature, and system airflow history for PowerEdge AMD processor servers.

Details of the granular information are as follows based on your selection:

Table 9. Granularity of data 

Duration Granularity of data

6 Hours or 12 Hours or 1 Day Data is displayed based on the Metric gathering interval
set in the Preferences section.
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Table 9. Granularity of data (continued)

Duration Granularity of data

7 Days or 1 Month Data is displayed at an interval of one hour.

3 Months or 6 Months or 1 Year Data is displayed at an interval of one day.

4. To view the latest metrics, click the refresh icon.

Table 10. List of Power Manager metrics and supported devices 

Metric Supported devices

Power History ● 12th and later generations of PowerEdge servers (Intel)

NOTE: Cabled PSU servers are not supported.

NOTE: PowerEdge Fm120 aqua is not supported.

● PowerEdge MX7000
● PowerEdge M1000e
● PowerEdge VRTX
● PowerEdge FX2
● PowerEdge FX2s

Energy Consumption ● 12th and later generations of PowerEdge servers (Intel)
● PowerEdge MX7000
● PowerEdge M1000e
● PowerEdge VRTX
● PowerEdge FX2
● PowerEdge FX2s

Thermal History ● 12th and later generations of PowerEdge servers (Intel)
● PowerEdge MX7000
● PowerEdge M1000e
● PowerEdge VRTX
● PowerEdge FX2
● PowerEdge FX2s

CPU Utilization ● 13th and later generations of PowerEdge Intel servers
● 15th and later generations of Poweredge AMD servers

with iDRAC version 4.30.30.30 and later

Input Output Utilization ● 13th and later generations of PowerEdge servers (Intel)

Memory Utilization ● 13th and later generations of PowerEdge servers (Intel)

System Airflow ● Non-modular PowerEdge servers
○ Latest generation of AMD servers with iDRAC Data

Center license and iDRAC version 4.10.10.10 and
above

NOTE: 14th generation AMD servers with iDRAC
version 4.10.10.10 and above.
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Manage data center during power reduction
The Emergency Power Reduction (EPR) feature helps reduce power consumption of devices immediately during a power
emergency. For example, if there is a power failure occurs and your devices are running on a UPS, you can apply EPR to reduce
the power consumption of your managed devices.

EPR also helps in preventing device damage due to overheating in an event of cooling infrastructure failure. Use temperature-
triggered policies for enabling EPR on a group of devices when its average inlet temperature crosses a defined threshold value.

NOTE: Applying EPR on the devices throttles down the power to an extremely low level, impacting performance, or shuts

down the devices completely. All devices on which an EPR is applied are affected. Use this feature only in an emergency

situation.

Following are the EPR options available for servers, chassis, and groups:

● Throttle—set to minimal power consumption state.

NOTE: Only the Throttle option is supported for a chassis.

● Shut down—shut down the server

After applying EPR on devices and groups, they are marked as EPR Enabled (Throttle) or EPR Enabled (Shut down) on the
devices and groups page. The summary of devices and groups on which EPR is applied is displayed on the Emergency Power
Reduction page in Power Manager.

Topics:

• Enabling Emergency Power Reduction
• Viewing active Emergency Power Reduction
• Disabling Emergency Power Reduction

Enabling Emergency Power Reduction
During a power shortage, enable the Emergency Power Reduction (EPR) on devices so that they run on minimal power.

About this task

NOTE: Temperature-triggered EPR cannot be activated manually. When a temperature-triggered policy is active and the

group temperature is equal to or exceeds the threshold value, Power Manager automatically applies the EPR.

To enable EPR, perform the following steps:

Steps

1. From OpenManage Enterprise, perform one of the following steps:

● For device:
a. Click Devices.

All the devices that are discovered in OpenManage Enterprise are displayed.

b. From the list of devices, click a device name.

The details of the device are displayed on the Overview page.

c. To view Power Manager related information, click Metrics page.
● For group:

a. Click Devices > Static Groups > Group name.

All the devices that are part of the static group are displayed.

b. To view Power Manager related information, click Group Details.

10

28 Manage data center during power reduction



2. To enable EPR, click the Policies and EPR tab, and then click Apply EPR.

In the confirmation screen, select one of the options and click Apply EPR.
● Throttle—All selected devices and groups are allowed to consume an extremely low level of power. This settings affects

performance.

NOTE: The throttle option is supported for servers with iDRAC DC or iDRAC Enterprise licenses and chassis.

● Shut down—All selected devices or devices part of the selected group are shut down gracefully.
NOTE: If a group consists of servers and chassis, and you select the Shut down option, then only the servers in the

group are shut down. The shut-down option applies only to servers.

3. Click Yes on the confirmation screen.
EPR is enabled on the selected device or group. A red color bar indicator is displayed on the Policies and EPR tab along
with the type of EPR option applied.

Viewing active Emergency Power Reduction

About this task

To view the list of devices and groups to which Emergency Power Reduction (EPR) is applied, perform the following:

Steps

From OpenManage Enterprise, perform any one of the following:

● To view an EPR applied on a device or a group, click Devices tab, click the device name, Power Management and
Monitoring tab, and then click Policies and EPR.

● To view EPRs applied on all devices and groups in Power Manager:

a. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Emergency Power Reduction .

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Emergency Power
Reduction.

The Emergency Power Reduction tab is displayed.

The following fields are displayed:
● ASSIGNED TO—Device name or service tag to which the EPR is applied.
● ENTITY TYPE—Type of device. The supported entity types are, devices, and groups.
● EPR TYPE—Type of EPR applied. The supported EPR types are Throttle and Shut down.
● EPR SOURCE—Source of EPR trigger. You can apply an EPR manually or automatically.
● CREATED ON—Time the EPR was applied.

b. To filter and view the data, click Advanced Filters.

You can filter your data using the following components:
● Assigned To—Filters EPRs based on the device name or service tag.
● EPR Source—Filters the EPR source. The supported filters are, All, Manual, and Temperature-triggered.

c. To sort any column alphabetically, click a column name so that an arrow is displayed with the column name.

Disabling Emergency Power Reduction
To restore the devices or groups to their normal state, disable the Emergency Power Reduction (EPR).

About this task

NOTE: An EPR activated due to temperature-triggered event cannot be disabled manually. After the temperature reduces

to the normal value, Power Manager automatically removes the EPR.

To disable a manually applied EPR, perform the following steps:

Steps

1. Launch OpenManage Enterprise.

2. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Emergency Power Reduction .
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If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Emergency Power
Reduction.

3. Select the devices or groups for which you want to disable EPR, and click Disable.

In the confirmation page, click Yes.

EPR is disabled successfully.
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Policies
Power Manager supports two types of policies you can use to monitor power and temperature of your data center devices.

Topics:

• Static policy
• Temperature-triggered policy
• Creating policy
• Viewing policy
• Editing policy
• Disabling policy
• Enabling policy
• Deleting policy

Static policy
A static policy contains various settings that help regulate the power consumption of a specific device or a group. A power
management policy is useful in different situations. For example, you can create a policy to:

● Ensure that power consumption does not exceed the capacity of the circuit.

● Schedule power usage according to the workload of the device or group For example, to reduce the overall power use in
your data center, apply an aggressive power cap policy when the workload is low.

● Increase rack density. For example, to increase the rack density or number of devices in a group you can set power cap at
group level and add more servers. The policy cap keeps the power within the defined limit.

NOTE: After applying a policy on a group, if you add more devices to the group and the power consumption exceeds the

power cap, then you receive alerts in Alert Log.

For example, an active policy with power cap value of 1000 Watts is applied on a device, and then another active policy with
power cap value of 1500 Watts is applied on the same device, the policy with power cap value of 1000 Watts is applied on the
device as this policy is the most restrictive policy.

Temperature-triggered policy
A temperature-triggered policy is used to prevent damage to devices due to overheating in the event of cooling infrastructure
failure. It limits the processing capability of the devices in the group, hence reducing the heat generation. The policy helps in
maintaining the data center temperature to align to the standards defined by American Society of Heating, Refrigerating and
Air-Conditioning Engineers (ASHRAE). Create temperature-triggered policy on a group of devices by defining a temperature
threshold value. After defining the threshold value and enabling the policy, if the average inlet temperature of the group crosses
the temperature threshold value, Power Manager enforces an EPR—Throttle on the group. In the EPR page, the source of EPR
is displayed as Temperature-triggered —Throttle on the group.

Creating policy
Create a policy to limit the power consumption for devices and groups or apply EPR on devices in a group when the average
inlet temperature exceeds the temperature threshold.

Prerequisites

Ensure that the following prerequisites are met:
● Devices or groups are added to Power Manager.
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● Servers have the iDRAC and OpenManage Enterprise Advanced license.
○ If a device is PowerEdge VRTX or PowerEdge FX2 chassis, it has a Chassis Management Controller (CMC) Enterprise

license.

About this task

To create a policy, perform the following steps:

Steps

1. Launch OpenManage Enterprise.

2. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Policies.

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Policies.

The Policies tab is displayed.

3. Click Create.
The Create Policy wizard is displayed.

4. In the General section, provide the following information and click Next.

a. In Type, select the type of policy.

● ○ Static policy—Applies a cap on the power consumption of a device or group.
○ Temperature-triggered policy—Applies Emergency Power Reduction (EPR) on a group of devices when its

temperature equals or exceeds a specified value.

NOTE: After a policy is created, you cannot change the type of policy.

To activate the policy after creation, Enable option is selected by default.

b. Provide a policy name and description.

5. In the Devices/Groups section, select the required option:

● To add a device:

a. Select the Device option and click Select Device.

The Select Device page is displayed.

b. Click Advanced Filters.

The following filters are displayed:
● Health State
● Power State
● Connection State
● Name
● Service Tag
● Model
● Type
● Managed State
● Part of Group

c. Select the device, and click Add Selected.

● To add a group:

a. Select the Group option and click Select Group.

The Select Group page is displayed.

b. Click Advanced Filters.

The following filters are displayed:
● Name
● Type

c. To clear the filters, click Clear All filters.
d. Select the group, and click Add Selected.

NOTE: You can select only one device or group when creating a policy.

NOTE: After you create a policy for a device, you cannot apply the policy to a group. Similarly, after creating a policy

for a group, you cannot apply the policy to a device.
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6. Click Next.

7. For a static policy:

In the Policy Settings section, select the monitoring period from the Monitoring time period drop-down menu, and
provide the Power cap value, and then click Next.

Use the Power History section as a reference to set the power cap value.
● Power History for a device—this section displays minimum, average, and maximum power consumption with lower and

upper bound values. The values change as you change the duration of Monitoring time period.
● Power History for a group—this section displays minimum, average, and maximum power consumption with lower and

upper bound values. The minimum, average, and maximum power history of the group is the sum of all the minimum,
average, and maximum power consumption of individual devices in the group. The values change as you change the
duration of Monitoring time period. The upper and lower bound value for a group is the sum of upper bound and lower
bound values for all devices part of the group. The Power Cap displayed is the sum of all the power cap values of the
devices in the group.

Guidance for providing power cap values:
● The default Power Cap Value displayed is the upper bound value of the device. You can change the Power Cap value

and the Power Cap percentage gets populated automatically.
● If you change the percentage of Power Cap then the Power Cap value gets populated automatically.
● If you change the Percentage of Range then the Power Cap Value gets populated automatically.
● For groups, provide the power cap value or percentage of consumption at the group level or at every device level.
● Provide the power cap value that range between the lower and upper bounds of the device.

NOTE: For the following list of PowerEdge servers, the Lower Bound and Upper Bound threshold range values are

always static.

Table 11. Power cap range for servers 

Generation of servers Models Value Range (Watts)

14th generation ● VxRail G560
● VxRail G560F
● PowerEdge C6420
● PowerEdge R6415
● PowerEdge R7415
● PowerEdge R7425

Zero to 32767

13th generation ● PowerEdge C6320
● PowerEdge C6320p

Zero to 700

For a temperature-triggered policy:

In the Policy Settings section, select a monitoring period from the Monitoring time period drop-down menu, select or
provide the Temperature Threshold value, and then click Next.

Use the Temperature data section as a reference to set the temperature threshold value. Based on your selection of
Monitoring time period value, the temperature summary details are displayed.

● The values change as you change the duration of Monitoring time period.
● Select your preferred American Society of Heating, Refrigerating and Air-Conditioning Engineers (ASHRAE) temperature

threshold from the Temperature Threshold drop-down menu. Based on your ASHRAE class selection, the temperature
value is populated.

Select the ASHRAE standard relevant in your region or provide a custom value in Celsius only.

○ ASHRAE Recommended27 degrees Celsius or 81 degrees Fahrenheit
○ ASHRAE Class A1 Allowable—32 degrees Celsius or 90 degrees Fahrenheit
○ ASHRAE Class A2 Allowable— 35 degrees Celsius or 95 degrees Fahrenheit
○ ASHRAE Class A3 Allowable— 40 degrees Celsius or 104 degrees Fahrenheit
○ ASHRAE Class A4 Allowable—45 degrees Celsius or 113 degrees Fahrenheit

● You can also provide a custom temperature threshold value.

8. In the Policy Schedule section, provide the following information and click Next.
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Power Manager enables you to create and apply multiple policies on a specific device or group. At any instance, if multiple
policies are active on a device, either by policies set on the device or by policies set on the group the device is a part of, the
most restrictive power cap among the policies is applied on the device.

a. For the Time Span option, select Always for the policy to be active from the time of creation. If the policy does not
have to be active always when enabled, click Range and provide a time range during which the policy must be active
when it is enabled.

b. For the Day(s) option, select Always for the policy to be active from the time of creation. If the policy does not have to
be active always when enabled, click Daily, to select specific days on which the policy must be active when it is enabled.

c. For Active Date option, select the date range during which the policy must be active when enabled.

NOTE: A temperature-triggered policy cannot be scheduled.

9. In the Summary section, view the policy details and click Finish.

The policy is created successfully.

The following table provides more information about all the fields in the policy wizard.

Table 12. Policy wizard details 

Field Mandatory Value Range

Type Yes

By default, the type is
selected as Static.

● Static policy
● Temperature-triggered

policy

Name Yes Combination of characters,
special characters, and
numbers

Limit: 1 to 255 characters

Description No Combination of characters,
special characters, and
numbers

Limit: 0 to 255 characters

Enable No

By default, the check-box is
selected.

● Select
● Clear

Monitoring time period Yes

By default, the time period is
selected as 1 Day.

● 1 Day
● 7 Days
● 1 Month
● 3 Months

For static policy

Power cap Yes

By default, the power cap
is populated with the Upper
Bound value and hundred
percent.

Recommended limit: Lower
Bound-Upper Bound

Time Span Yes

By default, the option is
selected as Always.

Range Limit: 12 hours format

Day(s) Yes

By default, the option is
selected as Always.

Daily Select at least one day.

Active Date Yes Range
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Table 12. Policy wizard details (continued)

Field Mandatory Value Range

By default, the option is
selected as Always.

● From
● To
Limit: Current and future
dates

For temperature-triggered policy

Temperature Threshold Yes

By default, the option that
is selected is ASHRAE
Recommended.

● Custom value range: -10
degrees to 60 degrees

● ASHRAE
Recommended

● ASHRAE Class A1
● ASHRAE Class A2
● ASHRAE Class A3
● ASHRAE Class A4

Viewing policy
View all the policies that are created for devices and groups in Power Manager.

About this task

To view a policy, perform the following steps:

Steps

From OpenManage Enterprise, perform any one of the following:

● To view all the policies created in Power Manager:

If you are using OpenManage Enterprise verison 3.4 or earlier, click Power Management > Policies.

If you are using OpenManage Enterprise verison 3.5, click Plugins > Power Management > Policies.

The Policies tab is displayed.

Select your category of filters, and view the data. Following is a list of categories available:
○ State—Filters the policies based on the state of the policy. The supported filters are All, Enabled, Disabled.
○ Name—Filters the policies based on the name of the policy.
○ Description—Filters the policies based on description of the policy.
○ Type—Filters the policies based on the type of policy. The supported filters are, All, Static, and Temperature-

Triggered.
○ Assigned To—Filters policies based on device or group it is assigned to.

To filter and view the data, click Advanced Filters.

To clear the filters, click Clear All filters.

To sort any column alphabetically, click a column name so that an arrow is displayed with the column name.

● To view all the policies created for a device—click Devices > Power Management and Monitoring > Policies

All the policies applied to the device are displayed with the details.

● To view all the policies created for a group—click Devices, click a custom group with static membership, click Group
Details, and then click Policies.

The policies applied to the group are displayed with the details.
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Editing policy
Update a policy based on the changes in power consumption history or average inlet temperature that is generated by the
devices or groups.

About this task

When there are changes to a group membership and the group has an active policy, Power Manager notifies you to reevaluate
the policy associated with the group.

NOTE: After you create a policy for a device, you cannot apply the policy to a group. Similarly, after creating a policy for a

group, you cannot apply the policy to a device.

NOTE: For a temperature-triggered policy, if the temperature threshold value is increased after the EPR is applied,

then Power Manager automatically removes the EPR if the updated temperature threshold value is greater than average

temperature of the group.

To edit a policy, perform the following steps:

Steps

1. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Policies.

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Policies.

The Policies tab is displayed.

2. Select a policy and click Edit.
The power policy wizard is displayed.

For more information about each field in the wizard, see Creating policy.

3. To save your changes, click Finish.
The changes are saved successfully.

Disabling policy
To remove power consumption or temperature policy limits, disable the relevant policy.

About this task

To disable a policy, perform one of the following steps:

Steps

1. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Policies.

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Policies.

The Policies tab is displayed.

2. Perform one of the following methods:

a. Select the policy that you want to disable, and click Disable.
b. In the confirmation window, click Yes.

OR

a. Select the policy that you want to disable, and click Edit.

The Create Policy wizard is displayed.

b. In General section, clear the Enable check-box and click Next until you reach the Summary section and then click
Finish.

The policy is disabled successfully.
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Enabling policy
On enabling a policy, the power or temperature cap is activated on the devices and groups.

About this task

To enable a policy, perform the following steps:

Steps

1. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Policies.

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Policies.

The Policies tab is displayed.

2. Enable a policy using any one of the following methods:

● Select the policy that you want to enable, and click Enable.
● At the time of creation or when editing the policy, select the Enable option from Create Power Policy wizard.

3. In the confirmation window, click Yes.
The policy is enabled successfully, and a tick mark is displayed against the policy.

Deleting policy
Delete policies that are no longer required.

About this task

When an active policy is deleted, any power consumption restrictions or temperature thresholds that are applied by the policy
are also deleted.

NOTE: If you delete an active temperature-triggered policy, the Emergency Power Reduction (EPR) is automatically

removed on the group.

To delete a policy, perform the following steps:

Steps

1. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Policies.

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Policies.

The Policies tab is displayed.

2. Select a policy that you want to delete, and click Delete.

3. In the confirmation window, click Yes.
The policy is deleted successfully.
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Thresholds
Thresholds enable you to specify warning and critical limits for power and temperature metrics on devices and groups. Power
Manager generates alerts through OpenManage Enterprise if the configured limits are violated and you are notified of the
violations. The status of power and temperature are displayed in form of graphs on the Metrics or Group Details tab.

Topics:

• Creating Alert Thresholds
• Viewing alert thresholds
• Editing alert thresholds
• Deleting alert thresholds

Creating Alert Thresholds
To monitor the devices and groups for threshold violations, define the threshold values of power and temperature.

Prerequisites

Ensure that you have added devices or groups to Power Manager.

About this task

To configure alert thresholds for power and temperature, perform the following steps:

Steps

1. From OpenManage Enterprise, perform one of the following steps:

● For device:
a. Click Devices.

All the devices that are discovered in OpenManage Enterprise are displayed.

b. From the list of devices, click a device name.

The details of the device are displayed on the Overview page.

c. To view Power Manager related information, click Metrics page.
● For group:

a. Click Devices > Static Groups > Group name.

All the devices that are part of the static group are displayed.

b. To view Power Manager related information, click Group Details.

2. To set thresholds, click Alert Thresholds tab, and click Edit.
The Edit Alert Thresholds page is displayed.

3. Provide the threshold values for Power and Temperature.

NOTE: When the alert threshold value units are set for power in BTU/Hr and temperature in Fahrenheit, ensure that

you provide only the values and no other special character as the value may change after saving it.

NOTE: When the power or temperature values exceed the lower or upper warning values, a warning-level alert is

generated and forwarded to OpenManage Enterprise.

NOTE: When the power or temperature value exceeds the lower or upper critical values, a critical-level alert is

generated and sent to OpenManage Enterprise.

4. Click Apply to save the values.
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The thresholds are saved successfully, and the scales are color coded based on the current state of the device or group.

View the following tables for each threshold value range.

Table 13. Alert threshold range details for Watt and Celsius scale 

Field Mandatory Value Range

Power (Watt)

Upper Warning No Limit: 1–29307121 integers

Upper Critical No Limit: 1–29307121 integers

Temperature (Celsius)

Lower Critical No Limit: -10 - 60 degrees

Lower Warning No Limit: -10 - 60 degrees

Upper Warning No Limit: -10 -60 degrees

Upper Critical No Limit: -10 to 60 degrees

Table 14. Alert threshold range details for BTU/hour and Fahrenheit scale 

Field Mandatory Value Range

Power (BTU/hour)

Upper Warning No Limit: 3–99937283 integers

Upper Critical No Limit: 3–99937283 integers

Temperature (Fahrenheit)

Lower Critical No Limit: 14-140 degrees

Lower Warning No Limit: 14-140 degrees

Upper Warning No Limit: 14-140 degrees

Upper Critical No Limit: 14-140 degrees

Viewing alert thresholds
View the status of the device or group that is based on the configured alert thresholds.

Prerequisites

Ensure that you have added devices or groups to Power Manager.

About this task

To view the alert thresholds graphs for power and temperature:

Steps

1. From OpenManage Enterprise, perform one of the following steps:

● For device:
a. Click Devices.

All the devices that are discovered in OpenManage Enterprise are displayed.

b. From the list of devices, click a device name.

The details of the device are displayed on the Overview page.

c. To view Power Manager related information, click Metrics page.
● For group:
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a. Click Devices > Static Groups > Group name.

All the devices that are part of the static group are displayed.

b. To view Power Manager related information, click Group Details.

2. View the power and temperature status on the Alert Thresholds tab.

The Collected Atfield displays the last collection time.

The pointer on the scale gives the average power and thermal data.

Power Manager displays the minimum and maximum power and temperature values based on the device and the previous
readings that were collected. The scale is grayed-out if the thresholds are not set or if the threshold values are cleared off.
The upper and lower warning and critical values are displayed only if the threshold values are set. To view more information
about any violations, see the Alert Log on the Alerts page and the Audit Logs on the Monitor page.

Editing alert thresholds
Update alert thresholds based on changes to device utilization or updates in group membership.

Prerequisites

Ensure that you have added devices or groups to Power Manager.

About this task

To edit the threshold values for a device or a group, perform the following steps:

Steps

1. From OpenManage Enterprise, perform one of the following steps:

● For device:
a. Click Devices.

All the devices that are discovered in OpenManage Enterprise are displayed.

b. From the list of devices, click a device name.

The details of the device are displayed on the Overview page.

c. To view Power Manager related information, click Metrics page.
● For group:

a. Click Devices > Static Groups > Group name.

All the devices that are part of the static group are displayed.

b. To view Power Manager related information, click Group Details.

2. On the Alert Thresholds tab, click Edit.
The Edit Alert Thresholds page is displayed.

3. Provide the values and click Apply.
Threshold values are updated successfully.

Deleting alert thresholds
To remove the thresholds that are configured on devices or groups, clear all the thresholds.

About this task

To delete alert thresholds, perform the following steps:

Steps

1. From OpenManage Enterprise, perform one of the following steps:

● For device:
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a. Click Devices.

All the devices that are discovered in OpenManage Enterprise are displayed.

b. From the list of devices, click a device name.

The details of the device are displayed on the Overview page.

c. To view Power Manager related information, click Metrics page.
● For group:

a. Click Devices > Static Groups > Group name.

All the devices that are part of the static group are displayed.

b. To view Power Manager related information, click Group Details.

2. On the Alert Thresholds tab, click Edit.
The Edit Alert Thresholds page is displayed.

3. To remove all the thresholds, clear all the existing threshold values, and click Apply.
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Alerts
An alert is helpful when monitoring thresholds and you want a notification about when the power of a device or a group exceeds
the limits set on them or when there are changes to a group you are monitoring.

An alert is generated under the following circumstances:
● When the values cross the defined alert thresholds
● When the values for a device or group come back to normal state.
● When the policy cap of an active policy is violated.
● When there are changes to a group that has an active policy that is applied on it.
● When a policy is applied on a group and if new devices are added or devices are removed from the group.

You can view alerts by going to OpenManage Enterprise > Alerts > Alert Log:

For information about managing the alerts, see OpenManage Enterprise User's Guide.

Topics:

• Creating Alert Policy

Creating Alert Policy
To receive alerts that are related to Power Manager, select the Power Manager specific sub-categories while creating an Alert
Policy.

About this task

For information about creating Alert Policy, see OpenManage Enterprise User's Guide.

Steps

1. Launch OpenManage Enterprise, and click Alerts > Alert Policies.
The Alert Policies page is displayed.

2. In Alert Policies page, click Create.
The Create Alert Policy wizard is displayed.

3. Provide a name and description for the policy.

To enable the policy after creation, Enable option is selected by default.

4. In Category section, expand Application > System Health category and select the following sub-categories for the Power
Manager alerts and click Next.

● Metrics—to receive alerts on alert threshold violations.
● Power Configuration—to receive alerts on policy cap violations.

5. In Target section, select the required Power Manager devices or groups and click Next.

6. In Date and Time section, provide a period for which the policy has to be active, select the days when the policy should be
active, and click Next.

7. In the Severity section, select the severity level of the alert for which this policy must be activated.

To select all the severity categories, select the All check-box.

8. In Actions section, select one or more check-boxes to initiate the actions when the policy is run and click Next.

9. In the Summary section, review the details that are provided and click Finish.

The alert policy is successfully created and listed in the Alert Policies section.

For more information about creating and managing the alerts, see OpenManage Enterprise User's Guide.
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Widgets for Power Manager
Widgets provide quick access to the power and thermal history of selective groups. They also allow you to, view the maximum
energy consumers regarding servers, chassis, and groups.

Topics:

• Adding or removing groups from OpenManage Enterprise dashboard to monitor Power Manager data
• Viewing top five energy consumers
• Viewing power and thermal history of Power Manager groups
• Viewing ratio of devices discovered in OpenManage Enterprise to devices added in Power Manager
• Viewing ratio of devices discovered in OpenManage Enterprise to devices added in Power Manager
• Viewing top ten power offenders
• Viewing top ten temperature offenders

Adding or removing groups from OpenManage
Enterprise dashboard to monitor Power Manager data
Add your favorite groups to the dashboard to quickly monitor their power and thermal data.

Prerequisites

Ensure that the following prerequisites are met:
● The groups are added in Power Manager.
● Identify the favorite groups for monitoring.

NOTE: You can add a maximum of three groups to the dashboard.

About this task

To add groups to the OpenManage Enterprise dashboard, perform the following steps:

Steps

1. Launch OpenManage Enterprise.

2. Click Home tab and go to the Power Manager section.

3. To add or remove a group to the Power History or Thermal History graphs, click Add Groups.
The Add group(s) to dashboard page is displayed.

4. (Optional) Select or clear the groups using the check-boxes and click Apply.

To filter the groups, expand Advanced Filters option. The following categories are displayed:
● Name
● Type

To clear the filters, click Clear All Filters.

The groups are updated in the selected metric graphs.

Viewing top five energy consumers

About this task

View the devices consuming most of the energy in the Power Manager section of the OpenManage Enterprise dashboard.
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Steps

1. Launch OpenManage Enterprise, and go to the Power Manager section.

2. To view the top five energy consumers, click the Top Energy Consumers tab.

3. View data regarding servers, chassis, and groups using the Filter drop-down menu.

Viewing power and thermal history of Power Manager
groups

About this task

View Power Manager-specific data on the OpenManage Enterprise dashboard.

Steps

1. Launch OpenManage Enterprise, and go to Power Manager section.

2. To view the power or thermal history of a group, click the Power History or Thermal History tab.
The graph is displayed.

3. (Optional) To change the duration, select an option from the Duration drop-down menu.

4. (Optional) To view data for a different group, select a group from the Group drop-down menu.

5. (Optional) To refresh the data, click the refresh option.

Viewing ratio of devices discovered in OpenManage
Enterprise to devices added in Power Manager

About this task

View the ratio of total devices that are discovered in OpenManage Enterprise and that are compatible with Power Manager to
total number of devices that are monitored through Power Manager.

Steps

1. Launch OpenManage Enterprise and go to the Power Manager section.

2. To view the ratio, click the Devices Statistics tab.

Viewing ratio of devices discovered in OpenManage
Enterprise to devices added in Power Manager

About this task

View the ratio of total devices that are discovered in OpenManage Enterprise and that are compatible with Power Manager to
total number of devices that are monitored through Power Manager.

Steps

1. Launch OpenManage Enterprise and go to the Power Manager section.

2. To view the ratio, click the Devices Statistics tab.
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Viewing top ten power offenders

Prerequisites

Ensure that you have configured the power and temperature thresholds in Alert Thresholds tab under Metrics tab for
devices, or under Group Details for groups.

About this task

To view a list of devices and groups that have violated the defined threshold values of power, run the in-built for Power
Manager: Metric Thresholds Report for Devices and Power Manager: Metric Thresholds Report for Groups. The
total violation count for power is the sum of upper warning, and upper critical violation counts. The total violation count for
temperature is the sum of upper warning, upper critical, lower warning, and lower critical violation counts.

To view the top offenders, perform the following steps:

Steps

1. Launch OpenManage Enterprise.

2. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Overview tab.

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Overview tab.

The Overview tab is displayed.

3. View the Top 10 Power Offenders section.
Device information that is provided by default include details such as device name, service tag, number of times the device
has violated the defined power threshold, and nature of violations that are based on the alert threshold values defined.

4. To view the groups that have violated the power threshold, select the Groups option from the Entity Type drop-down
menu.
Device information that is provided by default include details such as group name, number of times the group has violated
the defined power threshold, and nature of violations that are based on the alert threshold values defined.

5. To view devices or groups in a particular violation state, select an option from the State drop-down menu.

6. (Optional) To refresh the data, click the refresh option.

Viewing top ten temperature offenders

Prerequisites

Ensure that you have configured the power and temperature thresholds in Alert Thresholds tab under Metrics tab for
devices, or under Group Details for groups.

About this task

To view a list of devices and groups that have violated the defined threshold values of power, run the in-built for Power
Manager: Metric Thresholds Report for Devices and Power Manager: Metric Thresholds Report for Groups. The
total violation count for power is the sum of upper warning, and upper critical violation counts. The total violation count for
temperature is the sum of upper warning, upper critical, lower warning, and lower critical violation counts.

To view the top offenders, perform the following steps:

Steps

1. Launch OpenManage Enterprise.

2. If you are using OpenManage Enterprise version 3.4 or earlier, click Power Management > Overview tab.

If you are using OpenManage Enterprise version 3.5, click Plugins > Power Management > Overview tab.

The Overview tab is displayed.

3. To view the devices that have violated the temperature threshold, go to Top 10 Temperature Offenders section.
Device information that is provided by default includes information such as device name, service tag, number of times the
device has violated the defined temperature threshold, and nature of violations that are based on the alert threshold values
defined.

4. To view the groups that have violated the temperature threshold, select Groups option from the Entity Type drop-down
menu.
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Device information that is provided by default includes information such as group name, service tag, number of times the
group has violated the defined temperature threshold, and nature of violations that are based on the alert threshold values
defined.

5. To view devices or groups in a particular violation state, select an option from the State drop-down menu.

6. (Optional) To refresh the data, click the refresh option.
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Reports in Power Manager
Reports contain information about the specific devices or devices part of a group, jobs, alerts, and other elements of your data
center. Power Manager supports built-in and user-defined reports. Download these reports to view the status of the Power
Manager devices and groups.

You can download the built-in reports in HTML, CSV, PDF, or XLS formats. The following built-in reports available for Power
Manager related data through OpenManage Enterprise Reports tab:
● Power Manager: Metric Thresholds Report for Devices-This report displays the metric and alert threshold details of

all Power Manager devices such as device name, device details, metric type, the threshold values set on the devices, and
number of times the values have exceeded the defined thresholds.

● Power Manager: Metric Thresholds Report for Groups-This report displays the alert threshold details of all the Power
Manager groups such as group name, metric type, threshold values set on groups, and number of times the values have
exceeded the defined thresholds.

● Power Manager: Policies Report of Groups-This report displays all the Power Manager policies details such as group
name, policy name, policy type, whether the policy enabled, policy active, power cap, temperature threshold, and violations.

● Power Manager: Power and Thermal Report of Devices-This report displays all the power and temperature details of
Power Manager devices such as device name, device details, power and temperature values, energy consumed and what
time the data was collected.

● Power Manager: Power and Thermal Report of Groups-This report displays all the power and temperature details of
Power Manager groups such as the group name, power and temperature values of groups, energy consumed and what time
the data was collected.

Also, you can create or build customized reports with Power Manager details along with other device details from OpenManage
Enterprise.

Definitions and attributes that are used for a built-in report cannot be edited or deleted. But, you can edit or delete the
user-defined reports.

For information about running and emailing reports, or deleting custom reports, see OpenManage Enterprise User's Guide.

NOTE: The reports are generated based on your selection for Report Duration and Aggregation Period in Power

Manager Settings page.

Topics:

• Create custom report

Create custom report
View a detailed report for specific devices or devices part of a group by creating custom reports.

About this task

NOTE: If custom reports are created along with Power Manager categories, these categories are hidden when Power

Manager is disabled or deleted when Power Manager is uninstalled.

To create custom report, perform the following steps:

Steps

1. Launch OpenManage Enterprise, click Monitor > Reports.
The Reports page is displayed.

2. To create a custom report, click Create.
The Report Definition page is displayed.

3. Provide a name and description, and then click Next.

4. In Category, select one of the following and in the confirmation screen click Yes:
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● To view data of Power Manager devices:
a. Select Power Manager Devices.
b. In the confirmation page, click Yes.
c. In Device Group, select the required system groups or search for devices using the search box.

● To view data of Power Manager groups:
a. Select Power Manager Groups.
b. In the confirmation page, click Yes.

5. (Optional) To create a query, click Edit in Filter section. Create the queries and click Finish. For more information about
creating a query, see OpenManage Enterprise User's Guide.

6. In Column Selection, Ordering, and Sorting, expand the category, select the required fields using the check-box to add
them into the Column Order box.

The Device Metric Threshold, and Device Power and Thermal Metrics are populated only for Power Manager devices.

The Group, Group Metric Threshold, Group Power and Thermal Metrics, and Group Power Policy columns are
populated only for Power Manager groups.

7. To sort by fields, use the Sort by drop-down menu and to sort the values in ascending and descending order, use the
Direction drop-down menu.

● If you have selected any column from Metric Threshold collection, select the Metric Type of information you want to
see.

● If you have selected any column from Power and Thermal Metrics collection, select the Report Duration and
Aggregation Period to view the information.

NOTE: When creating a custom report, ensure that you select the Aggregation Period as Daily if the Report

Duration is anything other than 1 Day.

8. Review the fields added, and then click Finish.
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Frequently Asked Questions

Why am I not able to view the metrics?
Cause: After removing the required iDRAC or DC License, or the OpenManage Enterprise Advanced Feature license, the
license-dependent features are not available on the User Interface (UI). Hence, the metric is not available, and the values are
not collected by Power Manager from the next inventory cycle.

Why do I see two entries with the same date in the graph
when the time duration was chosen for showing the graph
is changed?
Cause: When viewing the Metrics and Monitoring History graphs for 3 months, 6 months, or 1 year the data is auto-
converted from UTC time zone to your current time zone and displayed. And, due to the time zone differences, there are two
entries for the same day on the graphs. Hence, the last entry is for the current day, and the last but one entry is for the
previous day.

Why do I see slight variations in values of power and
temperature in Alert Thresholds section?
Cause: When the power and temperature values are provided in BTU/Hour and Fahrenheit, they are converted to Watt and
Celsius. When displaying the values, they are reconverted and rounded off to the next highest numbers and displayed. Hence,
the values are slightly higher when displayed in BTU/Hour and Fahrenheit scale.

Why are there same number of power cap or threshold
violations for all the entries in my report?
Cause: For an in-built or custom report which consists of Violation attribute along with Time Stamp attribute, the violation
count that is displayed for all the entries is always for the latest value.

Why do I see blank entries for total energy consumed in
reports or metrics graphs?
Cause: The Total Energy Consumed field has no entry for servers and PowerEdge MX7000 devices due to the following
reasons:
● After the first metric collection the energy consumption value is not available yet and hence, the second metric collection

has to happen.
● If you change Data gathering interval to 60 minutes, then for 60 minutes duration Energy Consumption cannot be

calculated. This happens when data is collected for a day with hourly granularity for reports.
● If power metric in iDRAC is reset during the interval that is chosen, and the latest reading has a lower value than the oldest

reading.
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Why do I not see all metric types for different types of
devices?
Cause: Different devices support different types of metrics.

Table 15. List of supported devices and metrics 

Device Type Supported Metrics

12th generation of PowerEdge servers ● Maximum, minimum, and average power
● Maximum and average temperature
● System airflow
● Energy consumption

13th generation and 14th generation of PowerEdge servers ● Maximum, minimum, and average power
● Maximum and average temperature
● Maximum, minimum, and average CPU utilization
● Maximum, minimum, and average Input Output utilization
● Maximum, minimum, and average Memory Utilization
● System airflow
● Energy consumption

PowerEdge M1000e, VRTX, FX2, and FX2s chassis ● Maximum, minimum, and average power
● Instant temperature
● Energy consumption

PowerEdge MX7000 chassis ● Maximum, and minimum power
● Maximum and minimum temperature
● Energy consumption

NOTE: Modular servers do not support System Airflow values.

Also, if all the criteria is met and still you are not able to view Power Manager data, ensure that the Server Power Monitoring
feature is enabled on the device you are discovering. To view the discovery log of a device:

1. In OpenManage Enterprise, click Monitor > Jobs.

The Jobs page is displayed.

2. Search for the discovery type job for the device and select the job.
3. Click the View Details on the right side of the tab.

Details about the job are displayed.

In the Messages: section, check the status for Server Power Monitoring feature.

NOTE: If the Server Power Monitoring feature is disabled, then the device is not compatible with Power Manager.

Why do I see a failure of EPR in audit log but EPR is applied
successfully for the device?
Cause: Applying EPR on the target device may fail due to the following reasons:
● Connectivity issues between the appliance and the target device
● If the target device is part of Power Manager with an expired license.
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Why do I see a failure of EPR in audit log but EPR is applied
successfully for the group?
Cause: When EPR option is applied for a group, and if the EPR option is applied successfully for at least one device in the
group, we can see the EPR banner at the group level. However, the EPR option may fail on other devices of the group due
to connectivity issues or license expiry and so on. Hence, there are EPR audit logs for successful and failure scenarios for all
devices of the group.

Why are devices not listed for addition to Power Manager?
Cause: You cannot view certain devices in Power Manager because of the following reasons:
● If devices do not have OpenManage Enterprise Advanced license.
● If the devices are discovered in OpenManage Enterprise, and then Power Manager is installed, then the devices are not

displayed in Power Manager until you Run Inventory on OpenManage Enterprise.
● Devices like switches, storage sleds, Input/Output Modules are not supported in Power Manager.
● Servers that are discovered through the Operating System(In-Band) are not supported in Power Manager.

Why can I not install Power Manager?
Cause: There are two cases in which the installation of Power Manager may fail:
● If you have selected the online updates option in OpenManage Enterprise, check for the connectivity for the online path is

successful.
● If you have selected the offline updates option in OpenManage Enterprise, ensure that the

ome_powermanager_1.0.0.tar.gz folder has all the files for extension catalog with the sign file and the extension
installer packages, including the RPMs. The installation fails if there is a mismatch between the catalog and .tar files.

Why can I not disable or uninstall Power Manager?
Cause: If active policies or EPR option is enabled, you cannot disable or uninstall Power Manager.

Resolution: Disable the active policies and EPR option and then try to disable or uninstall Power Manager.

Why are policies being disabled when too many policies are
selected for deletion or disable or enable?
Cause: When you select multiple policies for enabling or disabling or deleting, the job is initiated. However, the policies are
disabled on the User Interface (UI) until the action is complete. After the job is complete, there are entries to the audit logs for
these actions.

Why cannot I remove some devices or groups from Power
Manager?
Cause: If you have applied Emergency Power Reduction (EPR) option on the device or a group, then you cannot remove the
device or group from Power Manager.

Resolution: Disable the EPR option on the device or group, and then remove them from Power Manager.
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Why is Power Manager not listed on Console and
Extensions page?
Cause: Power Manager may not be listed due to the following reasons:
● The offline share folder is not accessible.
● Power Manager extension and tar folder.s are not present in the offline share folder
● If the extension catalog file is edited, then the signature files get corrupted.

Resolution: Ensure that the offline share folder is reachable through OpenManage Enterprise with the following files:
● ome_powermanager_1.0.0.tar.gz
● plugins_catalog
● plugins_catalog.json.asc
Also, download the plugins_catalog file and replace it with the corrupt file.

Why can I not apply Policies on some devices or groups?
Cause: You can apply policy only on devices that are supported by Power Manager having valid license and that are added to
Power Manager.

You can apply policies on supported PowerEdge servers with iDRAC Enterprise, PowerEdge FX2, FX2s, and VRTX chassis with
CMC Enterprise license.

NOTE: PowerEdge M1000e and PowerEdge MX7000 chassis do not require CMC Enterprise license.

Why are some alerts not being forwarded using SNMP?
Cause: The following events are not forwarded as SNMP alerts:
● Device membership or group membership changes
● Device management such as change in license status

Alerts are generated by OpenManage Enterprise or Power Manager, that is displayed in the system health category and
metric/power configuration subcategory the SNMP trap forwarding is not supported.

Why some email alerts are not getting forwarded?
Cause: The following events are not forwarded as SNMP alerts:
● Device membership or group membership changes
● Device management such as change in license status

SNMP trap forwarding is not supported.

Why are some of the devices getting automatically removed
from Power Manager?
Cause: If the OpenManage Enterprise Advanced license has expired or is removed from a target node, then the device is
removed from Power Manager after the device capability check is run.

Why do I not see temperature metric for some devices?
Cause: Temperature metric is not visible for devices if they are powered off.
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Why can I not select a particular child group?
Cause: When you select a group, all the child groups within this group are also selected. But when you clear a child group the
selection gets cleared at the main group level also.

Why am I seeing No Data Available or No
Information available message for some devices
metrics?
Cause: When the first metric collection has not yet happened or if the device is not reachable the following message is
displayed: No Data Available
When a device is not added to Power Manager even though it is a supported device, the following message is displayed: No
Information available.

Why are some of the fields in reports empty?
Cause: The fields may be empty in a report due to the following reasons:
● When the device was not reachable for that duration.
● When that category is not applicable for that device.
● When the values are not defined for certain fields in Power Manager and these fields are part of the report.

For example, when you have not configured the power and temperature threshold values for a device, the following fields
are added to the report, but the values are not populated:
○ Upper Warning Power
○ Upper Critical Power
○ Lower Critical Temperature
○ Lower Warning Temperature
○ Upper Warning Temperature
○ Upper Critical Temperature

If you have configured the above threshold values and only when the threshold values are violated, the following fields are
populated and displayed in the report:
● Lower Critical Violation Count
● Lower Warning Violation Count
● Upper Critical Violation Count
● Upper Warning Violation Count

Why do I not see regular metric data points in the metric
graphs?
Cause: A metric graph having irregular metric points indicate that data was not collected for that device at that duration of
time.

Why can I not clear the check box for policies?
Cause: The checkbox for policies in Power Policies page is disabled if that policy is being enabled or disabled or edited. After
the job is completed, you can clear the policy.
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How do I see the old metric data?
Cause: The old metric data is not available after a few days because the data is deleted. This configuration depends on the
selection of Delete Power Manager data option available in Power Manager Preferences section.

Why are the values I set using threshold REST API not
configured?
Cause: If you use threshold REST API before installing and adding the devices to Power Manager, the values are not retained.

Resolution: Install and add the devices to Power Manager, and then use the threshold REST APIs.
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Why cannot I apply Emergency Power Reduction (EPR) on
target device or a group?
Scenario:

When you are trying to apply EPR on a device, the EPR operation may fail and there is an entry in the Audit Logs.

When you are trying to apply EPR option on a group, the EPR operation may fail with the following error message: Unable to
enable the Emergency Power Reduction feature because target devices are unavailable in the
group.
Resolution:

Ensure that all the following conditions are met:
● There is at least one device in the group that is eligible for applying EPR.
● Throttle option is applicable for the following devices:

○ If the device is a server, then iDRAC Enterprise license is applied.
○ If the device is PowerEdge M1000e or PowerEdge MX7000 chassis.

● Shutdown option is applicable only for servers.

Power and temperature units are not updated on UI
Scenario: When you change the power and temperature units in Power Manager through REST APIs and check the UI, the
updates are not reflected on the UI.

Resolution:

After changing the power and temperature units, go to the Power Manager Settings page and then view the Metrics tab.

Why is OpenManage Enterprise unresponsive when I
try to perform extension lifecycle-related actions (install/
uninstall/enable/disable)?
Scenario:

After rebooting OpenManage Enterprise appliance, if you try to perform any extension lifecycle-related actions for Power
Manager, the job is initiated in the back-end but you still see the Console and Extensions page. And, the following message is
displayed after some time: This page isn't working
Resolution:

Wait for some time, and view the status. The extension lifecycle-related action is completed successfully.

Power cap value or the percentage for MX 7000 chassis is
not updated when either one of the entries is changed
Scenario:
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For an MX7000 chassis, the power cap value is displayed as same as the upper bound value. When you manually change the
power cap percentage, the value is not updated and even if you change the value, the percentage is not updated.

Resolution:

Provide the power cap value, and save the policy. The policy imposes the specified power cap value on the selected devices or
groups.

Power policy not updated after the changes
Scenario:

When the time span of an active policy is changed, the policy is not disabled on the device.

Resolution:

Resolve the issue using one of the following methods:
● Manually disable the policy on the device.
● Disable the policy in Power Manager, change the time span, and then enable the policy.

Events not generated for alert thresholds
Scenario:

Events are not generated for the following combination of temperature threshold violations:
● Lower Warning to Upper Warning
● Lower Critical to Upper Critical
● Upper Warning to Lower Warning
● Upper Critical to Lower Critical

Resolution:

Provide realistic warning and critical values so that there are no immediate alert generating temperature changes.

Error when removing a device from a group using REST API
Scenario:

When you try to remove a device that is part of multiple groups using the REST API, then an error message is displayed.

Resolution:

To remove a device that is part of multiple groups, remove the device from the group in OpenManage Enterprise. The changes
are automatically reflected in Power Manager.

Multiple alerts for group membership changes in Audit Logs
Scenario:

Multiple entries on group membership changes in Audit Logs.

Resolution:

When there are updates to the static group membership through OpenManage Enterprise, there are multiple entries of this
update in the Audit Logs and Alert Log.

Ignore action not working for groups-related alerts
Scenario:

When you select the Ignore option for a group alert in Alert Log page, you still receive the alerts. Only the alerts for the first
device of the group are ignored.
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Resolution:

Create an alert policy by selecting the group for which you want to ignore the alerts by selecting the Ignore option in Create
Alert Policy wizard.

Policy not deactivated
Scenario:

When scheduling a power policy for a single day, the policy does not deactivate later.

Resolution:

To deactivate the policy, perform one of the following actions:
● In Power Management > Power Policies page, select the policy and click Disable.
● In Power Management > Power Policies page, select the policy and click Edit. In Create Power Policy wizard, clear the

selection for Enable option and save the policy.
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Other information you may need
In addition to this guide, you can access the following documents that provide more information about Dell EMC OpenManage
Enterprise Power Manager and other related products.

Table 16. Other information you may need 

Document Description Availability

Dell EMC OpenManage
Enterprise Power Manager
Release Notes

Provides information about known issues and
workarounds in Power Manager.

1. Go to Dell.com/OpenManageManuals.
2. Click Dell OpenManage Enterprise and

select the required version of OpenManage
Enterprise.

3. Click Manuals & documents to access
these documents.

Dell EMC OpenManage
Enterprise Power Manager
REST API Guide

Provides information about integrating Power
Manager by using Representational State
Transfer (REST) APIs and also includes
examples of using REST APIs to perform
common tasks.

Dell EMC OpenManage
Enterprise User's Guide

Provides information about using the features
of OpenManage Enterprise.

Dell EMC OpenManage
Enterprise Release Notes

Provides information about known issues and
workarounds in OpenManage Enterprise.

Dell EMC OpenManage
Enterprise Support Matrix

Lists the devices that are supported by
OpenManage Enterprise.

Dell EMC OpenManage
Enterprise and
OpenManage Enterprise -
Modular Edition RESTful API
Guide

Provides information about integrating
OpenManage Enterprise by using
Representational State Transfer (REST) APIs
and also includes examples of using REST
APIs to perform common tasks.
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