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Introduction
This guide provides information about the software requirement, system requirements and the steps to install, configure, and uninstall Dell 
EMC OpenManage Connection Version 4.0 for IBM Tivoli Netcool/OMNIbus.

Dell EMC OpenManage Connection for IBM Tivoli Netcool/OMNIbus (ITNO) provides capabilities to monitor Dell EMC PowerEdge Servers, 
Dell EMC Remote Access Controllers (DRACs)/Integrated Dell EMC Remote Access Controllers (iDRACs), Modular Infrastructure 
(MX7000, M1000e, FX2/FX2s, VRTX), Hyper Converged Infrastructure (VxRail and Nutanix XC-Series), OEM Servers, Storage, 
Networking devices and Workstations. The OpenManage Connection for ITNO monitors Dell EMC devices by receiving alerts on the 
Netcool/OMNIbus console. It also supports launching One-to-One as well as One-to-Many Dell EMC element mangers, consoles and tools 
directly from the event context for further troubleshooting, configuration and management activities.

The following Dell EMC devices are supported by the Dell EMC OpenManage Connection:

• OEM servers

• Datacenter Scalable Solutions (DSS)

• 11th generation of PowerEdge servers to 14th Generation of PowerEdge servers

• Precision Rack workstations

• Hyper-converged platforms (HCI) - VxRail, Nutanix XC-Series

• Dell EMC Remote Access Controllers:

– Integrated Dell Remote Access Controller 9 (iDRAC9)

– Integrated Dell Remote Access Controller 8 (iDRAC8)

– Integrated Dell Remote Access Controller 7 (iDRAC7)

– Integrated Dell Remote Access Controller 6 (iDRAC6)

– Dell EMC Remote Access Controller 5 (DRAC5)

• Dell EMC Chassis:

– PowerEdge FX2

– PowerEdge VRTX

– PowerEdge M1000e

– PowerEdge MX7000

• Dell EMC Storage Arrays:

– SC-Series Storage Arrays

– 11th Generation of PowerVault NX storage arrays to 13th Generation of PowerVault NX Storage Arrays

– PS-Series Storage Arrays

– Modular Disk Storage Arrays

• Dell EMC Network Switches:

– S-Series Switches

– M-Series Switches

– Z-Series Switches

– C-Series Switches

– N-Series Switches

– W-Series Switches

This guide is intended for system administrators who are familiar with IBM Tivoli Netcool/OMNIbus 8.1 and 7.4.
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Before installing this version of Dell EMC OpenManage Connection for IBM Tivoli Netcool/OMNIbus, download the latest Installation Guide 
from dell.com/omconnectionsEnterpriseSystemsManagement.

For more information about accessing documents, see Accessing Documents From The Dell Support Site - Software.
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Prerequisites
Complete the following prerequisites.

Topics:

• Supported operating systems and requirements for the managing system

• Supported Operating Systems for managed systems

• Supported Dell EMC devices and firmware

Supported operating systems and requirements for 
the managing system
The following tables lists the operating systems and requirements for integrating the Dell EMC OpenManage Connection on the systems 
where the Netcool/OMNIbus version 8.1 and 7.4 components are installed:

Table 1. Supported operating systems for Dell EMC OpenManage Connection for IBM Tivoli Netcool/OMNIbus 8.1

Windows Server SUSE Linux Enterprise Server (SLES) Red Hat Enterprise Linux Server (RHEL)

Windows Server 2012 R2 64-bit (Standard, 
Datacenter)

SLES 12 SP2 64-bit RHEL 7.5 64-bit (Server)

Windows Server 2016 (Standard)

NOTE: Only for Desktop Support.

RHEL 7.4 64-bit (Server)

RHEL 7.3 64-bit (Server)

Table 2. Supported operating systems for Dell EMC OpenManage Connection for IBM Tivoli Netcool/OMNIbus 7.4

Windows Client SUSE Linux Enterprise Server (SLES) Red Hat Enterprise Linux Server (RHEL)

Windows 10 64-bit SLES 11 SP4 64-bit RHEL 6.9 64-bit (Server, Workstation)

Windows 8.1 64-bit (Enterprise, Professional, 
Standard)

Windows 8 64-bit (Enterprise, Professional, 
Standard)

Windows 7 64-bit SP1 (Enterprise, 
Professional)

Windows 7 32-bit SP1 (Enterprise, 
Professional)
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Table 3. IBM Tivoli Netcool/OMNIbus component requirements

Component Requirement Purpose

Probes Configure the MTTrapd Simple Network 
Management Protocol (SNMP) probe and 
the Netcool/OMNIbus Knowledge Library 
(NcKL).

To receive and process the SNMP traps sent 
by Dell EMC devices.

ObjectServer Install and configure the confpack utility. To import Dell EMC integration automation 
triggers, tools, menus, and conversion 
classes.

Desktop Make sure that the SNMP/WSMan 
communication between the desktop and 
Dell EMC devices exists.

To retrieve the required information from Dell 
EMC devices.

Web GUI Install and configure the OMNIbus web GUI 
and WAAPI.

Make sure that the SNMP/WSMan 
communication channel between the web 
GUI server and the managed Dell EMC 
systems exists.

To support Dell EMC tools available for Dell 
EMC OpenManage Connection.

To retrieve the required information from Dell 
EMC devices.

Supported Operating Systems for managed systems
The following table lists the operating systems supported on the supported Dell EMC devices:

Table 4. Supported operating systems for Dell EMC Workstations

Windows Server SUSE Linux Enterprise Server (SLES) Red Hat Enterprise Linux Server (RHEL)

Windows Server 2012 R2 (Datacenter, 
Foundation, Essentials, and Standard 
editions)

SLES 12 SP3 64-bit RHEL 7.5 64-bit

Windows 8.1 Professional 64 bit SLES 11 SP4 RHEL 7.4 64-bit

Windows 7 Professional 32-bit and 64-bit RHEL 6.10 64-bit

RHEL 6.9 64-bit

Table 5. Supported operating systems for Dell EMC Servers

VMware vSphere ESXi Windows Server SUSE Linux Enterprise Server 
(SLES)

Red Hat Enterprise Linux 
Server (RHEL)

ESXi 6.7 Windows 2019 SLES 15 64-bit RHEL 7.5 64-bit

ESXi 6.5 U1 Windows 2016 SLES 12 SP3 64-bit) RHEL 7.4 64-bit

ESXi 6.0 U3 Windows Server 2012 R2 
(Datacenter, Foundation, 
Essentials, and Standard 
editions)

SLES 11 SP4 RHEL 6.10 64-bit

RHEL 6.9 64-bit
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Supported Dell EMC devices and firmware
The following table lists the Dell EMC devices and their supported firmware versions for Dell EMC OpenManage Connection.

Table 6. Dell EMC devices and firmware

Dell EMC Devices Supported OMSA Versions Supported Firmware Versions

iDRAC9 NA • 3.21.23.22

• 3.21.21.21

iDRAC8 NA • 2.60.60.60

• 2.52.52.52

iDRAC7 NA • 2.60.60.60

• 2.52.52.52

iDRAC6 Modular NA • 3.85

• 3.80

iDRAC6 Monolithic NA • 2.91

• 2.90

DRAC5 NA • 1.6

• 1.5

PowerEdge servers • 9.2.1

• 9.2

• 9.1

NA

Hyper-Converged Platforms (HCI) Devices

VxRail, Nutanix XC-Series

14G

• 3.21.23.22

• 3.21.21.21

13G

• 2.60.60.60

• 2.52.52.52

OEM Servers • 9.2.1

• 9.2

• 9.1

NA

Dell EMC MX7000 NA OpenManage Enterprise Modular (OME-M)

• 1.0.1

• 1.00

Dell EMC FX2 NA • 2.10

• 2.0

Dell EMC VRTX NA • 3.10

Prerequisites 9



Dell EMC Devices Supported OMSA Versions Supported Firmware Versions

• 3.0

Dell EMC M1000e NA • 6.1

• 6.0

Dell EMC Workstations • 9.2.1

• 9.2

• 9.1

NA

Datacenter Scalable Solutions (DSS 1500 
and DSS 2500)

NA • 2.60.60.60

• 2.52.52.52

Datacenter Scalable Solutions (DSS 1510) NA • 2.60.60.60

• 2.52.52.52

Datacenter Scalable Solutions (DSS 9620, 
DSS 9600 and DSS 9630)

NA • 3.21.23.22

• 3.21.21.21

PowerVault NX Storage Arrays • 9.2.1

• 9.2

• 9.1

NA

SC-Series Storage Arrays NA • 7.2.40.36

• 7.2.31.3

PS-Series Storage Arrays NA • 10.0.1

• 9.1.7

Modular Disk Storage Arrays NA • 08.25.14

• 08.25.13

Dell EMC Network Switches NA S-Series

• 9.14

• 9.13

M-Series

• 9.14

• 9.13

Z-Series

• 9.14

• 9.13

C-Series

• 9.14

• 9.13

N-Series
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Dell EMC Devices Supported OMSA Versions Supported Firmware Versions

• 6.5.2.5

• 6.3.3.14

W-Series

• W-Series Mobility Controllers (6.4)

Dell EMC Precision Workstation • 9.2.1

• 9.2

• 9.1

• NA

NOTE: Dell EMC Workstations refers to Dell EMC Precision R7910 and R7920 Rack Workstations.
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Installing Dell EMC OpenManage Connection for 
Netcool/OMNIbus

To install Dell EMC OpenManage Connection for Netcool/OMNIbus, you must extract the component-specific files on the systems where 
you have installed the Netcool/OMNIbus components and deploy them. For more information on extracting component-specific files, see 
Integration Details for Netcool/OMNIbus Components.

Before you begin deploying the files:

1 Follow the below instructions to download Dell EMC OpenManage Connection for IBM Tivoli Netcool/OMNIbus.

2 Open the browser and enter the URL www.dell.com/support

3 Navigate to your Dell EMC product page or search by Dell EMC Service Tag.

4 Select Drivers and Downloads from the left pane options.

5 The page will display a list of supported software and plug-in available for the selected Dell EMC device.

6 Click on Dell EMC OpenManage Connection v4.0 for IBM Tivoli Netcool/OMNIbus and download the file.

Topics:

• Dell EMC OpenManage Connection for Netcool/OMNIbus package details

• Installing Probe Integration

• Installing ObjectServer Integration

• The Dell EMC ConfigUtility

• Installing Desktop Integration

• Installing Web GUI Integration

Dell EMC OpenManage Connection for Netcool/
OMNIbus package details
The Dell EMC OpenManage Connection for Netcool/OMNIbus is packaged as a zip file. This is applicable to systems running Windows and 
Linux including VMware ESXi environments. When you extract the Dell_EMC_OpenManage_Connection_for_OMNIbus_v4_0.zip zip file, 
the following folders and files are extracted:

• desktop_integration

• objectserver_integration

• probe_integration

• webgui_integration

• Dell_EMC_OMC_4_0_For_IBM_OMNIbus_IG.pdf

• Dell_EMC_OMC_4_0_For_Omnibus_ReadMe.txt

• license_en.txt

NOTE: Once the folders and files have been extracted, and the system requirements are met with, ensure that you see the 
Dell_EMC_OMC_4_0_For_Omnibus_ReadMe.txt and the license_en.txt files before you proceed with the installation.

Deploy the contents of the folders on the corresponding Netcool/OMNIbus components to monitor the supported Dell EMC devices.
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Integration details for Netcool/OMNIbus components
The following table lists the Netcool/OMNIbus components and the Integration folders for Dell EMC OpenManage Connection. Deploy the 
integration files of Dell EMC OpenManage Connection from the corresponding folder to the Netcool/OMNIbus components folder.

Table 7. Netcool/OMNIbus Components

Component Integration Folders

probe_integration Contains the rules and lookup table files for the supported Dell EMC devices.

objectserver_integration Contains the exported Dell EMC integration automation triggers, tools, menus, and 
conversion classes.

desktop_integration Contains utilities that you require for configuring and launching the consoles for the 
supported Dell EMC devices.

webgui_integration Contains the Dell EMC integration tools, menus, and utilities that you require for 
configuring the Dell EMC device consoles from the Netcool/OMNIbus web GUI.

Installing Probe Integration
The probe integration folder contains the following folder and version file:

• Dell

To deploy the integration of the supported Dell EMC devices:

1 Copy the dell folder under probe_integration and place it under the %NC_RULES_HOME%\include-snmptrap folder on the system 
where you have installed the Probe component.

NOTE: On systems running Linux, use the $NC_RULES_HOME/include-snmptrap folder.

2 Navigate to the $NC_RULES_HOME folder, open the snmptrap.rules.file and perform the following steps:

a Append the following command in the include rules section:

include "$NC_RULES_HOME/include-snmptrap/dell/dell.master.include.rules"
b Append the following command in the include lookup table section:

include "$NC_RULES_HOME/include-snmptrap/dell/dell.master.include.lookup"

NOTE: This step is applicable to systems running Linux only.

3 Ensure that the copied dell folder and the files under it have permissions for the probe rules in accordance with the IBM guidelines. For 
more information, see IBM Netcool/OMNIbus documentation.

4 Perform the followings steps:

Server traps

a Uncomment the dell-StorageManagement-MIB.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

b Uncomment the dell-StorageManagement-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

c Uncomment the dell-MIB-Dell-10892.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

d Uncomment the dell-MIB-Dell-10892.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.
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OOB Server (iDRAC9, DRAC8, iDRAC7) traps

a Uncomment the dell-IDRAC-MIB.include.snmptrap.lookup file include statement in the dell.master.include.lookup 
file.

b Uncomment the dell-IDRAC-MIB.include.snmptrap.rules file include statement in the dell.master.include.rules file.

FX2 CMC, VRTX CMC, CMC, iDRAC6, DRAC5 traps

a Uncomment the dell-RAC-MIB.include.snmptrap.lookup file include statement in the dell.master.include.lookup file.

b Uncomment the dell-RAC-MIB.include.snmptrap.rules file include statement in the dell.master.include.rules file.

SC-Series Storage Array traps

a Uncomment the dell-STORAGE-SC-MIB.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

b Uncomment the dell-STORAGE-SC-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

PS-Series Storage Array traps

a Uncomment the equalLogic-EQLMEMBER-MIB.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

b Uncomment the equalLogic-EQLDISK-MIB.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

c Uncomment the equalLogic-SCSI-MIB.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

d Uncomment the equalLogic-EQLMEMBER-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

e Uncomment the equalLogic-EQLDISK-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

f Uncomment the equalLogic-EQLVOL-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules

g Uncomment the equalLogic-GROUP-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules

h Uncomment the equalLogic-IPADD-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules

Modular Disk Storage Array traps

a Uncomment the dell-MDStorageArray-MIB.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

b Uncomment the dell-MDStorageArray-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

Dell EMC Network Switch traps

• S-Series, M-Series, Z-Series, and C-Series Switches

1 Uncomment the dell.switch.master.include.lookup file include statement in the dell.master.include.lookup file.

2 Uncomment the dell.switch.master.include.rules file include statement in the dell.master.include.rules file.

• S-Series Switches

1 Uncomment the dell-F10-S-SERIES-CHASSIS-MIB.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

2 Uncomment the dell-F10-S-SERIES-CHASSIS-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

• N-Series Switches

1 Uncomment the dell.Nseriesswitch.master.include.lookup file include statement in the 
dell.master.include.lookup file.
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2 Uncomment the dell.Nseriesswitch.master.include.rules file include statement in the 
dell.master.include.rules file.

• W-Series Switches

1 Uncomment the dell.Wseriesswitch.master.include.lookup file include statement in the 
dell.master.include.lookup file.

2 Uncomment the dell.Wseriesswitch.master.include.rules file include statement in the 
dell.master.include.rules file.

• Management Systems

1 Uncomment the dell-NGM-MIB.include.snmptrap.lookup file include statement in the dell.master.include.lookup 
file.

2 Uncomment the dell-NGM-MIB.include.snmptrap.rules file include statement in the dell.master.include.rules file.

5 Copy the delldevice_int_mttrapdprobe.ver version file to the %OMNIHOME% directory on the system where you have 
installed the Probe component on systems running Windows. On systems running Linux, copy the 
delldevice_int_mttrapdprobe.ver version file to the $OMNIHOME directory.

6 Restart the OMNIbus MTTrapd SNMP probe service (NCOMTTRAPDProbe) or process (nco_p_mttrapd).

Installing ObjectServer Integration
The objectserver_integration folder contains the following files and folder:

• OMNIbus81

• delldevice_confpack_64bit_v_4_0.jar

• delldevice_int_objectserver.ver

NOTE: Before installing the ObjectServer, user will have to delete the existing Dell EMC Classes 2080 for DellServer and 2085 
for Equallogic.

To delete the Dell EMC Classes on system running on Windows:

• Launch Netcool Administrator.

• Connect to Object Server.

• Navigate to Automation > Classes

• Delete DellServer and Dell Equallogic Classes.

To delete the Dell EMC Classes on system running Linux:

• Launch nco_config
• Connect to Object Server.

• Navigate to Automation > Classes

• Delete DellServer and Dell Equallogic Classes.

To deploy the Dell EMC integration components on the system that hosts the ObjectServer:

1 Run the following command with the required security credentials to access the OMNIbus ObjectServer:

a For IBM Tivoli Netcool/OMNIbus 8.1:

• On systems running 64–bit Linux:

$OMNIHOME/bin/nco_confpack -import -server <ObjectServer> -user <username> -password 
<password> -package <copied folder>/OMNIbus81/delldevice_confpack_64bit_v_4_0.jar

• On systems running Windows:

%OMNIHOME%\bin\nco_confpack.bat -import -server <ObjectServer> -user <username> -
password <password> -package <copiedfolder>
\OMNIbus81\delldevice_confpack_64bit_v_4_0.jar

b For IBM Tivoli Netcool/OMNIbus 7.4:
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• On systems running 64–bit Linux:

$OMNIHOME/bin/nco_confpack -import -server <ObjectServer> -user <username> -password 
<password> -package <copied folder>/delldevice_confpack_64bit_v_4_0.jar

• On systems running Windows:

%OMNIHOME%\bin\nco_confpack.bat -import -server <ObjectServer> -user <username> -
password <password> -package <copiedfolder>\delldevice_confpack_64bit_v_4_0.jar

NOTE: By default, the ObjectServer is NCOMS.

2 Navigate to opt/IBM/Tivoli/Netcool/OMNIbus/bin and run ./nco_event
3 In the Event List on the desktop, click File > Resync > All.

This action synchronizes the newly added menu items for the Dell EMC tools and conversion classes that are updated from the jar 
files.

NOTE: Resync can be performed only for ObjectServer integration.

4 In the %OMNIHOME% directory on the system where the ObjectServer is installed, copy the delldevice_int_objectserver.ver file.

NOTE: On systems running Linux, use the $OMNIHOME directory.

5 Restart the Object Server.

Configuring Dell EMC Server Administrator Web Server 
console on the ObjectServer
The Dell EMC Server Administrator Web Server console uses the configured URL to launch in the default browser.
To configure the Web Server console URL on systems running Windows and Linux:

1 Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.

2 In the Configuration window, select Menu > Tools.

3 On systems running Windows, double-click Dell EMC Server Administrator Web Server Console (Windows) on the right pane to 
launch the Tool Details window.

On systems running Linux, double-click Dell EMC Server Administrator Web Server Console on the right pane to launch the Tool 
Details window.

4 Click the executable tab and edit the following URL by providing the IP address and the port number:

https://<Server Administrator Web Server Host/IP>:<Server Administrator Web Server PORT>/
omalogin.html?managedws=false&mnip=@Node

For example:

https://11.95.145.156:1311/omalogin.html?managedws=false&mnip=@Node

For more information, see the Dell EMC Server Administrator documentation at dell.com/support/home.

Configuring OpenManage Enterprise (OME) console on the 
ObjectServer
The OME console uses the configured URL to launch the console in the default browser.
To configure the OME console URL on systems running Windows:

1 Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.

2 In the Configuration window, select Menu > Tools.

3 Double-click Dell EMC OpenManage Enterprise Console (Windows) on the right pane to launch the Tool Details window.
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4 Click the executable tab and edit the following URL by providing the IP address and the port number for OME:

https://<OpenManage Enterprise Host/IP>

For example:

https://11.95.145.156:2607/

For more information, see the OpenManage Enterprise User's Guide at dell.com/support/home.

Configuring PowerVault Modular Disk Storage Manager 
console on the ObjectServer
The PowerVault Modular Disk Storage Manager (MDSM) console uses the configured URL to launch the console in a separate window. 
Ensure that MSDM is installed on the system on which you want to launch this console.
To configure the installed path of the MDSM client on systems running Windows and Linux:

1 Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.

2 In the Configuration window, select Menu > Tools.

3 On systems running Windows, double-click Dell EMC Modular Disk Storage Manager (Windows) on the right pane to launch the 
Tool Details window.

On systems running Linux, double-click Dell EMC Modular Disk Storage Manager on the right pane to launch the Tool Details 
window.

4 Click the executable tab and edit the following command:

• On systems running Windows (by default):

"C:\\Program Files (x86)\\Dell\\MD Storage Software\\MD Storage Manager\\client\\Modular 
Disk Storage Manager Client.exe"

• On systems running Linux (by default):

"/opt/dell/mdstoragesoftware/mdstoragemanager/client/SMclient"

For more information, see the Modular Disk Storage Manager User's Guide at dell.com/support/home.

Configuring Dell EMC OpenManage Network Manager 
(OMNM) console on the ObjectServer
The Dell EMC OpenManage Network Manager (OMNM) console uses the configured URL to launch the console in a separate window.
To configure the OMNM console URL on systems running Windows and Linux:

1 Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.

2 In the Configuration window, select Menu > Tools.

3 On systems running Windows, double-click Dell EMC OpenManage Network Manager (Windows) on the right pane to launch the 
Tool Details window.

On systems running Linux, double-click Dell EMC OpenManage Network Manager on the right pane to launch the Tool Details 
window.

4 Click the executable tab and edit the following URL:

http://OMNM_IP_Address_OR_Host:OMNM_Port
For more information, see the OpenManage Network Manager User’s Guide at dell.com/support/home.

For example:

http://192.168.10.12:8080
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Configuring Dell EMC AirWave Management Platform console 
on the ObjectServer
The Dell EMC AirWave Management Platform console uses the configured URL to launch the console in a default browser.
To configure the Dell EMC AirWave Management Platform console URL on systems running Windows and Linux:

1 Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.

2 In the Configuration window, select Menu > Tools.

3 On systems running Windows, double-click Dell EMC AirWave Management Platform Console (Windows) on the right pane to 
launch the Tool Details window.

On systems running Linux, double-click Dell EMC AirWave Management Platform Console on the right pane to launch the Tool 
Details window.

4 Click the executable tab and edit the following URL:

https://airwavemanagementplatform_IP_Address

The Dell EMC ConfigUtility
Using the Dell EMC ConfigUtility, you can set the SNMP community string, WSMan parameters, and the TIPJAVAHOME parameters for 

desktop and web GUI.

NOTE: Once the community string, WSMan, and the TIPJAVAHOME parameters are configured using the Dell EMC ConfigUtility, 
the same community string is used to launch the consoles for the supported Dell EMC devices.

Related Links:

• Using the ConfigUtility for Desktop.

• Using the ConfigUtility for Web GUI.

Installing Desktop Integration
The desktop_integration folder for Dell EMC devices contains the following files:

• dell_config.properties

• dell_MD_Array_Common.jar

• dell_OMNIbus_Connection_KB_Tool_v_4_0.jar

• dell_OMC_ITNO_ConfigUtility_v_4_0.jar

• dell_OMC_ITNO_Helper_v_4_0.jar

• intel_wsman_v_1_0_1.jar

• delldevice_int_desktop.ver

• snmp4j-2.6.2.jar

• SYMsdk.jar

To deploy the Dell EMC integration components on the system that hosts the desktop client:

1 Copy all the files to the %OMNIHOME% directory on the system where you have installed the desktop client:

NOTE: 

• On systems running Windows, use the %OMNIHOME% directory.

• On systems running Linux, use the $OMNIHOME directory.

2 Configure the SNMP Community string, WSMan parameter and the TIPJAVAHOME parameters using the Dell EMC ConfigUtility 
(dell_OMC_ITNO_ConfigUtility_v_4_0.jar). For more information, see Dell EMC ConfigUtility.
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3 Add an environment variable named OMNIBROWSER and set it to the path of the default or desired browser.

NOTE: This is applicable to systems running Windows and Linux.

Using the Dell EMC ConfigUtility for Desktop
To use the Dell EMC ConfigUtility to set the SNMP community string, WSMan parameters, and the TIPJAVAHOME parameters for the 
Desktop:

1 Navigate to the %OMNIHOME% directory on the system where the Desktop component is installed.

2 Run the following command to configure the SNMP community string:

a For IBM Tivoli Netcool/OMNIbus 8.1:

On systems running Windows:

%NCHOME%\platform\<specificplatform>\jre_1.7.0\jre\bin\java  -Ddell.config.path=desktop -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar –communitystring=public
On systems running Linux:

$NCHOME/platform/<specificplatform>/jre64_1.7.0/jre/bin/java  -Ddell.config.path=desktop 
-jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar –communitystring=public

b For IBM Tivoli Netcool/OMNIbus 7.4:

On systems running Windows:

%NCHOME%\platform\<specificplatform>\jre_1.6.7\jre\bin\java  -Ddell.config.path=desktop -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar –communitystring=public
On systems running Linux:

$NCHOME/platform/<specificplatform>/jre_1.6.7/jre/bin/java  -Ddell.config.path=desktop -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar –communitystring=public

3 Run the following command to configure the WSMan parameters such as the user name and the password:

a For IBM Tivoli Netcool/OMNIbus 8.1:

On systems running Windows:

%NCHOME%\platform\<specificplatform>\jre_1.7.0\jre\bin\java  -Ddell.config.path=desktop -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar –wsmanusername=root –wsmanpassword
On systems running Linux:

$NCHOME/platform/<specificplatform>/jre64_1.7.0/jre/bin/java  -Ddell.config.path=desktop 
-jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar –wsmanusername=root –wsmanpassword

b For IBM Tivoli Netcool/OMNIbus 7.4:

On systems running Windows:

%NCHOME%\platform\<specificplatform>\jre_1.6.7\jre\bin\java  -Ddell.config.path=desktop -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar –wsmanusername=root –wsmanpassword
On systems running Linux:

%NCHOME%\platform\<specificplatform>\jre_1.6.7\jre\bin\java  -Ddell.config.path=desktop -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar –wsmanusername=root –wsmanpassword

4 Run the following command to configure the TIPJAVAHOME parameters:

a For IBM Tivoli Netcool/OMNIbus 8.1:

On systems running Windows:

%NCHOME%\platform\<specificplatform>\jre_1.7.0\jre\bin\java  -Ddell.config.path=desktop -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar -tipjavahome=<WebSphere java home path>
On systems running Linux:

$NCHOME/platform/<specificplatform>/jre64_1.7.0/jre/bin/java  -Ddell.config.path=desktop 
-jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar -tipjavahome=<WebSphere java home path>

b For IBM Tivoli Netcool/OMNIbus 7.4:
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On systems running Windows:

%NCHOME%\platform\<specificplatform>\jre_1.6.7\jre\bin\java  -Ddell.config.path=desktop -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar -tipjavahome=<java home path>
On systems running Linux:

$NCHOME/platform/<specificplatform>/jre_1.6.7/jre/bin/java  -Ddell.config.path=desktop -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar -tipjavahome=<java home path>

Configuring Dell EMC Warranty Report tool on the Desktop 
Server
The Dell EMC Warranty Report tool can be launched from the events that are generated from the Dell EMC device that you are monitoring 
and is used to retrieve the warranty information about that device.

The Warranty Report tool should be configured on the Desktop Server if you do not have direct internet access and are using proxy 
settings to access the internet. In this case, on systems running Linux, ensure to resolve the host name api.dell.com in the file /etc/
host. On systems running Windows, ensure to resolve the host name api.dell.com in the file C:\Windows\System32\drivers
\etc\hosts.

For example:

143.166.11.198 api.dell.com

Installing Web GUI Integration
The import sub folder within the webgui_integration folder contains the following files:

• cmclauncher_linux.cgi

• cmclauncher_nt.cgi

• compellent_linux.cgi

• compellent_nt.cgi

• dell_config.properties

• dell_MD_Array_Common.jar

• dell_OMC_ITNO_ConfigUtility_v_4_0.jar

• dell_OMC_ITNO_Helper_v_4_0.jar

• delldevice_int_webgui.ver

• draclauncher_linux.cgi

• draclauncher_nt.cgi

• eqllauncher_linux.cgi

• eqllauncher_nt.cgi

• export.xml

• idraclauncher_linux.cgi

• idraclauncher_nt.cgi

• intel_wsman_v_1_0_1.jar

• kblauncher_linux.cgi

• kblauncher_nt.cgi

• n_switchadminlauncher_linux.cgi

• n_switchadminlauncher_nt.cgi

• omsalauncher_linux.cgi

• omsalauncher_nt.cgi
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• snmp4j-2.6.2.jar

• SYMsdk.jar

• vrtxcmclauncher_linux.cgi

• vrtxcmclauncher_nt.cgi

• warranty_linux.cgi

• warranty_nt.cgi

To deploy the Dell EMC integration components on the system that hosts the web GUI:

1 By default, the web GUI is installed in C:\IBM\netcool \omnibus_webgui folder or C:\IBM\netcool\omnibus\omnibus_webgui folder. If 
your installation directory is in a different location, you need to add the OMNIWEBGUI environment variable in the web GUI installed 
directory.

2 If the Web GUI component is installed in a non default location or a location other than %NCHOME%\..\tipv2, then configure the 
TIPJAVAHOME environmental path with this version of Java as follows: java -Ddell.config.path=webgui -jar 
dell_OMC_ITNO_ConfigUtility_v_4_0.jar -tipjavahome="C:\Program Files (x86)\IBM\WebSphere
\AppServer\java_1.7_64\bin".

For example:

If Java is installed in the location C:\Program Files (x86)\Java\jre6\bin\java.exe, then configure the TIPJAVAHOME path as 

tipjavahome= C:\Program Files (x86)\Java\jre6\bin.

NOTE: If you have installed only IBM Tivoli Netcool OMNIbus in your system, then Tivoli Integrated Portal (TIP) will not be 
available. In this case, you can use the WebShpere home directory location while configuring the TIPJAVAHOME 
environmental path.

For example:

If Java is installed in the location "C:\Program Files (x86)\IBM\WebSphere\AppServer\java_1.7_64\bin", then configure the 
TIPJAVAHOME path as tipjavahome= "C:\Program Files (x86)\IBM\WebSphere\AppServer\java_1.7_64\bin".

3 Copy the following jar files and the dell_config.properties file from the $NCHOME/omnibus_webgui to the system where you have 
installed the Web GUI component.

• dell_config.properties

• dell_MD_Array_Common.jar

• dell_OMC_ITNO_ConfigUtility_v_4_0.jar

• dell_OMC_ITNO_Helper_v_4_0.jar

• delldevice_int_webgui.ver

• export.xml

• intel_wsman_v_1_0_1.jar

• snmp4j-2.6.2.jar

• SYMsdk.jar

4 Configure the SNMP Community string, WSMan parameters, and the TIPJAVAHOME using the Dell EMC ConfigUtility file. For more 
information, see Dell EMC ConfigUtility.

5 On the system where the web GUI component is installed, in the $NCHOME/omnibus_webgui, copy the delldevice_int_webgui.ver 
file.

6 Navigate to the import folder in the location where you have extracted webgui_integration folder and run the following command for 
each integration:

NOTE: By default, the ObjectServer is NCOMS. If your ObjectServer is anything other than NCOMS, then navigate 

to the import folder, open the export.xml file and replace all occurrences of the datasource , which is NCOMS, with 

the actual ObjectServer name.

For example: Change

datasource="NCOMS"
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to

datasource="<ObjectServer_Name>"

a For IBM Tivoli Netcool/OMNIbus 8.1:

On systems running Windows:

<WEB GUI home directory>\waapi\bin\runwaapi -host <hostname> -user <Web GUI username> -
password <Web GUI password> -file export.xml
On systems running Linux:

<WEB GUI home directory>/waapi/bin/runwaapi -host <hostname> -user <Web GUI username> -
password <Web GUI password> -file export.xml

b For IBM Tivoli Netcool/OMNIbus 7.4:

On systems running Windows:

<WEB GUI home directory>\waapi\bin\runwaapi -host <hostname> -user <Web GUI username> -
password <Web GUI password> -file export.xml
On systems running Linux:

<WEB GUI home directory>/waapi/bin/runwaapi -host <hostname> -user <Web GUI username> -
password <Web GUI password> -file export.xml

NOTE: Before running the runwaapi command, you will have to provide the exact path of the CGI file code in the 

export.xmlfile.

For example: For Linux,

<cgi fileName="<file location>/omsalauncher_nt.cgi" acl="*" name="omsalauncher_nt.cgi" 
useSmartPageCommands="false"/> 

7 Restart WebGUI TIP services.

Using the Dell EMC ConfigUtility for Web GUI
To use the Dell EMC ConfigUtility to set the SNMP community string, WSMan parameters, and the TIPJAVAHOME parameters for the 
Web GUI:

1 Navigate to the web GUI Installation directory on the system where the web GUI component is installed.

2 Run the following command to configure the SNMP community string:

a For IBM Tivoli Netcool/OMNIbus 8.1:

On systems running Windows:

<WebShpere home directory>\java_1.7_64\jre\bin\java -Ddell.config.path=webgui -jar 
dell_OMC_ITNO_ConfigUtility_v_4_0.jar –communitystring=public
On systems running Linux:

<WebShpere home directory>/java_1.7_64/jre/bin/java -Ddell.config.path=webgui -jar 
dell_OMC_ITNO_ConfigUtility_v_4_0.jar –communitystring=public

b For IBM Tivoli Netcool/OMNIbus 7.4:

On systems running Windows:

<Tivoli Integrated Portal home directory>\java\jre\bin\java -Ddell.config.path=webgui -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar –communitystring=public
On systems running Linux:

<Tivoli Integrated Portal home directory>/java/jre/bin/java -Ddell.config.path=webgui -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar –communitystring=public

3 Run the following command to configure the WSMan parameters such as the user name and the password:

a For IBM Tivoli Netcool/OMNIbus 8.1:
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On systems running Windows:

<WebShpere home directory>\java_1.7_64\jre\bin\java -Ddell.config.path=webgui -jar 
dell_OMC_ITNO_ConfigUtility_v_4_0.jar –wsmanusername=root –wsmanpassword
On systems running Linux:

<WebShpere home directory>/java_1.7_64/jre/bin/java -Ddell.config.path=webgui -jar 
dell_OMC_ITNO_ConfigUtility_v_4_0.jar –wsmanusername=root –wsmanpassword

b For IBM Tivoli Netcool/OMNIbus 7.4:

On systems running Windows:

<Tivoli Integrated Portal home directory>\java\jre\bin\java -Ddell.config.path=webgui -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar –wsmanusername=root –wsmanpassword
On systems running Linux:

<Tivoli Integrated Portal home directory>/java/jre/bin/java -Ddell.config.path=webgui -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar –wsmanusername=root –wsmanpassword

4 Run the following command to configure the TIPJAVAHOME parameters:

a For IBM Tivoli Netcool/OMNIbus 8.1:

On systems running Windows:

<WebShpere home directory>\java_1.7_64\jre\bin\java -Ddell.config.path=webgui -jar 
dell_OMC_ITNO_ConfigUtility_v_4_0.jar -tipjavahome=<WebSphere java home path>
On systems running Linux:

<TWebShpere home directory>/java_1.7_64/jre/bin/java -Ddell.config.path=webgui -jar 
dell_OMC_ITNO_ConfigUtility_v_4_0.jar -tipjavahome=<WebSphere java home path>

b For IBM Tivoli Netcool/OMNIbus 7.4:

On systems running Windows:

<Tivoli Integrated Portal home directory>\java\jre\bin\java -Ddell.config.path=webgui -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar -tipjavahome=<java home path>
On systems running Linux:

<Tivoli Integrated Portal home directory>/java/jre/bin/java -Ddell.config.path=webgui -
jar dell_OMC_ITNO_ConfigUtility_v_4_0.jar -tipjavahome=<java home path>

Updating the Dell EMC Tools menu on the Web GUI Server
To update the Dell EMC Tools menu on the Alerts menu of the Web GUI component:

1 Perform the following steps to edit the Alert menu:

a Click Administration > Event Management Tools.
b Navigate to Menu Configuration.
c Select Alerts from the Available menus on the right pane.
d Click Modify.
e Select menu from the Available items drop-down list.
f Add Dell EMC Tools to the Current items.
g Click Save.

2 Navigate to Administration > Availability > Events > Active Event List (AEL) and refresh the list to synchronize the newly added 
menu items.

3 Right-click a Dell EMC device alert and make sure that the respective Dell EMC console launch tools are available.

Configuring Dell EMC consoles on the Web GUI server on 
systems running Linux
You must configure the Dell EMC device specific console on the web GUI server on systems running Linux.
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To configure a Dell EMC console launch tool on a system running Linux:

1 Log in to the web GUI on a system running Linux.

2 Click Administration > Event Management Tools > Tool Creation.

NOTE: For Netcool OMNIbus version 8.1, you will have to select Tool 
Configuration.

3 Double-click on the Dell EMC console that you want to launch.

4 Modify the name of the CGI Script or the URL based on the Dell EMC console you want to launch.

For more information about the Dell EMC consoles that you must configure and their respective CGI Script or the URL see the table 
below.

For example:

To Launch the iDRAC console:

Navigate to Administration > Event Management Tools > Tool Creation, click iDRACConsole and then modify the name of the CGI Script 
in the URL section to idraclauncher_linux.cgi in the right pane.

Table 8. Dell EMC console launch tools and their respective CGI script/URL/Command

Console launch tools CGI Script/URL

Dell EMC Server Administrator Console omsalauncher_linux.cgi
Dell EMC Server Administrator Web Server 
Console

https://<Server Administrator Web Server Host/IP>:<Server 
Administrator Web Server PORT>/omalogin.html?
managedws=false&mnip=@Node

Dell EMC iDRAC Console idraclauncher_linux.cgi
Dell EMC Remote Access Controller Console draclauncher_linux.cgi
Dell EMC Chassis Management Controller Console cmclauncher_linux.cgi
SC-Series Storage Manager Console compellent_linux.cgi
PS-Series Group Manager Console eqllauncher_linux.cgi
Dell EMC OpenManage Switch Administrator 
Console

n_switchadminlauncher_linux.cgi

Dell EMC OpenManage Network Manager 
Console

http://OMNM_IP_Address_OR_Host:OMNM_Port

Dell EMC AirWave Management Platform Console https://airwavemanagementplatform_IP_Address
Dell EMC OpenManage Enterprise Console https://OME_IP_Address_OR_Host
Dell EMC Warranty Report warranty_linux.cgi
Dell EMC Server Trap Configuration Information kblauncher_linux.cgi

Configuring Dell EMC Server Administrator Web Server 
console on the Web GUI
To configure the Launch Dell EMC Server Administrator Web Server console:

1 Log in to the web GUI.

2 Click Administration > Event Management Tools > Tool Creation.

3 Select DellEMCServerAdministratorWebServerConsole on the right pane to launch the Tool Configuration window.
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4 Edit the following URL by providing the IP address and the port number:

https://<Server Administrator Web Server Host/IP>:<Server Administrator Web Server PORT>/
omalogin.html?managedws=false&mnip=@Node

For example:

https://11.95.145.156:1311/omalogin.html?managedws=false&mnip=@Node

For more information, see the Dell EMC Server Administrator documentation at dell.com/support/home.

Configuring Dell EMC OpenManage Enterprise (OME) console 
on the Web GUI
To configure the Launch Dell EMC OpenManage Enterprise console:

1 Log in to the web GUI.

2 Click Administration > Event Management Tools > Tool Creation.

3 Select DellEMCOpenManageEnterpriseConsole on the right pane to launch the Tool Configuration window.

4 Edit the following URL by providing the IP address and the port number for OME:

https://<OpenManage Enterprise Host/IP>

For example:

https://11.95.145.156:2607/

For more information, see the OpenManage Enterprise User's Guide at dell.com/support/home.

Configuring PowerVault Modular Disk Storage Manager 
console on the Web GUI
PowerVault Modular Disk Storage Manager (MDSM) console must be installed on the server from where you want to launch the console.
To configure the Dell EMC Modular Disk Storage Manager console:

1 Log in to the web GUI.

2 Click Administration > Event Management Tools > Tool Creation.

3 Select DellEMCModularDiskStorageManagerConsole on the right pane to launch the Tool Configuration window.

4 Update the following command if required:

On systems running Windows:

"%PROGRAM FILES%\Dell\MD Storage Software\MD Storage Manager\client\Modular Disk Storage 
Manager Client.exe"

On systems running Linux:

"/opt/dell/mdstoragesoftware/mdstoragemanager/client/SMclient"

Configuring Dell EMC OpenManage Network Manager 
(OMNM) console on the Web GUI
To configure the Dell EMC OpenManage Network Manager console:

1 Log in to the web GUI.

2 Click Administration > Event Management Tools > Tool Creation.
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3 Select DellEMCOpenManageNetworkManagerConsole on the right pane to launch the Tool Configuration window.

4 Edit the following URL by providing the IP address and the port number for OMNM:

http://OMNM_IP_Address_OR_Host:OMNM_Port

For example:

http://192.168.10.12:8080

For more information, see the OpenManage Essentials User's Guide at dell.com/support/home.

Configuring Dell EMC AirWave Management Platform console 
on the Web GUI
To configure the Dell EMC AirWave Management Platform console:

1 Log in to the web GUI.

2 Click Administration > Event Management Tools > Tool Creation.

3 Select DellEMCAirWaveManagementPlatformConsole on the right pane to launch the Tool Configuration window.

4 Edit the following URL:

https://airwavemanagementplatform_IP_Address

Configuring Dell EMC Warranty Report tool on the web GUI
The Dell EMC Warranty Report tool can be launched from the events that are generated from the Dell EMC device that you are monitoring 
and is used to retrieve the warranty information about that device.

The Warranty Report tool should be configured on the web GUI server if you do not have direct internet access and are using proxy 
settings to access the internet. In this case, on systems running Linux, ensure to resolve the host name api.dell.com in the file /etc/
host. On systems running Windows, ensure to resolve the host name api.dell.com in the file C:\Windows\System32\drivers
\etc\hosts.

For example:

143.166.11.198 api.dell.com

26 Installing Dell EMC OpenManage Connection for Netcool/OMNIbus



Upgrading Dell EMC OpenManage Connection for 
Netcool/OMNIbus

To upgrade the Dell EMC OpenManage Connection for Netcool/OMNIbus:

1 Uninstall the existing connection. For more information, see the Dell EMC OpenManage Connection for Netcool/OMNIbus Installation 
Guide, for the existing version, at dell.com/omconnectionsEnterpriseSystemsManagement.

2 Install the latest version using the installation procedure described in Installing Dell EMC OpenManage Connection for Netcool/
OMNIbus.

4
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Uninstalling Dell EMC OpenManage Connection 
for Netcool/OMNIbus

To uninstall Dell EMC OpenManage Connection for Netcool/OMNIbus you must uninstall or remove the component-specific files.

Topics:

• Uninstalling Probe Integration

• Uninstalling ObjectServer Integration

• Uninstalling Desktop Integration

• Uninstalling Web GUI Integration

Uninstalling Probe Integration
To uninstall the Probe integration:

1 Navigate to $NC_RULES_HOME\snmptrap-rules.file and remove the following commands:

• include "$NC_RULES_HOME/include-snmptrap/dell/dell.master.include.rules"
• include "$NC_RULES_HOME/include-snmptrap/dell/dell.master.include.lookup"

2 Navigate to the %NC_RULES_HOME%/include-snmptrap folder on the system where you have installed the Probe component.

NOTE: On systems running Linux, use the $NC_RULES_HOME/include-snmptrap folder.

3 Delete the dell folder under $NC_RULES_HOME/include-snmptrap.

4 Navigate to the %OMNIHOME% directory and delete the delldevice_int_mttrapdprobe.ver version file.

5 Restart the OMNIbus MTTrapd SNMP probe service (NCOMTTRAPDProbe) or process (nco_p_mttrapd).

Uninstalling ObjectServer Integration
To uninstall the ObjectServer integration:

1 Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.

2 In the Configuration window, select Menu > Tools.

3 Right-click the following tools and click Delete:

• Dell EMC Server Administrator Console

• Dell EMC Server Administrator Web Server Console

• Dell EMC iDRAC Console

• Dell EMC Remote Access Controller Console

• Dell EMC Chassis Management Controller Console

• Dell EMC SC-Series Storage Manager Console

• Dell EMC Modular Disk Storage Manager Console

• Dell EMC PS-Series Group Manager Console

• Dell EMC OpenManage Switch Administrator Console

• Dell EMC OpenManage Network Manager Console

• Dell EMC AirWave Management Platform Console

5
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• Dell EMC Warranty Report

• Dell EMC OpenManage Enterprise Console

• Dell EMC Server Trap Configuration Information

NOTE: Dell EMC OpenManage Enterprise Console is only applicable for systems running on Linux Operating System.

4 In the Configuration window, select Menu > Menus.

5 Under the Alerts Menu, select Dell EMC Tools.

6 Right-click Dell EMC Tools and click Delete.

7 In the Configuration window, navigate to Automation Triggers and delete the following triggers:

• dell_idrac_clear

• dell_idrac_deduplicate_clear

• dell_omsa_clear

• dell_omsa_deduplicate_clear

• dell_cmc_clear

• dell_cmc_deduplicate_clear

• dell_compellent_clear

• dell_compellent_duplicate_clear

• dell_equallogic_clear

• dell_equallogic_deduplicate_clear

• dell_mdarray_clear

• dell_mdarray_deduplicate_clear

• dell_enterprise_switch_clear

• dell_enterprise_switch_duplicate_clear

• dell_nseries_clear

• dell_nseries_deduplicate_clear

8 In the Configuration window, navigate to Visual Conversions and expand the Class menu. Right-click the following and click Delete:

• Dell EMC Server (2080)

• Dell EMC iDRAC (2088)

• Dell EMC DRAC (2087)

• Dell EMC CMC (2086)

• Dell EMC Chassis (2094)

• Dell EMC VRTX CMC (2084)

• Dell EMC SC-Series Storage Arrays (2090)

• Dell EMC MD Storage Array (2809)

• Dell EMC PS-Series Storage (2085)

• Dell EMC Networking Switches (2091)

• Dell EMC N-Series Switch (2092)

• Dell EMC W-Series Mobility Controller (2093)

9 In the %OMNIHOME% directory on the system where the ObjectServer is installed, remove the file delldevice_int_objectserver.ver.

10 Open Event List and select File > Resync > All.

11 Restart the ObjectServer.

Uninstalling Desktop Integration
To uninstall the desktop integration:

1 Navigate to the %OMNIHOME% directory on the system where you have installed the desktop integration components.

2 Perform the following steps:
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• Remove the file delldevice_int_desktop.ver

• All Desktop Integration — Remove the following files:

– dell_config.properties

– dell_MD_Array_Common.jar

– dell_OMNIbus_Connection_KB_Tool_v_4_0.jar

– dell_OMC_ITNO_Helper_v_4_0.jar

– dell_OMC_ITNO_ConfigUtility_v_4_0.jar

– intel_wsman_v_1_0_1.jar

– snmp4j-2.6.2.jar

– SYMsdk.jar

Uninstalling Web GUI Integration
To uninstall the web GUI integration:

1 Login to the web GUI.

2 Remove the following files from the webgui_integration folder.

• dell_config.properties

• dell_MD_Array_Common.jar

• dell_OMC_ITNO_ConfigUtility_v_4_0.jar

• dell_OMC_ITNO_Helper_v_4_0.jar

• delldevice_int_webgui.ver

• export.xml

• intel_wsman_v_1_0_1.jar

• snmp4j-2.6.2.jar

• SYMsdk.jar

3 Navigate to Administration > Event Management Tools > Tool Creation.

4 Select the following tools and click Delete.

• Dell EMC Server Administrator Console

• Dell EMC Server Administrator Web Server Console

• Dell EMC iDRAC Console

• Dell EMC Remote Access Controller Console

• Dell EMC Chassis Management Controller Console

• Dell EMC SC-Series Storage Manager Console

• Dell EMC Modular Disk Storage Manager Console

• Dell EMC PS-Series Group Manager Console

• Dell EMC OpenManage Switch Administrator Console

• Dell EMC OpenManage Network Manager Console

• Dell EMC AirWave Management Platform Console

• Dell EMC Warranty Report

• Dell EMC OpenManage Enterprise Console

• Dell EMC Server Trap Configuration Information

5 Navigate to Administration > Event Management Tools > Menu Configuration.

6 Under Available menus, select DellEMCTools and click Delete.

7 Navigate to Administration > Maps > CGI Registry.

8 Select the following .cgi files, and then click Unregister.

• idraclauncher_linux.cgi

• idraclauncher_nt.cgi
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• draclauncher_linux.cgi

• draclauncher_nt.cgi

• cmclauncher_linux.cgi

• cmclauncher_nt.cgi

• compellent_linux.cgi

• compellent_nt.cgi

• eqllauncher_linux.cgi

• eqllauncher_nt.cgi

• n_switchadminlauncher_linux.cgi

• n_switchadminlauncher_nt.cgi

• omsalauncher_linux.cgi

• omsalauncher_nt.cgi

• warranty_linux.cgi

• warranty_nt.cgi

• kblauncher_linux.cgi

• kblauncher_nt.cgi

9 Restart the Web GUI component.
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Accessing documents from the Dell EMC support 
site

You can access the required documents using the following links:

• For Dell EMC Enterprise Systems Management documents — www.dell.com/esmmanuals

• For Dell EMC OpenManage documents — www.dell.com/openmanagemanuals

• For Dell EMC Remote Enterprise Systems Management documents — www.dell.com/esmmanuals

• For iDRAC and Dell Lifecycle Controller documents — www.dell.com/idracmanuals

• For Dell EMC OpenManage Connections Enterprise Systems Management documents — www.dell.com/esmmanuals

• For Dell EMC Serviceability Tools documents — www.dell.com/serviceabilitytools

• a Go to www.dell.com/support.

b Click Browse all products.

c From All products page, click Software, and then click the required link from the following:

– Analytics

– Client Systems Management

– Enterprise Applications

– Enterprise Systems Management

– Public Sector Solutions

– Utilities

– Mainframe

– Serviceability Tools

– Virtualization Solutions

– Operating Systems

– Support

d To view a document, click the required product and then click the required version.

• Using search engines:

– Type the name and version of the document in the search box.
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Contacting Dell
NOTE: If you do not have an active Internet connection, you can find contact information on your purchase invoice, packing slip, 
bill, or Dell product catalog.

Dell provides several online and telephone-based support and service options. Availability varies by country and product, and some services 
may not be available in your area. To contact Dell for sales, technical support, or customer service issues:

1 Go to Dell.com/support.

2 Select your support category.

3 Verify your country or region in the Choose a Country/Region drop-down list at the bottom of the page.

4 Select the appropriate service or support link based on your need.

7
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