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1
Introduction
This document describes the activities that you can perform with Dell Server Management Pack Suite 
version 6.2 for Microsoft System Center Operations Manager.

The integration of Dell Server Management Pack Suite with Microsoft System Center 2012 R2 Operations 
Manager, Microsoft System Center 2012 SP1 Operations Manager, Microsoft System Center 2012 
Operations Manager, or Microsoft System Center Operations Manager 2007 R2, environment allows you 
to manage, monitor, and also ensure the availability of the Dell devices.

CAUTION: To avoid data corruption, data loss, or both; perform the procedures in this document 
only if you have proper knowledge and experience in using Microsoft Windows operating system 
and Microsoft System Center 2012 R2 Operations Manager, Microsoft System Center 2012 SP1 
Operations Manager, Microsoft System Center 2012 Operations Manager, and Microsoft System 
Center Operations Manager 2007 R2.

NOTE: Read the Dell Server Management Pack Suite’s release notes, which contain the latest 
information about software and management server requirements, in addition to information about 
known issues. The release notes is posted to the Systems Management documentation page on 
dell.com/OMConnectionsEnterpriseSystemsManagement. The release notes is also packaged in 
the self-extracting executable Dell_Server_Management_Pack_Suite_v6.2_Axx.exe file. (where xx is 
the Dell Server Management Pack Suite version 6.2 release number) file.

 

Terms used in this document
Table 1. Terms used in this document

Term Refers to

OpsMgr Microsoft System Center 2012 R2 Operations Manager, Microsoft 
System Center 2012 SP1 Operations Manager, Microsoft System 
Center 2012 Operations Manager, and Microsoft System Center 
Operations Manager 2007 R2, unless otherwise specified.

OpsMgr 2012 Microsoft System Center 2012 R2 Operations Manager, Microsoft 
System Center 2012 SP1 Operations Manager, and Microsoft System 
Center 2012 Operations Manager, unless otherwise specified.

Dell Remote Access Controller 
(DRAC)

iDRAC of Dell servers, Dell branded OEM servers, and Dell OEM 
Ready servers, unless otherwise specified.

Chassis Chassis Management Controller (CMC), unless otherwise specified.

Dell Servers Dell PowerEdge servers, Dell PowerVault monolithic and modular 
servers, supported Rack Workstations, Dell branded OEM servers, 
and Dell OEM Ready servers, unless otherwise specified.
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Term Refers to

Agent-based monitoring Servers and Rack Workstation Agent-based Monitoring, unless 
otherwise specified.

Agent-free monitoring Servers and Rack Workstations Agent-free Monitoring, unless 
otherwise specified.

What is new in this release

The release highlights of Dell Server Management Pack Suite are:

• Support for Dell branded OEM servers, and Dell OEM Ready servers.

• Simplified discovery and monitoring; Chassis, and Chassis Modular Server Correlation does not 
require RACADM utility.

Key Features of Dell Server Management Pack Suite

This version of Dell Server Management Pack Suite provides the following features for managing the Dell 
devices:

Table 2. Features and Functionalities

Feature Functionality

Agent-based Discovery and Monitoring — Dell 
Servers and Rack Workstation

Supports agent-based discovery and monitoring of 
Dell PowerEdge, Dell PowerVault monolithic and 
modular systems, Dell OEM Ready servers, and 
supported Dell Precision Racks running the 
supported Windows operating system, and 
supported Dell OpenManage Server Administrator.

Agent-free Discovery and Monitoring — Dell 
Servers and Rack Workstation

Supports:

• Agent-free discovery and monitoring of 12th 
generation and 13th generation of Dell 
PowerEdge servers, Dell PowerVault systems, 
supported Dell Precision Racks, Dell branded 
OEM servers, and Dell OEM Ready servers.

• SNMP traps for agent-free monitoring systems.

Discovery and Monitoring — Chassis Management Supports:

• Discovery and monitoring of Dell Chassis, and 
Dell OEM Ready chassis devices.

• Discovery of server modules and chassis slot 
summary for CMC chassis.

• SNMP traps for Dell Chassis devices.

Discovery and Monitoring — Dell Remote Access 
Controllers (DRAC)

Supports:

• Discovery and monitoring of supported iDRAC 
devices.

• SNMP and PET traps for DRAC devices.
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Feature Functionality

Chassis Blade Correlation Supports:

• Correlation of Dell servers with Server modules 
of CMC chassis, and Dell OEM Ready chassis.

• Correlation of Chassis shared storage 
components with Dell modular servers.
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2
Overview of Dell Server Management 
Pack Suite Functionality
The Dell Server Management Pack Suite for OpsMgr enables you to:

• Discover and classify Dell systems:

– Dell Servers (Agent-based monitoring and Agent-free monitoring)

– Dell Remote Access Controllers

– Dell Chassis (Dell PowerEdge FX2/ FX2s, Dell PowerEdge VRTX, Dell PowerEdge M1000e, and Dell 
OEM Ready Chassis)

– Supported Dell Precision Racks

• Monitor the discovered Dell systems.

• View, analyze, and resolve alerts using Knowledge Base (KB) articles.

• Perform various tasks on the discovered Dell systems.

• View reports for discovered Dell systems.
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3
Agent-based Monitoring Feature
Agent-based monitoring feature supports the discovery and monitoring of Dell PowerEdge monolithic 
and modular servers, Dell PowerVault storage servers, Dell OEM Ready servers, and supported Dell 
Precision Racks by running the supported Windows operating system and OpenManage Server 
Administrator (OMSA). For information on supported OMSA versions, see Dell Server Management Pack 
Suite Version 6.2 for Microsoft System Center Operations Manager Release Notes.

The Dell Server Management Pack Suite installer automatically imports the Agent-based monitoring 
feature.

 

Comparison of Scalable and Detailed Edition features

The following table helps you understand the environment in which you can use Scalable and Detailed 
Edition features.

Table 3. Scalable management pack versus Detailed management pack

Features Scalable Edition Detailed Edition

Agent-based Monitoring • Inventory and monitoring of 
component groups. Also, 
display the presence of iDRAC.

• Reports — Only OpenManage 
Windows Event log report is 
available.

• Detailed inventory and health 
monitoring of individual 
components.

• View metrics for memory, 
processors, network interfaces, 
sensors, storage controllers, 
disks and virtual disks. Also, 
displays BIOS information.

• Reports — Availability of BIOS 
configuration, firmware and 
driver version, and RAID 
configuration reports.

Discovery and grouping

The Dell Server Management Pack Suite enables you to discover and classify Dell Servers — Monolithic, 
Modular, Sleds, and supported Dell Precision Racks. The following table lists the details of the hardware 
discovery and grouping.

Table 4. Dell Hardware discovery and grouping

Group Diagram View Hardware Type

Dell Servers Dell Monolithic Servers Dell PowerEdge systems.
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Group Diagram View Hardware Type

Dell Modular Servers

Dell Sled Servers

Dell PowerVault storage servers.

Dell Rack Workstations Rack Workstation Diagram Dell Precision Racks.

Discovering Dell Server in OpsMgr

Dell servers are discovered through the OpsMgr Agent Management infrastructure.

NOTE: Discover Dell server in the Agent Managed view under the Administration section of the 
OpsMgr console.

To discover a Dell server:

1. Log on to the management server as an OpsMgr administrator.

2. On the OpsMgr console, click Administration.

3. At the bottom of the navigation pane, click Discovery Wizard.

4. Run the Discovery Wizard, select Windows computers and follow the instructions on the screen.

For more information, see the OpsMgr documentation at technet.microsoft.com.

NOTE: The installer automatically imports the Agent-based monitoring feature management 
packs into the OpsMgr. If the installer fails to install the management packs, then, import the 
management packs using the OpsMgr Import Management Packs wizard or the Feature 
Management Dashboard.

NOTE: Dell servers that do not have Dell OpenManage Server Administrator (OMSA) installed, or 
have unsupported OMSA versions are grouped as Dell Unmanaged.

Discoveries by the Agent-based Monitoring Feature

Table 5. Agent-based Monitoring Feature Discoveries

Discovery Description

Dell Server Discovery Classifies the Dell servers and populates the 
attributes.

Dell Server Network Interface Discovery Discovers the network interface at group level of 
the Dell server.

Dell Server Hardware Components Discovery Discovers hardware components at a group level 
(such as sensors, processor, memory, and power 
supply).

Dell OpenManage Software Services Discovery Discovers the objects for OpenManage Server 
Administrator Windows services.

Dell Server Detailed BIOS Discovery Discovers BIOS objects for each Dell server 
(Detailed edition only).
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Discovery Description

Dell Server Detailed Memory Discovery Discovers memory instances for the Dell server 
(Detailed edition only).

Dell Server Detailed Power Supply Discovery Discovers power supply instances for the Dell 
server (Detailed edition only).

Dell Server Detailed Processor Discovery Discovers processor instances for the Dell server 
(Detailed edition only).

Dell Server Detailed Storage Discovery Discovers the complete storage hierarchy for the 
Dell server (Detailed edition only).

Dell Windows Server Detailed Sensor Discovery Discovers sensor instances for Dell server (Detailed 
edition only).

Dell Windows Server Detailed Network Interfaces 
Discovery Module

Discovers the physical and teamed network 
interface instances of the Dell server (Detailed 
edition only).

Dell Windows Server Network Interfaces Group 
Discovery Module

Discovers the Network Interfaces group.

Dell Rack Workstation Group Discovery Discovers the Dell Rack Workstation group.

Dell Unmanaged Server Group Discovery Discovers Dell servers that are not being 
monitored either due to the absence of Dell 
instrumentation, or has an instrumentation version 
lower than the required version.

Monitoring

The Monitoring pane of the OpsMgr is used to select views that provide complete health information of 
the discovered Dell servers. The Severity Level Indicators helps you to indicate the health of the Dell 
servers on the network.

It includes monitoring the health of Dell modular and monolithic servers, and Dell Precision Racks and 
their components, both at regular intervals and on occurrence of events.

Monitored hardware components

The following table provides information on the monitored hardware components supported in Scalable 
and Detailed feature.

Table 6. Monitored hardware components — Scalable and Detailed feature

Hardware components Scalable Detailed

iDRAC Yes Yes

Memory Yes Yes
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Hardware components Scalable Detailed

Network Interfaces Group Yes Yes

OpenManage Software Services Yes Yes

Power Supplies Yes Yes

Processors Yes Yes

Storage Yes Yes

Storage Controller Yes Yes

Sensors Yes Yes

Physical Network Interface Instance No Yes

BIOS Config Instance No No

Battery Sensor No Yes

Battery Sensor Group No Yes

Current Sensor No Yes

Current Sensor Group No Yes

Chassis Intrusion Sensor No Yes

Fan Sensor No Yes

Fan Sensor Group No Yes

Memory Unit Instance No Yes

Network Interfaces Physical Group No Yes

Network Interfaces Teamed Group No Yes

Processor Unit Instance No Yes

Power Supplies Unit Instance No Yes

Storage Controller Physical Disk 
Instance

No Yes

Storage Connector Physical Disk 
Group

No Yes
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Hardware components Scalable Detailed

Storage Controller Connector 
Instance

No Yes

Storage Controller Enclosure Instance No Yes

Storage Controller Sensors No Yes

Storage Controller Virtual Disk Group No Yes

Storage Enclosure EMM Instance No Yes

Storage Enclosure Physical Disk 
Group

No Yes

Storage Enclosure Power Supply 
Group

No Yes

Storage Enclosure Sensors No Yes

Teamed Network Interface Instance No Yes

Voltage Sensor No Yes

Voltage Sensor Group No Yes

Views

Dell Server Management Pack Suite provides the following types of views for Monitoring, under 

Monitoring → Dell on the OpsMgr console:

• Alerts Views

• Diagram Views

• Performance and Power Monitoring Views

• State Views

Alerts Views

This view is available for managing hardware and storage events from Dell servers and Rack Workstations. 
The following alerts are displayed:

• Alerts for events received from Dell OpenManage Server Administrator for Dell servers and Rack 
Workstations.

NOTE: Informational alerts are turned off by default. To enable informational alerts, run the Set 
Informational Alerts On task for Agent-based monitoring feature on the Feature Management 
Dashboard.

• Link-up or Link-down alerts for events received from Broadcom and Intel network interface cards.
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Viewing Alerts on the OpsMgr Console

To view alerts on the OpsMgr console:

1. Launch the OpsMgr console and click Monitoring.

2. Click Dell → Alerts Views.

The following alerts are displayed:

• Network Interface Alerts — Link-up and Link-down alerts from the discovered NICs are 
displayed.

• Server and Rack Workstation Alerts — Server Administrator alerts from Dell servers and Rack 
Workstation are displayed.

• Dell Rack Workstation Alert Views

– Network Interface Alerts — Link-up and Link-down alerts from the discovered NICs are 
displayed.

– Rack Workstation Alerts — Server Administrator alerts from Dell Rack Workstation are 
displayed.

3. Select any of the Alerts Views.

On the right pane of each of the individual Alerts Views, alerts that meet the criteria you specify, 
(such as alert severity, resolution state, or alerts that are assigned to you) are displayed.

4. Select an alert to view the details in the Alert Details pane.

Diagram Views

The Diagram Views offers a hierarchical and graphical representation of all Dell servers and supported 
Rack Workstations on the network.

Viewing Diagram Views on the OpsMgr console

To view the diagram views on the OpsMgr console:

1. Launch the OpsMgr console and click Monitoring → Dell → Diagram Views.

2. Navigate to the Diagram Views folder for the following views:

• Complete Diagram View

• Dell Rack Workstation Diagram Views

– Rack Workstation Diagram

• Dell Server Diagram Views

– Modular Systems Diagram

– Monolithic Servers Diagram

– Sled Servers Diagram

3. Select any of the Diagram Views.

On the right pane the hierarchical and graphical representation of the selected Dell server or Rack 
Workstation is displayed.

4. Select a component in the diagram to view its details in the Detail View pane.
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Complete Diagram View

The Complete Diagram View offers a graphical representation of all Dell devices that OpsMgr monitors. 
You can expand and verify the status of individual devices and their components in the diagram. You can 
view the details for the following:

• Dell Modular and Monolithic servers

• Dell Sled Group

• Dell Rack Workstations

• Chassis Management Controllers

• Remote Access Controllers

• Dell Unmanaged systems

Rack Workstation Diagram

The Dell Rack Workstation Diagram Views offers a graphical representation of all supported Rack 
Workstations and allows you to expand and verify the status of individual devices and their components 
in the diagram. Select a Rack Workstation in the diagram to view its details in the Detail View pane.

Modular and Monolithic Systems

The Modular Systems Diagram and Monolithic Servers Diagram views offer the following details:

• Physical and teamed network interfaces

• Memory

• Power supply

• Sensors

• Processors

• Dell OpenManage software services

• Storage components

• BIOS (inventory only)

• iDRAC

Modular Systems Diagram

The Dell Modular Systems Diagram View offers a graphical representation of all Dell modular systems 
and allows you to expand and verify the status of individual devices and their components in the diagram.

Monolithic Servers Diagram

The Dell Monolithic Systems Diagram View offers a graphical representation of all Dell monolithic 
systems and allows you to expand and verify the status of individual devices and their components in the 
diagram.

Sled Servers Diagram

The Dell Sled Servers Diagram View offers a graphical representation of all Dell Sled servers and allows 
you to expand and verify the status of individual devices and their components in the diagram. Select a 
Sled server in the diagram to view its details in the Detail View pane.

Dell Server Instance Diagram

Select a Dell server from the Dell Modular System or Dell Monolithic System diagram views, to view the 
diagram specific to that particular system.
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Figure 1. Dell Server Instance Diagram

System-specific diagrams illustrate and indicate the status of the following components:

• Physical and teamed network interfaces

• Memory

• Power supply

• Sensors

• Processors

• Dell OpenManage software services

• Storage components

• BIOS (inventory only)

The memory, processors, network, sensors, storage, and power supply components are displayed in 
detail by the Detailed edition of the Agent-based monitoring feature.

Storage Controller Component Hierarchy

Expand the Storage component in any Dell system instance diagram view, to view the status and health 
of components such as physical disks, connectors, virtual disks, controllers, sensors, and enclosures.

Network Interfaces Component Hierarchy

The Network Interfaces group is created only when an Intel or Broadcom network interface card is 
present and enabled on the Dell Server (Agent-based). Network interfaces are grouped under Physical 
Interfaces and Teamed Interfaces. If you disable a network interface, the network interfaces group will 
be removed from management in the next discovery cycle.

A reference relationship is created between a Teamed network interface and its associated Physical 
network interfaces. You can view the reference relationship only when you enable the Enable 
Correlation attribute of Dell Windows Server Physical and Teamed Relationship Discovery. For more 
information, see Enabling Correlation.

Enabling Correlation

To enable the Enable Correlation attribute:

1. Launch the OpsMgr console.

2. From the navigation pane, click Authoring.

3. In the Authoring tab, click Management Pack Objects → Object Discoveries.

4. Search for Dell Windows Server Physical and Teamed Relationship Discovery Rule 
in the Look for: field.
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5. Right-click Dell Windows Server Physical and Teamed Relationship Discovery Rule → Overrides → 
Override the Object Discovery → For all objects of class: Teamed Network Interface instance 
(Enriched).

The Override Properties page is displayed.

6. Select Enable Correlation and set the Override Value to True and click OK.

The status roll-up of network interfaces on the diagram view is displayed only up to the Network 
Interfaces group level. For example, if the remaining components of the Dell server are normal and only 
one or more of the network interfaces are critical or noncritical, then, the Dell system displays the health 
state normal icon, and the Network Interfaces group displays the critical or warning icon.

Figure 2. Network Interfaces Diagram View

Enabling Network Interfaces Group to Dell Server Health Roll Up

For the status roll-up to be displayed at the server level, enable the Network Interfaces Group to Dell 
Server Health Roll up dependency monitor.

To enable the monitor:

1. Launch the OpsMgr console.

2. From the navigation pane, click Authoring.

3. Click Monitors on the left pane and then, search Network Interfaces Group for the type of server 
you want to enable the functionality. For example, Dell Windows Server.

4. Click Entity Health → Availability.

5. Right-click Network Interfaces Group to Dell Server Health Roll up and select Overrides → 
Override the Monitor → For all objects of class: Dell Windows Server

The Override Properties screen is displayed.

6. Select Enabled and set the Override Value to True.

7. Under Management Pack, either select a management pack created from the Select destination 
management pack: drop-down menu or create a management pack by clicking New...

To create a management pack:

a. Click New...

The Create a Management Pack screen is displayed.

b. Provide a name for the management pack in the Name field and click Next.

For information on creating a management pack, see the OpsMgr documentation at 
technet.microsoft.com.

c. Click Create.

The management pack you created is selected in the Select destination management pack: 
drop-down menu.
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8. Click Apply.

Performance and Power Monitoring Views

To view the performance and power monitoring on the OpsMgr console:

1. Launch the OpsMgr console and click Monitoring.

2. In the Monitoring pane, click Dell → Performance and Power Monitoring for the following views:

• Agent-based Disk Performance (%)

• Ambient Temperature (Centigrade)

• Amperage (Amps)

• Energy Consumption (kWh)

• Peak Amperage (Amps)

• Peak Power (Watts)

• Physical Network Interface

• Power Consumption (Watts)

• Power Consumption (BTU/hr)

• Teamed Network Interface

NOTE: Power monitoring is applicable only for Dell servers with power monitoring capability for 
a particular attribute. It is enabled only when the detailed edition of Agent-based monitoring 
feature is present.

NOTE: Agent-based Disk Performance (%), Teamed and Physical network interface instances 
are disabled by default and appears only when the detailed edition of the Agent-based 
monitoring feature is installed and imported.

3. Select the counters from the individual performance views and select the time range for which the 
values are required.

The data collected is represented in a graphical format for each system.

A unit monitor, monitors the performance counter over two successive cycles to check if it exceeds a 
threshold value. When the threshold value is exceeded, the Dell server changes state and generates an 
alert. This unit monitor is disabled by default. You can override (enable) the threshold values from the 
Authoring pane of the OpsMgr console. Unit monitors are available under Dell Windows Server objects 
for Agent-based monitoring feature. To enable the threshold values of unit monitors, see Enabling 
Performance and Power Monitoring Unit Monitors.

For more information on performance information collection, see Performance Collection Rules.

Enabling Performance and Power Monitoring Unit Monitors

To enable the unit monitors for Performance and Power Monitoring Views:

1. Launch OpsMgr console and click Authoring.

2. Click Management Pack Objects → Monitors, and then search for Performance in the Look for: 
field.

3. Click Dell Windows Server → Performance.

4. Right-click the unit monitor you want to enable.

5. Select Overrides → Override the Monitor and select an option based on your requirement.

For example, to override the unit monitors for all objects of class: Dell Windows Server, select For all 
objects of class: Dell Windows Server
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The Override Properties screen is displayed.

6. Select Enabled and set the Override Value to True.

7. Under Management Pack, either select a management pack created from the Select destination 
management pack: drop-down menu or create a management pack by clicking New...

To create a management pack:

a. Click New...

The Create a Management Pack screen is displayed.

b. Provide a name for the management pack in the Name field and click Next.

For information on creating a management pack, see the OpsMgr documentation at 
technet.microsoft.com.

c. Click Create.

The management pack you created is selected in the Select destination management pack: 
drop-down menu.

8. Click Apply.

State Views

This view is available for viewing the health of all Dell servers and Rack Workstations. In the OpsMgr 

console, click Monitoring → Dell → State Views, the status of each Dell server and Rack Workstation 
managed by the OpsMgr on the network is displayed.

You can view the status for the following:

• Servers and Rack Workstations (Agent-based)

• Dell Rack Workstation State Views

– Managed Rack Workstation (Agent-based)

• Dell Server State Views

– FM Servers

– Sled Servers (Agent-based)

The health of a component is derived by reviewing the unresolved alerts associated with the component.

Unit Monitors

Unit monitors assess the various conditions that can occur in monitored objects. The result of this 
assessment determines the health state of a target.

The unit monitors are:

• Event Monitor — triggered by the event that the Dell instrumentation logs in the Windows event log, 
indicating the health of the corresponding object.

• Periodic Monitor — triggered by a periodic poll configured as Interval Seconds.

The following tables illustrates the various Dell monitors and the applicable parameters.

Dell Unit Monitors — Scalable Edition

Monitors to assess various conditions that can occur in Agent-based — Scalable Edition monitored 
objects.
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Table 7. Dell Unit Monitors — Scalable Edition

Object Unit Monitor

Memory

Dell Server Memory Status Event and Periodic

Dell Server Memory Redundancy Status Event and Periodic

OpenManage Software Services

Dell Server Management (DSM) Connection 
Service Availability Status

Periodic

DSM Data Manager Availability Status Periodic

DSM Event Manager Availability Status Periodic

DSM Shared Service Availability Status Periodic

DSM Storage Service Availability Status Periodic

Windows Management Instrumentation 
(WMI) Service Availability Status

Periodic

Power Supplies 

Dell Server Power Supplies Status Event and Periodic

Processors

Dell Server Processors Status Event and Periodic

Sensors

Dell Server Battery Status Event and Periodic

Dell Server Current Status Event and Periodic

Dell Server Fans Status Event and Periodic

Dell Server Intrusion Sensor Status Event and Periodic

Dell Server Temperature Sensor Status Event and Periodic

Dell Server Voltage Sensor Status Event and Periodic

Storage Controller

Storage Controller Status Event and Periodic
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Object Unit Monitor

Network Interfaces Group (Basic)

Global Network Interfaces (Basic) 
Connection Status

Event and Periodic

Network Interfaces Group (Enriched)

Global Enriched Network Interfaces Status Event and Periodic

Global Network Interfaces (Basic) 
Connection Status

Event and Periodic

iDRAC

Dell Server iDRAC Network Interface Monitor Periodic

Dell OM Performance

Ambient Temperature Average Threshold 
AlertMonitor

Periodic

Amperage Average Threshold AlertMonitor Periodic

EnergyConsumption Average Threshold 
AlertMonitor

Periodic

PowerConsumption (BTU/hr) Average 
Threshold

Periodic

PowerConsumption (Watts) Average 
Threshold AlertMonitor

Periodic

Dell OM Server Unsupported Unit Monitor Periodic

Dell Unit Monitors — Detailed Edition

Table 8. Dell Unit Monitors — Detailed Edition

Object Unit Monitor

Memory Unit Instance

Detailed Memory Event Monitor Event and Periodic

Detailed Memory Unit Monitor Event and Periodic

Power Supplies Unit Instance

Detailed Power Supply Event and Periodic

Processor Unit Instance

22



Object Unit Monitor

Detailed Processor Event and Periodic

Storage Controller Connector Instance

Controller Connector Event Monitor Event and Periodic

Controller Connector Unit Monitor Event and Periodic

Storage Controller EMM Instance

Enclosure EMM Event Monitor Event and Periodic

Enclosure EMM Unit Monitor Event and Periodic

Storage Controller Enclosure Instance

Controller Enclosure Event Monitor Event and Periodic

Controller Enclosure Unit Monitor Event and Periodic

Storage Controller Physical Disk Instance

Controller Physical Disk Event Monitor Event and Periodic

Controller Physical Disk Unit Monitor Event and Periodic

Enclosure Physical Disk Event Monitor Event and Periodic

Enclosure Physical Disk Unit Monitor Event and Periodic

Storage Controller Power Supply Instance

Enclosure Power Supply Event Monitor Event and Periodic

Enclosure Power Supply Unit Monitor Event and Periodic

Storage Controller Sensors

Controller Sensor Event Unit Monitor Event and Periodic

Controller Sensor Unit Monitor Event and Periodic

Storage Controller Virtual Disk Group Event and Periodic

Storage Controller Virtual Disk Instance Event and Periodic

Controller Virtual Disk Event Monitor Event
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Object Unit Monitor

Controller Virtual Disk Unit Monitor Periodic

Storage Enclosure Physical Disk Group Event and Periodic

Storage Enclosure Sensors

Enclosure Fan Event Unit Monitor Event and Periodic

Enclosure Fan Unit Monitor Event and Periodic

Enclosure Temperature Event Monitor Event and Periodic

Enclosure Temperature Unit Monitor Event and Periodic

Physical Network Interface Instance (Basic)

Connection Status Event and Periodic

Physical Network Interface Instance (Enriched)

Administrative Status Event and Periodic

Connection Status Event and Periodic

Link Status Event and Periodic

Operational Status Event and Periodic

Teamed Network Interface Instance (Basic)

Teamed Network Interface (Basic) Availability 
Status

Event and Periodic

Teamed Network Interface Instance (Enriched)

Teamed Network Interface Instance 
(Enriched) Administrative Status

Event and Periodic

Teamed Network Interface Instance 
(Enriched) Connection Status

Event and Periodic

Teamed Network Interface Instance 
(Enriched) Link Status

Event and Periodic

Teamed Network Interface Instance 
(Enriched) Operational Status

Event and Periodic

Teamed Network Interface Instance 
(Enriched) Redundancy Status

Event and Periodic
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Object Unit Monitor

Fan Sensor

Fan Sensor Unit Monitor Periodic

Current Sensor

Current Sensor Unit Monitor Periodic

Voltage Sensor

Voltage Sensor Unit Monitor Periodic

Battery Sensor

Battery Sensor Unit Monitor Periodic

Chassis Intrusion Sensor

Chassis Intrusion Sensor Unit Monitor Periodic

Rules

The following section lists the rules specific to the Dell Agent-based monitoring feature.

Dell Systems Event Processing Rules

The Dell Server Management Pack Suite processes rules from Server Administrator and 
Server Administrator Storage Management events.

Server Administrator

All informational, warning, and critical events for Server Administrator have a corresponding event 
processing rule.

Each of these rules are processed based on the following criteria:

• Source Name = "Server Administrator"

• Event ID = Actual event ID of the Server Administrator instrumentation event

• Data Provider = Windows system event log

Storage Management

All informational, warning, and critical events for the Server Administrator Storage Management Service 
have a corresponding event processing rule.

Each of these rules are processed based on the following criteria:

• Source Name = "Server Administrator"

• Event ID = Actual event ID of the Server Administrator Storage Management Service event

• Data Provider = Windows system event log
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Performance Collection Rules

In the OpsMgr console, click Monitoring → Dell → Performance and Power Monitoring Views to view 
the performance information that is collected from Dell servers. By default this feature is disabled, to 
enable the feature, see Enabling Performance Collection Rules.

The performance collection rules collect information on the following parameters:

• Agent-based Disk Performance (%)

• Ambient Temperature (Centigrade)

• Amperage (Amps)

• Energy Consumption (kWh)

• Peak Amperage (Amps)

• Peak Power (Watts)

• Physical Network Interface

• Power Consumption (BTU/hr)

• Power Consumption (Watts)

• Teamed Network Interface

NOTE: 

• When the Detailed edition of the Agent-based monitoring feature is imported, the disabled 
Performance (excluding Network Performance) and Agent-based Disk Performance (%) 
collection rules are enabled by default.

• Agent-based Disk Performance (%) — This view displays the Remaining Rated Write Endurance 
of Solid-State Drives (SSDs) of a Dell server (Agent-based). Search for the object SSD to view the 
data.

NOTE: Network Statistics are defined in Detailed edition of Agent-based monitoring feature only 
and are disabled by default. To enable the feature, see Enabling Performance Collection Rules.

Enabling Performance Collection Rules

To enable this feature:

1. Launch OpsMgr console and click Authoring.

2. Click Rules and search for Enriched in the Look for: field.

3. Right-click the rule you want to enable.

For example, to collect information on Network Interface of all Dell systems, perform step 4 to step 5 
for the rules listed below:

• Total Transmitted Packets

• Received Bytes

• Total Received Packets

• Transmitted Bytes

4. Select Overrides → Override the Rule → For all objects of class.

5. Select Enabled and set the Override Value to True..

6. Under Management Pack, either select a management pack created from the Select destination 
management pack: drop-down menu or create a new management pack by clicking New...

To create a new management pack:

a. Click New...
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The Create a Management Pack screen is displayed.

b. Provide a name for the management pack in the Name field and click Next.

For information on creating a management pack, see the OpsMgr documentation at 
technet.microsoft.com.

c. Click Create.

The management pack you created is selected in the Select destination management pack: 
drop-down menu.

7. Click Apply.

Tasks

Tasks are available in the Tasks pane of the OpsMgr console. When you select a device or a component, 
the relevant tasks appear in the Tasks pane.

Task Summary

Performing Dell Tasks

Following table provides a summary of the Dell tasks that you can perform on the OpsMgr:

Table 9. Dell Tasks

Task Description

Check Power Status Check the overall power status of the system.

Clear ESM Logs Backs up the content of the Embedded System 
Management (ESM) log and clears the ESM log file 
for a selected system.

Force Power Off Turns off the system power without shutting down 
the operating system.

Get Warranty Information Retrieves the warranty information for the selected 
system.

NOTE: An active internet connection is 
required to retrieve the warranty information.

Launch Dell License Manager on X64 bit 
Management Server

Launches the Dell license manager on 
management systems running 64-bit operating 
system.

Launch Dell OpenManage Power Center Launches the Dell OpenManage Power Center 
console on the Management Server.

Launch Dell Remote Access Console Launches the DRAC console for the Agent-based 
discovered DRAC.

Launch OpenManage Server Administrator Launches the OpenManage Server Administrator.
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Task Description

Launch Remote Desktop Launches the remote desktop for the selected 
system.

Power Cycle Turns off the power, and after a delay, turns it on 
again.

Power Off Gracefully Shuts down the operating system first, then turns 
off the system power.

Power On Turns on the system power. This option is available 
only if the system is off.

Power Reset Turns off the system power and turns it on again.

Turn LED Identification On Turns on the identify LED for 255 seconds on the 
selected system.

Turn LED Identification Off Turns off the identify LED on the selected system.

Dell Windows Server Tasks

Check Power Status

You can check the power status and allow power control tasks through the IPMI shell.

NOTE: To enable Advanced Power Control, install Baseboard Management Controller Management 
Utility (BMU) in the default path. If BMU is not installed in the default path, create a new console 
task. For more information on creating a new console task, see Creating Advanced Power Control 
And LED Identification Tasks.

To check the power status of a system:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alert Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Check Power Status.

Clear ESM Logs

The Server Administrator Embedded Server Management (ESM) log, also referred to as the hardware log, 
maintains a list of all system events generated by the hardware, such as error-correcting code (ECC), 
system reset and boot, and probe threshold changes. You can refer to this log when hardware errors 
appear or when the system is not functioning properly.

To run the Clear ESM Logs task:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell system in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Clear ESM Logs.

The Run Tasks window is displayed.

4. Click Run to clear the ESM logs of the device that you selected.
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When you run the Clear ESM Logs task, on the task execution screen only the result of the task initiating 
is displayed. For example, the task execution screen may show a success result even if the ESM logs are 
not cleared. This means that the Clear ESM Logs task initiation was successful.

Force Power Off

The Force Power Off task allows you to turn off the Dell server without shutting down the operating 
system.

NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in 
the default path, create a new console task. For more information on creating a new console task, 
see Creating Advanced Power Control And LED Identification Tasks.

To power off the system:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alert Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Force Power Off.

Get Warranty Information

The Get Warranty Information task allows you to view the warranty status of the selected Dell server.

NOTE: An active Internet connection is required to retrieve the warranty information.

To get warranty information:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Get Warranty Information.

Launch Dell License Manager on X64 Bit Management Server

The Launch Dell License Manager on X64 bit Management Server task allows you to launch the Dell 
License Manager on management systems running 64-bit operating system. Dell License Manager is a 
one-to-many license deployment and reporting tool for Dell iDRAC licenses.

NOTE: If the Dell License Manager has not been installed in the default path, create a new task to 
launch Dell License Manager. For more information, see Creating A Launch License Manager Task.

To launch Dell License Manager:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Launch Dell License Manager on X64 bit 
Management Server.

Launch Dell OpenManage Power Center

NOTE: Launching OpenManage Power Center is possible only if Windows or Linux operating system 
and OpenManage Server Administrator are installed on the managed node.
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The Launch Dell OpenManage Power Center task allows you to launch the OpenManage Power Center 
console.

To launch Dell OpenManage Power Center:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Server Tasks → Launch Dell OpenManage Power Center.

Launch Dell Remote Access Console

To launch Dell Remote Access console:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Launch Dell Remote Access Console.

Launch Dell OpenManage Server Administrator 

To launch Server Administrator:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Launch Server Administrator.

NOTE: The Dell Server Management Pack Suite tasks launch the remote console in the Internet 
Explorer.

Launch Remote Desktop

To launch remote desktop:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Launch Remote Desktop.

NOTE: Launching remote desktop is possible only if the remote desktop is enabled manually in 
the managed node.

Power Cycle

The Power Cycle task allows you to turn off the Dell server and turn it on again after a delay.

NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in 
the default path, create a new console task. For more information on creating a new console task, 
see Creating Advanced Power Control And LED Identification Tasks.

To run the power cycle:

1. In the OpsMgr console, navigate to a Diagram Views, State Views, or Alert Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

30



3. In the Tasks pane, select Dell Windows Server Tasks → Power Cycle.

Power Off Gracefully

The Power Off Gracefully task allows you to shut down the operating system and power off the Dell 
server.

NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in 
the default path, create a new console task. For more information on creating a new console task, 
see Creating Advanced Power Control And LED Identification Tasks.

To power off the system gracefully:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alert Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Power Off Gracefully.

Power On 

The Power On task allows you to power on the server. This option is available even if the system power is 
off.

NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in 
the default path, create a new console task. For more information on creating a new console task, 
see Creating Advanced Power Control And LED Identification Tasks.

To power on a system:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Power On.

Power Reset

The Power Reset task allows you to power off and then power on the Dell server.

NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in 
the default path, create a new console task. For more information on creating a new console task, 
see Creating Advanced Power Control And LED Identification Tasks.

To reset the power of the system:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Power Reset.

Turn LED Identification On

The Turn LED Identification On task allows you to turn on the LED identification on the selected Dell 
server.

NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in 
the default path, create a new console task. For more information on creating a new console task, 
see Creating Advanced Power Control And LED Identification Tasks.
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To turn on LED identification:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Turn LED Identification On.

Turn LED Identification Off

The Turn LED Identification Off task allows you to to turn off the LED identification on the selected Dell 
server.

NOTE: To enable Advanced Power Control, install BMU in the default path. If BMU is not installed in 
the default path, create a new console task. For more information on creating a new console task, 
see Creating Advanced Power Control And LED Identification Tasks.

To turn off LED identification:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Turn LED Identification Off.

Reports

The reporting feature allows you to create reports for Dell OpenManage Windows Event Log, Dell server 
BIOS, firmware, and RAID configuration.

NOTE: 

• Agent-based monitoring feature supports Reports only for object-level.

• Dell server BIOS, firmware, and RAID configuration reports are available only in the Detailed 
Edition of Server (Agent-based) management pack.

Accessing Reports

To access reports:

1. Click Reporting on the OpsMgr console.

2. Click on Dell Windows Server (Scalable Edition) for the Windows Event Log and click on Dell 
Windows Server (Detail Edition) for BIOS, firmware and driver versions, and RAID reports.

You can also access Reporting from the Diagram View or State View by clicking on the server instance. 
The option for Dell Reports is located in the Tasks pane under the Dell System instance reports along 
with the default Microsoft reports.

Generating OpenManage Windows Event Log Report

To create a report for OpenManage Windows Event Logs:

1. On the OpsMgr console, click Reporting. 

2. Click Dell Windows Server (Scalable Edition).

3. Click OpenManage Windows Event Log then click Open in the Tasks pane.

4. Select a time period for which you want the report generated.
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5. Click Add Object.

6. Search for objects of class Dell Windows Server and click Add.

You will find the object in the Selected object pane.

7. Choose the Severity of the events whose report you want to generate.

8. Click Run. 

The OpenManage Windows Event Log report is generated.

Generating BIOS Configuration Report

To create a report for the BIOS configuration:

1. On the OpsMgr console, click Reporting.

2. Click Dell Windows Server (Detail Edition).

3. Click BIOS Configuration, then click Open in the Tasks pane.

4. Select a time period for which you want the report generated.

5. Click Add Object.

6. Search for objects of class Dell Windows Server and click Add.

You will find the object in the Selected object pane.

7. Choose the required Properties.

8. Click Run.

The BIOS Configuration report is generated.

Generating Firmware and Driver Versions Report

To create a report for firmware and driver versions:

1. On the OpsMgr console, click Reporting.

2. Click Dell Windows Server (Detail Edition).

3. Click Firmware and Driver Versions, then click Open on the Task pane.

4. Select a time period for which you want the report generated.

5. Click Add Object.

6. Search for objects of class Dell Windows Server and click Add.

You will find the object in the Selected object pane.

7. Click Run.

The Firmware and Driver Versions report is generated.

Generating RAID Configuration Report

To create a report for RAID configuration:

1. On the OpsMgr console, click Reporting. 

2. Click Dell Windows Server (Detailed Edition).

3. Click RAID Configuration, then click Open on the Task pane.

4. Select a time period for which you want the report generated.

5. Click Add Object.

6. Search for objects of class Dell Windows Server and click Add.

You will find the object in the Selected object pane.
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7. Choose the required Properties.

8. Click Run.

The RAID Configuration report is generated.
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4
Agent-free Monitoring Feature
Agent-free monitoring feature provides detailed inventory and monitoring of 12th generation and 13th 
generation of Dell PowerEdge servers, Dell PowerVault systems, supported Dell Precision Racks, Dell 
branded OEM servers, and Dell OEM Ready servers through the server's iDRAC by using WS-MAN and 
SNMP. 

Dell Server Management Pack Suite installer automatically imports the Agent-free monitoring feature if 
the prerequisites are met.

 

Comparison of Scalable and Detailed Edition Features

The following table helps you understand the environment in which you can use Scalable and Detailed 
Edition features.

Table 10. Scalable Management Pack Versus Detailed Management Pack

Features Scalable Edition Detailed Edition

Agent-free Monitoring • Inventory up to individual 
components.

• Health monitoring at server, 
Rack Workstation and 
component group level.

• Inventory and health 
monitoring of individual 
components.

• View metrics for power, 
temperature, and network 
interface cards, processor, 
memory, CUPS (Compute 
Usage per Second), PCIe SSD 
wear percentage and IO 
performance metrics.

Discovery and grouping

The Dell Server Management Pack Suite enables you to discover and classify Dell servers.

The following table lists the details of the hardware discovery and grouping by the Dell Agent-free 
monitoring feature.

Table 11. Dell Hardware discovery and grouping

Group Diagram View Hardware Type

Dell Servers Dell Monolithic Servers

Dell Modular Servers

Dell PowerEdge systems.

Dell PowerVault storage servers.

35



Group Diagram View Hardware Type

Dell Sled Group

Dell Rack Workstation Rack Workstation Diagram Dell Precision Racks

Discovering a Dell Server using Agent-free Monitoring Feature

NOTE: Install Microsoft SMASH Library (MPB) file before discovering a Dell Server using Agent-free 
monitoring feature. For information on installing the Microsoft SMASH Library (MPB) file, see the 
"Installing the WS-Management and SMASH Device Template" section of the Dell Server 
Management Pack Suite Version 6.2 for Microsoft System Center Operations Manager Installation 
Guide at dell.com/OMConnectionsEnterpriseSystemsManagement .

To discover a Dell server using the Agent-free monitoring feature:

1. Log on to OpsMgr 2012 as an administrator for the OpsMgr Management group.

2. On the OpsMgr console, click Authoring.

3. At the bottom of the navigation pane, click Add Monitoring Wizard.

The Add Monitoring Wizard screen is displayed.

4. On the Select Monitoring Type screen, select WS-Management and SMASH Device Discovery and 
click Next.

5. On the General Properties screen, in the Name field provide a name for the wizard.

6. Under Management pack, click New.

The Create a Management Pack screen is displayed.

7. Provide a name for the management pack in the Name field and click Next.

For information on creating a management pack, see the OpsMgr documentation at 
technet.microsoft.com.

8. Click Create.

The management pack you created is selected in the Management pack drop-down box.

9. Click Next.

10. On the Specify the target drop-down menu, select a resource pool for monitoring Agent-free 
devices and click Next.

11. On the Specify the account to be used to run discovery screen, click New and create a Simple 
Authentication Run As Account.

For more information on creating a Simple Authentication type Run As Account, see Creating a 
Simple Authentication Run As Account.

NOTE: If you are using AD domain credentials for iDRAC, then, enter the credentials in the 
following format: username@domainname.com

12. Select the Run As Account you created from the Run As Account drop-down menu and click Next.

13. Click Add.

14. On the Add Devices screen specify the iDRAC IP address of the systems you want to monitor using 
the Agent-free monitoring feature. You can specify the iDRAC IP address of the systems by:

• Scanning the IP Subnet that you provided.

• Scanning a specified IP Range.

• Importing a text file containing the list of iDRAC IP addresses.

15. Click Advanced Options, select the Skip CA Check and Skip CN Check option and click OK.
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16. Click Scan for Devices to search Dell servers on the network.

The IP addresses are listed under Available Devices.

17. Click Add to add the list of IP addresses you want to monitor and click OK.

18. On the Specify the devices you want to monitor screen, click Create.

19. Click Close.

The scanned Dell servers initially appear in Monitoring → WS-Management and SMASH Monitoring 
→ WS-Management Device State screen. After the OpsMgr completes the automatically triggered 

SMASH discovery, the Dell servers appear in Monitoring → WS-Management and SMASH 
Monitoring → SMASH Device State screen.

20. Enable the Agent-free monitoring feature through Feature Management Dashboard.

Automatic trap destination configuration

To receive SNMP traps, the Agent-free Monitoring Feature automatically configures the IP address of the 
management server as a trap destination on the iDRAC during the discovery of Dell servers. Make sure 
that you have selected the State option to enable the alert destination on iDRAC.

Discoveries by the Dell Agent-free Monitoring Feature

Table 12. Dell Agent-free Monitoring Feature Discoveries

Discovery Object Description

Dell Server Discovery Classifies the Dell servers and populates the key 
attributes and components.

Dell Device Helper Discovery Discovers the DellDeviceHelper as an object.

Dell Host NIC Correlation Discovery Correlates the Host NIC interfaces with Physical 
interfaces.

NOTE: Teamed network interfaces will show 
only one of the NICs in the team.

Monitoring

After you install the Dell Server Management Pack Suite, you can use the Monitoring pane of the OpsMgr 
to select views that provide health information of the discovered Dell servers. The Agent-free monitoring 
feature discovers and monitors the health of the Dell servers.

The Severity Level Indicators indicates the health of the Dell servers on the network. It includes 
monitoring health of Dell modular, monolithic systems and supported Dell Precision Racks and their 
components at regular intervals.

As the system components monitored through Agent-based monitoring feature and Agent-free 
monitoring feature are not exactly the same, it is possible that the overall server health that is shown 
through Agent-based (OMSA) and Agent-free (iDRAC) methods could be different. Drill-down to the 
specific component status when you observe such discrepancies to resolve specific problem conditions 
in the system component to bring the overall health of the server to OK state.
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Monitored hardware components

The following table provides information on the monitored hardware components supported in Scalable 
and Detailed feature.

Table 13. Monitored hardware components — Scalable and Detailed feature

Hardware components Scalable Detailed

BIOS No No

Battery Sensor No Yes

Battery Sensor Group No Yes

Current Sensor No Yes

Current Sensor Group No Yes

Fan Sensor No Yes

Fan Sensor Group No Yes

Host NIC No Yes

iDRAC Network Interface No Yes

iDRAC No No

Intrusion Sensor No Yes

Intrusion Sensor Group No Yes

License Group Yes No

License No Yes

Memory No No

Memory Unit Instance No No

Physical Network Interface No Yes

Processors Yes No

Processor Group Yes No

Power Supply No Yes

PCIeSSD Extender No Yes
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Hardware components Scalable Detailed

PCIeSSD Backplane No Yes

PCIeSSD Physical Disk No Yes

Server Sensors No Yes

Storage Controller Connector No Yes

Storage Controller No Yes

Storage Controller Sensor No Yes

Storage Controller Battery Group No Yes

Storage Controller Battery No Yes

Storage Virtual Disk Group No Yes

Storage Virtual Disk No Yes

Storage Controller Physical Disk 
Group

No Yes

Storage Controller Physical Disk No Yes

Storage Controller Enclosure No Yes

Storage Controller Enclosure EMM No Yes

Storage Controller Enclosure Fan 
Sensor

No Yes

Storage Controller Enclosure Fan 
Sensor Group

No Yes

Storage Controller Enclosure Power 
Supply

No Yes

Storage Controller Enclosure Power 
Supply Group

No Yes

Storage Controller Enclosure 
Temperature Sensor Group

No Yes

Storage Controller Enclosure 
Temperature Sensor

No Yes

Storage Controller Enclosure Sensor No Yes
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Hardware components Scalable Detailed

SD Card Group No Yes

SD Card No Yes

Server Host NIC Group No Yes

Server Host NIC No No

Temperature Sensor No Yes

Temperature Sensor Group No Yes

Voltage Sensor No Yes

Voltage Sensor Group No Yes

Views

Dell Server Management Pack Suite provides the following types of views for Monitoring, under the Dell 
folder on the OpsMgr console:

• Alerts Views

• Diagram Views

• State Views

• Performance and Power Monitoring Views

Alerts Views

This view is available for managing hardware and storage events from Dell servers and Rack Workstations. 
The following alerts and traps are displayed by the Agent-free monitoring feature:

• Link up or Link down alerts for events received from Broadcom and Intel network interface cards for 
Dell PowerEdge, PowerVault systems and Dell Precision Racks.

• Platform Event Traps (PET) for Dell servers and Rack Workstations.

Viewing Alerts on the OpsMgr Console

To view Agent-free monitoring feature alerts on the OpsMgr console:

1. Launch the OpsMgr console and click Monitoring.

2. Click Dell → Alerts Views.

The following Alerts Views are displayed:

• Server and Rack Workstation Alerts — SNMP traps for 12th and 13th generation of Dell 
PowerEdge servers, PowerVault storage servers and Dell Precision Racks with iDRAC7 or iDRAC8 
are displayed.

• Dell Rack Workstation Alert Views

– Rack Workstation Alerts

3. Select Server and Rack Workstation Alerts or Rack Workstation Alerts.
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On the right pane of each of the individual Alerts Views, alerts that meet the criteria you specify, 
such as alert severity, resolution state, or alerts that are assigned to you is displayed.

4. Select an alert to view the details in the Alert Details pane.

Diagram Views

The Diagram Views offers a hierarchical and graphical representation of all Dell servers and supported 
Rack Workstations on the network.

Viewing Diagram Views On The OpsMgr Console

To view the Server In-band diagram views on the OpsMgr console:

1. Launch the OpsMgr console and click Monitoring → Dell → Diagram Views.

2. Navigate to the Diagram Views folder for the following views:

• Complete Diagram View

• Modular Systems Diagram

• Monolithic Servers Diagram

3. Select any of the Diagram Views.

On the right pane the hierarchical and graphical representation of the selected Dell device is 
displayed.

4. Select a component in the diagram to view its details in the Detail View pane.

Rack Workstation Diagram

The Dell Rack Workstation Diagram Views offers a graphical representation of all supported Rack 
Workstations and allows you to expand and verify the status of individual devices and their components 
in the diagram. Select a Rack Workstation in the diagram to view its details in the Detail View pane.

Modular and Monolithic Systems

The Modular Systems Diagram and Monolithic Servers Diagram views offer the following details:

• Physical network interfaces

• Memory

• Power supply

• Sensors

• Processors

• Storage components

• BIOS (inventory only)

• iDRAC NIC

• Host NIC

• SD Card

• License

Modular Systems Diagram

The Dell Modular Systems Diagram View offers a graphical representation of all Dell modular systems 
and allows you to expand and verify the status of individual devices and their components in the diagram.
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Monolithic Servers Diagram

The Dell Monolithic Systems Diagram View offers a graphical representation of all Dell monolithic 
systems and allows you to expand and verify the status of individual devices and their components in the 
diagram.

Sled Servers Diagram

The Dell Sled Servers Diagram View offers a graphical representation of all Dell Sled servers and allows 
you to expand and verify the status of individual devices and their components in the diagram. Select a 
Sled server in the diagram to view its details in the Detail View pane.

Dell Server Instance Diagram

Select a Dell server, from the Dell Modular System or Dell Monolithic System diagram views, to view the 
diagram specific to that particular system.

System-specific diagrams illustrate and indicate the status of the following components:

• Physical interfaces

• Memory

• Power supply

• Sensors

• Processors

• Storage components

• Host NIC

• License

• PCIe/ SSD

• SD Card

• BIOS (inventory only)

• iDRAC NIC

Storage Controller Component Hierarchy

Expand the Storage component in any Dell system instance diagram view, to view the status and health 
of components such as physical disks, connectors, virtual disks, controllers, sensors, and enclosures.

Performance and Power Monitoring Views

To view the performance and power monitoring on the OpsMgr console:

1. Launch the OpsMgr console and click Monitoring.

2. In the Monitoring pane, click Dell → Performance and Power Monitoring for the following views:

• Agent-free Disk Performance (%)

• Dell Performance View

• System Board Usage

– CPU Usage (%)

– IO Usage (%)

– Memory Usage (%)

– Overall System Usage (%)
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NOTE: All performance metric rules are disabled by default for Agent-free monitoring feature.

3. Select the counters from the individual performance views and select the time range for which the 
values are required.

The data collected is represented in a graphical format for each system.

A unit monitor, monitors the performance counter over two successive cycles to check if it exceeds a 
threshold value. When the threshold value is exceeded, the server changes state and generates an alert. 
This unit monitor is disabled by default. You can override (enable) the threshold values from the 
Authoring pane of the OpsMgr console. Unit monitors are available under Dell Server objects for Agent-
free monitoring feature. To enable the threshold values of unit monitors, see Enabling Performance and 
Power Monitoring Unit Monitors.

For more information on performance information collection, see Performance Collection Rules.

Enabling Performance and Power Monitoring Unit Monitors

To enable the unit monitors for Performance and Power Monitoring Views:

1. Launch OpsMgr console and click Authoring.

2. Click Management Pack Objects → Monitors, and then search for Performance in the Look for: 
field.

3. Click Dell Server → Performance.

4. Right-click the unit monitor you want to enable.

5. Select Overrides → Override the Monitor and select an option based on your requirement.

For example, to override the unit monitors for all objects of class: Dell Server, select For all objects of 
class: Dell Server

The Override Properties screen is displayed.

6. Select Enabled and set the Override Value to True.

7. Under Management Pack, either select a management pack created from the Select destination 
management pack: drop-down menu or create a management pack by clicking New...

To create a management pack:

a. Click New...

The Create a Management Pack screen is displayed.

b. Provide a name for the management pack in the Name field and click Next.

For information on creating a management pack, see the OpsMgr documentation at 
technet.microsoft.com.

c. Click Create.

The management pack you created is selected in the Select destination management pack: 
drop-down menu.

8. Click Apply.

State Views

This view is available for viewing the health of all Dell servers and supported Rack Workstations. In the 

OpsMgr console, click Monitoring → Dell → State Views, the status of each Dell server and Rack 
Workstation managed by OpsMgr on the network is displayed.
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You can view the status for the following groups:

• Servers and Rack Workstations (Agent-free)

• Dell Rack Workstation State Views

– Managed Rack Workstation (Agent-free)

• Dell Server State Views

– FM Servers

– Sled Servers (Agent-free)

– Unmanaged Servers (Agent-free)

The health of a component is derived by reviewing the unresolved alerts associated with the component.
Severity Level Indicators explains the various state components that the Dell Server Management Pack 
Suite uses with their corresponding severity levels.

Dell Unit Monitors for Agent-free Monitoring Feature

Monitors to assess various conditions that can occur in Agent-free monitored objects.

Table 14. Dell Unit Monitors For Agent-free Monitoring

Object Unit Monitor

Dell Server

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic

Dell Server Power Supply

Dell Server Power Supply Unit Periodic

Dell Server Processor Group

Dell Server Processor Group Periodic

Dell Storage Controller

Dell Server Storage Controller Periodic

Dell Server Controller Battery

Dell Server Controller Battery Unit Periodic

Dell Battery Sensor

Dell Server Battery Sensor Health Periodic

Dell Battery Sensor Group
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Object Unit Monitor

Dell Server Battery Group Sensor Health Periodic

Dell Current Sensor

Dell Server Current Sensor Health Periodic

Dell Fan Sensor

Dell Server Fan Sensor Health Periodic

Dell Fan Sensor Group

Dell Server Fan Group Sensor Health Periodic

Dell Intrusion Sensor

Dell Server Intrusion Sensor Health Periodic

Dell Modular Blade Server With Operating System

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic

Dell Modular Blade Server Without Operating System

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic

Dell Monolithic Server With Operating System

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic

Dell Monolithic Server Without Operating System

Dell Server Run As Account Association Periodic

Dell Server Unit Monitor Periodic

Dell Network Interfaces Group

Dell Server Network Interface Group Periodic

Dell iDRAC Network Interface
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Object Unit Monitor

Dell Server iDRAC Network Interface Unit Periodic

Dell Server Host NIC

Dell Server Host NIC Periodic

Dell Server License

Dell Server License Periodic

Dell Server License Group

Dell Server License Group Periodic

Physical Network Interface

Dell Server Network Interface Unit Periodic

PCIe SSD Backplane

Dell Server PCIeSSD Backplane Periodic

PCIe SSD Extender

Dell Server PCIeSSD Extender Periodic

PCIe SSD Physical Disk

Dell Server PCIeSSD Physical Disk Predictive 
Failure Disk

Periodic

Dell Server PCIeSSD Physical Disk Primary 
Status

Periodic

Dell Server SD Card

Dell Server SD Card Periodic

Dell Server SD Card Group Periodic

Dell Server Connector Enclosure

Dell Server Connector Enclosure Periodic

Dell Storage Controller Enclosure EMM 

Dell Server Enclosure EMM Periodic
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Object Unit Monitor

Dell Storage Controller Enclosure Fan Sensor

Dell Server Enclosure Fan Sensor Periodic

Dell Storage Controller Enclosure Physical Disk 

Dell Server Enclosure External Physical Disk Periodic

Dell Storage Controller Enclosure Power Supply 

Dell Server Enclosure Power Supply Periodic

Dell Storage Controller Enclosure Temperature Sensor

Dell Server Temperature Sensor Periodic

Dell Storage Controller Internal Physical Disk

Dell Server Internal Physical Disk Unit Periodic

Dell Storage Controller Physical Disk

Dell Server Controller Direct Attached 
Physical Disk

Periodic

Dell Storage Group

Dell Server Storage Periodic

Dell Storage Virtual Disk

Dell Server Controller Virtual Disk Unit Periodic

Dell Temperature Sensor

Dell Server Temperature Sensor Health Periodic

Dell Temperature Sensor Group

Dell Server Temperature Sensor Group 
Health

Periodic

Dell Voltage Sensor

Dell Server Voltage Sensor Health Periodic

Dell Voltage Sensor Group
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Object Unit Monitor

Dell Server Sensors Voltage Group Periodic

Rules

The following section lists the rules specific to the Dell Agent-free monitoring feature.

Dell Systems Event Processing Rules

The Dell Server Management Pack Suite processes rules from Dell servers.

Dell Servers 

All informational, warning, and critical SNMP traps for Dell servers discovered using Dell Agent-free 
monitoring feature, have a corresponding SNMP trap rule.

Each of these rules are processed based on the following criteria:

• Source Name = "Dell Server ip"

• OID = Actual trap ID of the trap event

• Data Provider = SNMP trap event provider

Tasks

Tasks are available in the Tasks pane of the OpsMgr console. When you select a device or a component, 
the relevant tasks appear in the Tasks pane.

Task Summary

Performing Dell Tasks using Dell Agent-free Monitoring Feature

Following table provides a summary of the Dell tasks that you can perform using Dell Server Agent-free 
monitoring feature:

Table 15. Dell Tasks using Dell Agent-free Monitoring Feature

Task Description

Get Warranty Information Retrieves the warranty information for the selected 
system.

NOTE: An active Internet connection is 
required to retrieve the warranty information.

Launch Dell License Manager Launches the Dell License Manager on the 
management system.
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Task Description

NOTE: Launching Dell License Manager is 
possible only if a Windows or Linux operating 
system is installed and Dell License Manager is 
also installed.

Launch Dell OpenManage Power Center Launches the Dell OpenManage Power Center 
console for the selected system.

NOTE: Launching OpenManage Power Center 
is possible only if Windows or Linux operating 
system, OpenManage Server Administrator, 
and Dell OpenManage Power Center are 
installed on the managed node.

Launch Dell OpenManage Server Administrator 
(Monolithic Server)

Launches the Dell OpenManage Server 
Administrator console for the selected system.

NOTE: Launching Dell OpenManage Server 
Administrator is possible only if a Windows or 
Linux operating system and Dell OpenManage 
Server Administrator are installed on the 
managed node.

Launch Dell Remote Access Console Launches the iDRAC console for the agent-free 
discovered Dell servers and Rack Workstations.

Launch Remote Desktop (Monolithic Server) Launches the remote desktop for the selected 
system.

NOTE: Launching remote desktop is possible 
only if Windows operating system is installed 
and remote desktop is manually enabled in 
the managed node.

Dell Server Tasks

Get Warranty Information

You can use this task to see the warranty status of the selected server.

To get warranty information:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Server Tasks → Get Warranty Information.

Launch Dell License Manager

The Launch Dell License Manager task allows you to launch the Dell License Manager on management 
systems. Dell License Manager is a one-to-many license deployment and reporting tool for Dell iDRAC 
licenses.
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NOTE: If the Dell License Manager has not been installed in the default path create a new task to 
launch Dell License Manager. For more information, see Creating A Launch License Manager Task.

To launch Dell License Manager:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Task pane, select Dell Windows Server Tasks → Launch Dell License Manager.

Launch Dell OpenManage Power Center

You can use this task to launch the OpenManage Power Center console.

To launch Dell OpenManage Power Center:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Windows Server Tasks → Launch Dell OpenManage Power Center.

Launch Dell OpenManage Server Administrator (Monolithic Server)

NOTE: Launching OpenManage Server Administrator is possible only if Windows or Linux operating 
system and OpenManage Server Administrator is installed on the managed node.

To launch Server Administrator from the OpsMgr console:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Server Tasks → Launch Dell OpenManage Server Administrator 
(Monolithic Server).

NOTE: The Dell Server Management Pack Suite tasks launch the remote console in the Internet 
Explorer.

Launch Dell Remote Access Console

To launch Dell Remote Access Console:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Task pane, select Dell Server Tasks → Launch Dell Remote Access Console.

Launch Remote Desktop (Monolithic Server)

NOTE: Launching remote desktop is possible only if the Windows operating system is installed and 
remote desktop is manually enabled on the managed system.

NOTE: Remote Desktop task uses hostname to connect to the management server of a system. If 
the management server cannot resolve the hostname then, add the hostname and the IP address to 
a route to the server using its hostname that is configured on the management server.
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To launch Remote Desktop from the OpsMgr console:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell server in any of the Diagram Views or State Views or an alert in the Alerts 
Views.

3. In the Tasks pane, select Dell Server Tasks → Launch Remote Desktop (Monolithic Server).
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5
DRAC Monitoring Feature
DRAC monitoring feature supports discovery, and monitoring for the various generations of iDRAC 
(iDRAC6, iDRAC7, and iDRAC8 systems) using SNMP.

 

Discovery and grouping

The Dell Server Management Pack Suite enables you to discover and classify Dell Remote Access 
Controllers (DRAC), and integrated DRAC (iDRAC).

The following table lists the details of the hardware discovery and grouping by the Dell DRAC monitoring 
feature.

Table 16. Dell Hardware discovery and grouping

Group Diagram View Hardware Type

Dell Remote Access Controllers Remote Access Controller Group iDRAC modular, and iDRAC 
monolithic instances.

NOTE: DRAC monitoring 
feature does not support the 
discovery of xx0x iDRAC 
modular controllers. You 
can manage these devices 
using the Scalable Edition of 
Agent-based monitoring 
feature.

Discovering DRAC Devices

The DRAC devices must be discovered as network devices under the Administration section of the 
OpsMgr console.
To discover DRAC devices:

1. Log on to the management server as an OpsMgr administrator.

2. On the OpsMgr console, click Administration.

3. At the bottom of the navigation pane, click Discovery Wizard.

4. Run the Discovery Wizard, select Network devices and follow the instructions on the screen.

For more information, see the OpsMgr documentation at technet.microsoft.com.

5. On the Add a Device console screen in OpsMgr 2012, type the IP address that you want to scan, 
select the appropriate Run As account from the SNMP V1 or V2 Run As account drop-down box.

6. Enable the DRAC monitoring feature using Feature Management Dashboard.
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Scalability Recommendation For OpsMgr 2012

When managing large number of network devices in a distributed setup, use dedicated resource pools of 
Management Servers for each device type, if the same Management Group is also used to manage agent-
based devices.

Discoveries by the DRAC Monitoring Feature

Table 17. DRAC Monitoring Feature Discoveries

Discovery Object Description

iDRAC Discovery Discovers all supported Integrated Dell Remote 
Access Controllers.

Dell Integrated Remote Access Modular 
Discovery

Discovers the Chassis Name and Chassis Service 
Tag of Dell Integrated Remote Access Controllers 
for Modular systems.

iDRAC6 Modular Discovery Discovers the iDRAC6 (Modular) group.

iDRAC6 Monolithic Discovery Discovers the iDRAC6 (Monolithic) group.

iDRAC7 Modular Discovery Discovers the iDRAC7 (Modular) group.

iDRAC7 Monolithic Discovery Discovers the iDRAC7 (Monolithic) group.

iDRAC8 Modular Discovery Discovers the iDRAC8 (Modular) group.

iDRAC8 Monolithic Discovery Discovers the iDRAC8 (Monolithic) group.

Dell Remote Access Group Discovery Discovers the Dell Remote Access group and 
populates iDRAC.

Dell Integrated Remote Access Monolithic Group 
Discovery

Discovers the Dell Integrated Remote Access 
Monolithic group and iDRAC (Monolithic).

Dell Integrated Remote Access Modular Group 
Discovery

Discovers and populates the iDRAC (Modular) 
group.

Monitoring

After you install the Dell Server Management Pack Suite, you can use the Monitoring pane of the OpsMgr 
to select views that provide complete health information of the discovered Dell DRAC devices. The DRAC 
monitoring feature discovers and monitors the health of the Dell DRAC devices. It includes monitoring 
health of Dell DRAC devices, both at regular intervals and on occurrence of events. The Severity Level 
Indicators indicates the health of the Dell DRAC devices on the network.

NOTE: To monitor the health of DRAC devices, associate the community string Run As account with 
the SNMP Monitoring Account with the target as Dell Remote Access Controller class or respective 
DRAC object (if you have different Run As accounts for different DRAC devices).
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Alerts Views

This view is available for managing hardware and storage events from Dell DRAC devices. SNMP traps and 
Platform Event Traps (PET) sent by DRAC devices are displayed by the DRAC monitoring feature.

Viewing Alerts on the OpsMgr Console

To view DRAC alerts on the OpsMgr console:

1. Launch the OpsMgr console and click Monitoring.

2. Click Dell → Alerts Views.

The following Alerts Views are displayed.

• PET Traps — These alerts contain information on PET traps from iDRAC6, iDRAC7, and iDRAC8 
devices.

• Remote Access Alerts — These alerts contains information on SNMP traps from iDRAC6, iDRAC7 
and iDRAC8 devices.

3. Select an alert to view the details in the Alert Details pane.

On the right pane of each of the individual Alerts Views, alerts that meet the criteria you specify, 
such as alert severity, resolution state, or alerts that are assigned to you is displayed.

Diagram Views

The Diagram Views offers a hierarchical and graphical representation of all Dell DRAC devices on the 
network.

Viewing Diagrams On The OpsMgr Console

To view the diagrams for DRAC monitoring feature on the OpsMgr console:

1. Launch the OpsMgr console and click Monitoring → Dell → Diagram Views.

2. In the Monitoring pane on the left side, navigate to the Diagram Views folder for the following views:

• Complete Diagram View

• Remote Access Controllers Group

3. Select any of the Diagram Views.

On the right pane the hierarchical and graphical representation of the selected Dell device is 
displayed.

4. Select a component in the diagram to view its details in the Detail View pane.

Remote Access Controllers Group

The Remote Access Controllers Group diagram view offers a graphical representation of all iDRAC6, 
iDRAC7 and iDRAC8 devices. Select a component in the diagram to view its details in the Detail View 
pane.
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Figure 3. Remote Access Controllers Group Diagram

State Views

This view is available for viewing the health of the Dell DRAC devices. In the OpsMgr console, click 

Monitoring → Dell → State Views → DRAC, the status of each Dell DRAC device managed by OpsMgr 
on the network is displayed.

The health of a component is derived by reviewing the unresolved alerts associated with the component.
Severity Level Indicators explains the various state components that the Dell Server Management Pack 
Suite uses with their corresponding severity levels.

Dell Unit Monitors for DRAC Monitoring Feature 

Monitors to assess various conditions that can occur in DRAC monitored objects.

Table 18. Dell Unit Monitors for DRAC Monitoring Feature

Object Unit Monitor

iDRAC6 Modular

Dell Remote Access Status Event and Periodic

iDRAC6 Monolithic

Dell Remote Access Status Event and Periodic

iDRAC7 Modular

NOTE: For iDRAC7 modular and monolithic servers, the Dell RAC periodic-based and Dell RAC 
triggered-based unit monitors are disabled.

Dell Remote Access Status Event and Periodic

Controller Global Status Event and Periodic

Controller Global Storage Status Event and Periodic
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Object Unit Monitor

iDRAC7 Monolithic

Dell Remote Access Status Event and Periodic

Controller Global Status Event and Periodic

Controller Global Storage Status Event and Periodic

iDRAC8 Modular

NOTE: For iDRAC8 modular and monolithic servers, the Dell RAC periodic-based and Dell RAC 
triggered-based unit monitors are disabled.

Dell Remote Access Status Event and Periodic

Controller Global Status Event and Periodic

Controller Global Storage Status Event and Periodic

iDRAC8 Monolithic

Dell Remote Access Status Event and Periodic

Controller Global Status Event and Periodic

Controller Global Storage Status Event and Periodic

Rules

The following section lists the rules specific to the Dell DRAC monitoring feature.

Dell Systems Event Processing Rules

The Dell Server Management Pack Suite processes rules from DRAC traps.

DRAC Devices

All informational, warning, and critical SNMP traps for the DRAC devices have a corresponding SNMP trap 
rule.

Each of these rules are processed based on the following criteria:

• Source Name = "DRAC/CMC name or ip"

• OID = Actual trap ID of the DRAC /CMC SNMP trap event

• Data Provider = SNMP trap

NOTE: Informational alerts are turned off by default. To receive these alerts, import informational 
alerts management pack.
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Tasks

Tasks are available in the Tasks pane of the OpsMgr console. When you select a device or a component, 
the relevant tasks appear in the Tasks pane.

Task Summary

Performing Dell Tasks using DRAC

Following table provides a summary of the Dell tasks that are performed using the DRAC:

Table 19. Dell Tasks using DRAC

Task Description

Launch Dell License Manager Launches the Dell License manager on the 
management system.

Launch Dell Remote Access Console Launches the DRAC console for the discovered 
DRAC.

Launch Remote Desktop Launches the remote desktop for the selected 
system.

NOTE: This feature is available only on 
systems with iDRAC7, and iDRAC8.

Launch Server Administrator Launches the Server Administrator.

NOTE: 

• Server Administrator console is launched 
only if the Server Administrator is 
configured on the default port.

• This feature is available only on systems 
with iDRAC7, and iDRAC8.

Dell Remote Access Controller (DRAC) Tasks

Launch Dell License Manager

The Launch Dell License Manager task allows you to launch the Dell License Manager on management 
systems. Dell License Manager is a one-to-many license deployment and reporting tool for Dell iDRAC 
licenses.

NOTE: If the Dell License Manager has not been installed in the default path, create a new task to 
launch Dell License Manager. For more information, see Creating a Launch License Manager Task.

To launch Dell License Manager:

1. In the OpsMgr console, navigate to Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell DRAC /iDRAC device in any of the Diagram Views or State Views or an alert in 
the Alerts Views.

3. In the Tasks pane, select Dell Remote Access Controller Tasks → Launch Dell License Manager.

57



Launch Dell Remote Access Console

You can use this task to launch the Dell Remote Access Console, if the DRAC is installed on the 
Dell system.

To launch Dell Remote Access console:

1. In the OpsMgr console, navigate to a Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired DRAC/iDRAC device in any of the Diagram Views or State Views or an alert in the 
Alerts Views.

3. In the Tasks pane, select Dell Remote Access Controller Tasks → Launch Dell Remote Access 
Console.

Launch Remote Desktop

NOTE: 

• The remote desktop feature is available only on systems with iDRAC7, and iDRAC8.

• Launching remote desktop is possible only if remote desktop is enabled manually in the 
managed node.

To launch remote desktop:

1. In the OpsMgr console, navigate to Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell DRAC/ iDRAC device in any of the Diagram Views or State Views or an alert in 
the Alerts Views.

3. In the Tasks pane, select Dell Remote Access Controller Tasks → Launch Remote Desktop.

Launch Server Administrator

NOTE: 

• Dell Server Administrator console is launched only if the Server Administrator is configured on 
the default port.

• Dell Server Administrator feature is available only on systems with iDRAC7, and iDRAC8.

To launch Server Administrator:

1. In the OpsMgr console, navigate to Dell Diagram Views, State Views, or Alerts Views.

2. Select the desired Dell DRAC/ iDRAC device in any of the Diagram Views or State Views or an alert in 
the Alerts Views.

3. In the Tasks pane, select Dell Remote Access Controller Tasks → Launch Server Administrator.
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6
Chassis Monitoring Feature 
The Chassis monitoring feature supports discovery and monitoring of Chassis Management Controller 
(CMC) on Dell PowerEdge FX2/FX2s chassis, Dell PowerEdge VRTX chassis, Dell PowerEdge M1000e 
chassis, and Dell OEM Ready chassis using SNMP and WS-MAN.

Chassis monitoring feature also supports Detailed monitoring of individual chassis components in 
OpsMgr 2012.

 

Discovery and grouping

The Dell Server Management Pack Suite enables you to discover and classify Dell Chassis Management 
Controllers (CMC), Dell PowerEdge FX2/ FX2s, Dell PowerEdge M1000e, and Dell PowerEdge VRTX.

The following table lists the details of the hardware discovery and grouping by the Dell CMC monitoring 
feature.

Table 20. Dell Hardware discovery and grouping

Group Diagram View Hardware Type

Dell CMC Dell Chassis Management 
Controllers (CMC) group

CMC instances on the network, 
chassis slot summary and server 
modules for CMC.

Dell PowerEdge M1000e Dell M1000e Chassis group Dell PowerEdge M1000e

Dell PowerEdge VRTX Dell VRTX Chassis group Dell PowerEdge VRTX

Dell FX2 Dell FX2 Chassis Group Dell PowerEdge FX2

Discovering Chassis devices

The Chassis devices should be discovered as network devices under the Administration section of the 
OpsMgr console.

To discover Chassis devices:

1. Log on to the management server as an OpsMgr administrator.

2. On the OpsMgr console, click Administration.

3. At the bottom of the navigation pane, click Discovery Wizard.

4. Run the Discovery Wizard, select Network devices and follow the instructions on the screen.

For more information, see the OpsMgr documentation at technet.microsoft.com.
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NOTE: Select the Run As accounts created for discovering the chassis devices. For more 
information, see the "Configuring Dell Chassis Management Controller feature for correlating 
Server modules with Chassis slot summary" section of the Dell Server Management Pack Suite 
Version 6.2 for Microsoft System Center Operations Manager Installation Guide at dell.com/
OMConnectionsEnterpriseSystemsManagement.

5. On the Add a Device console screen in OpsMgr 2012, type the IP address that you want to scan, 
select the appropriate Run As account from the SNMP V1 or V2 Run As account drop-down box.

6. Enable the Chassis monitoring feature using the Feature Management Dashboard.

Discoveries by the Dell Chassis Monitoring Feature

Table 21. Dell Chassis Monitoring Feature Discoveries

Discovery Object Description

Dell CMC Discovery Discovers all supported Dell CMCs, Dell 
PowerEdge FX2, Dell PowerEdge VRTX, Dell 
PowerEdge M1000e, and Dell OEM Ready chassis.

Dell CMC Slot Discovery Discovers slots on the CMC device.

Dell Chassis Detailed Discovery Discovers all Dell chassis components.

Monitoring

After you install the Dell Server Management Pack Suite, you can use the Monitoring pane of the OpsMgr 
to select views that provide complete health information of the discovered Dell CMC devices. The 
Chassis monitoring feature discovers and monitors the health of the Dell CMC devices. The Severity Level 
Indicators indicates the health of the Dell CMC devices on the network.

Chassis Monitoring includes monitoring the health of Dell chassis devices, both at regular intervals and on 
occurrence of events.

NOTE: To perform Chassis Detailed monitoring, create Run As Accounts with WS-Man credentials 
needed for accessing the Dell CMCs and associate it to the profiles — Dell CMC Login Account Run 
As Profiles.

Monitored hardware components

NOTE: 

• Some inventory attributes and health will not be available if RACADM utility is not present. 
Hence, an one-time warning alert is generated asking you to install RACADM utility.

• In absence of RACADM utility CMC Group, CMC component, IO Module component, IO Module 
Group, and Power Supply Group components will be in Warning state. To monitor CMC Group, 
CMC component, IO Module component, IO Module Group, and Power Supply Group 
components; enable RACADM utility.

The following table provides information on the monitored hardware components supported in Scalable 
and Detailed feature.
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Table 22. Monitored hardware components — Scalable and Detailed feature

Hardware Components Scalable Detailed

CMC Slot Information No No

CMC Slot No No

Fan Group No Yes

Fan No Yes

IO Module No Yes

IO Module Group No Yes

PCIe Device Group No No

PCIe Device No No

Power Supply Group No Yes

Power Supply No Yes

Storage No Yes

Storage Controller No Yes

Storage Controller Virtual Disk Group No Yes

Storage Controller Virtual Disk No Yes

Storage Controller Physical Disk 
Group

No Yes

Storage Controller Physical Disk No Yes

Storage Enclosure No Yes

Alerts Views

This view is available for managing hardware and storage events from Dell CMC devices. SNMP traps sent 
by Chassis devices are displayed by the Chassis monitoring feature.

Viewing Alerts on the OpsMgr Console

To view Chassis monitoring alerts on the OpsMgr console:

1. Launch the OpsMgr console and click Monitoring.

2. Click Dell → Alerts Views.

The following individual Alerts Views are displayed:
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• CMC Alerts — SNMP traps from the discovered Chassis devices are displayed.

• Dell Chassis Alert Views

– Dell FX2 Chassis Alerts — SNMP traps from the discovered Dell PowerEdge FX2 chassis 
devices are displayed.

– Dell M1000e Chassis Alerts — SNMP traps from the discovered Dell PowerEdge M1000e 
chassis devices are displayed.

– Dell VRTX Chassis Alerts — SNMP traps from the discovered Dell PowerEdge VRTX chassis 
devices are displayed.

3. Select any of the Alerts Views.

On the right pane of each of the individual Alerts Views, alerts that meet the criteria you specify, 
such as alert severity, resolution state, or alerts that are assigned to you is displayed.

4. Select an alert to view the details in the Alert Details pane.

Diagram Views

The Diagram Views offers a hierarchical and graphical representation of all Dell CMC devices, Dell FX2, 
Dell M1000e, and Dell VRTX on the network.

Viewing Diagrams on the OpsMgr Console

To view the diagrams for chassis monitoring feature on the OpsMgr console:

1. Launch the OpsMgr console and click Monitoring → Dell → Diagram Views.

2. Navigate to the Diagram Views folder for the following views:

• Complete Diagram View.

• Chassis Management Controllers Group.

• Dell Chassis Diagram Views.

– Dell FX2 Chassis Diagram View.

– Dell M1000e Chassis Diagram View.

– Dell VRTX Chassis Diagram View.

3. Select any of the Diagram Views.

On the right pane the hierarchical and graphical representation of the selected Dell device is 
displayed.

4. Select a component in the diagram to view its details in the Detail View pane.

Chassis Management Controllers group

The Chassis Management Controllers Group diagram view offers a graphical representation of all Dell 
CMC, Dell PowerEdge FX2, Dell PowerEdge M1000e, and Dell PowerEdge VRTX, and their inventory. 
For Chassis discovery, see Discovering Chassis devices.
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Figure 4. Chassis Management Controllers group diagram

For discovered CMC chassis, enable slot discovery which is disabled by default to view:

• The occupied and free slot summary in the Chassis Slots Summary.

• The slot-inventory details modified on CMC chassis that are reflected in the Diagram View.

• The correlation of discovered Dell servers using Agent-free or Agent-based monitoring feature with 
the server modules of CMC chassis that are displayed in the Chassis Management Controllers Group 
diagram. The Dell system is visible under the slot in the diagram.

NOTE: Create Run As Account for CMC slot discovery with simple, basic, or digest authentication 
only. For more information, see "Configuring the Dell Chassis Management Controller Feature for 
Correlating Server Modules with Chassis Slot Summary" section of the Dell Server Management 
Pack Suite Version 6.2 for Microsoft System Center Operations Manager Installation Guide at 
dell.com/support/home.

NOTE: The iDRAC firmware of the modular systems should be compatible with the CMC firmware, 
failing which, the Service Tag is displayed as Not Available and the Chassis Blade Correlation may 
not be possible.

Dell Chassis Diagram Views

The Dell Chassis diagram view offers a graphical representation of Dell PowerEdge FX2, Dell PowerEdge 
M1000e chassis, and Dell PowerEdge VRTX chassis devices. Select a component in the diagram to view 
its details in the Detail View pane.

State Views

This view is available for viewing the health of the Dell CMC devices. In the OpsMgr console, click 

Monitoring → Dell → State Views, the status of each Dell device managed by OpsMgr on the network is 
displayed.
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Select the Dell CMC device group for which you want to see the State view. You can view the status for 
the following:

• CMC

• Dell Chassis State Views

– Dell FX2 Chassis State View

– Dell M1000e Chassis State View

– Dell VRTX Chassis State View

The health of a component is derived by reviewing the unresolved alerts associated with the component.
Severity Level Indicators explains the various state components that the Server Management Pack Suite 
uses with their corresponding severity levels.

Dell Unit Monitors for Chassis Monitoring Feature 

Monitors to assess various conditions that can occur in Chassis monitored objects.

Table 23. Dell Unit Monitors for Chassis Monitoring Feature

Object Unit Monitor

Dell CMC

Dell CMC Status Event and Periodic

Dell Chassis Overall Health 

Dell Chassis Overall Health Unit Monitor Event and Periodic

Dell Chassis IO Module

Dell Chassis IO Module Health Poll Based 
UnitMonitor

Periodic

Dell Modular Chassis Fan

Dell Chassis Fan Health Poll Based 
UnitMonitor

Periodic

Dell Chassis Modular Controller

Dell Chassis CMC Health Poll Based 
UnitMonitor

Periodic

Dell Chassis Modular Controller Group

Dell Chassis CMC Group Health Poll Based 
UnitMonitor

Periodic

Dell Chassis Modular Power Supply
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Object Unit Monitor

Dell Chassis Power Supply Health Poll Based 
UnitMonitor

Periodic

Dell Chassis Modular Power Supply Group

Dell Chassis Power Supply Group Health 
PollBased UnitMonitor

Periodic

Dell Chassis Modular PCIe Device

Dell Chassis PCIe Device Health PollBased 
UnitMonitor

Periodic

Dell Chassis Storage Enclosure

Dell Chassis Storage Enclosure Health 
PollBased UnitMonitor

Periodic

Dell Chassis Storage Controller

Dell Chassis Storage Controller Health Poll 
Based UnitMonitor

Periodic

Dell Chassis Storage Controller Battery Health 
Poll Based UnitMonitor

Periodic

Dell Chassis Storage Controller Virtual Disk

Dell Chassis Storage VirtualDisk Health Poll 
Based UnitMonitor

Periodic

Dell Chassis Storage Controller Enclosure Internal Physical Disk

Dell Chassis Storage Internal PhysicalDisk 
Primary Health Status Poll Based UnitMonitor

Periodic

Dell Chassis Storage Internal PhysicalDisk 
Predictive Failure Health Status Poll Based 
UnitMonitor

Periodic

Dell Chassis Storage Controller Enclosure External Physical Disk

Dell Chassis Storage External PhysicalDisk 
Primary Health Status Poll Based UnitMonitor

Periodic

Dell Chassis Storage External PhysicalDisk 
Predictive Failure Health Status Poll Based 
UnitMonitor

Periodic
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Rules

The following section lists the rules specific to the Dell Chassis monitoring feature.

Dell Systems Event Processing Rules

The Dell Server Management Pack Suite processes rules from Chassis traps.

Chassis Devices

All informational, warning, and critical SNMP traps for the Chassis devices have a corresponding SNMP 
trap rule.

Each of these rules are processed based on the following criteria:

• Source Name = "DRAC/CMC name or ip"

• OID = Actual trap ID of the DRAC /CMC SNMP trap event

• Data Provider = SNMP trap

NOTE: Informational alerts are turned off by default. To receive these alerts, import informational 
alerts management pack.

Tasks

Tasks are available in the Tasks pane of the OpsMgr console. When you select a device or a component, 
the relevant tasks appear in the Tasks pane.

Task Summary

Performing Dell Task using the Dell Chassis

Following table provides a summary of the Dell task that you can perform using the Dell chassis:

Table 24. Dell Task using The Dell Chassis

Task Description

Launch Dell CMC Console Launches the CMC console.

Dell Chassis Tasks

Launch Dell CMC Console

To launch the CMC console.

1. In the OpsMgr console, navigate to Dell Diagram Views, State Views, or Alerts Views.

2. Select the CMC device in any of the Diagram Views or State Views or an alert in the Alerts Views.

3. In the Tasks pane, select Dell CMC Tasks → Launch Dell CMC Console.
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7
Chassis Modular Server Correlation 
Feature
Chassis Modular Server Correlation feature supports:

• Correlation of discovered Dell Modular Servers using Agent-free or Agent-based monitoring feature 
with Chassis slots.

NOTE: CMC slot discovery is disabled by default. Hence, enable CMC slot discovery for the 
correlation feature to work.

• Correlation of Chassis Shared Storage components with Dell servers.

NOTE: Imports Chassis detailed monitoring for the correlation of chassis shared components 
with Dell servers.

 

Discoveries by the Chassis Modular Server Correlation 
Feature
Table 25. Chassis Modular Server Correlation Feature Discoveries

Discovery Object Description

Dell CMC Chassis to Modular Server Correlation 
Discovery

Discovers the correlation between the CMC 
chassis and the Dell modular systems.

Dell Chassis Storage to Blade Server Correlation 
Discovery 

Discovers the correlation between chassis shared 
components with Dell Servers (Agent-based).
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8
Feature Management Dashboard
The Feature Management Dashboard provides facilities for the configuration of Dell Server Management 
Pack Suite monitoring features to monitor the various Dell systems — Dell servers, Dell Precision Racks, 
Dell Remote Access Controllers (DRAC), Dell PowerEdge FX2/ FX2s, Dell PowerEdge VRTX, Dell 
PowerEdge M1000e, and integrated DRAC (iDRAC). The Feature Management Dashboard provides the 
following monitoring features.

• Agent-based Monitoring Feature

• Agent-free Monitoring Feature

• DRAC Monitoring Feature

• Chassis Monitoring Feature

• Chassis Modular Server Correlation Feature

 

Discovery by Dell Feature Management Pack
Table 26. Dell Feature Management Pack Discovery

Discovery Object Description

Dell Feature Management Host Discovery Populates the dashboard if the management server 
is the feature management pack host. The 
management server on which the Dell Server 
Management Pack Suite is installed first, is selected 
as the feature management pack host.

Tasks

Tasks are available in the Tasks pane of the OpsMgr console. When you select a device or a component, 
the relevant tasks appear in the Tasks pane.

Feature Management Tasks

The following table lists the tasks available on the Feature Management Dashboard. Some tasks listed in 
the Feature Management Tasks table appear only after you have imported a particular monitoring feature.
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NOTE: 

• In the Event log, ignore the errors pertaining to reimporting of existing management packs 
under the error logs. These errors occur when Feature Management Dashboard reimports all 
the dependent management packs that are already imported while importing a monitoring 
feature.

• Wait for a task to complete (view the state update change in the dashboard) before launching 
another task using the Feature Management Dashboard.

• The Refresh dashboard task may not update the dashboard immediately; it might take a few 
minutes to update the dashboard contents.

NOTE: .

Table 27. Feature Management Tasks

Tasks Description

Chassis Modular Server Correlation

Import Chassis Modular Server Correlation 
Feature

Imports the chassis modular server correlation 
feature.

Refresh Dashboard Updates the Feature Management Dashboard.

Refresh Node Count Updates the node count.

Remove Chassis Modular Server Correlation 
Feature

Removes the chassis modular server correlation 
monitoring feature.

Upgrade Chassis Modular Server Correlation 
Feature

Upgrades to the latest version of the chassis 
modular server correlation feature.

Chassis Monitoring

Import Chassis Monitoring Detailed Feature Imports the chassis detailed monitoring feature.

Import Chassis Monitoring Scalable Feature Imports the chassis scalable monitoring feature.

Refresh Dashboard Updates the Feature Management Dashboard.

Refresh Node Count Updates the node count.

Remove Chassis Monitoring Feature Removes the chassis monitoring feature (both 
scalable and detailed monitoring feature).

Set to Chassis Detailed Monitoring Feature If the Scalable feature is running on the system, 
the Feature Management Dashboard switches 
from the Scalable feature to the Detailed feature.

On upgrading from a previous version, run this 
task to use the latest version for this monitoring 
feature.

Set to Chassis Scalable Monitoring Feature If the Detailed feature is running on the system, 
the Feature Management Dashboard switches 
from the Detailed feature to the Scalable feature. 
On upgrading from the previous version, run this 
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Tasks Description

task to use the latest version for this monitoring 
feature.

DRAC Monitoring

Import DRAC Monitoring Feature Imports the DRAC monitoring feature.

Refresh Dashboard Updates the Feature Management Dashboard.

Refresh Node Count Updates the node count.

Remove DRAC Monitoring Feature Removes the DRAC monitoring feature.

Upgrade DRAC Monitoring Feature Upgrades to the latest version of the DRAC 
monitoring feature.

Server and Rack Workstation Agent-based Monitoring 

Enable Agent Proxying Enables agent proxying for Dell servers.

Import Agent-based Detailed Feature Imports the Detailed feature of the Agent-based 
monitoring feature.

Import Agent-based Scalable Feature Imports the Scalable feature of the Agent-based 
monitoring feature.

Refresh Dashboard Updates the Feature Management Dashboard.

Refresh Node Count Updates the node count.

Remove Agent-based Monitoring Feature Removes the Agent-based monitoring feature.

Set Agent-based as Preferred Monitoring 
Method

This task enables the Agent-based monitoring 
feature as the preferred monitoring method for 
the Dell servers and Rack Workstations, when 
the Dell servers and Rack Workstations in the 
setup are monitored through both, Agent-based 
monitoring feature, and Agent-free monitoring 
feature.

Set Informational Alerts Off Informational alerts are turned off when the 
Agent-based Scalable Monitoring is in use.

Set Informational Alerts On Informational alerts are turned on when the 
Agent-based Scalable Monitoring is in use.

Set to Agent-based Detailed Feature If the Scalable feature is running on the system, 
the Feature Management Dashboard switches 
from the Scalable feature to the Detailed feature.

On upgrading from the previous version, run this 
task to use the latest version for this monitoring 
feature.
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Tasks Description

Set to Agent-based Scalable Feature If the Detailed feature is running on the system, 
the Feature Management Dashboard switches 
from the Detailed feature to the Scalable feature.

On upgrading from the previous version, run this 
task to use the latest version for this monitoring 
feature.

Server and Rack Workstation Agent-free Monitoring

Associate Run-As Account This task associates the Run As Account used for 
SMASH discovery with all Dell Server objects, 
required for health monitoring. For more 
information, see Associate Run-As Account Task.

Import Agent-free Detailed Feature Imports the Detailed feature of Agent-free 
monitoring feature.

Import Agent-free Scalable Feature Imports the Scalable feature of Agent-free 
monitoring feature.

Refresh Dashboard Updates the Feature Management Dashboard.

Refresh Node Count Updates the node count.

Remove Agent-free Monitoring Feature Removes the Agent-free monitoring feature.

Set Agent-free as Preferred Monitoring 
Method

This task enables the Agent-free monitoring 
feature as the preferred monitoring method for 
the Dell servers and Rack Workstations, when 
the Dell servers and Rack Workstations in the 
setup are monitored through both, Agent-based 
monitoring feature, and Agent-free monitoring 
feature.

Set to Agent-free Detailed Feature If the Scalable feature is running on the system, 
the Feature Management Dashboard switches 
from the Scalable feature to the Detailed feature.

On upgrading from the previous version, run this 
task to use the latest version for this monitoring 
feature.

Set to Agent-free Scalable Feature If the Detailed feature is running on the system, 
the Feature Management Dashboard switches 
from the Detailed feature to the Scalable feature.

On upgrading from the previous version, run this 
task to use the latest version for this monitoring 
feature.

71



9
Licensing for Dell Server Management 
Pack Suite
License Information

Agent-free monitoring feature in Dell Server Management Pack Suite for OpsMgr is licensed. Information 
on the process for obtaining software licenses is as follows.

Licenses

Licenses are available as tiered bundles of 1, 50, 200, and Unlimited node(s). One node license is available 
for evaluation purposes at no additional charge. You are required to purchase at least one license per 
OpsMgr Management group.

For more information on licensing, go to Dell TechCenter website and then OpenManage Integration 
Suite for Microsoft System Center wiki page.

Purchasing Licenses

To leverage the Agent-free monitoring feature functionalities, you must first purchase the appropriate 
License Key SKU (based on the desired number of managed nodes). You can purchase licenses from Dell 
Sales. The order confirmation and license is sent as an email to the email ID that you have specified in My 
Account — Dell. The purchased licenses are also downloadable from the Dell Online Licensing portal — 
dell.com/support/licensing.

Checking License Usage

A Console requires a license to manage PowerEdge servers. To view the PowerEdge servers managed by 

Agent-free monitoring feature for OpsMgr: In OpsMgr, select Monitoring → Dell → Feature 
Management Dashboard

The number of nodes consumed is displayed in the Total Node Count column.

When the number of PowerEdge servers increase in a data center, you can purchase the appropriate 
license bundle.

Change from Dell Server Management Pack Suite Version 6.0 for OpsMgr

Until Dell Server Management Pack Suite Version 6.0 for OpsMgr; Dell Connections License Manager 
(DCLM) was required to manage licenses. For Dell Server Management Pack Suite Version 6.1 and later, 
you do not require DCLM.

There is no longer a license-count enforcement due to DCLM being removed. You can continue to 
manage the Dell PowerEdge servers using Agent-free monitoring feature for OpsMgr even after reaching 
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or exceeding the limit of the number of licenses purchased from Dell. The Checking License 
Usage section presents the steps to help you determine the number of nodes being managed to ensure 
that you have the appropriate number of license entitlements from Dell Inc. Purchase additional licenses 
if the number of nodes you are managing exceed the number of licenses you have purchased.

Licenses that you have purchased for Dell Server Management Pack Suite Version 6.0 for OpsMgr are still 
applicable to Dell Server Management Pack Suite Version 6.1 and later for OpsMgr. So, after a product 
upgrade, the earlier license is still valid and you can still manage servers per the permissible count 
mentioned in the previously purchased license.

License terms and conditions

The licenses are also governed by the same license terms as the product EULA. You can get the latest 
updated license terms at dell.com/learn/us/en/uscorp1/terms?s=corp. For further queries, contact Dell 
Sales and Support.
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Related documentation and resources
This chapter gives the details of documents and references to help you work with Dell Server 
Management Pack Suite.

 

Microsoft guidelines for performance and scalability for 
Operations Manager

For optimal performance, deploy device-specific Server Management Pack Suite on different 
management servers.

For information on Microsoft’s recommendations for scalability, see the Microsoft website at 
technet.microsoft.com.

NOTE: Make sure that the Autogrow option is enabled in Operations Manager Data Warehouse 
and/or Database for improved performance.

Other documents you may need

Besides this User's Guide, you may need to see the following guides available at dell.com/support/home.

• Integrated Dell Remote Access Controller User’s Guide

• Dell OpenManage Installation and Security User's Guide

• Dell OpenManage Server Administrator Installation Guide

• Dell OpenManage Server Administrator Compatibility Guide

• Dell OpenManage Server Administrator CIM Reference Guide

• Dell OpenManage Server Administrator Messages Reference Guide 

• Dell OpenManage Server Administrator Command Line Interface User's Guide 

• Dell OpenManage Baseboard Management Controller Utilities User’s Guide

• Dell OpenManage Port Information Guide

• Dell Lifecycle Controller User’s Guide 

• Dell Chassis Management Controller User’s Guide

• Dell Chassis Management Controller for Dell PowerEdge VRTX User’s Guide

• Dell Chassis Management Controller for Dell PowerEdge FX2 User’s Guide

The Dell Systems Management Tools and Documentation DVD contains a release notes file for Server 
Administrator and additional release notes files for other systems management software applications 
found on the DVD.
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Accessing Documents From Dell Support Site

To access the documents from Dell Support site:

1. Go to dell.com/support/manuals. 

2. In the Tell us about your Dell system section, under No, select Choose from a list of all Dell 
products and click Continue. 

3. In the Select your product type section, click Software and Security. 

4. In the Choose your Dell Software section, click the required link from the following:

• Client System Management

• Enterprise System Management

• Remote Enterprise System Management

• Serviceability Tools

5. To view the document, click the required product version.

NOTE: You can also directly access the documents using the following links:

• For Enterprise System Management documents — dell.com/openmanagemanuals 

• For Remote Enterprise System Management documents — dell.com/esmmanuals 

• For Serviceability Tools documents — dell.com/serviceabilitytools

• For Client System Management documents — dell.com/OMConnectionsClient 

• For OpenManage Connections Enterprise systems management documents — dell.com/
OMConnectionsEnterpriseSystemsManagement

• For OpenManage Connections Client systems management documents — dell.com/
OMConnectionsClient 

Contacting Dell

NOTE: If you do not have an active Internet connection, you can find contact information on your 
purchase invoice, packing slip, bill, or Dell product catalog.

Dell provides several online and telephone-based support and service options. Availability varies by 
country and product, and some services may not be available in your area. To contact Dell for sales, 
technical support, or customer service issues:

1. Visit dell.com/support.

2. Select your support category.

3. Verify your country or region in the Choose a Country/Region drop-down menu at the top of page.

4. Select the appropriate service or support link based on your need.
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Appendix A — Issues And Resolutions

Issues and resolutions 

The following table lists the known issues, resolutions, and where the issues are applicable.

Table 28. Issues and resolutions

Issue Resolution Applicable To

In the Diagram View for Dell 
network devices, the basic 
attributes are not displayed for 
the Dell DRAC and chassis 
objects.

To resolve this issue, you can view 
the detailed set of attributes by 
clicking the objects in the State 
View.

Dell Chassis Monitoring Feature

Server Modules and Chassis 
Slot Summary Information are 
not visible under CMC.

• Make sure that OpenManage 
Server Administrator (OMSA) or 
DRAC tools are installed on the 
management server managing 
the CMC.

• Make sure that you have 
configured the 
RunAsAccounts for CMC 
devices and associated them 
with "Dell CMC Login 
Account".

• Make sure that Dell CMC Slot 
Discovery and rules are 
enabled from the Authoring 
Pane of the OpsMgr console.

Dell Chassis Monitoring Feature

Errors while running the 
Repair option in Dell Server 
Management Pack version 6.2 
from the Add/Remove 
Programs or Uninstall or 
change a program window.

Use the Repair option in the 
installer. For more information, 
see ”Using The Repair Option In 
The Installer" section of the Dell 
Server Management Pack Suite 
Version 6.2 for Microsoft System 
Center Operations Manager 
Installation Guide.

Dell Server Management Pack 
Suite

If there is a delayed response 
while discovering a CMC 
device, then the latest 
information from the device is 
not updated, the Script 
Timeout Error is generated or 
the log files in the Temp folder 
are not cleared.

Increase the Script Timeout value 
on the Override Properties screen 
for the CMC device which is 
experiencing a delayed response. 
For more information on 
Overrides, see the OpsMgr 
documentation at 
technet.microsoft.com.

Dell Chassis Monitoring Feature
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Issue Resolution Applicable To

Feature management host 
server health service is 
nonfunctional.

If the selected management server 
has stopped functioning, the 
executed Feature Management 
task fails. In such an instance, 
where the selected management 
server is corrupt or the health 
service cannot be obtained, 
decommission the management 
server to remove stale objects. For 
more information, see 
technet.microsoft.com/en-us/
library/hh456439.aspx.

Select a management server from 
the remaining management 
servers, and override the 
FMPHostFQDN of Feature 
Management Host Discovery.

Dell Server Management Pack 
Suite

Dell OM: Server and its 
component health 
computation failed alert is 

displayed under Monitoring → 
Alerts Views → Server Alerts 
on the console.

Manually associate the Run As 
Account for monitoring Dell 
server. For more information, see 
Associating Run As Account for 
monitoring a Dell Server using 
Agent-free Monitoring Feature.

Dell Agent-free Monitoring 
Feature

Known Limitations 
Table 29. Known Limitations

Limitation Applicable to

Dell MP, Power Control, and LED tasks use only 
the default credentials. When you create a new 
task in the Authoring pane and view it, you can see 
the username and the password you specified. The 
credentials are not hidden when you view the task.

Dell Server Management Pack Suite

While using health explorer, some unit monitors in 
Server Management Pack Suite (under Sensors and 
OpenManage Services instances) may display a 
green status though the sub-instance does not 
exist. This is because unit monitors cannot have an 
Unavailable state when the target class is present 
and the unit monitor has been executed.

Dell Server Management Pack Suite

Intrusion unit monitor status under sensors is only 
for chassis and does not include health of bezel 
intrusion.

Dell Server Management Pack Suite
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Appendix B

Creating a Simple Authentication Run As Account
1. Log on to OpsMgr 2012 as an administrator for the OpsMgr Management Group.

2. On the OpsMgr console, click Administration.

3. Click Run As Configuration → Accounts.

4. Right-click Accounts, and then click Create Run As Account.

The Create Run As Account Wizard screen is displayed.

5. Click Next.

6. From the Run As account type: drop-down menu, select Simple Authentication.

7. Provide a display name in the Display name: text box.

8. Provide a brief description in the Description (optional): text box and click Next.

9. On the Credentials screen provide the iDRAC login credentials for the systems you want to discover 
using the Agent-free monitoring feature.

10. Click Next.

11. Select the Less secure or More secure option as appropriate.

For more information, see the OpsMgr documentation at technet.microsoft.com/en-us/library/
hh321655.aspx.

NOTE: If the iDRAC login credentials are different for each of the systems, create a separate 
Run As Account for each of them.

12. Click Create.

13. After the Run As Account has been created, click Close.

Associating Run As Account for Monitoring a Dell Server 
using the Agent-free Monitoring Feature
For monitoring the Dell server, the Run As account used to discover it must be associated with the Dell 
server in the SMASH Device Monitoring Profile. The management pack performs the association 
automatically. But sometimes, you have to manually associate the Run As account.

To manually associate the Run As account in the SMASH Device Monitoring Profile:

1. Launch OpsMgr 2012, and click Administration.

2. In the Administration pane, browse to Run As Configuration → Profiles.

3. From the list of available profiles, right-click SMASH Device Monitoring Profile and click Properties.

The Introduction screen is displayed.

4. Click Next.

The Specify the Run As profile's general properties screen is displayed.

5. Click Next.
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The Run As Accounts screen is displayed.

6. Click Add.

The Add a Run As Account screen is displayed.

7. Select the run as account used to discover the Dell server from the Run As account: drop-down list.

NOTE: If you are using multiple Run As accounts to discover devices, associate each device 
with its associated Run As account.

8. Click. A selected class, group, or object and add the association for the server in the SMASH 
Monitoring Profile.

• Click Select → Class option, use Dell server as the selection.

• Click Select → Group option, use the group containing the Dell server objects as the selection.

• Click Select → Object option, use the individual Dell server object as the selection.

9. Click OK.

10. Click Save and Close.

NOTE: If the Run As Account association is not successful, the alert Dell OM: Server and its 
component health computation failed is displayed under Monitoring → Alerts View → Server 
Alerts on the console.

Severity Level Indicators

The following table lists the icons that indicate the severity levels of the discovered Dell devices on the 
OpsMgr console.

Table 30. Severity Level Indicators

Icon Severity Level

Normal/OK — The component is working as expected.

Warning/Noncritical — A probe or other monitoring device has detected a reading for 
the component that is above or below the acceptable level. The component may still 
be functioning, but it could fail. The component may also be functioning in an 
impaired state.

Critical/Failure/Error — The component has either failed or failure is imminent. The 
component requires immediate attention and may need to be replaced. Data loss may 
have occurred.

The health status is not applicable for the specific component.

The service is unavailable.
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Associate Run As-Account task — Agent-free Monitoring 
Feature

Associate Run As-Account task associates the Run As Account used for SMASH discovery with all Dell 
Server objects, required for health monitoring. This task is available as an option for performing object-
level association.

WARNING: Perform the Associate Run As-Account task only if necessary. This task affects the 
configuration of all Dell Server objects. Dell Server Run As Account Association unit monitor 
automatically performs the object-level association.
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Appendix C - Enabling External Program 
Tasks
For tasks provided by the Dell Server Management Pack Suite that launch external programs have to be 
installed in the default location. Create new tasks to launch the application if the program is not installed 
in the default location.

 

Creating Advanced Power Control and LED Identification 
Tasks
Advanced power control and LED identification tasks use the default BMC credentials and install path (C:
\Program Files\Dell\SysMgt\bmc).

If the systems deviate from the default BMC credentials and install path, install BMU 2.0 or later on the 
management server and create new console tasks.

CAUTION: For the following steps, create a task and set the password in plaintext. If BMC is not 
installed on management server, the OpsMgr Console may display an error with the entire 
command in a dialog box, and reveal the password. If you export the created override 
management pack containing this task to a disk, you can open the exported management pack in 
a common text editor or OpsMgr Authoring Console and the view the password in plain text. 
Create a task only if necessary and consider the security aspects before you proceed.

To create a task:

1. Launch the OpsMgr console and click Authoring.

2. In the Authoring pane, right-click Tasks under Management Pack Objects, and select Create new 
task.

Create Task Wizard scree is displayed.

3. In the Select a Task Type screen, select Command line under Console Tasks.

4. Select the destination management pack and click Next.

5. Enter Task name, Description, and select Dell Windows Server as the Task target and click Next. 

The Command-Line screen is displayed.

6. Enter the path of the application ipmitool.exe (the path where BMU was installed on the 
management server) in the Application field.

For example, C:\Program Files\Dell\SysMgt\bmc\ipmitool.exe. For the two LED 

identification tasks, the application path is C:\Program Files\Dell\SysMgt\bmc\ipmish.exe 
(default BMU path may differ based on the operating system language).

7. For power control tasks, in the Parameters field, enter the command-line parameters in the 
following format:

• Enter -I lanplus -H and then choose the Remote Access IP with IPMI capability from the 
drop-down menu.
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• Enter -U <username> -P <password> -k <kgkey> <IPMI Task String>
• Replace <IPMI Task String> with one of the following options:

– power status (for Check Power Status task)

– power on (for Power On task)

– power soft (for Power Off Gracefully task)

– power off (for Force Power Off task)

– power cycle (for Power Cycle task)

– power reset (for Power Reset task)

– identify on (for LED Identification On task)

– identify off (for LED Identification Off task)

Example:

-I lanplus -H $Target/Property[Type="Dell.WindowsServer.Server"]/
RemoteAccessIP$ -U root -P <password> -k <kgkey> power status

8. For LED on or off tasks, enter the command-line parameters in the following format:

• Enter -ip and choose the Remote Access IP with IPMI capability from drop-down menu.

• Enter -u <username> -p <password> -k <kgkey> <IPMI task string>.
9. Click Create to create the task and repeat this procedure for each new BMC task.

Creating a Launch License Manager Task
Launch License Manager Task uses the default Dell License Manager (DLM) install path 
(%PROGRAMFILES(X86)%\Dell\SysMgt\LicenseManager\Dell.DlmUI.exe or %PROGRAMFILES%\Dell
\SysMgt\LicenseManager\Dell.DlmUI.exe), that cannot be modified.

If the systems deviate from this, install DLM on the management server and create new console tasks in 
the Authoring pane targeted on DLM for Dell Server.

To create a new task:

1. Launch OpsMgr console and click Authoring.

2. In the Authoring pane, right-click Tasks under Management Pack Objects, and select Create a New 
Task.

3. In the Task Type screen, select Command line under Console Tasks.

4. Select the destination management pack and click Next.

5. Enter Task name, Description, and set the Task Target with one of the following:

• Dell Windows Server (for Agent-based Monitoring)

• Dell Server (for Agent-free Monitoring)

• Dell iDRAC7 or iDRAC8 (for DRAC Monitoring)

6. Click Next.

The Command Line screen is displayed.

7. Enter the path of the application Dell.DlmUI.exe (the path where DLM was installed on the 
management server) in the Application field.

For example, C:\Program Files\Dell\SysMgt\LicenseManager\Dell.DlmUI.exe (default 

DLM path may differ based on the operating system language).

8. Click Create to create the task and repeat this procedure for each new DLM task.
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