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Introduction To Dell SPI For HPOM For 
Microsoft Windows
The Dell Smart Plug-in (SPI) Version 4.0 for Hewlett Packard Operations Manager (HPOM) 9.0 for 
Microsoft Windows Installation Guide provides information about the software and system requirements 
to upgrade, install, configure, repair, and uninstall Dell SPI for HPOM. This plug-in is applicable for 64-bit 
systems.

Dell SPI for HPOM enables the datacenter customers to monitor the Dell devices (servers, chassis, remote 
access controllers, storage, and network switches) in an environment managed by HP Operations 
Manager console. It also supports console launch of Dell devices and other Dell tools to perform 
troubleshooting, configuration, and management activities.

The Dell SPI for HPOM supports the following Dell devices:

• Dell PowerEdge 9th Generation (9G) to 12th Generation (12G) servers

• Dell Remote Access Controller 5 (DRAC5), Integrated Dell Remote Access Controller 6 (iDRAC6), and 
Integrated Dell Remote Access Controller 7 (iDRAC7)

• Dell PowerEdge 1955 Chassis (DRAC/MC), Dell PowerEdge M1000e (CMC), Dell PowerEdge VRTX 
(VRTX CMC), and Dell PowerEdge FX2 (FX2 CMC)

• Dell Compellent Storage Arrays, Dell PowerVault MD Storage Arrays, Dell EqualLogic PS-Series 
Storage Arrays, and Dell PowerVault NX 9th Generation (9G) to 12th Generation (12G) Storage Arrays

• Dell Network Switches (S-Series, M-Series, Z-Series, 8000 Series, and 8100 Series)

The Dell SPI installer (Dell Smart Plug-in v4.0_x64.msi), Installation Guide, and the Release Notes are 
packaged in the self-extracting executable Dell_Smart_Plug-in v4.0_Axx.exe file. Before installing this 
version of Dell SPI, download the latest documents from dell.com/support/manuals.

Read the Dell SPI Release Notes for the latest information about software requirements, management 
server requirements, known issues, and resolutions.
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Prerequisites For Installing The Dell SPI
The requirements for installing the Dell SPI are as follows:

• Install Dell SPI only on HPOM 9.0 for Windows management server.

• Ensure that you have administrator and HP_OVE_ADMIN privileges on the HPOM management 
server.

• Ensure that you have WinRM privileges to monitor Dell systems running ESXi.

• Ensure that .Net Framework 3.5 is installed on the management server.

 

Software Requirements For Management Server

The following table lists the software requirements for the management server.
Table 1. Software Requirements For The Management Server

Requirement Description

Operating systems supported by Dell SPI for 
HPOM 9.0 for Microsoft Windows

Dell SPI for HPOM 9.0 for Microsoft Windows 
supports the following operating systems:

• Windows Server 2012

• Windows Server 2008 R2 SP1

• Windows Server 2008 R2

HPOM 9.0 for Microsoft Windows with the latest 
HPOM 9.0 patches

For more information about installing HPOM, see 
the HP Operations Manager 9.0 Installation Guide 
available on the HP support website.

Trap Interceptor with SNMPv2 If you want to monitor the SNMPv2 traps from Dell 
devices, then configure the HPOM trap interceptor 
to receive SNMPv2 traps. For more information, 
see Configure SNMP conditions section in HP 
Operations Manager online help.

SNMP Service If you want to monitor the SNMPv1 traps from Dell 
devices, install and enable SNMP Service. For more 
information, see Related Documents.

WinRM 2.0 service Install and configure WinRM version 2.0 or later to 
establish communication with the Dell ESXi 
systems that you are monitoring. For more 
information, see Configuring User Authorization 
For WinRM.

Dell Connections License Manager (DCLM) Install and configure the licensing server for 
monitoring Dell Out-of-Band (OOB) servers. For 
more information, see Dell Connections License 
Manager Installation Guide at support.dell.com/
manuals.
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Software Requirements For Managed Systems

The following table lists the software requirements for the managed systems.

NOTE: Ensure that DNS is configured properly for all managed systems, and the managed nodes 
have DNS resolvable Fully Qualified Domain Name (FQDN) host names.

Table 2. Software Requirements For Managed Systems

Requirement Description

Operating Systems Install the supported Microsoft Windows, Linux, or 
ESXi version. For more information about the 
supported operating systems, see Related 
Documents.

SNMP service Install and enable the SNMP service, and ensure 
that the management server can communicate 
with the managed node. For more information, see 
Related Documents and What To Do Next?

SNMP agent Configure the SNMP agent to set the community 
name, enable Get operations, and send traps to 
the HPOM management server.

Configure the SNMP service trap destination to 
receive traps on the management server.

For more information about configuring the SNMP 
agent on Dell servers running Windows, ESXi, or 
Linux operating systems, see Related Documents.

Dell OpenManage Server Administrator Dell OpenManage Server Administrator (OMSA) 
versions 7.2 to 7.4 are supported for Dell servers 
running Windows, ESXi, or Linux operating 
systems.

Install Dell OpenManage Server Administrator on 
ESXi and enable the OEM CIM providers and 
ensure that the management server can 
communicate with the systems.

For more information about enabling the OEM 
CIM providers or configuring SNMP for Dell servers 
running Windows, ESXi, or Linux operating 
systems, see Related Documents.

Supported Firmware Versions

The following table lists the supported firmware versions for Dell devices.
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Table 3. Supported Firmware Versions For Dell Devices

Dell Device Supported OMSA Versions Supported Firmware Versions 

Dell PowerEdge 9th Generation 
(9G) to 12th Generation (12G) 
servers

7.2–7.4 NA

DRAC5 NA 1.5 and 1.6

iDRAC6 11G Modular NA 3.42 and 3.50

iDRAC6 11G Monolithic NA 1.95 and 1.96

iDRAC7 NA 1.51.51 and 1.55.55

DRAC/MC NA 1.5 and 1.6

CMC NA 4.45 and 4.50

VRTX CMC NA 1.2 and 1.3

FX2 CMC NA 1.1

Dell Compellent Storage Arrays NA 6.4.3 and 6.5.1

Dell EqualLogic PS-Series 
Storage Arrays

NA 6.0 and 7.0

Dell PowerVault MD Storage 
Arrays

NA 07.84.47.60, 07.84.53.60, and 
08.10.03.00

Dell PowerVault NX 9th 
Generation (9G) to 12th 
Generation (12G) Storage Arrays

7.2–7.4 NA

Dell Network Switches NA • S-Series

– S25 (8.4.2.7)

– S50 (8.4.2.7)

– S55 (8.3.5.5)

– S60 (8.3.3.9)

– S4810 (9.2 and 9.3)

– S4820T (9.2 and 9.3)

• Z-Series

– Z9000 (9.2 and 9.3)

• M-Series

– MXL (9.2 and 9.3)

– MIOA (9.2 and 9.3)

• 8000 Series / 8100 Series

– 5.2 and 6.0
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Configuring User Authorization For WinRM
To configure user authorization for WinRM:

1. From the Windows menu, click Start → Run.

2. In the Run window, type winrm configsddl default and click OK.

3. Click Add to add the required local or domain users or groups to the list.

4. Provide the appropriate permission(s) to the respective users and click OK.
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Installing The Dell SPI For HPOM For 
Microsoft Windows
You must close the HPOM console before you install Dell SPI.

To install the Dell SPI on the HPOM management server:

1. Download the Dell SPI installer from the Dell support website at support.dell.com.

2. Extract the contents of Dell_Smart_Plug-in v4.0_Axx.exe on the management server.

3. Navigate to the directory where you have extracted the contents of Dell_Smart_Plug-in v4.0_Axx.exe 
and run the Dell Smart Plug-in v4.0_x64.msi.

4. In the Welcome screen, click Next.

5. Select the I accept the terms in the license agreement option and click Next.

6. In the Documentation Availability and Location screen, click Next.

7. In the Destination Folder screen, click Next to install the Dell Smart Plug-in v4.0 in the default 
destination. To install it in a custom folder, click Change and provide a destination folder.

8. In the Auto Deploy screen, select Yes to auto-deploy the policy files during installation. To deploy 
them manually on the management server, select No.

The Ready to Install screen displays information about the Dell devices supported by the Dell SPI and 
the Dell SPI installation location.

9. Click Install, then click Finish.

 

Verifying The Dell SPI Installation
To verify the Dell SPI installation:

1. Launch the HPOM console and verify that the following hierarchies are created:

• Services Hierarchy

– Systems Infrastructure

* Dell Hardware
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Figure 1. Dell Hardware Services hierarchy after installation

1. Dell Chassis

a. CMC

b. DRAC MC

c. VRTX CMC

d. FX2 CMC

2. Dell DRAC

a. DRAC5

b. iDRAC6 Modular

c. iDRAC6 Monolithic

d. iDRAC7 Modular

e. iDRAC7 Monolithic

3. Dell Network Switches

a. 8000 | 8100 Series Switches
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b. M-Series Switches

c. S-Series Switches

d. Z-Series Switches

4. Dell Servers

a. ESXi Servers

b. Linux Servers

c. Windows Servers

5. Dell Storage

a. Compellent Storage Arrays

b. EqualLogic PS-Series Storage Arrays

c. PowerVault MD Storage Arrays

d. PowerVault NX Storage Arrays

– Dell SPI Licensing

NOTE: The Dell SPI Licensing service will appear when the auto grouping policy is 
complete.

• Nodes Hierarchy

Figure 2. Dell Hardware Nodes hierarchy after installation

– Dell Managed Systems
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a. Dell Chassis

1. CMC

2. DRAC MC

3. VRTX CMC

4. FX2 CMC

b. Dell DRAC

1. DRAC5

2. iDRAC6 Modular

3. iDRAC6 Monolithic

4. iDRAC7 Modular

5. iDRAC7 Monolithic

c. Dell Network Switches

1. 8000 | 8100 Series Switches

2. M-Series Switches

3. S-Series Switches

4. Z-Series Switches

d. Dell Servers

1. Modular Servers

2. Monolithic Servers

e. Dell Storage

1. Compellent Storage Arrays 

2. EqualLogic PS-Series Storage Arrays

3. PowerVault MD Storage Arrays

4. PowerVault NX Storage Arrays

f. Dell Unresponsive Devices

2. Navigate to Policy Management → Policy Groups → SPI for Dell Devices.

a. Verify that the following are present under SPI for Dell Devices:

• Dell Server

• Dell Storage

• Dell Switches

• Dell Connections License Manager Scheduled Status Poll

• Dell Device Generic Traps

• Dell Hardware Autogroup Policy
b. Verify that the following policies are present under SPI for Dell Devices → Dell Server:

• Dell DRAC and Chassis Scheduled Status Poll

• Dell DRAC and Chassis Traps

• Dell DRAC and Chassis Traps (Manual Ack)

• Dell OOB Server Traps

• Dell OOB Server Traps (Manual Ack)

• Dell Server Scheduled Status Poll

• Dell Server Traps
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• Dell Server Traps (Manual Ack)
c. Verify that the following policies are present under SPI for Dell Devices → Dell Storage:

• Dell Compellent Storage Array Traps

• Dell Compellent Storage Array Traps (Manual Ack)

• Dell Compellent Storage Array Scheduled Status Poll

• Dell EqualLogic Arrays Scheduled Status Poll

• Dell EqualLogic Traps

• Dell EqualLogic Traps (Manual Ack)

• Dell MD Storage Arrays Scheduled Status Poll

• Dell PowerVault MD Storage Array Traps (Manual Ack)

• Dell PowerVault NX Storage Arrays Scheduled Status Poll
d. Verify that the following policies are present under SPI for Dell Devices → Dell Switches:

• Dell 8000 | 8100 Network Switch Scheduled Status Poll

• Dell 8000 | 8100 Network Switch Traps

• Dell 8000 | 8100 Network Switch Traps (Manual Ack)

• Dell Enterprise Series Switch Traps (Manual Ack)

• Dell Enterprise Switch Scheduled Status Poll

3. Verify that the auto-deployed policies are present in the Policy Inventory.

From Nodes, right-click on the management server, and click View → Policy Inventory to view the 
following policies:

• Dell 8000 | 8100 Network Switch Scheduled Status Poll

• Dell 8000 | 8100 Network Switch Traps

• Dell Compellent Storage Array Traps

• Dell Compellent Storage Arrays Scheduled Status Poll

• Dell Connections License Manager Scheduled Status Poll

• Dell Device Generic Traps

• Dell DRAC and Chassis Scheduled Status Poll

• Dell DRAC and Chassis Traps

• Dell Enterprise Series Switch Traps (Manual Ack)

• Dell Enterprise Switch Scheduled Status Poll

• Dell EqualLogic Arrays Scheduled Status Poll

• Dell EqualLogic Traps

• Dell Hardware Autogroup Policy

• Dell MD Storage Arrays Scheduled Status Poll

• Dell OOB Server Traps

• Dell PowerVault MD Storage Array Traps (Manual Ack)

• Dell PowerVault NX Storage Arrays Scheduled Status Poll

• Dell Server Scheduled Status Poll

• Dell Server Traps

4. Verify that the following tools are displayed under their respective folders under Tools.

a. The following tools are displayed under Tools → Dell Tools:

• Dell Chassis

• Dell DRAC
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• Dell Network Switches

• Dell Server

• Dell SPI Licensing

• Dell Storage

• OpenManage Essentials Console

• OpenManage Power Center Console

• Warranty Report
b. The following tools are displayed under Tools → Dell Tools → Dell Chassis:

• CMC Console

• DRAC/MC Console
c. The following tools are displayed under Tools → Dell Tools → Dell DRAC:

• DRAC Console

• OpenManage Server Administrator Console
d. The following tools are displayed under Tools → Dell Tools → Dell Network Switches:

• 8000 | 8100 Switches

– OpenManage Switch Administrator Console

• Dell OpenManage Network Manager Console

• Dell Switch Telnet tool
e. The following tools are displayed under Tools → Dell Tools → Dell Server:

• Dell Remote Access Controller Console (in-band)

• OpenManage Server Administrator Console

• OpenManage Server Administrator Web Server Console
f. The following tools are displayed under Tools → Dell Tools → Dell SPI Licensing:

• Dell Connections License Manager Console Launch Tool
g. The following tools are displayed under Tools → Dell Tools → Dell Storage:

• Dell Compellent Storage Arrays

– Dell Compellent Enterprise Manager Client Console

– Dell Compellent Storage Manager Console

• Dell EqualLogic PS-Series Arrays

– EqualLogic Group Manager Console

• Dell PowerVault MD Storage Arrays

– MD Storage Manager Console

• Dell PowerVault NX Storage Arrays

– OpenManage Server Administration Console

– OpenManage Server Administration Web Server Console

– Dell Remote Access Controller Console (in-band)

5. Verify that the Dell SPI configuration utility is installed in the default or the custom directory. The 
default location is:

C:\Program Files\Dell\OpenManage Connection for HP\.

If any of the step fails, check the prerequisites and try again. To use the Repair, and Uninstall options 
in the installer, see:

• Using The Repair Option In The Installer.
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• Uninstalling The Dell SPI.
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What To Do Next?
After installing the Dell SPI, configure the SNMP parameters for the supported Dell devices, DCLM 
parameters for OOB server monitoring, and WSMAN parameters for ESXi systems to ensure that 
communication between the management server and the Dell systems is established correctly. To 
configure the communication parameters, run the DellSPICongfigUtility.exe that is part of the Dell SPI 
installer.

You can configure the following:

• SNMP parameters

– Timeout
– Retries

• Dell OpenManage Server Administrator Web Server Console URL

– -dwsurl
• Warranty Report URL

• DCLM Parameters

– Webservice URL
– Username
– Password

• WSMAN Connection Parameters

– Username
– Password
– Timeout
– Security options that include Certificate Authority check, Common Name check, and 

Revocation check

NOTE: You can configure the Warranty Report URL, DCLM Webservice URL, and the Dell 
OpenManage Server Administrator Web Server Console URL according to the environment.

NOTE: 

There is no specific configuration settings that need to be performed by the user in order to launch 
the following consoles from Dell SPI for HPOM:

• DRAC Console

• Dell Remote Access Controller Console (in-band)

• DRAC/MC Console

• CMC Console

• EqualLogic Group Manager Console

• Dell Compellent Storage Manager Console

• OpenManage Server Administrator Console

• OpenManage Switch Administrator Console
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The following table lists the command line options to set the different values for SNMP, Dell 
OpenManage Server Administrator Web Server Console URL, WSMAN, DCLM, and Warranty Report URL.

Table 4. Command Line Options

Option Description

-snmptimeout Specifies the SNMP timeout value in milliseconds. 
The default value is 5000 (5 seconds). Set a value 
between 100 milliseconds to 4294967290 
milliseconds.

-snmpretries Specifies the number of SNMP retries. The default 
value is 1.

-dwsurl Specifies the Dell OpenManage Server 
Administrator Web Server Console URL.

-dclmwebserviceurl Specifies the DCLM webservice URL.

Example: http://dclmserver.domain.com:8543/

-dclmusername Specifies the DCLM user name for logging in with 
basic authentication.

Example: domain\username

-dclmpassword Specifies the DCLM password for logging in with 
basic authentication.

-getall Specifies the values of all the options and displays 
them on the screen. This option obtains the values 
for all the individual parameters except the 
following:

• wsmanusername
• wsmanpassword
• dclmusername
• dclmpassword

-resetdefaults Resets all the configurable values to the default 
values.

NOTE: This option does not reset the values 
for the following options:

• -wsmanusername
• -wsmanpassword
• dclmusername
• dclmpassword

-help Displays the Help for using this tool.

-wsmanusername Specifies the user name of a local or a domain 
account on Dell servers running ESXi operating 
system. Specifies the WSMAN user name for 
logging into the ESXi system with basic 
authentication.
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Option Description

-wsmanpassword Specifies the password for the user name you 
specified.

-wsmancacheck Skips the authentication of Certificate Authority 
that issued the certificate. The value is either yes 
or no. The default value is no. If you set the value 
to yes, then the authentication of Certificate 
Authority is checked.

-wsmancncheck Skips authentication of the Common Name (CN). 
The value is either yes or no. The default value is 
no. If you set the value to yes, then the Common 
Name is checked.

-wsmanrevocationcheck Specifies a value to indicate whether the WSMAN 
connection should validate the revocation status 
of the server certificate or not. The value is either 
yes or no. The default value is no. If you set the 
value to yes, then the revocation status of the 
server certificate is checked.

-wsmantimeout Specifies WSMAN timeout value in milliseconds. 
The default value is 30000 (30 seconds). Set a 
value between 500 milliseconds to 4294967290 
milliseconds.

 

Using The Dell SPI Configuration Utility
To use the Dell SPI configuration utility:

1. Launch a command prompt on the management server.

2. Navigate to DellSPIConfigUtility.exe.

The default location is C:\Program Files\Dell\OpenManage Connection for HP.

3. To set any of the parameters, listed in Table 4. of the above section, for the supported Dell Devices, 
type the following command:

DellSPIConfigUtility.exe -<option>=<value> and press Enter.

For example, if you want to set the WSMAN timeout, type the following command: 
DellSPIConfigUtility.exe -wsmantimeout=500

You must set the values for wsmanusername and wsmanpassword if you are monitoring the ESXi 

systems. You can also set the values to launch the Dell OpenManage Server Administrator Web 
Server Console.

When you specify the value for wsmanpassword , type the following command: 

DellSPIConfigUtility.exe -wsmanpassword and press Enter. While specifying the 

wsmanpassword,

• You do not need to specify = after -wsmanpassword.

• When you modify the password, the utility prompts you to enter the old password and then the 
new password twice.
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• When you specify the password for the first time, you need to enter the password twice.

NOTE: The utility prompts you to change the password even when you change the username.

If you enter invalid values, the utility displays the error message with the help text.

To view the values for each option other than the values for wsmanusername and wsmanpassword, 

type the following command: DellSPIConfigUtility.exe -<option>

Configuring Dell Connections License Manager 
Parameters
To configure the Dell Connections License Manager (DCLM) parameters:

1. Install the Dell Connections License Manager.

For more information, see Dell Connections License Manager Version x.x Installation Guide at 
support.dell.com/manuals.

2. Launch the command prompt on the management server.

3. Navigate to DellSPIConfigUtility.exe.

The default location is C:\Program Files\Dell\OpenManage Connection for HP.

4. Set the Dell Connections License Manager web service URL by typing the following command:

DellSPIConfigUtility.exe -dclmwebserviceurl=http://<License Server IP>:<port 
number>

For example: DellSPIConfigUtility.exe -dclmwebserviceurl=http://<IP Address Or 
Fully Qualified Domain Name>:8543

5. Set the Dell Connections License Manager user name by typing the following command:

DellSPIConfigUtility.exe -dclmusername=<username>
6. Enter the password by typing the following command:

DellSPIConfigUtility.exe -dclmpassword.

NOTE: You do not have to specify = after -dclmpassword.

You have to re-enter the password to verify if you have entered the password correctly.

When you modify the password, the utility prompts you to enter the old password and then the new 
password twice.

NOTE: The utility prompts you to change the dclmpassword when you change the 

dclmusername.

Configuring Dell Connections License Manager URL
To configure the Dell Connections License Manager (DCLM) URL:

1. Click Tools → Dell Tools → Dell SPI Licensing → Dell Connections License Manager Console 
Launch Tool.

2. In the right pane, right-click Dell Connections License Manager Console Launch Tool , and then 
click Properties from the pop-up menu.

The Dell Connections License Manager Console Launch Tool Properties window is displayed.
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3. In the Dell Connections License Manager Console Launch Tool Properties window, click the Details 
tab.

4. In the URL: (Required) box, enter the URL of the Dell Connections License Manager Console.

Example: http://mylicenseserver.mydomain.com:8544/DellLicenseManagement

5. Click Apply, and then click OK.

The Dell Connections License Manager URL is configured on the HPOM Console.

Configuring The Warranty Report URL
The warranty URL is configured in the Dell SPI by default. To change the default Warranty URL by using 
the DellSPIConfigUtility.exe, perform the following steps:

1. Launch the command prompt on the management server.

2. Navigate to DellSPIConfigUtility.exe.

The default location is C:\Program Files\Dell\OpenManage Connection for HP.

3. To configure the Dell Warranty Report URL, enter the following command:

DellSPIConfigUtility.exe -warrantyurl="<Warranty URL>"

The Warranty Report URL is configured on the HPOM Console.

Configuring Dell Modular Disk (MD) Storage Manager 
Console
To configure the Dell Modular Disk (MD) Storage Manager Console:

1. Install the Modular Disk (MD) Storage Manager Client on the management server.

2. Click Tools → Dell Tools → Dell Storage → Dell PowerVault MD Storage Arrays.

3. In the right pane, right-click MD Storage Manager Console, and then click Properties from the pop-
up menu.

The MD Storage Manager Console Properties window is displayed.

4. In the MD Storage Manager Console Properties window, click the Details tab.

5. From the Command Type: (Required) drop-down list, click Executable.

6. Obtain the path of Modular Disk Storage Manager Client.exe. 

The default path is C:\Program Files (x86)\Dell\MD Storage Software\MD Storage Manager\client
\Modular Disk Storage Manager Client.exe.

7. In the Command: (Required) box, enter the Modular Disk Storage Manager Client.exe location 
details or click Browse to navigate to the location where you installed the Modular Disk Storage 
Manager Client.exe file.

8. Click Apply, and then click OK.

The MD Storage Manager Console is configured on the HPOM Console.

Configuring Dell OpenManage Power Center (OMPC) 
Tool
To configure the Dell OMPC tool:

1. Install the OpenManage Power Center (OMPC).
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For more information, see Dell OpenManage Power Center Version x.x User's Guide at 
support.dell.com/manuals.

2. In the HPOM console, select Tools → Dell Tools.

3. In the right pane, right-click OpenManage Power Center Console , and then click Properties from 
the pop-up menu.

The OpenManage Power Center Console Properties window is displayed.

4. In the OpenManage Power Center Console Properties window, click the Details tab.

5. From the Command Type: (Required) drop-down list, select URL.

6. In the Command: (Required) box, enter the URL of the OMPC Console.

The default URL is https://localhost:8643/powercenter.

NOTE: OMPC Console will launch successfully using the default URL only if OMPC is installed 
on the same HPOM server. If OMPC is installed on another server, obtain the URL from the 
respective OMPC server where OMPC is installed, and then set the OMPC URL.

• Example: https://10.94.145.132:8643/powercenter

• Example: https://hpom1w2k8r2.hpdom.com:8643/powercenter

7. Click Apply, and then click OK.

The OMPC Console is configured on the HPOM Console.

Configuring Dell OpenManage Essentials (OME) Tool
To configure the Dell OME tool:

1. Install the OpenManage Essentials (OME).

For more information, see Dell OpenManage Essentials Version x.x User's Guide at support.dell.com/
manuals.

2. In the HPOM console, click Tools → Dell Tools.

3. On the right pane, right-click OpenManage Essentials Console, and then click Properties from the 
pop-up menu.

The OpenManage Essentials Console Properties window is displayed.

4. In the OpenManage Essentials Console Properties window, click the Details tab.

5. From the Command Type: (Required) drop-down list, select URL.

6. In the Command: (Required) box, enter the URL of the OME Console.

The default URL is https://localhost:2607/Web/Default.aspx.

NOTE: OME Console will launch successfully using the default URL only if OME is installed on 
the same HPOM server. If OME is installed on another server, obtain the URL from the 
respective OME server, and then set the OME URL.

• Example: https://<IP Address Or Fully Qualified Domain Name>:2607/Web/Default.aspx

• Example: https://10.94.149.172:2607/Web/Default.aspx

• Example: https://hpom1w2k8r2.hpdom.com:2607/Web/Default.aspx

7. Click Apply, and then click OK.

The OME Console is configured on the HPOM Console.
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Configuring Dell OpenManage Network Manager 
(OMNM) Tool
To configure the Dell OMNM tool:

1. Install Dell OpenManage Network Manager.

For more information, see Dell OpenManage Network Manager Version x.x Quick Start Guide at 
support.dell.com/manuals.

2. In the HPOM console, click Tools → Dell Tools → Dell Network Switches.

3. In the right pane, right-click OpenManage Network Manager Console, and then click Properties 
from the pop-up menu.

The Dell OpenManage Network Manager Console Properties window is displayed.

4. In the Dell OpenManage Network Manager Console Properties window, click the Details tab.

5. From the Command Type: (Required) drop-down list, select URL.

6. In the Command: (Required) box, enter the Dell OpenManage Network Manager Console URL

The default URL is https://localhost:8080.

NOTE: The Dell OpenManage Network Manager Console will launch successfully using the 
default URL only if OMNM is installed on the same HPOM server. If OMNM is installed on 
another server, obtain the URL from the respective OMNM server, and then set the OMNM URL.

• Example: https://<IP Address Or Fully Qualified Domain Name>:8080

• Example: https://10.94.149.172:8080

• Example: https://hpom1w2k8r2.hpdom.com:8080

7. Click Apply, and then click OK.

The Dell OpenManage Network Manager Console is configured on the HPOM Console.

Configuring Dell Compellent Enterprise Manager Client 
Console
To configure the Dell Compellent Enterprise Manager Client Console:

1. Install the Dell Compellent Enterprise Manager client on the management server where you have 
installed HPOM.

2. Click Tools → Dell Tools → Dell Storage → Dell Compellent Storage Arrays.

3. In the right pane, right-click Dell Compellent Enterprise Manager Client Console, and then click 
Properties from the pop-up menu.

The Dell Compellent Enterprise Manager Client Console Properties window is displayed.

4. In the Dell Compellent Enterprise Manager Client Console Properties window, click the Details tab.

5. From the Command Type: (Required) drop-down list, click Executable.

6. Obtain the path of EnterpriseClient.exe.

The default command is: /c "cd C:\Program Files (x86)\Compellent Technologies\Compellent 
Enterprise Manager\msagui\" & start EnterpriseClient.exe

7. In the Command: (Required) box, enter the EnterpriseClient.exe location details or click Browse to 
navigate to the location where you installed the EnterpriseClient.exe file.

8. Click Apply.
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9. Click OK.

The Dell Compellent Enterprise Manager Client Console is configured on the HPOM Console.

Configuring Dell Switch Telnet Tool
To configure the Dell Switch Telnet Tool:

1. Click Features → Add Features on the Server Manager.

The Select Features window is displayed.

2. Click Telnet Client features and click Next.

3. In the Confirm Installation Selections window, click Install.

4. Click System Properties → Advanced → Environment variables and ensure that the path for 
Telnet.exe is included in the %Path%.

The Dell Switch Telnet Tool is configured on the HPOM Console.

Setting The Schedule For Dell Auto-grouping Policy
To set the schedule for the Dell policies:

1. Click Policy Management → Policy Groups → SPI for Dell Devices.

2. From the list of Dell policies, right-click Dell Hardware Autogroup Policy, and then click All Tasks → 
Edit.

The Dell Hardware Autogroup Policy [4.0] (Scheduled Task) screen is displayed.

3. In the Schedule tab, click any of the options in the drop-down menu, and input the desired schedule.

Ensure that the values of the desired schedules are equal to or greater than the values of the Dell 
recommended default schedules.

4. Click Save and Close.

5. Deploy the Dell Hardware Autogroup Policy on the management server after setting the schedule.

For more information about deploying the Dell Hardware Autogroup Policy, see Dell Smart Plug-in 
Version 4.0 for HP Operations Manager 9.0 For Microsoft Windows User's Guide.

The following figure displays the Dell Hardware Services hierarchy after auto-grouping:
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Figure 3.

The following figure displays the Dell Hardware Nodes hierarchy after auto-grouping:

24



25



Creating Connections License Manager 
Domain Groups
The following groups are created in the Windows Server Active Directory during installation of Dell 
Connections License Manager:

• Dell Connections License Administrators

• Dell Connections License Operators

• Dell Connections License Users

If the preceding domain groups are not automatically created during installation, then manually create 
the preceding groups. To create domains and add users to domains, see the Windows documentation 
from Microsoft at technet.microsoft.com.

NOTE: After creating the required domain groups, add your Management Server Machine Account 
as part of the Dell Connections License Users group and add the current user account to the Dell 
Connections License Administrators group.
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Removing Dell Devices
To remove Dell devices from the HPOM console, perform the following steps:

1. To remove a Dell device from the HPOM console, see the section Delete, copy, and move managed 
nodes under Maintaining nodes in the HP Operations Manager online help.

2. Before removing an iDRAC7 device from the HPOM console, relinquish the acquired Dell 
Connections License by performing the following steps:

a. Launch the command prompt on the management server.

b. Navigate to DellSPIConfigUtility.exe.

The default location is C:\Program Files\Dell\OpenManage Connection for HP.

c. Type the following command:

DellSPIConfigUtility.exe —relinquish=<iDRAC7 device servicetag/
ServerNodeID>

NOTE: 

The ServerNodeID is used only when you want to remove a Dell PowerEdge FM120 

device.
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Using The Repair Option In The Installer
If you accidentally delete any of the policies from the SPI for Dell Devices policy group or from the Policy 
Inventory of the management server, use the Repair option in the Dell SPI installer to reinstall the 
policies.

The Repair option installs the missing Dell SPI policies and automatically deploys all the policies on the 
management server. Before you use the Repair option, ensure that you remove or undeploy all the Dell 
SPI policies from the HPOM management server node on the HPOM console.

NOTE: If you modify any of the policies and then delete them, the Repair option installs only the 
original version of the policies. You must modify them again as per the requirements. The repair 
option resets the values of the SNMP, WSMAN, DWSURL, DCLM Webservice URL and Warranty 
Report URL parameters to the default values only if the Retain Dell SPI configuration was not 
checked during the installation steps. You must set the values of the parameters again.

Additionally, if any of the files are missing or corrupted, the Repair option replaces the file.

Repairing the Dell SPI program features using Windows Control Panel ensures that your existing Dell SPI 
configuration settings are retained on the HP Management system.

 

Repairing The Program Features
To repair the program features:

1. Run the Dell Smart Plug-In v4.0_x64.msi from the extracted folder.

The Welcome screen is displayed.

2. Click Next.

The installer displays two options: Repair and Remove.

3. Select the Repair option, and then click Next.

The Retain the User Configuration screen is displayed.

4. In the Retain the User Configuration, select Yes to retain the current Dell SPI configuration during 
the Repair operation or No to reset the default configuration, and then click Next.

NOTE: If you select Yes, the parameters that were configured by using the 
DellSPIConfigUtility.exe are retained.

The Ready to Repair screen is displayed.

5. Click Install.

6. Click Finish once the installation process is complete.
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Repairing The Dell SPI Program Features Using Windows 
Control Panel
To repair the Dell SPI Program Features using Windows Control Panel:

1. From the Start menu, click Control Panel → Programs → Uninstall a program.

2. In the Uninstall or change a program window, select Dell Smart Plug-in v4.0 for HP Operations 
Manager for Windows, and click Repair to initiate the repair process.

The parameters that were configured by using the DellSPIConfigUtility.exe are retained by default.

The Dell SPI is repaired.

NOTE: You can also repair The Dell SPI Program Features by using the Change option in the 
Windows Control Panel.
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Upgrading From Dell SPI Version 3.0 
If you have Dell SPI version 3.0 installed on the management server, you can upgrade the same to version 
4.0.

When you upgrade from version 3.0, the existing policies are upgraded to the version 4.0 and the existing 
Dell groups from Nodes and Services are removed and recreated automatically.

NOTE: The upgrade process does not preserve the schedule settings for the policy files. However, 
the parameters that were configured using the DellSPIConfigUtility.exe are retained.

 

Upgrading Dell SPI
1. Run the Dell Smart Plug-In v4.0.msi from the extracted folder.

The Welcome screen is displayed. You are also prompted with a message that another version of 
Dell SPI is installed and whether you want to upgrade to a newer version.

2. Click Yes to proceed with the installation.

3. Follow steps 5 to 11 mentioned in Installing The Dell SPI.

NOTE: After the upgrade process is complete, the Dell Hardware Autogroup Policy runs 
automatically to group the Dell devices.
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Uninstalling The Dell SPI For HPOM For 
Microsoft Windows
You can uninstall the Dell SPI from the Windows Control Panel or use the Remove option in the Dell SPI 
installer. When you uninstall Dell SPI, the Dell SPI components such as files and scripts are removed from 
the installed system.

Before you uninstall Dell SPI, ensure that the following requirements are met:

• Dell policies are not running on the management server.

• All the Dell SPI policies are either removed or undeployed from the HPOM management server node 
on the HPOM console.

• The Dell SPI directories are closed.

CAUTION: Uninstall the Dell SPI before you uninstall HPOM. If you uninstall HPOM first and then 
attempt to uninstall the Dell SPI, the uninstallation process may fail with errors.

NOTE: When you uninstall the Dell SPI, the following errors are displayed:

• One or more Dell SPI processes in progress.

• Stop all Dell SPI processes and try again.

To resolve this, disable the policies, or wait till the policies complete, and then retry the 
uninstallation.

 

Removing The Dell SPI Using Windows Control Panel
To remove the Dell SPI using Windows Control Panel:

1. From the Start menu, select Control Panel → Programs → Uninstall a program.

2. In Uninstall or change a program, click Dell Smart Plug-in v4.0 for HP Operations Manager for 
Windows, and then click Uninstall.

3. In the Programs and Features window, click Yes.

The Dell SPI v4.0 is removed from the HPOM management server.

NOTE: You can also remove The Dell SPI Program Features using the Change option in the 
Windows Control Panel.

Removing Dell SPI Using The Installer
To remove Dell SPI v4.0 using the installer:

1. Run the Dell Smart Plug-In v4.0_x64.msi from the folder where you extracted the contents of the 
self extracting package Dell_Smart_Plug-in v4.0_Axx.exe.

The Welcome screen is displayed.

2. Click Next.

The installer displays two options: Repair and Remove.
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3. Select Remove and click Next.

The Remove the Program screen is displayed.

4. In the Remove the Program screen, click Remove.

The Dell SPI v4.0 for HP Operations Manager is removed from the management server.

Verifying The Uninstallation Of Dell SPI
To verify that the Dell SPI is completely uninstalled from the management server:

1. From the HPOM console, click Policy Management → Policy Group and ensure that the SPI for Dell 
Devices is removed.

2. Click Nodes and ensure that the Dell Managed Systems Group is removed.

3. Click Services → System Infrastructure and ensure that the Dell Hardware service, Dell SPI 
Licensing service, and the services tree for all Dell devices are removed.

4. Click Tools and ensure that the Dell Tools folder is removed.

5. Ensure that the Dell SPI installation directory is removed from the default or the custom path.

The default path is C:\Program Files\Dell\OpenManage Connection For HP.

6. Ensure that the policies directory is removed.

The default path is C:\Program Files\HP\HP BTO Software\install\DellSPIPolicy.
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Related Documents
In addition to this guide, you can access the following guides available on the Dell support website at 

support.dell.com/manuals. On the Manuals page, click Software and Security → Enterprise System 
Management. Click the appropriate product link on the right side to access the documents.

For example, to view Dell SPI documentation, click Software and Security → Enterprise System 
Management → Dell Smart Plug-in for HP Operations Manager Version 9.0 for Microsoft Windows.

• Dell Smart Plug-in Version 4.0 For HP Operations Manager 9.0 For Microsoft Windows User’s Guide

• Dell Connections License Manager User's Guide

• Dell Integrated Remote Access Controller User’s Guide

• Dell OpenManage Essentials User's Guide

• Dell OpenManage Power Center User's Guide

• Dell OpenManage Server Administrator User’s Guide

• Dell OpenManage With VMware ESX/ESXi Systems Management Guide

• Dell Remote Access Controller 5 User’s Guide

• Dell Remote Access Controller/ Modular Chassis User's Guide

• Dell Chassis Management Controller User’s Guide

• Dell Chassis Management Controller for Dell PowerEdge VRTX User’s Guide

• Dell Chassis Management Controller for Dell PowerEdge FX2/FX2s User’s Guide

• Dell OpenManage Network Manager User's Guide
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